Software and System Requirements for JavaFX Technology

January 2010  
This document provides the system and software requirements that must be met before using the JavaFX 1.2 technology. The JavaFX 1.2 technology runs on Windows and Mac OS X. A Beta release of the JavaFX 1.2 SDK is provided for the Ubuntu Linux and OpenSolaris operating systems. Each of the following JavaFX tools and technology components has been tested by using the listed platforms and technologies.
 
Contents
 
NetBeans IDE 6.8 for JavaFX 1.2 Requirements
JavaFX 1.2 SDK Requirements
JavaFX 1.2 Production Suite Requirements
Other Configuration Requirements
 
NetBeans IDE 6.8 for JavaFX 1.2 Requirements

Before you install the IDE, the following software and system requirements must be met, especially for the Java SE Development Kit. Otherwise, you cannot proceed with the IDE installation. The installation of NetBeans IDE for JavaFX includes the JavaFX SDK.

 
Windows
Mac
Linux (Beta)
OpenSolaris (Beta)
Processors
Intel Pentium 4, Intel Centrino, Intel Xeon, or Intel Core Duo (or compatible) 1.8 GHz minimum (2.6 GHz Intel Pentium 4 or equivalent recommended)
Dual-Core Intel, PowerPC G5
Intel Pentium 4, Intel Centrino, Intel Xeon, or Intel Core Duo (or compatible) 1.8 GHz minimum (2.6 GHz Intel Pentium 4 or equivalent recommended)
Intel Pentium 4, Intel Centrino, Intel Xeon, or Intel Core Duo (or compatible) 1.8 GHz minimum (2.8 GHz recommended)
Operating Systems
Windows XP with Service Pack 3 or Windows Vista Home Premium, Business, Ultimate, or Enterprise (certified for 32-bit editions) or Windows 7 Ultimate (certified for 32-bit editions)
Mac OS X 10.4.10 minimum
Ubuntu 8.04 LTE
OpenSolaris 2009.06
Memory
512 MB of RAM (2 GB recommended)
512 MB of RAM (2 GB recommended)
512 MB of RAM (2 GB recommended)
512 MB of RAM (2 GB recommended)
Disk Space
778 MB of free disk space (1 GB recommended)
778 MB of free disk space (1 GB recommended)
778 MB of free disk space (1 GB recommended)
778 MB of free disk space (1 GB recommended)
Web Browsers
Internet Explorer 6 minimum, FireFox 3.0 minimum
Firefox 3.0 minimum, Safari 3 minimum
FireFox 3.0 minimum
FireFox 3.0 minimum
Java SE Development Kit (JDK) *
JDK 6 Update 13 minimum ( JDK 6 Update 14 recommended).
JDK 5 Update 16 (version 1.5.0_16) minimum ( Java for Mac OS X 10.4, Release 7 or Java for Mac OS X 10.5 Update 2 or later )
JDK 6 Update 13 minimum ( JDK 6 Update 14 recommended)
JDK 6 Update 13 minimum ( JDK 6 Update 14 recommended)
Media
 
 
Requires GStreamer. For more information, check its documentation. The default GStreamer version is 0.10.18. To determine the media that GStreamer supports on your system, use the gst-inspect command.
Requires GStreamer. For more information, check its documentation. The default GStreamer version is 0.10.21. To determine the media that GStreamer supports on your system, use the gst-inspect command.
Apple QuickTime Player
7.5.5 minimum is required to run the JavaFX Mobile Emulator, which is currently available only on the Microsoft Windows platform. System restart is required after QuickTime installation.
 
 
 
DirectShow Filters
MP3 and AMR splitters and decoders are needed (for example, K-Lite Codec Pack) for the JavaFX Mobile Emulator.
 
 
 
 

* The JDK installation includes the Java Runtime Environment (JRE).

JavaFX 1.2 SDK Requirements

The JavaFX 1.2 SDK Includes the JavaFX compiler and runtime tools, graphics, media, web services, UI controls and rich text libraries to create RIAs for the desktop, browser and mobile platforms. Ensure that you meet the following requirements prior to installing the JavaFX 1.2 SDK on your system.

 
Windows
Mac
Linux (Beta)
OpenSolaris (Beta)
Processors
Intel Pentium 4, Intel Centrino, Intel Xeon, or Intel Core Duo (or compatible) 1.8 GHz minimum
Dual-Core Intel, PowerPC G5
Intel Pentium 4, Intel Centrino, Intel Xeon, or Intel Core Duo (or compatible) 1.8 GHz minimum
Intel Pentium 4, Intel Centrino, Intel Xeon, or Intel Core Duo (or compatible) 1.8 GHz minimum
Operating Systems
Windows XP with Service Pack 3 or Windows Vista Home Premium, Business, Ultimate, or Enterprise (certified for 32-bit editions) or Windows 7 Ultimate (certified for 32-bit editions)
Mac OS X 10.4.10 minimum
Ubuntu 8.04 LTE
OpenSolaris 2009.06
Memory
512 MB of RAM (1 GB recommended)
512 MB of RAM (1 GB recommended)
512 MB of RAM (1 GB recommended)
512 MB of RAM (1 GB recommended)
Disk Space
256 MB of free disk space
256 MB of free disk space
256 MB of free disk space
256 MB of free disk space
Web Browsers
Internet Explorer 6 minimum, FireFox 3.0 minimum
Firefox 3.0 minimum, Safari 3 minimum
FireFox 3.0 minimum
FireFox 3.0 minimum
Java SE Development Kit (JDK). *
JDK 6 Update 13 minimum ( JDK 6 Update 14 recommended)
JDK 5 Update 16 (version 1.5.0_16) minimum ( Java for Mac OS X 10.4, Release 7 or Java for Mac OS X 10.5 Update 2 or later)
JDK 6 Update 13 minimum ( JDK 6 Update 14 recommended)
JDK 6 Update 13 minimum ( JDK 6 Update 14 recommended)
Media
 
 
Requires GStreamer. For more information, check its documentation. The default GStreamer version is 0.10.18. To determine the media that GStreamer supports on your system, use the gst-inspect command.
Requires GStreamer. For more information, check its documentation. The default GStreamer version is 0.10.21. To determine the media that GStreamer supports on your system, use the gst-inspect command.
Apple QuickTime Player
7.5.5 minimum is required to run the JavaFX Mobile Emulator, which is currently available only on the Microsoft Windows platform. System restart is required after QuickTime installation.
 
 
 
DirectShow Filters
MP3 and AMR splitters and decoders are needed (for example, K-Lite Codec Pack) for the JavaFX Mobile Emulator.
 
 
 
 

* The JDK installation includes the Java Runtime Environment (JRE).

JavaFX 1.2 Production Suite Requirements

The system requirements for JavaFX 1.2 Production Suite depend on some of the system requirements for Adobe Illustrator and Adobe Photoshop.

 
Windows
Mac
Processors
Intel Pentium 4, Intel Centrino, Intel Xeon, or Intel Core Duo (or compatible) 1.8 GHz minimum
Dual-Core Intel
Operating Systems
Microsoft Windows XP with Service Pack 2 or Windows Vista Home Premium, Business, Ultimate, or Enterprise (certified for 32-bit editions)
Mac OS X 10.4.10 minimum
Memory
1 GB of RAM (2 GB recommended)
1 GB of RAM (2 GB recommended)
Disk Space
30 MB of free disk space
30 MB of free disk space
Web Browsers
Internet Explorer 6 minimum, FireFox 3.0 minimum
Firefox 3.0 minimum, Safari 3 minimum
Screen Resolution
1024x768 pixels (1280x800 recommended) with 16-bit video card
1024x768 pixels (1280x800 pixels recommended) with 16-bit video card
Java SE Development Kit (JDK) *
JDK 6 Update 13 minimum ( JDK 6 Update 14 recommended)
JDK 5 Update 16 (version 1.5.0_16) minimum ( Java for Mac OS X 10.4, Release 7 or Java for Mac OS X 10.5 Update 2 or later)
Adobe Illustrator
Adobe Illustrator CS3: Required for JavaFX 1.2 Plugin for Adobe Illustrator CS3
Adobe Illustrator CS4: Required for JavaFX 1.2 Plugin for Adobe Illustrator CS4
Adobe Illustrator CS3: Required for JavaFX 1.2 Plugin for Adobe Illustrator CS3
Adobe Illustrator CS4: Required for JavaFX 1.2 Plugin for Adobe Illustrator CS4
Adobe Photoshop
Adobe Photoshop CS3: Required for JavaFX 1.2 Plugin for Adobe Photoshop CS3
Adobe Photoshop CS4: Required for JavaFX 1.2 Plugin for Adobe Photoshop CS4
Adobe Photoshop CS3: Required for JavaFX 1.2 Plugin for Adobe Photoshop CS3
Adobe Photoshop CS4: Required for JavaFX 1.2 Plugin for Adobe Photoshop CS4
 

* The JDK installation includes the Java Runtime Environment (JRE).

Other Configuration Requirements

If you want to install all the components together (NetBeans IDE 6.8 for JavaFX 1.2 and the JavaFX 1.2 Production Suite), you must meet the following requirements. Note that the JavaFX 1.2 SDK is bundled with NetBeans IDE 6.8 for JavaFX 1.2.

 
Windows
Mac
Processors
Intel Pentium 4, Intel Centrino, Intel Xeon, or Intel Core Duo (or compatible) 1.8 GHz minimum
Dual-Core Intel
Operating Systems
Windows XP with Service Pack 3 or Windows Vista Home Premium, Business, Ultimate, or Enterprise (certified for 32-bit editions)
Mac OS X 10.4.10 minimum
Memory
1 GB of RAM (2 GB recommended)
1 GB of RAM (2 GB recommended)
Disk Space
808 MB of free disk space
808 MB of free disk space
Web Browsers
Internet Explorer 6 minimum, FireFox 3.0 minimum
Firefox 3.0 minimum, Safari 3 minimum
Screen Resolution
1024x768 pixels (1280x800 recommended) with 16-bit video card
1024x768 pixels (1280x800 pixels recommended) with 16-bit video card
Java SE Development Kit (JDK) *
JDK 6 Update 13 minimum ( JDK 6 Update 14 recommended).
JDK 5 Update 16 (version 1.5.0_16) minimum ( Java for Mac OS X 10.4, Release 7 or Java for Mac OS X 10.5 Update 2 or later)
Apple Quicktime Player
7.5.5 minimum is required to run the JavaFX Mobile Emulator, which is currently available only on the Microsoft Windows platform. System restart is required after QuickTime installation.
 
Adobe Illustrator
Adobe Illustrator CS3: Required for JavaFX 1.2 Plugin for Adobe Illustrator CS3
Adobe Illustrator CS4: Required for JavaFX 1.2 Plugin for Adobe Illustrator CS4
Adobe Illustrator CS3: Required for JavaFX 1.2 Plugin for Adobe Illustrator CS3
Adobe Illustrator CS4: Required for JavaFX 1.2 Plugin for Adobe Illustrator CS4
Adobe Photoshop
Adobe Photoshop CS3: Required for JavaFX 1.2 Plugin for Adobe Photoshop CS3
Adobe Photoshop CS4: Required for JavaFX 1.2 Plugin for Adobe Photoshop CS4
Adobe Photoshop CS3: Required for JavaFX 1.2 Plugin for Adobe Photoshop CS3
Adobe Photoshop CS4: Required for JavaFX 1.2 Plugin for Adobe Photoshop CS4
 

* The JDK installation includes the Java Runtime Environment (JRE).

 
Rate This Article
 
Discussion

We welcome your participation in our community. Please keep your comments civil and on point. You can optionally provide your email address to be notified of replies—your information is not used for any other purpose. By submitting a comment, you agree to these Terms of Use.