Java™ 2 Platform 5.0 and Java for Business 5.0

  

The configurations listed on this page apply to both the J2SE Development Kit (JDK) and J2SE Runtime Environment (JRE). This chart includes links to the installation instructions followed by the minimum free disk space required before starting installation.

Sun also provides the Java for Business product (JFB). Note that not all configurations are supported on both JFB and J2SE. Refer to the columns in the following table. A blank cell indicates that support is not provided.

Refer to the Supported Locales document for the supported writing systems (languages) for each platform. The JRE does not support all writing systems on all platforms.

Also refer to specific footnotes at the end of this table.


System Virtualization Support

Support is available for Oracle VM 2.2.0.0.0, VirtualBox 3.x, Solaris Containers and Solaris LDOMs.

Note:
  • If a product is supported and certified on OEL or RHEL, it is also certified and supported in the virtualized installation of the same version of OEL or RHEL running on Oracle VM. (e.g. OEL4 --> OEL4 on Oracle VM, OEL5 --> OEL5 on Oracle VM, RHEL4 --> RHEL4 on Oracle VM, RHEL 5 --> RHEL5 on Oracle VM). Oracle recommends using latest updates levels and OVM versions available.
  • Every Oracle product that is certified on Windows means it is also certified and supported when running on Windows in a virtualized environment with Oracle VM as long as the Windows OS is supported with Oracle VM.
Hardware
Platform
JFB
Support
J2SE
Support
Operating System VersionDesktop ManagersBrowsersJREJDK
Solaris™ Operating System, 32-bit and 64-bit
1 Solaris
x64
(64-bit)
JFBJ2SESolaris 10 OS (32/64 bit)JDS, Gnome 2-metacity, CDE-dtwmFirefox 1.5
Firefox 2.0.x
Mozilla 1.7
32-bit Install
53MB Disk
64-bit Install
23MB Disk
32-bit Install
122MB Disk
64-bit Install
26MB Disk
Solaris
SPARC
JFBJ2SESolaris 10 OS (32/64 bit)JDS-Gnome 2-metacity, CDE-dtwmFirefox 1.5
Firefox 2.0.x
Mozilla 1.7
32-bit Install
65MB Disk
64-bit Install
29MB Disk
32-bit Install
134MB Disk
64-bit Install
33MB Disk
JFBJ2SESolaris 9 OS (32/64 bit)Gnome 2-metacity, CDE-dtwmMozilla 1.4
Netscape 7
JFBJ2SESolaris 8 OS (32/64 bit)CDE-dtwm/OpenWin-olwmNetscape 4.7
Solaris
x86
(32-bit)
JFBJ2SESolaris 10 OS (32 bit)JDS-Gnome 2-metacity, CDE-dtwmFirefox 1.5
Firefox 2.0.x
Mozilla 1.7
32-bit Install
53MB Disk
32-bit Install
122MB Disk
JFBJ2SESolaris 9 OS (32 bit)Gnome 2-metacity, CDE-dtwmMozilla 1.4
Netscape 7
JFBJ2SESolaris 8 OS (32 bit)CDE-dtwm/OpenWin-olwmNetscape 4.7
Windows (32-bit)
Windows
x86
JFB Windows 7 Home PremiumAero, Windows XP & Classic DesktopIE 8.x
Firefox 2.0.x,
Firefox 3.0.x or
Firefox 3.5.x
Install
Disk space
Install
Disk space
JFB Windows 7 Professional
JFB Windows 7 Ultimate
JFBJ2SEWindows Vista Home Basic (SP1,SP2)Windows XP & Classic DesktopIE 7.x or IE 8.x
Firefox 2.0.x,
Firefox 3.0.x or
Firefox 3.5.x
JFBJ2SEWindows Vista Home Premium (SP1,SP2)
JFBJ2SEWindows Vista Home Business (SP1,SP2)
JFBJ2SEWindows Vista Home Ultimate (SP1, SP2)
JFB Windows Server 2008 Standard (SP1, SP2)Windows XP & Classic DesktopIE 7.x or IE 8.x
Firefox 2.0.x,
Firefox 3.0.x or
Firefox 3.5.x
JFB Windows Server 2008 Enterprise (SP1, SP2)
JFB Windows Server 2008 Datacenter (SP1, SP2)
JFB Windows Web Server 2008 (SP1, SP2)
JFBJ2SEWindows 2000 Professional (SP3, SP4)Windows Active & Classic DesktopIE 5.50 or IE 6
Mozilla 1.4
Mozilla 1.7
Firefox 2.0.x
JFBJ2SEWindows 2000 Server (SP3, SP4)
JFBJ2SEWindows 98 (2nd Edition)Classic DesktopIE 5.50 or IE 6
JFBJ2SEWindows MEClassic DesktopIE 5.50 or IE 6
JFBJ2SEWindows Server 2003, Web Edition (R2, SP1, SP2)Windows XP & Classic DesktopIE 6 or IE 7.x or IE 8.x
Firefox 2.0.x,
Firefox 3.0.x or
Firefox 3.5.x
JFBJ2SEWindows Server 2003, Standard Edition (R2, SP1, SP2)
JFBJ2SEWindows Server 2003, Enterprise Edition (R2, SP1, SP2)
JFBJ2SEWindows Server 2003, Datacenter Edition (R2, SP1, SP2)
Windows 64-bit
3 Windows
x64
JFB Windows 7 Home PremiumAero, Windows XP & Classic Desktop
  • 64-bit OS, 32-bit Browsers:
    IE 8.x
    Firefox 2.0.x,
    Firefox 3.0.x or
    Firefox 3.5.x
Install
Disk space
Install
Disk space
JFB Windows 7 Professional
JFB Windows 7 Ultimate
JFB Windows Server 2008 R2 StandardAero, Windows XP & Classic Desktop
  • 64-bit OS, 32-bit Browsers:
    IE 8.x
    Firefox 2.0.x,
    Firefox 3.0.x or
    Firefox 3.5.x
JFB Windows Server 2008 R2 Enterprise
JFB Windows Server 2008 R2 Datacenter
JFB Windows Web Server 2008 R2
JFBJ2SEWindows Vista Home Basic (SP1, SP2)Windows XP & Classic Desktop
  • 64-bit OS, 32-bit Browsers:
    IE 7.x or IE 8.x
    Firefox 2.0.x,
    Firefox 3.0.x or
    Firefox 3.5.x
JFBJ2SEWindows Vista Home Premium (SP1, SP2)
JFBJ2SEWindows Vista Home Business (SP1, SP2)
JFBJ2SEWindows Vista Home Ultimate (SP1, SP2)
JFB Windows Server 2008 Standard (SP1, SP2)Windows XP & Classic Desktop
  • 64-bit OS, 32-bit Browsers:
    IE 7.x or IE 8.x
    Firefox 2.0.x,
    Firefox 3.0.x or
    Firefox 3.5.x
JFB Windows Server 2008 Enterprise (SP1, SP2)
JFB Windows Server 2008 Datacenter (SP1, SP2)
JFB Windows Web Server 2008 (SP1, SP2)
JFBJ2SEWindows 2003, Standard Edition (R2, SP1, SP2)Windows XP & Classic Desktop
  • 64-bit OS, 32-bit Browsers:
    IE 6 or IE 7.x or IE 8.x
    Firefox 2.0.x,
    Firefox 3.0.x or
    Firefox 3.5.x
JFBJ2SEWindows 2003, Enterprise Edition (R2, SP1, SP2)
JFBJ2SEWindows 2003, Datacenter Edition (R2, SP1, SP2)
Linux 32-bit
Linux
x86
JFB Oracle Enterprise Linux 6.xGnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5Firefox 3.0.x or Firefox 3.5.xInstall
59MB Disk
Install
131MB Disk
JFB Oracle Enterprise Linux 5.6+Gnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5Firefox 3.0.x or Firefox 3.5.x
JFB Oracle Enterprise Linux 5.5Gnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5Firefox 3.0.x or Firefox 3.5.x
JFB Oracle Enterprise Linux 5.4Gnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5Firefox 3.0.x or Firefox 3.5.x
JFB Oracle Enterprise Linux 4.8Gnome 2.7.3 - Metacity 2.6.2Firefox 2.0.x or Firefox 3.0.x
JFB Red Hat Enterprise Linux 6.xGnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5Firefox 3.0.x or Firefox 3.5.x
JFB Red Hat Enterprise Linux 5.6+Gnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5Firefox 3.0.x or Firefox 3.5.x
JFB Red Hat Enterprise Linux 5.5Gnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5Firefox 3.0.x or Firefox 3.5.x
JFB Red Hat Enterprise Linux 5.4Gnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5Firefox 2.0.x or Firefox 3.0.x
JFBJ2SERed Hat Enterprise Linux 5.0 (5.1, 5.2, 5.3)Gnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5Firefox 2.0.x or Firefox 3.0.x
JFBJ2SERed Hat Enterprise Linux AS 4.0 (4.1 - 4.8)Gnome 2.8.0-metacity 2.6.2Firefox 2.0.x
Mozilla 1.4
Mozilla 1.7
JFBJ2SERed Hat Enterprise Linux ES 4.0 (4.1 - 4.8)Gnome 2.8.0-metacity 2.6.2
JFBJ2SERed Hat Enterprise Linux AS 3.0Gnome 2.2.2-metacity 2.6.2Mozilla 1.4
JFBJ2SERed Hat Enterprise Linux ES 3.0Gnome 2.2.2-metacity 2.6.2
JFBJ2SERed Hat Enterprise Linux WS 2.1Gnome 1.4-sawfish 1.0
JFBJ2SERed Hat Enterprise Linux ES 2.1Gnome 1.4-sawfish 1.0
JFBJ2SERed Hat Enterprise Linux AS 2.1Gnome 1.4-sawfish 1.0
JFBJ2SESUSE 10Gnome 2.12.0.1-2 - Metacity 2.12.0-3Firefox 2.0.x
JFBJ2SESUSE 9.2Gnome 2.6.1-metacity 2.6.2Mozilla 1.4
JFBJ2SESUSE 9.1Gnome 2.2-metacity 2.6.2
JFBJ2SESUSE 9Gnome 2.2-metacity 2.6.2
JFBJ2SESUSE 8.2Gnome 2.2-metacity 2.6.2
JFBJ2SESLEC 8Gnome 2.0-metacity 2.6.2
JFB SLES 11GNOME 2.24.1-2.28 - Metacity is 2.24.0-3Firefox 3.0.6 or 3.0.8
JFBJ2SESLES 10Gnome 2.12.0.1-26.6 - Metacity 2.12.3-0.15Firefox 2.0.x
JFBJ2SESLES 9Gnome 2.4.0-metacity 2.6.2Mozilla 1.4
JFBJ2SESLES 8Gnome 2.0.5-metacity 2.6.2
JFBJ2SETurboLinux 8.0Gnome-sawfish 1.0
JFBJ2SESun Java™ Desktop System, Release 2Gnome 2-metacity 2.4
JFBJ2SESun Java™ Desktop System, Release 1Gnome 2-metacity 2.4
Linux 64-bit
5 Linux
x64
JFB Oracle Enterprise Linux 6.xGnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5
  • 64-bit OS, 32-bit Browsers:
    Firefox 3.0.x or Firefox 3.5.x
Install
57MB Disk
Install
118MB Disk
JFB Oracle Enterprise Linux 5.6+Gnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5
  • 64-bit OS, 32-bit Browsers:
    Firefox 3.0.x or Firefox 3.5.x
JFB Oracle Enterprise Linux 5.5Gnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5
  • 64-bit OS, 32-bit Browsers:
    Firefox 3.0.x or Firefox 3.5.x
JFB Oracle Enterprise Linux 5.4Gnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5
  • 64-bit OS, 32-bit Browsers:
    Firefox 3.0.x or Firefox 3.5.x
JFB Oracle Enterprise Linux 4.8Gnome 2.7.3 - Metacity 2.6.2
  • 64-bit OS, 32-bit Browsers:
    Firefox 2.0.x or Firefox 3.0.x
JFB Red Hat Enterprise Linux 6.xGnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5
  • 64-bit OS, 32-bit Browsers:
    Firefox 3.0.x or Firefox 3.5.x
JFB Red Hat Enterprise Linux 5.6+Gnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5
  • 64-bit OS, 32-bit Browsers:
    Firefox 3.0.x or Firefox 3.5.x
JFB Red Hat Enterprise Linux 5.5Gnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5
  • 64-bit OS, 32-bit Browsers:
    Firefox 3.0.x or Firefox 3.5.x
JFB Red Hat Enterprise Linux 5.4Gnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5
  • 64-bit OS, 32-bit Browsers:
    Firefox 2.0.x or Firefox 3.0.x
JFBJ2SERed Hat Enterprise Linux 5.0 (5.1, 5.2, 5.3)Gnome 2.16.0-6.el5 - Metacity 2.16.0-12.el5
  • 64-bit OS, 32-bit Browsers:
    Firefox 2.0.x or Firefox 3.0.x
JFBJ2SERed Hat Enterprise Linux AS 4.0 (4.1 - 4.8).Gnome 2.8.0-metacity 2.6.2
  • 64-bit OS, 32-bit Browsers:
    Firefox 2.0.x
    Mozilla 1.4 or Mozilla 1.7
JFBJ2SERed Hat Enterprise Linux ES 4.0 (4.1 - 4.8)Gnome 2.8.0-metacity 2.6.2
JFBJ2SERed Hat Enterprise Linux AS 3.0Gnome 2.2.2-metacity 2.6.2
  • 64-bit OS, 32-bit Browsers:
    Mozilla 1.4
JFBJ2SERed Hat Enterprise Linux ES 3.0Gnome 2.2.2-metacity 2.6.2
JFBJ2SESUSE 9.2Gnome 2.6.1-metacity 2.6.2
JFBJ2SESUSE 9.1Gnome 2.2-metacity 2.6.2
JFBJ2SESUSE 9Gnome 2.2-metacity 2.6.2
JFBJ2SESUSE 8.2Gnome 2.2-metacity 2.6.2
JFB SLES 11GNOME 2.24.1-2.28 - Metacity is 2.24.0-3
  • 64-bit OS, 32-bit Browsers:
    Firefox 3.0.6 or 3.0.8
JFBJ2SESLES 10Gnome 2.12.0.1-26.6 - Metacity 2.12.3-0.15
  • 64-bit OS, 32-bit Browsers:
    Firefox 2.0.x
JFBJ2SESLES 9Gnome 2.4.0-metacity 2.6.2
  • 64-bit OS, 32-bit Browsers:
    Mozilla 1.4
JFBJ2SESLES 8Gnome 2.0.5-metacity 2.6.2

Note: As of April 8, 2014 Microsoft stopped supporting Windows XP and therefore it is no longer a supported platform. See Third Party Vendor-Specific Support Terms on Oracle Software Technical Support Policies for details.

Update Release Footnotes

  • Oracle Enterprise Linux 5.5 support for JFB was introduced in 1.5.0_24.
  • Oracle Enterprise Linux 5.4 support for JFB was introduced in 1.5.0_24.
  • Oracle Enterprise Linux 4.8 support for JFB was introduced in 1.5.0_24.
  • Red Hat Enterprise Linux 5.6 support for JFB was introduced in 1.5.0_29.
  • Red Hat Enterprise Linux 5.5 support for JFB was introduced in 1.5.0_24.
  • Red Hat Enterprise Linux 5.4 support for JFB was introduced in 1.5.0_21.
  • Windows 7 support was introduced in 1.5.0_21.
  • Windows Server 2008 R2 support was introduced in 1.5.0_21.
  • Windows Vista SP2 support was added in 1.5.0_21.
  • Windows Server 2008 SP2 support was added in 1.5.0_21.
  • SLES 11 support was added in 1.5.0_19.
  • Red Hat Enterprise Linux 5.3 support was added in 1.5.0_19.
  • Windows Server 2008 support was added in 1.5.0_19.
  • Red Hat Enterprise Linux 5.0 support was added in 1.5.0_16.
  • Windows Vista support was added in 1.5.0_14.
  • Solaris x64 support was introduced in 1.5.0_02.
  • AMD64/EM64T 32-bit mode Windows support was introduced in 1.5.0_02.
    Prior to 1.5.0_02, J2SE 5.0 supports AMD Opteron (32) Windows in this configuration.
  • AMD64/EM64T 64-bit mode Windows support was introduced in 1.5.0_02.
    Prior to 1.5.0_02, J2SE 5.0 supports AMD Opteron (64) Windows in this configuration.
  • AMD64/EM64T 32-bit mode Linux support was introduced in 1.5.0_02.
    Prior to 1.5.0_02, J2SE 5.0 supports AMD Opteron (32) Linux in this configuration.
  • AMD64/EM64T 64-bit mode Linux support was introduced in 1.5.0_02.
    Prior to 1.5.0_02, J2SE 5.0 supports AMD Opteron (64) Linux in this configuration.

Browser Footnotes

Browsers listed above are supported for Java™ Plug-in software and Java™ Web Start software.

  • 64-bit support for Java Plug-in software is currently not available.
  • For 64-bit versions of Solaris OS, Linux, and Windows, support is for 32-bit browsers only.
  • Netscape 7 and 7.1 are not offically supported, but should work.
  • For AMD64/EM64T 64-bit mode, support is for 32-bit browsers only.
  • Firefox 3.5.1 support was added in 1.5.0_21.
  • Firefox 3.6 is not fully compatible with its earlier versions, and therefore J2SE 5.0 does not work with Firefox 3.6.
    For Java based web applications to work, the Firefox 3.6 browser requires you to run Java SE 6 Update 18 or later.

Other Operating System Notes

Oracle is reviewing the Sun product roadmap and will provide guidance to customers in accordance with Oracle's standard product communication policies. Any resulting features and timing of release of such features as determined by Oracle's review of roadmaps, are at the sole discretion of Oracle. All product roadmap information, whether communicated by Sun Microsystems or by Oracle, does not represent a commitment to deliver any material, code, or functionality, and should not be relied upon in making purchasing decisions. It is intended for information purposes only, and may not be incorporated into any contract.



Left Curve
Java SDKs and Tools
Right Curve
Left Curve
Java Resources
Right Curve
VTS OnDemand RHS Banner



Duke's Choice RHS Banner

JavaOne 2014 Replay banner