JMF 2.1.1 - SW/HW Requirements

 

JMF Documentation


This page lists the hardware and software requirements for:

JMF 2.1.1 FCS Cross Platform

Hardware Requirements

  • 200 MHz Pentium, 160 MHz PowerPC, or 166 MHz UltraSparc
  • At least 64 MB RAM

Software Requirements

  • JDK 1.1.5 or later from Sun. (Tested on 1.1.5, 1.1.6, 1.1.7, and the Java 2 platform) Use of a JIT is strongly recommended. JDK 1.1.6 or later is required for Y2K compatibility.
  • Java 2 or JDK 1.x with Swing 1.1 or above to run JMFCustomizer.
  • JMF classes (included in this release).
  • Optional: Sample applets and applications (included in this release).
  • Optional: HotJava TM Browser 1.1.x (from Sun).
  • Optional: Netscape Communicator 4.03-4.05 with the JDK 1.1 patch or Netscape Communicator 4.06 or later.
  • Optional: Microsoft Internet Explorer 4.01 or later.
JMF 2.1.1 FCS with Windows Performance Pack

Hardware Requirements

  • 486 or Pentium based PC (Pentium 100MHz or better recommended).
  • Display card supporting 8, 16, 24 or 32 bit display mode.  (16-bit display mode recommended for fastest video performance).
  • Optional: A SoundBlaster-compatible sound card for Windows machines without built-in audio support.

Software Requirements

  • Windows 95/98 or Windows NT 4.0.
  • JDK 1.1.3 or later for Windows (from Sun). JDK 1.1.6 or later is required for Y2K compatibility.
  • Microsoft DirectShow (req. for MPEG playback).
  • JMF classes and native libraries (included in this release).
  • Optional: Sample applets and applications (included in this release).
  • Optional: Microsoft DirectX 2.1 or greater.
  • Optional: HotJava Browser 1.1.x (from Sun).
  • Optional: Netscape Communicator 4.03-4.05 with the JDK 1.1 patch or Netscape Communicator 4.06 or later.
  • Optional: Microsoft Internet Explorer 4.0 or later; 3.02 (requires Java Plug-in).

Capture Requirements

  • Video For Windows (VFW), Windows implementation only.
  • DirectShow (DS), Windows implementation only.
  • JavaSound, all implementations.
JMF 2.1.1 FCS with Solaris Performance Pack

Hardware Requirements

  • SparcStation 10, SparcStation 20, or an UltraSparc-based (recommended) workstation.
  • 8-bit or 24-bit frame buffer (24-bit recommended).

Software Requirements

  • Solaris 7 and above.
  • JDK 1.1.3 or later for Solaris (from Sun). JDK 1.1.6 or later is required for Y2K compatibility. See Running JMF on Solaris 7 for more information on using JMF with Solaris 7.
  • JMF classes and native libraries (included in this release).
  • Optional: Sample applets and applications (included in this release).
  • Optional: HotJava TM Browser 1.1.x (from Sun).
  • Optional: Netscape Communicator 4.06 or later.

Capture Requirements

  • SunVideo or SunVideoPlus, Solaris implementation only.
  • JavaSound, all implementations.
JMF 2.1.1 FCS with Linux Performance Pack

Hardware Requirements

  • Intel Pentium or equivalent x86 based PC
  • 8-bit, 16-bit, 24-bit or 32-bit frame buffer (24/32-bit recommended).

Software Requirements

  • Red Hat Linux 6.2 or better.
  • JDK 1.1.3 or later for Linux. JDK 1.1.6 or later is required for Y2K compatibility.
  • JMF classes and native libraries (included in this release).
  • Optional: Sample applets and applications (included in this release).
  • Optional: HotJava TM Browser 1.1.x (from Sun).
  • Optional: Netscape Communicator 4.06 or later.

Capture Requirements

  • Any capture card or camera that has a Video4Linux driver (bttv based cards are recommended)
RTP Servers and Clients

RTP Server Requirements

online documentation

RTP Client Requirements