Oracle Business Process Management logo

Oracle BPM Interoperability Matrix


Contents:





Oracle BPM Virtualization Policy

Oracle BPM now adheres to the Oracle-wide virtualization policy. For more information, see Supported Virtualization Technologies with Oracle Fusion Middleware.
 



Oracle BPM Studio 10.3.0 and 10.3.1



Operating System:

  • Windows Vista (on x86-32 and x86-64)
  • Windows XP SP2 (on x86-32 and x86-64)
  • Linux Red Hat 4.x and 5.x (on x86-32)
  • Linux SUSE 9 and 10 (on x86-32)
  • Mac OS X 10.5 (Leopard)

Application Server:

N/A

Database:

Embedded Derby DB


Browsers:

  • IE 6.0 and 7.0
  • Firefox 2.0
  • Safari 3.0


JVM Version:

  • Sun 1.5.0_11+ (included on x86-32 Studio distributions)
  • Sun 1.6.0_05+ (not included with Studio distributions)

top



Oracle BPM Studio 10.3.2



Operating System:

  • Windows 7 (on x86-32 and x86-64)
  • Windows XP SP3 (on x86-32 and x86-64)
  • Linux Red Hat 4.x and 5.x (on x86-32)
  • Linux SUSE 9 and 10 (on x86-32)

Application Server:

N/A

Database:

Embedded Derby DB


Browsers:

  • IE 7.0 and 8.0
  • Firefox 3.5+
  • Safari 3.0


JVM Version:

  • Sun 1.5.0_11+ (included on x86-32 Studio distributions)
  • Sun 1.6.0_05+ (not included with Studio distributions)

top



Oracle BPM Studio 10.3.3



Operating System:

  • Windows 7 (on x86-32 and x86-64)
  • Windows XP SP3 (on x86-32 and x86-64)
  • Linux Red Hat 4.x and 5.x (on x86-32)
  • Linux SUSE 9 and 10 (on x86-32)

Application Server:

N/A

Database:

Embedded Derby DB


Browsers:

  • IE 7.0 and 8.0
  • Firefox 3.5+
  • Safari 3.0


JVM Version:

  • Sun 1.5.0_11+ (included on x86-32 Studio distributions)
  • Sun 1.6.0_05+ (not included with Studio distributions)

top


ALBPM Studio 6.0



Operating System:

  • Windows Server 2003 SP1 & SP2 (x86-32)
  • Windows XP SP2 (x86-32)
  • Linux RHEL 4 (x86-32)
  • Linux RHEL 5.x (on x86-32)
  • Linux SUSE 10.0 (x86-32)

Application Server:

N/A

Database:

Embedded Derby DB


Browsers:

  • IE 6.0 and 7.0
  • Firefox 2.0


JVM Version:

  • Sun 1.5.0_11+ (included on x86-32 Studio distributions)
  • Sun 1.6.0_05+ (not included with Studio distributions)
  • JRockit 5.0 R27 for Linux RHEL 5.x

top


Oracle BPM Enterprise Standalone 10.3.0 and 10.3.1



Operating System:

  • Windows 2003 SP1 & SP2 (on x86-32 and x86-64)
  • Windows 2008 (on x86-32 and x86-64)
  • Linux Red Hat 4.x and 5.x (do not use virtualizatior XEN Kernel with WLS) (on x86-32 and x86-64)
  • Linux SUSE 9 and 10 (on x86-32 and x86-64)
  • OEL 4/OVM and OEL 5.0/OVM (on x86-32 and x86-64)
  • AIX 5.3
  • Solaris 10 (on SPARC 64)
  • HP-UX 11iv3 (Itanium and PA-RISC 64 bits)


Application Server:

  • WorkSpace: Tomcat Servlet 5.5.15, BEA WebLogic Server 10.0.1 (it can also be deployed on a WLP 10.0.1 WLS instance), Oracle WebLogic Server 10.3.0
  • Process Administrator: Tomcat Servlet 5.5.15
  • WorkSpace Administrator: Tomcat Servlet 5.5.15, BEA WebLogic Server 10.0.1, Oracle WebLogic Server 10.3.0
  • Archive Viewer: Tomcat Servlet 5.5.15, BEA WebLogic Server 10.0.1, Oracle WebLogic Server 10.3.0
  • PAPI-WS: Tomcat Servlet 5.5.15, BEA WebLogic Server 10.0.1, Oracle WebLogic Server 10.3.0
  • RSS Feeds: Tomcat Servlet 5.5.15, BEA WebLogic Server 10.0.1, Oracle WebLogic Server 10.3.0
  • ALSB Custom Transport EAR: N/A

The Oracle BPM 10gR3 Engine can be deployed the Advanced and Premium versions of WebLogic Server.


Engine Database:

  • Oracle 9i, 10g, and 11gR1 (including RAC configurations)
  • MS SQL Server 2005
  • IBM UDB DB2 8.1 and 9.1
  • Sybase 15.0

Access to all these databases are accomplished through the usage of Oracle BPM Embedded DataDirect JDBC Drivers

JMS Provider:

N/A


Directory Service:

  • Single Source JNDI Plugins: Not available. Deprecated in ALBPM 6.0.
  • Single Source JDBC Plugins: Oracle 9i, 10g and 11gR1, MS SQLServer 2005, IBM DB2 UDB 8.1 and 9.1 using DataDirect JDBC Drivers 3.6; Sybase ASE 15.0.2
  • Hybrid Plugins: Sun ONE System Directory Server 5.1.3 and 5.2 with Oracle 9i/10g/11gR1, MS Active Directory 2000/2003 and Oracle 9i/10g/11gR1, MS Active Directory 2000/2003 and MS SQL Server 2005, Sun ONE System Directory Server 5.1.3 and 5.2 with IBM DB2 8.1 or 9.1, Novell eDirectory 8.8 SP3 and Oracle 9i/10g/11gR1, Oracle Internet Directory 10.1.4.2 and Oracle 9i/10g/11gR1.


Browsers:

  • IE 6.0 and 7.0
  • Firefox 2.0
  • Safari 3.0


JVM Version:

  • Sun and JRockit JVM 1.6.0_05+ running in 32 bits mode (Linux RHEL 4.x and 5.x on x86-32 and x86-64; Linux SUSE 9 and 10 on x86-32 and x86-64; Linux OEL 4/OVM and OEL 5.0/OVM on x86-32 and x86-64; Windows 2008 on x86-32 and x86-64; Windows 2003 SP1 & SP2 on x86-32 and x86-64; Solaris 10 SPARC-32)
  • Sun JVM 1.6.0_05+ running in 64 bits mode (Solaris SPARC-64)
  • JRockit JVM 1.6.0_05+ running in 64 bits mode (Solaris 10 SPARC-64)
  • HP JVM 1.6 running in 32 bits mode (HP-UX 11iv3 PA-RISC-32)
  • HP JVM 1.6 running in 64 bits mode (HP-UX 11iv3 Itanium-64)
  • IBM Java 5 SR2 running in 32/64 bits mode (AIX 5.3 PPC)

top



Oracle BPM Enterprise Standalone 10.3.2



Operating System:

  • Windows 2003 SP1 & SP3 (on x86-32 and x86-64)
  • Windows 2008 (on x86-32 and x86-64)
  • Linux Red Hat 4.x and 5.x (do not use virtualizatior XEN Kernel with WLS) (on x86-32 and x86-64)
  • Linux SUSE 9 and 10 (on x86-32 and x86-64)
  • OEL 4/OVM and OEL 5.0/OVM (on x86-32 and x86-64)
  • AIX 5.3; Solaris 10 (on SPARC 64)
  • HP-UX 11iv3 (Itanium and PA-RISC 64 bits)


Application Server:

  • WorkSpace: Tomcat Servlet 5.5.15, Oracle WebLogic Server 10.3.0 and 10.3.3
  • Process Administrator: Tomcat Servlet 5.5.15
  • WorkSpace Administrator: Tomcat Servlet 5.5.15, Oracle WebLogic Server 10.3.0 and 10.3.3
  • Archive Viewer: Tomcat Servlet 5.5.15, Oracle WebLogic Server 10.3.0 and 10.3.3
  • PAPI-WS: Tomcat Servlet 5.5.15, Oracle WebLogic Server 10.3.0 and 10.3.3
  • RSS Feeds: Tomcat Servlet 5.5.15, Oracle WebLogic Server 10.3.0 and 10.3.3
  • ALSB Custom Transport EAR: N/A.

The Oracle BPM 10gR3 Engine can be deployed the Advanced and Premium versions of WebLogic Server.


Engine Database:

  • Oracle 9i, 10g, 11gR1 and 11gR2 (including RAC configurations)
  • MS SQL Server 2005
  • IBM UDB DB2 8.1 and 9.1
  • Sybase 15.0

Access to all these databases are accomplished through the usage of Oracle BPM Embedded DataDirect JDBC Drivers. Oracle Databases can also be accessed using Oracle Thin JDBC Drivers.

JMS Provider:

N/A


Directory Service:

  • Single Source JNDI Plugins: Not available. Deprecated in ALBPM 6.0.
  • Single Source JDBC Plugins: Oracle 9i, 10g, 11gR1 and 11gR2, MS SQLServer 2005, IBM DB2 UDB 8.1 and 9.1 using DataDirect JDBC Drivers 3.6; Sybase ASE 15.0.2
  • Hybrid Plugins: Sun ONE System Directory Server 5.1.3 and 5.2 with Oracle 9i/10g/11gR1/11gR2, MS Active Directory 2000/2003 and Oracle 9i/10g/11gR1/11gR2, MS Active Directory 2000/2003 and MS SQL Server 2005, Sun ONE System Directory Server 5.1.3 and 5.2 with IBM DB2 8.1 or 9.1, Novell eDirectory 8.8 SP3 and Oracle 9i/10g/11gR1/11gR2, Oracle Internet Directory 10.1.4.2 and Oracle 9i/10g/11gR1/11gR2.


Browsers:

  • IE 7.0 and 8.0
  • Firefox 3.5+
  • Safari 3.0


JVM Version:

  • Sun and JRockit JVM 1.6.0_05+ running in 32 bits mode (Linux RHEL 4.x and 5.x on x86-32 and x86-64; Linux SUSE 9 and 10 on x86-32 and x86-64; Linux OEL 4/OVM and OEL 5.0/OVM on x86-32 and x86-64; Windows 2008 on x86-32 and x86-64; Windows 2003 SP1 & SP3 on x86-32 and x86-64; Solaris 10 SPARC-32)
  • Sun JVM 1.6.0_05+ running in 64 bits mode (Solaris SPARC-64)
  • JRockit JVM 1.6.0_05+ running in 64 bits mode (Solaris 10 SPARC-64)
  • HP JVM 1.6 running in 32 bits mode (HP-UX 11iv3 PA-RISC-32)
  • HP JVM 1.6 running in 64 bits mode (HP-UX 11iv3 Itanium-64)
  • IBM Java 5 SR2 running in 32/64 bits mode (AIX 5.3 PPC)

top



Oracle BPM Enterprise Standalone 10.3.3



Operating System:

  • Windows 2003 SP1 & SP3 (on x86-32 and x86-64)
  • Windows 2008 (on x86-32 and x86-64)
  • Linux Red Hat 4.x and 5.x (do not use virtualizatior XEN Kernel with WLS) (on x86-32 and x86-64)
  • Linux SUSE 9 and 10 (on x86-32 and x86-64)
  • OEL 4/OVM and OEL 5.0/OVM (on x86-32 and x86-64)
  • AIX 5.3; Solaris 10 (on SPARC 64)
  • HP-UX 11iv3 (Itanium and PA-RISC 64 bits)


Application Server:

  • WorkSpace: Tomcat Servlet 5.5.15, Oracle WebLogic Server 10.3.0 and 10.3.3
  • Process Administrator: Tomcat Servlet 5.5.15
  • WorkSpace Administrator: Tomcat Servlet 5.5.15, Oracle WebLogic Server 10.3.0 and 10.3.3
  • Archive Viewer: Tomcat Servlet 5.5.15, Oracle WebLogic Server 10.3.0 and 10.3.3
  • PAPI-WS: Tomcat Servlet 5.5.15, Oracle WebLogic Server 10.3.0 and 10.3.3
  • RSS Feeds: Tomcat Servlet 5.5.15, Oracle WebLogic Server 10.3.0 and 10.3.3
  • ALSB Custom Transport EAR: N/A.

The Oracle BPM 10gR3 Engine can be deployed the Advanced and Premium versions of WebLogic Server.


Engine Database:

  • Oracle 9i, 10g, 11gR1 and 11gR2 (including RAC configurations)
  • MS SQL Server 2005
  • IBM DB2 UDB 8.1 and 9.1
  • Sybase 15.0

Access to all these databases are accomplished through the usage of Oracle BPM Embedded DataDirect JDBC Drivers. Oracle Databases can also be accessed using Oracle Thin JDBC Drivers.

JMS Provider:

N/A


Directory Service:

  • Single Source JNDI Plugins: Not available. Deprecated in ALBPM 6.0.
  • Single Source JDBC Plugins: Oracle 9i, 10g, 11gR1 and 11gR2, MS SQLServer 2005, IBM DB2 UDB 8.1 and 9.1 using DataDirect JDBC Drivers 4.2; Sybase ASE 15.0.2
  • Hybrid Plugins: Sun ONE System Directory Server 5.1.3 and 5.2 with Oracle 9i/10g/11gR1/11gR2, MS Active Directory 2000/2003 and Oracle 9i/10g/11gR1/11gR2, MS Active Directory 2000/2003 and MS SQL Server 2005, Sun ONE System Directory Server 5.1.3 and 5.2 with IBM DB2 8.1 or 9.1, Novell eDirectory 8.8 SP3 and Oracle 9i/10g/11gR1/11gR2, Oracle Internet Directory 10.1.4.2 and Oracle 9i/10g/11gR1/11gR2.


Browsers:

  • IE 7.0 and 8.0
  • Firefox 3.5+
  • Safari 3.0


JVM Version:

  • Sun and JRockit JVM 1.6.0_05+ running in 32 bits mode (Linux RHEL 4.x and 5.x on x86-32 and x86-64; Linux SUSE 9 and 10 on x86-32 and x86-64; Linux OEL 4/OVM and OEL 5.0/OVM on x86-32 and x86-64; Windows 2008 on x86-32 and x86-64; Windows 2003 SP1 & SP3 on x86-32 and x86-64; Solaris 10 SPARC-32)
  • Sun JVM 1.6.0_05+ running in 64 bits mode (Solaris SPARC-64)
  • JRockit JVM 1.6.0_05+ running in 64 bits mode (Solaris 10 SPARC-64)
  • HP JVM 1.6 running in 32 bits mode (HP-UX 11iv3 PA-RISC-32)
  • HP JVM 1.6 running in 64 bits mode (HP-UX 11iv3 Itanium-64)
  • IBM Java 5 SR2 running in 32/64 bits mode (AIX 5.3 PPC)

top


ALBPM Enterprise Standalone 6.0



Operating System:

  • Windows Server 2003 SP1 & SP2 or R2 (x86-32)
  • Linux SUSE 10.0 (x86-32, x86-64, Itanium-64)
  • Linux RHEL 4.x (x86-32, x86-64, Itanium-64)
  • AIX 5.3, Solaris 9 and 10 (SPARC)
  • HP-UX 11.23 and 11.31 (Itanium-64)


Application Server:

  • WorkSpace: Tomcat Servlet 5.5.15, BEA WebLogic Server 9.2.1 and 9.2.2, WebLogic Server 10.0.1 (it can also be deployed on a WLP 10.0.1 WLS instance), IBM WebSphere 6.1.0.5 (other patch levels introduced problems)
  • Process Administrator: Tomcat Servlet 5.5.15
  • WorkSpace Administrator: Tomcat Servlet 5.5.15, BEA WebLogic Server 9.2.1 and 9.2.2, WebLogic Server 10.0.1, IBM WebSphere 6.1.0.5 (other patch levels introduced problems)
  • Archive Viewer: Tomcat Servlet 5.5.15, BEA WebLogic Server 9.2.1 and 9.2.2, WebLogic Server 10.0.1, IBM WebSphere 6.1.0.5 (other patch levels introduced problems)
  • PAPI-WS: Tomcat Servlet 5.5.15, BEA WebLogic Server 9.2.1 and 9.2.2, BEA WebLogic Server 10.0.1, IBM WebSphere 6.1.0.5 (other patch levels introduced problems)
  • RSS Feeds: Tomcat Servlet 5.5.15, BEA WebLogic Server 9.2.1 and 9.2.2, BEA WebLogic Server 10.0.1, IBM WebSphere 6.1.0.5 (other patch levels introduced problems)
  • ALSB Custom Transport EAR: BEA WebLogic 9.2.1 and 9.2.2

The AquaLogic BPM 6.0 Engine can be deployed the Advanced and Premium versions of WebLogic Server.


Engine Database:

  • Oracle 9i, 10g (including RAC)
  • MS SQLServer 2005
  • IBM DB2 UDB 8.1 and 9.1 using DataDirect Embedded JDBC Drivers (DataDirect 3.6)
  • Sybase ASE 15.0.2 will be supported in OBPM 10gR3

JMS Provider:

N/A


Directory Service:

  • Single Source JNDI Plugins: Sun ONE Java System Directory Server 5.2 (JNDI), MS Active Directory 2003 (JNDI). (Deprecated - they cannot be created any more)
  • Single Source JDBC Plugins: Oracle 9i and 10g, MS SQLServer 2005, IBM DB2 UDB 8.1 and 9.1 using DataDirect JDBC Drivers 3.6; Sybase ASE 15.0.2 will be supported in OBPM 10gR3
  • Hybrid Plugins: Sun ONE System Directory Server 5.1.3 and 5.2 with Oracle 9i, Sun ONE System Directory Server 5.1.3 and 5.2 with Oracle 10g, MS Active Directory 2003 and Oracle 9i, MS Active Directory 2003 and Oracle 10g, MS Active Directory 2003 and MS SQL Server 2005, Sun ONE System Directory Server 5.1.3 and 5.2 with IBM DB2 8.1 or 9.1.


Browsers:

  • IE 6.0 and 7.0
  • Firefox 2.0
  • Safari 3.0


JVM Version:

  • Sun 1.5.0_11^ for Windows Server 2003 SP1 & SP2 (x86-32)
  • SUSE Linux 10.0 (x86-32)
  • Red Hat Enterprise Linux 4 (x86-32)
  • Solaris 9 and 10 (SPARC)
  • JRockit 5 for Red Hat Enterprise Linux 4 (Itanium-64 and x86-64) and Suse 10.0 (Itanium-64 and x86-64)
  • IBM 1.5.0_06 64 bits for AIX 5.3 running 32 bit JVM, HP-UX 11v2 and 11v3 Itanium-64 using HP-UX JVM 1.5.0_05

top


Oracle BPM Enterprise 10.3.0 and 10.3.1 for WebLogic



Operating System:

  • Windows 2003 SP1 & SP2 (on x86-32 and x86-64)
  • Windows 2008 (on x86-32 and x86-64)
  • Linux Red Hat 4.x and 5.x (do not use virtualization or XEN Kernel) (on x86-32 and x86-64)
  • Linux SUSE 9 and 10 (on x86-32 and x86-64)
  • OEL 4/OVM and OEL 5.0/OVM (on x86-32 and x86-64)
  • AIX 5.3 and AIX 6.1
  • Solaris 10 (on SPARC)
  • HP-UX 11iv3 (Itanium and PA-RISC 64 bits)

Application Server:

WLS 10.0.1 and 10.3.0:

  • WorkSpace: BEA WebLogic Server 10.0.1 (it can also be deployed on a WLP 10.0.1 WLS instance) and Oracle WebLogic 10.3.0
  • Process Administrator: BEA WebLogic Server 10.0.1 and Oracle WebLogic 10.3.0
  • WorkSpace Administrator: BEA WebLogic Server 10.0.1 and Oracle WebLogic 10.3.0
  • Archive Viewer: BEA WebLogic Server 10.0.1 and Oracle WebLogic 10.3.0
  • BPM Deployer: BEA WebLogic Server 10.0.1 and Oracle WebLogic 10.3.0
  • PAPI-WS: BEA WebLogic Server 10.0.1 and Oracle WebLogic 10.3.0
  • RSS Feeds: BEA WebLogic Server 10.0.1 and Oracle WebLogic 10.3.0
  • ALSB Custom Transport EAR: BEA WebLogic Server 10.0.1 and Oracle WebLogic 10.3.0.

WLP 10.2:

  • WorkSpace: BEA WebLogic Portal 10.2.

The Oracle BPM 10gR3 Engine can be deployed the Advanced and Premium versions of WebLogic Server.


Engine Database:

  • Oracle 9i, 10g, and 11gR1 (including RAC configurations)
  • MS SQL Server 2005
  • IBM UDB DB2 8.1 and 9.1
  • Sybase 15.0

Access to all these databases are accomplished through the usage of Oracle BPM Embedded DataDirect JDBC Drivers.


JMS Provider:

  • TIBCO EMS 4.1 and 4.2
  • BEA WebLogic 10.0.1
  • Oracle BPM 10.3.0 Embedded. (XA Compliant Resources required)


Directory Service:

  • Single Source JNDI Plugins: Not available. Deprecated in ALBPM 6.0.
  • Single Source JDBC Plugins: Oracle 9i/10g/11gR1, MS SQLServer 2005, IBM DB2 UDB 8.1 and 9.1 using DataDirect JDBC Drivers 3.6; Sybase ASE 15.0.2
  • Hybrid Plugins: Sun ONE System Directory Server 5.1.3 and 5.2 with Oracle 9i/10g/11gR1, MS Active Directory 2000/2003 and Oracle 9i/10g/11gR1, MS Active Directory 2000/2003 and MS SQL Server 2005, Sun ONE System Directory Server 5.1.3 and 5.2 with IBM DB2 8.1 or 9.1, Novell eDirectory 8.8 SP3 and Oracle 9i/10g/11gR1, Oracle Internet Directory 10.1.4.2 and Oracle 9i/10g/11gR1.


Browsers:

  • IE 6.0 and 7.0
  • Firefox 2.0
  • Safari 3.0


JVM Version:

  • Sun JVM 1.6.0_05+ running in 32 bits mode (Linux RHEL 4.x and 5.x on x86-32 and x86-64; Linux SUSE 9 and 10 on x86-32 and x86-64; Linux OEL 4/OVM and OEL 5.0/OVM on x86-32 and x86-64)
  • JRockit JVM 1.6.0_05+ running in 32 or 64 bits mode (Linux RHEL 4.x and 5.x on x86-32 and x86-64; Linux SUSE 9 and 10 on x86-32 and x86-64; Linux OEL 4/OVM and OEL 5.0/OVM on x86-32 and x86-64)
  • Windows 2008 on x86-32 and x86-64
  • Windows 2003 SP1 & SP2 on x86-32 and x86-64
  • Solaris 10 SPARC-32
  • Sun JVM 1.6.0_05+ running in 64 bits mode (Solaris SPARC-64)
  • JRockit JVM 1.6.0_05+ running in 64 bits mode (Solaris 10 SPARC-64)
  • HP JVM 1.6 running in 32 bits mode (HP-UX 11iv3 PA-RISC-32)
  • HP JVM 1.6 running in 64 bits mode (HP-UX 11iv3 Itanium-64)
  • IBM Java 5 SR2 or SR10 running in 64 bits mode for embedded Tomcat instance and IBM Java 6 SR2 running 64 bits mode for WLS (AIX 5.3 PPC)

top


Oracle BPM Enterprise 10.3.2 for WebLogic



Operating System:

  • Windows 2003 SP1 & SP3 (on x86-32 and x86-64)
  • Windows 2008 (on x86-32 and x86-64)
  • Linux Red Hat 4.x and 5.x (do not use virtualization or XEN Kernel) (on x86-32 and x86-64)
  • Linux SUSE 9 and 10 (on x86-32 and x86-64)
  • OEL 4/OVM and OEL 5.0/OVM (on x86-32 and x86-64)
  • AIX 5.3 and AIX 6.1
  • Solaris 10 (on SPARC)
  • HP-UX 11iv3 (Itanium and PA-RISC 64 bits)

Application Server:

Oracle WebLogic Server 10.3.0 and 10.3.3:

  • WorkSpace: Oracle WebLogic 10.3.0 and 10.3.3
  • Process Administrator: Oracle WebLogic 10.3.0 and 10.3.3
  • WorkSpace Administrator: Oracle WebLogic 10.3.0 and 10.3.3
  • Archive Viewer: Oracle WebLogic 10.3.0 and 10.3.3
  • BPM Deployer: Oracle WebLogic 10.3.0 and 10.3.3
  • PAPI-WS: Oracle WebLogic 10.3.0 and 10.3.3
  • RSS Feeds: Oracle WebLogic 10.3.0 and 10.3.3
  • ALSB Custom Transport EAR: Oracle WebLogic 10.3.0 and 10.3.3.

WLP 10.3.0:

  • WorkSpace: BEA WebLogic Portal 10.3.0.

The Oracle BPM 10gR3 Engine can be deployed the Advanced and Premium versions of WebLogic Server.


Engine Database:

  • Oracle 9i, 10g, 11gR1 and 11gR2 (including RAC configurations)
  • MS SQL Server 2005
  • IBM UDB DB2 8.1 and 9.1 and Sybase 15.0.

Access to all these databases are accomplished through the usage of Oracle BPM Embedded DataDirect JDBC Drivers. For WLS running on WLS 10.3.3 cluster mode and accessing an Oracle RAC instance, the Oracle Thin JDBC Drivers distributed with the WLS 10.3.3 version should be used.


JMS Provider:

  • TIBCO EMS 4.1 and 4.2
  • Oracle BPM 10.3.0 and 10.3.0 Embedded. (XA Compliant Resources required)


Directory Service:

  • Single Source JNDI Plugins: Not available. Deprecated in ALBPM 6.0.
  • Single Source JDBC Plugins: Oracle 9i/10g/11gR1/11gR2, MS SQLServer 2005, IBM DB2 UDB 8.1 and 9.1 using DataDirect JDBC Drivers 3.6; Sybase ASE 15.0.2
  • Hybrid Plugins: Sun ONE System Directory Server 5.1.3 and 5.2 with Oracle 9i/10g/11gR1/11gR2, MS Active Directory 2000/2003 and Oracle 9i/10g/11gR1/11gR2, MS Active Directory 2000/2003 and MS SQL Server 2005, Sun ONE System Directory Server 5.1.3 and 5.2 with IBM DB2 8.1 or 9.1, Novell eDirectory 8.8 SP3 and Oracle 9i/10g/11gR1/11gR2, Oracle Internet Directory 10.1.4.2 and Oracle 9i/10g/11gR1/11gR2.


Browsers:

  • IE 7.0 and 8.0
  • Firefox 3.5+
  • Safari 3.0


JVM Version:

  • Sun JVM 1.6.0_05+ running in 32 bits mode (Linux RHEL 4.x and 5.x on x86-32 and x86-64; Linux SUSE 9 and 10 on x86-32 and x86-64; Linux OEL 4/OVM and OEL 5.0/OVM on x86-32 and x86-64)
  • JRockit JVM 1.6.0_05+ running in 32 or 64 bits mode (Linux RHEL 4.x and 5.x on x86-32 and x86-64; Linux SUSE 9 and 10 on x86-32 and x86-64; Linux OEL 4/OVM and OEL 5.0/OVM on x86-32 and x86-64)
  • Windows 2008 on x86-32 and x86-64
  • Windows 2003 SP1 & SP3 on x86-32 and x86-64
  • Solaris 10 SPARC-32
  • Sun JVM 1.6.0_05+ running in 64 bits mode (Solaris SPARC-64)
  • JRockit JVM 1.6.0_05+ running in 64 bits mode (Solaris 10 SPARC-64)
  • HP JVM 1.6 running in 32 bits mode (HP-UX 11iv3 PA-RISC-32)
  • HP JVM 1.6 running in 64 bits mode (HP-UX 11iv3 Itanium-64)
  • IBM Java 5 SR2 or SR10 running in 64 bits mode for embedded Tomcat instance and IBM Java 6 SR2 running 64 bits mode for WLS (AIX 5.3 PPC).

top


Oracle BPM Enterprise 10.3.3 for WebLogic



Operating System:

  • Windows 2003 SP1 & SP3 (on x86-32 and x86-64)
  • Windows 2008 (on x86-32 and x86-64)
  • Linux Red Hat 4.x and 5.x (do not use virtualization or XEN Kernel) (on x86-32 and x86-64)
  • Linux SUSE 9 and 10 (on x86-32 and x86-64)
  • OEL 4/OVM and OEL 5.0/OVM (on x86-32 and x86-64)
  • AIX 5.3 and AIX 6.1
  • Solaris 10 (on SPARC)
  • HP-UX 11iv3 (Itanium and PA-RISC 64 bits)

Application Server:

Oracle WebLogic Server 10.3.0 and 10.3.3 and 10.3.6:

  • WorkSpace: Oracle WebLogic 10.3.0 and 10.3.3 and 10.3.6
  • Process Administrator: Oracle WebLogic 10.3.0 and 10.3.3 and 10.3.6
  • WorkSpace Administrator: Oracle WebLogic 10.3.0 and 10.3.3 and 10.3.6
  • Archive Viewer: Oracle WebLogic 10.3.0 and 10.3.3 and 10.3.6
  • BPM Deployer: Oracle WebLogic 10.3.0 and 10.3.3 and 10.3.6
  • PAPI-WS: Oracle WebLogic 10.3.0 and 10.3.3 and 10.3.6
  • RSS Feeds: Oracle WebLogic 10.3.0 and 10.3.3 and 10.3.6
  • ALSB Custom Transport EAR: Oracle WebLogic 10.3.0 and 10.3.3 and 10.3.6

WLP 10.3.0: WorkSpace:

  • BEA WebLogic Portal 10.3.0.

The Oracle BPM 10gR3 Engine can be deployed the Advanced and Premium versions of WebLogic Server.


Engine Database:

  • Oracle 9i, 10g, 11gR1 and 11gR2 (including RAC configurations)
  • MS SQL Server 2005
  • IBM DB2 UDB 8.1 and 9.1 and Sybase 15.0.

Access to all these databases are accomplished through the usage of Oracle BPM Embedded DataDirect JDBC Drivers. For WLS running on WLS 10.3.3 cluster mode and accessing an Oracle RAC instance, the Oracle Thin JDBC Drivers distributed with the WLS 10.3.3 version should be used.


JMS Provider:

  • TIBCO EMS 4.1 and 4.2
  • Oracle BPM 10.3.0 and 10.3.0 Embedded. (XA Compliant Resources required)


Directory Service:

  • Single Source JNDI Plugins: Not available. Deprecated in ALBPM 6.0.
  • Single Source JDBC Plugins: Oracle 9i/10g/11gR1/11gR2, MS SQLServer 2005, IBM DB2 UDB 8.1 and 9.1 using DataDirect JDBC Drivers 4.2; Sybase ASE 15.0.2
  • Hybrid Plugins: Sun ONE System Directory Server 5.1.3 and 5.2 with Oracle 9i/10g/11gR1/11gR2, MS Active Directory 2000/2003 and Oracle 9i/10g/11gR1/11gR2, MS Active Directory 2000/2003 and MS SQL Server 2005, Sun ONE System Directory Server 5.1.3 and 5.2 with IBM DB2 8.1 or 9.1, Novell eDirectory 8.8 SP3 and Oracle 9i/10g/11gR1/11gR2, Oracle Internet Directory 10.1.4.2 and Oracle 9i/10g/11gR1/11gR2.


Browsers:

  • IE 7.0 and 8.0
  • Firefox 3.5+
  • Safari 3.0


JVM Version:

  • Sun JVM 1.6.0_05+ running in 32 bits mode (Linux RHEL 4.x and 5.x on x86-32 and x86-64; Linux SUSE 9 and 10 on x86-32 and x86-64; Linux OEL 4/OVM and OEL 5.0/OVM on x86-32 and x86-64)
  • JRockit JVM 1.6.0_05+ running in 32 or 64 bits mode (Linux RHEL 4.x and 5.x on x86-32 and x86-64; Linux SUSE 9 and 10 on x86-32 and x86-64; Linux OEL 4/OVM and OEL 5.0/OVM on x86-32 and x86-64)
  • Windows 2008 on x86-32 and x86-64
  • Windows 2003 SP1 & SP3 on x86-32 and x86-64
  • Solaris 10 SPARC-32
  • Sun JVM 1.6.0_05+ running in 64 bits mode (Solaris SPARC-64)
  • JRockit JVM 1.6.0_05+ running in 64 bits mode (Solaris 10 SPARC-64)
  • HP JVM 1.6 running in 32 bits mode (HP-UX 11iv3 PA-RISC-32)
  • HP JVM 1.6 running in 64 bits mode (HP-UX 11iv3 Itanium-64)
  • IBM Java 5 SR2 or SR10 running in 64 bits mode for embedded Tomcat instance and IBM Java 6 SR2 running 64 bits mode for WLS (AIX 5.3 PPC).

top


ALBPM Enterprise 6.0 for WebLogic



Operating System:

  • Windows Server 2003 SP1 & SP2 or R2 (x86-32)
  • SUSE Linux 10.0 (x86-32, x86-64, Itanium-64)
  • Linux RHEL 4.x (x86-32, x86-64, Itanium-64)
  • Linux RHEL 5.x (x86-64)
  • AIX 5.3
  • Solaris 9 and 10 (SPARC)
  • HP-UX 11.23 and 11.31 (Itanium-64)

Application Server:

WLS 9.2.1 and 9.2.2:

  • WorkSpace: BEA WebLogic Server 9.2.1 and 9.2.2
  • Process Administrator: BEA WebLogic Server 9.2.1 and 9.2.2 (it is not possible to create the Engine, WorkSpace and WorkSpace Admin EARs - for full functionality use Process Administrator deployed to Tomcat 5.5)
  • WorkSpace Administrator: BEA WebLogic Server 9.2.1 and 9.2.2
  • Archive Viewer: BEA WebLogic Server 9.2.1 and 9.2.2
  • BPM Deployer: BEA WebLogic Server 9.2.1 and 9.2.2
  • PAPI-WS: BEA WebLogic Server 9.2.1 and 9.2.2
  • RSS Feeds: BEA WebLogic 9.2.1 and 9.2.2
  • ALSB Custom Transport EAR: BEA WebLogic 9.2.1 and 9.2.2

WLS 10.0.1:

  • WorkSpace: BEA WebLogic Server 10.0.1 (it can also be deployed on a WLP 10.0.1 WLS instance)
  • Process Administrator: BEA WebLogic Server 10.0.1 (it is not possible to create the Engine, WorkSpace and WorkSpace Admin EARs - for full functionality use Process Administrator deployed to Tomcat 5.5)
  • WorkSpace Administrator: BEA WebLogic Server 10.0.1
  • Archive Viewer: BEA WebLogic Server 10.0.1
  • BPM Deployer: BEA WebLogic Server 10.0.1
  • PAPI-WS: BEA WebLogic Server 10.0.0.1


Engine Database:

  • Oracle 9i, 10g (including RAC)
  • MS SQLServer 2005
  • IBM DB2 UDB 8.1 and 9.1 using BEA WebLogic Server Embedded DataDirect JDBC Drivers
  • Sybase ASE 15.0 will be supported in OBPM 10gR3


JMS Provider:

  • TIBCO EMS 4.1
  • WebLogic 9.2 MP1 or WebLogic 10.0 Embedded. (XA Compliant Resources required)


Directory Service:

  • Single Source JDBC Plugins: Oracle 9i and 10g, MS SQLServer 2005, IBM DB2 UDB 8.1 and 9.1 using DataDirect JDBC Drivers 3.6; Sybase ASE 15.0 will be supported in OBPM 10gR3
  • Hybrid Plugins: Sun ONE System Directory Server 5.1.3 and 5.2 with Oracle 9i, Sun ONE System Directory Server 5.1.3 and 5.2 with Oracle 10g, MS Active Directory 2003 and Oracle 9i, MS Active Directory 2003 and Oracle 10g, MS Active Directory 2003 and MS SQL Server 2005, Sun ONE System Directory Server 5.1.3 and 5.2 with IBM DB2 8.1 or 9.1.


Browsers:

  • IE 6.0 and 7.0
  • Firefox 2.0
  • Safari 3.0


JVM Version:

  • JRockit 5 for Windows Server 2003 SP1 & SP2
  • Linux RHEL 4.x (x86-32, x86-64 and Itanium-64)
  • Linux RHEL 5.x (x86-32 and x86-64) and Suse 10.0 (x86-32, x86-64 and Itanium-64)
  • Sun 1.5.0_11^ Solaris 9 and 10 (SPARC)
  • IBM 1.5.0_06 64 bits for AIX 5.3 running 32 bits JVM, HP-UX 11v2 and 11v3 Itanium-64 using HP-UX JVM 1.5.0_05

top



Oracle BPM Enterprise 10.3.0 and 10.3.1 for WebSphere



Operating System:

  • Windows 2003 SP1 & SP2 (on x86-32 and x86-64)
  • Windows 2008 (on x86-32 and x86-64)
  • Linux Red Hat 4.x and 5.x (on x86-32 and x86-64)
  • Linux SUSE 9 and 10 (on x86-32 and x86-64)
  • AIX 5.3
  • Solaris 10 (on SPARC)
  • HP-UX 11iv3 (Itanium and PA-RISC 64 bits)


Application Server:

  • WorkSpace: IBM WebSphere 6.1.0.19 (other patch levels introduced problems)
  • Process Administrator: Tomcat 5.5.15
  • WorkSpace Administrator: IBM WebSphere 6.1.0.19 (other patch levels introduced problems)
  • Archive Viewer: IBM WebSphere 6.1.0.19 (other patch levels introduced problems)
  • BPM Deployer: IBM WebSphere 6.1.0.19 (other patch levels introduced problems - works only on non-clustered configurations)
  • PAPI-WS: IBM WebSphere 6.1.0.19 (other patch levels introduced problems)
  • RSS Feeds: IBM WebSphere 6.1.0.19 (other patch levels introduced problems)
  • ALSB Custom Transport EAR: N/A.


Engine Database:

  • Oracle 9i, 10g, and 11gR1 (including RAC configurations)
  • IBM UDB DB2 8.1 and 9.1

Access to all these databases are accomplished through the usage of Oracle BPM Embedded DataDirect JDBC Drivers

JMS Provider:

IBM WebSphere 6.1.0.19 Embedded messaging infrastructure.


Directory Service:

  • Single Source JNDI Plugins: Not available. Deprecated in ALBPM 6.0.
  • Single Source JDBC Plugins: Oracle 9i/10g/11gR1, IBM DB2 UDB 8.1 and 9.1 using DataDirect JDBC Drivers 3.6
  • Hybrid Plugins: Sun ONE System Directory Server 5.1.3 and 5.2 with Oracle 9i/10g/11gR1, MS Active Directory 2000/2003 and Oracle 9i/10g/11gR1, Sun ONE System Directory Server 5.1.3 and 5.2 with IBM DB2 8.1 or 9.1.

Browsers:

  • IE 6.0 and 7.0
  • Firefox 2.0
  • Safari 3.0


JVM Version:

  • Sun JVM 1.5.0 for Solaris SPARC 32 and 64 bits
  • IBM Java 5 SR2 or SR10 running in 64 bits mode for embedded Tomcat and ALBPM application and IBM Java 6 SR2 running 64 bits mode (AIX 5.3 PPC)

top



Oracle BPM Enterprise 10.3.2 for WebSphere



Operating System:

  • Windows 2003 SP1 & SP3 (on x86-32 and x86-64)
  • Windows 2008 (on x86-32 and x86-64)
  • Linux Red Hat 4.x and 5.x (on x86-32 and x86-64)
  • Linux SUSE 9 and 10 (on x86-32 and x86-64)
  • AIX 5.3
  • Solaris 10 (on SPARC)
  • HP-UX 11iv3 (Itanium and PA-RISC 64 bits)


Application Server

  • WorkSpace: IBM WebSphere 6.1.0.29
  • Process Administrator: Tomcat 5.5.15
  • WorkSpace Administrator: IBM WebSphere 6.1.0.29
  • Archive Viewer: IBM WebSphere 6.1.0.29
  • BPM Deployer: IBM WebSphere 6.1.0.29 (works only on non-clustered configurations)
  • PAPI-WS: IBM WebSphere 6.1.0.29
  • RSS Feeds: IBM WebSphere 6.1.0.29
  • ALSB Custom Transport EAR: Not Supported


Engine Database

  • Oracle 9i, 10g, 11gR1 and 11gR2 (including RAC configurations)
  • IBM UDB DB2 8.1 and 9.1

Access to all these databases are accomplished through the usage of Oracle BPM Embedded DataDirect JDBC Drivers. For Oracle DB, it is also possible to use Oracle Thin JDBC Drivers.

JMS Provider

IBM WebSphere 6.1.0.29 Embedded messaging infrastructure.


Directory Service

  • Single Source JNDI Plugins: Not available. Deprecated in ALBPM 6.0.
  • Single Source JDBC Plugins: Oracle 9i/10g/11gR1/11gR2, IBM DB2 UDB 9.1 and 9.5 using DataDirect JDBC Drivers 3.6
  • Hybrid Plugins:Sun ONE System Directory Server 5.1.3 and 5.2 with Oracle 9i/10g/11gR1/11gR2, MS Active Directory 2000/2003 and Oracle 9i/10g/11gR1/11gR2, Sun ONE System Directory Server 5.1.3 and 5.2 with IBM DB2 9.1 and 9.5


Browsers

  • IE 7.0 and 8.0
  • Firefox 3.5+
  • Safari 3.0


JVM Version

  • Sun JVM 1.5.0 for Solaris SPARC 32 and 64 bits
  • IBM Java 5 SR10 (older SRs are known to cause problems) running in 64 bits mode for embedded Tomcat and ALBPM application and IBM Java 6 SR2 running 64 bits mode (AIX 5.3 PPC)

top



Oracle BPM Enterprise 10.3.3 for WebSphere



Operating System:

  • Windows 2003 SP1 & SP3 (on x86-32 and x86-64)
  • Windows 2008 (on x86-32 and x86-64)
  • Linux Red Hat 4.x and 5.x (on x86-32 and x86-64)
  • Linux SUSE 9 and 10 (on x86-32 and x86-64)
  • AIX 5.3
  • Solaris 10 (on SPARC)
  • HP-UX 11iv3 (Itanium and PA-RISC 64 bits)


Application Server

  • WorkSpace: IBM WebSphere 6.1.0.29, 7.0.0.19
  • Process Administrator: Tomcat 5.5.15
  • WorkSpace Administrator: IBM WebSphere 6.1.0.29, 7.0.0.19
  • Archive Viewer: IBM WebSphere 6.1.0.29, 7.0.0.19
  • BPM Deployer: IBM WebSphere 6.1.0.29, 7.0.0.19 (works only on non-clustered configurations)
  • PAPI-WS: IBM WebSphere 6.1.0.29, 7.0.0.19
  • RSS Feeds: IBM WebSphere 6.1.0.29, 7.0.0.19
  • ALSB Custom Transport EAR: Not Supported


Engine Database

  • Oracle 9i, 10g, 11gR1 and 11gR2 (including RAC configurations)
  • IBM DB2 UDB 8.1, 9.1 and 9.5

Access to all these databases are accomplished through the usage of Oracle BPM Embedded DataDirect JDBC Drivers. For Oracle DB, it is also possible to use Oracle Thin JDBC Drivers.

JMS Provider

IBM WebSphere 6.1.0.29, 7.0.0.19 Embedded messaging infrastructure.


Directory Service

  • Single Source JNDI Plugins: Not available. Deprecated in ALBPM 6.0.
  • Single Source JDBC Plugins: Oracle 9i/10g/11gR1/11gR2, IBM DB2 UDB 9.1 and 9.5 using DataDirect JDBC Drivers 4.2
  • Hybrid Plugins:Sun ONE System Directory Server 5.1.3 and 5.2 with Oracle 9i/10g/11gR1/11gR2, MS Active Directory 2000/2003 and Oracle 9i/10g/11gR1/11gR2, Sun ONE System Directory Server 5.1.3 and 5.2 with IBM DB2 9.1 and 9.5


Browsers

  • IE 7.0 and 8.0
  • Firefox 3.5+
  • Safari 3.0


JVM Version

  • Sun JVM 1.5.0 for Solaris SPARC 32 and 64 bits
  • IBM Java 5 SR10 (older SRs are known to cause problems) running in 64 bits mode for embedded Tomcat and ALBPM application and IBM Java 6 SR2 running 64 bits mode (AIX 5.3 PPC)

top



ALBPM Enterprise 6.0 for WebSphere


Operating System:

  • Windows Server 2003 SP1 & SP2 or R2 (x86-32)
  • Linux SUSE 10.0 (x86-32, x86-64, Itanium-64)
  • Linux RHEL 4.x (x86-32, x86-64, Itanium-64)
  • AIX 5.3
  • Solaris 9 and 10 (SPARC)


Application Server:

  • WorkSpace: Tomcat 5.5.15, IBM WebSphere 6.1.0.5 and 6.1.0.13 (other patch levels introduced problems)
  • Process Administrator: Tomcat 5.5.15; WorkSpace Administrator: Tomcat 5.5.15, IBM WebSphere 6.1.0.5 and 6.1.0.13 (other patch levels introduced problems)
  • Archive Viewer: Tomcat 5.5.15, IBM WebSphere 6.1.0.5 and 6.1.0.13 (other patch levels introduced problems)
  • BPM Deployer: IBM WebSphere 6.1.0.5 and 6.1.0.13 (other patch levels introduced problems)
  • PAPI-WS: Tomcat 5.5.15, IBM WebSphere 6.1.0.5 and 6.1.0.13 (other patch levels introduced problems)
  • RSS Feeds: Tomcat 5.5.15, IBM WebSphere 6.1.0.5 and 6.1.0.13 (other patch levels introduced problems)
  • ALSB Custom Transport EAR: N/A


Engine Database:

  • Oracle 9i, 10g (including RAC)
  • MS SQLServer 2005
  • IBM DB2 UDB 8.1 and 9.1 using DataDirect Embedded JDBC Drivers (DataDirect 3.6)
  • Sybase ASE 15.0 will be supported in OBPM 10gR3


JMS Provider:

  • TIBCO EMS 4.1
  • WebSphere 6.1.0.5 (other versions presented problems) Embedded Messaging
  • IBM MQ Series 5.3 (XA Compliant Resources)


Directory Service:

  • Single Source JDBC Plugins:Oracle 9i and 10g, MS SQLServer 2005, IBM DB2 UDB 8.1 and 9.1 using DataDirect JDBC Drivers 3.6; Sybase ASE 15.0 will be supported in OBPM 10gR3
  • Hybrid Plugins: Sun ONE System Directory Server 5.1.3 and 5.2 with Oracle 9i, Sun ONE System Directory Server 5.1.3 and 5.2 with Oracle 10g, MS Active Directory 2003 and Oracle 9i, MS Active Directory 2003 and Oracle 10g, MS Active Directory 2003 and MS SQL Server 2005, Sun ONE System Directory Server 5.1.3 and 5.2 with IBM DB2 8.1 or 9.1


Browsers:

  • IE 6.0 and 7.0
  • Firefox 2.0
  • Safari 3.0


JVM Version:

  • IBM 1.5.0 SR2 for Windows Server 2003 SP1 & SP2 (x86-32)
  • SUSE Linux 10.0 (x86-32, x86-64)
  • Red Hat Enterprise Linux 4 (x86-32, x86-64)
  • Sun 1.5.0_06 for Solaris 9 and 10 (SPARC)
  • IBM 1.5.0 SR2 64 bits for AIX 5.3 running in 32 bits JVM

  • Oracle Business Process Management 10.3.0 and 10.3.1 & WebCenter Interaction integration (formerly AquaLogic User Interaction): Oracle Web Center Interaction 10gR3 and Oracle Web Center Interacton Collaboration 10gR3.
     
  • Oracle Business Process Management 10.3.0 and 10.3.1 & Oracle Service Bus integration (formerly AquaLogic Service Bus): AquaLogic Service Bus 3.0.
     
  • Oracle Business Process Management 10.3.2 & Oracle Service Bus integration (formerly AquaLogic Service Bus): Oracle Service Bus 10.3.0. Note: On Windows and Linux, it is important to make sure that the Tomcat instance hosting the Process Administrator runs with Java 6 instead of the default Java 5 Java Virtual Machine.
     
  • Oracle Business Process Management 10.3.0 and 10.3.1 & Oracle WebLogic Portal integration: Oracle WebLogic Portal 10.2 and 10.3.0.
     
  • Oracle Business Process Management 10.3.2 & Oracle WebLogic Portal integration: Oracle WebLogic Portal 10.3.0.
     
  • Oracle Business Process Management 10.3.0 and 10.3.1 & Oracle BPEL Process Manager integration: Oracle BPEL PM 10gR3.

top

Left Curve
Popular Downloads
Right Curve
Untitled Document
Left Curve
More Middleware Downloads
Right Curve