J2EE Servers Supported by Oracle MapViewer

 

This document contains information on J2EE servers supported by the following versions of Oracle MapViewer.

 
 

J2EE Servers Supported by Oracle MapViewer 11g

 

 J2EE Server Name and Version

 Supported by MapViewer 11g (All Releases)?

 Oracle WebLogic Server  10g and Later  Yes
 GlassFish  3.1.2 or later  Yes
 Oracle Application Server  10g (10.1.3.x)  No
 WebLogic  9  Yes
 Oracle OC4J Standalone  10g (10.1.3.x)  No
 Apache Tomcat  6.x and Later  Yes
 WebSphere  6.x and 7.x  Yes
 JBoss  4.x and Later  Yes
 

 J2EE Servers Supported by Oracle MapViewer 10g (Patch 10.1.3.3)

 This matrix shows J2EE servers supported by MapViewer 10g (Patch 10.1.3.3). The matrix also shows any additional restrictions that apply or extra tasks that are required.

 

 J2EE Server Name and Version

 Supported by MapViewer 10g (Patch 10.1.3.3)?

 Oracle Application Server  10g (10.1.3)  Yes
 10g (10.1.2)  No
 Standalone OC4J  10g (10.1.3)  Yes
 10.1.2  No
 Tomcat  5.x  Yes
 4.x  No
 JBoss  4.x  Yes
 3.2.x  No
 WebLogic  10.x and 9  Yes A
 8  No
 WebSphere  6  Yes
 5.1  No

Notes for Oracle MapViewer 10g (Patch 10.1.3.3)

A. Oracle MapViewer 10.1.3.3 does not support WebLogic container JDBC data sources.