Introduction

By taking advantage of the Oracle Metadata Services (MDS) framework, Oracle WebCenter enables you to create rich, customizable applications and tailor them to the needs of your organization. You can customize the task flows associated with Oracle WebCenter’s Social Computing Services and WebCenter Spaces. You can customize task flows in JDeveloper and apply the customizations to a running WebCenter application.

Oracle WebCenter supports several levels of customization:

- **Seeded customization**, which application developers perform at design time. Seeded customizations stay with the application for the duration of the application’s deployment.

- **User customization**, which allows an end user to change the content of the application at runtime to suit individual preferences (for example, which columns are visible in a table), and have those changes “remembered” the next time the user opens the application.

- **Design time at runtime**, which enables different roles to perform various customizations during the runtime of the application. Oracle WebCenter supports this capability by integrating with Oracle Composer.
WebCenter task flow customization is an example of a seeded customization. As an application developer, you customize the task flows for your organization’s needs in JDeveloper, and apply them to the deployed application. These seeded customizations then remain with the application for the duration of its deployment.

Oracle WebCenter makes it easy for you to perform and apply task flow customizations. Since the Oracle WebCenter Framework design time experience is provided as an extension to Oracle JDeveloper 11g, you can take advantage of JDeveloper roles that scope the development environment for a particular task. One of these roles is the Customization Developer role, which helps you customize the metadata of your application with minimal coding. For more information on customizing a custom WebCenter application’s metadata, refer to the chapter, “Extending Runtime Editing Capabilities Using Oracle Composer” in Oracle Fusion Middleware Developer’s Guide for Oracle WebCenter for more details.

WebCenter Social Computing Services and WebCenter Spaces expose their common functionalities using task flows. By using JDeveloper’s Customization Developer role, you can customize WebCenter task flows to extend or alter the out-of-the-box look and feel and functionality of these task flows.

You can learn more about the types of customization in the Oracle Fusion Middleware Developer’s Guide for Oracle Application Development Framework. To learn more about Oracle WebCenter and WebCenter Services, see the Oracle Fusion Middleware Developer’s Guide for Oracle WebCenter. Both of these guides are available in the Oracle Fusion Middleware Documentation Library 11g Release 1 (11.1.1.2) on the Oracle Technology Network (http://download.oracle.com/docs/cd/E15523_01/index.htm).
The WebCenter Task Flow Customization Process

In Oracle WebCenter 11g Release 1 (11.1.1.2), you can perform view-level customization on your WebCenter applications, such as changing the look and feel of the task flow and adding or removing ADF components to and from a task flow. ADF model or controller customizations are not currently supported.

Before you can customize task flows, you must enable your application to accept these customizations. The steps for preparing an application for task flow customization differ depending on whether you are customizing task flows for use in WebCenter Spaces, a custom WebCenter application you have developed yourself, or both.

Note: When you apply task flow seeded customizations to a deployed WebCenter application, the customizations apply to all instances of the task flow across the application, eliminating the need to repeat customizations on all task flow instances.

Preparing a WebCenter Application for Customizing Task Flows

You must perform the following steps to prepare any WebCenter application for customizing task flows. After you’ve followed these steps, refer to the section appropriate to you:

- Preparing WebCenter Spaces for Customizing Task Flows
- Preparing a Custom WebCenter Application for Customizing Task Flows
- Preparing Both WebCenter Spaces and a Custom WebCenter Application for Customizing Task Flows

To prepare a WebCenter application for customizing task flows:

1. In JDeveloper, install the WebCenter Customization JDeveloper Extension. To do so, choose Help > Check for Updates.
2. In the Check for Updates wizard, click Next.
3. On the Search for Updates page, select the Oracle Fusion Middleware Products update center, and click Next.
4. On the Updates page, in the Available Updates field, enter “webcenter”.
5. Select “Oracle WebCenter Customization Framework Design Time” extension and click Finish. You may also want to install the new version of the Oracle WebCenter Framework and Services Design Time extension.
After you install the Oracle WebCenter Customization Framework Design Time extension, you must perform a few additional steps to enable customization of task flows in WebCenter Spaces.

To customize task flows in WebCenter Spaces:

1. Download oracle-129395.zip from the Oracle Technology Network (http://www.oracle.com/technetwork/middleware/webcenter/oracle-129395.zip) and extract the contents locally.

2. In JDeveloper, open the SpacesTaskflowCustomization.jws file.
Preparing a Custom WebCenter Application for Customizing Task Flows

After you install the Oracle WebCenter Customization Framework Design Time extension, you must perform a few additional steps to enable customization of task flows in a custom WebCenter application. First, ensure that you have created your application using the WebCenter application template. Then, follow these steps to prepare your application for customizing task flows.

To customize task flows in a custom WebCenter application.

1. In the Application Navigator, right-click the ViewController project, and choose Project Properties.

2. In the Project Properties dialog, select ADF View, then select the Enable Seeded Customizations check box.
Preparing Both WebCenter Spaces and a Custom WebCenter Application for Customizing Task Flows

After you install the Oracle WebCenter Customization Framework Design Time extension and performed the steps to prepare a WebCenter Spaces application and a custom WebCenter application for customizing task flows, you must perform a few steps to set up your environment to customize task flows in both types of applications.

To enable customization of WebCenter task flows at design time for both WebCenter Spaces and a custom WebCenter application, you must configure the CC layer values that you want to use in the JDeveloper Customization Developer role. In your file system directory, in JDEV_HOME/jdev, open the CustomizationLayerValues.xml and configure the CC layer values.

Use the fragment in Code Listing 1 when customizing WebCenter Spaces.

**Code Listing 1: Customization Layer for WebCenter Spaces**

3. Click OK and save your files.
For custom WebCenter applications with a standard customization configuration using the ADFSiteCC customization class, you must use a cust-layer-value of “site” instead of “webcenter” for the JDeveloper Customization Developer role.

Restart JDeveloper in the Customization Developer Role and Verify the Configuration

After you have enabled customization for your application, you can switch to the Customization Developer role and begin customizing your task flows.

1. In JDeveloper, choose Tools > Preferences > Roles, select Customization Developer role, then click OK.

Figure 4. Selecting the Customization Developer role
2. JDeveloper prompts you to restart. Choose Yes to restart JDeveloper in the Customization Developer role.

3. In JDeveloper, in the Customization Developer role, you see a Customization Context window with “Edit with following Customization Context” selected and the customization layer name selected as “site,” and the layer value set to “webcenter.” These values indicate that you have successfully configured your SampleWebCenterApplication to enable customization of Oracle WebCenter task flows.

![Customization Context]

Figure 5. Customization Context

Customizing WebCenter Task Flows

Out of the box, WebCenter Social Computing Services and WebCenter Spaces have well-defined user interfaces and behavior. One of the features that Oracle JDeveloper includes to help you extend the user interfaces and default behavior is the Customization Developer role.

JDeveloper’s Customization Developer role is a powerful mechanism that allows you to customize the ADF Library without changing the code in base library JAR. Since both Oracle WebCenter and Oracle ADF leverage MDS, you can use the Customization Role to extend WebCenter Spaces and WebCenter Services task flows. All WebCenter task flows are packaged in the ADF Library so task flow customization is possible in JDeveloper design time.

The following use cases demonstrate WebCenter task flow customization using the JDeveloper Customization Developer role.

- **Use Case 1:** In WebCenter Spaces, add a link to the WebCenter Spaces Global ToolBar task flow
- **Use Case 2:** In WebCenter Spaces, remove the primary tabs from the WebCenter Spaces Local ToolBar task flow
Use Case 3: In a WebCenter application (a custom WebCenter application or WebCenter Spaces), customize the WebCenter Discussion Forums task flow to show an image next to the author's name.

Use Case 1: (WebCenter Spaces) Adding a Link to the WebCenter Spaces Global Toolbar Task Flow

This example shows how to add a link to the WebCenter Spaces toolbar. The following image shows the various links that display: Group Spaces, Favorites, Preferences, and so on. This toolbar is a rendered view of the Global Toolbar task flow.

Before you can perform these steps, ensure that you have set up JDeveloper to enable WebCenter Spaces task flow customization, as previously described in this document.

To add a link to the WebCenter Spaces Global Toolbar task flow:

1. Ensure that the WebCenter Spaces application is open in JDeveloper and that you are using the Customization Developer role.

2. Ensure that the JDeveloper Application Navigator is showing libraries. You can select this from the Navigator Display Options list next to Projects in the Application Navigator.

3. In the Application Navigator, expand the ViewController project, and navigate to the WebCenter Spaces library.

5. Under globalToolbar, select BoilerPlate.jspx and open it.

6. Look for the `af:commandLink` tag with the id “profileLink”.

**Code Listing 2. af:commandLink in the BoilerPlate.jspx file**

```xml
<af:commandLink text="#{security.userDisplayName}" actionListener="#{backing_wc_resourceHandler.resourceActioned}" id="profileLink" inlineStyle="white-space:nowrap" partialSubmit="true" rendered="#{security.authenticated}"
..........  
</af:commandLink>
```

7. In the Design view, insert an `<af:goLink>` component after it. Set a link, such as “http://www.example.com/support/welcome.html” as the destination for the newly inserted goLink component.
Performing these steps created the necessary customization for BoilerPlate.jspx under Application_Directory/ViewController/libraryCustomizations/oracle/WebCenter/WebCenterapp/view/task flows/globalToolbar.

The resulting toolbar looks like this:

![Updated Global Toolbar Task Flow Label in WebCenter Spaces](image)

Figure 8. Updated Global Toolbar Task Flow Label in WebCenter Spaces

Use Case 2: (WebCenter Spaces) Removing Primary Tabs from the Local Toolbar Task Flow

In WebCenter Spaces, group space navigation is performed through tabs and menus. You can modify the application to show group space navigation only through menu items by customizing the Local Toolbar task flow.

![Local Toolbar Task Flow in WebCenter Spaces](image)

Figure 9. Local Toolbar Task Flow in WebCenter Spaces

Before you perform these steps, ensure that you have set up JDeveloper to enable WebCenter Spaces task flow customization, as previously described in this document.

To remove primary tabs from the WebCenter Spaces Local Toolbar task flow:

1. Ensure that the SpacesTaskflowCustomizationApplication application is open in JDeveloper and that you are using the Customization Developer role.
2. Ensure that the JDeveloper Application Navigator is showing libraries. You can select this from the Navigator Display Options list next to Projects in the Application Navigator.
3. In the Application Navigator, expand the ViewController project, and navigate to the WebCenter Spaces library.
5. Under localToolbar, select LocalBoilerPlate.jspx and open it.
6. In the Structure window, select the wcNavigationPane component with the id="primaryTabSet."
7. Delete this component by pressing the Delete key on your keyboard.

Performing these steps created the necessary customization for LocalBoilerPlate.jspx under Application_Directory/ViewController/libraryCustomizations/oracle/WebCenter/WebCenterapp/view/task flows/localToolbar for BoilerPlate.jspx.

The resulting toolbar looks as follows:
Use Case 3: Customizing the Discussion Forums Task Flow

This example shows how you can customize the Discussion Forums task flow to display a profile image for the user who initiated the discussion. The following is a sample Discussion Forum without the profile image.

Before you perform these steps, ensure that you have prepared a customizable WebCenter application.

To customize the Discussion Forums task flow:

1. In the Application Navigator, expand the ViewController project to view the WebCenter Discussion Services View library.
2. In the WebCenter Discussion Services View library, open the ListTopics.jspx file.

3. On your file system, in the SampleWebCenterApplication application directory, create a directory named “images” under ViewController/public_html.

4. While still on your file system, in the ViewController/public_html directory, add a few sample images in GIF format. You can name these image files as valid WebCenter usernames, for example admin.gif, sjones.gif, and so on. These images are the user profile images you’ll add to the task flow.

5. In JDeveloper, click the Refresh icon in the toolbar of the Application Navigator.

6. Save the application.

7. If you are not already using the Customization Developer role, switch to this role (choose Tools > Preferences, select Role, then select Customization Developer Role and restart JDeveloper).

8. In JDeveloper, open the ListTopics.jspx file.

9. In the Structure window, search for the <rtc:presence> tag on the page. This tag renders the username.
10. Right-click the rtc:presence tag, then choose Insert After > ADF Faces > Panel Group Layout from the context menu.

11. In the Structure window, right-click the new Panel Group Layout and choose Insert > Image Component.

12. In the Property Inspector for the new Image component, set the Source property to /images/#{row.postedBy}.gif. Doing so generates the image name (which you added to your application project) named according to the user who posted the discussion.

13. Save your files and rebuild the project.

The ListTopics.jspx.xml file that is generated now contains the following code:

**Example 1. Updated ListTopics.jspx.xml File**

```xml
<mds:customization version="11.1.1.54.01"
xmlns:mds="http://xmlns.oracle.com/mds">
  <mds:insert parent="frmltpgl11" position="last"
xmlns:af="http://xmlns.oracle.com/adf/faces/rich">
    <af:image - images=#{row.postedBy}.gif
```

![Figure 14. rtc:presence Tag in the Structure Window](image)
Modifying Customizations to a Deployed WebCenter Application

In the previous sections, we customized WebCenter task flows for three different scenarios. The output of these exercises is the generated MDS customization. The customizations show up as .xml or .jspx files in the View project of the application in the library customization package. These customization documents are essentially instructions for MDS to apply delta on top of the base document that is shipped to show the customized behavior at runtime. Once you create the customizations, you must apply them to the deployed WebCenter application.

Applying Seeded Customizations to Deployed WebCenter Applications
To see customizations performed on Oracle WebCenter task flows in JDeveloper at runtime, you must import these customizations to the MDS repository of the deployed WebCenter application. Because this step updates the runtime WebCenter application metadata repository, you should first back up the MDS schema before performing this step. Oracle also advises that you test your customizations in a development or stage environment first.

These steps cover how to apply the seeded customizations to a deployed instance of Oracle WebCenter Spaces. You can follow same steps to deploy customizations to a custom WebCenter application repository, as well.

To import design time Oracle WebCenter task flow seeded customizations to the MDS repository:

1. If you are using the sample workspace oracle-129395.zip, skip to Step 3. Otherwise, in the Application Navigator, from the Application Menu, choose Application Properties…

![Application Properties](image)

**Figure 16. Application Properties**

2. Choose Deployment and create a deployment profile by using the MAR File archive type.
3. Click OK to close the Create Deployment Profile dialog.

4. Click OK, then OK again to finish creating the Deployment Profile.

5. In the Application Navigator, from the Application Menu, choose Deploy > metadata ("metadata" is the name of the Deployment Profile, as shown in Figure 17).
6. In the Deploy metadata dialog, choose Deploy to JAR file, then click Finish.
Figure 19. Deploying to a JAR File

7. JDeveloper creates the MAR file in the application directory of your JDEV_USER home directory. Copy this MAR file, which contains the customizations, to the directory where the WebCenter application is deployed.

Note: Maintain a backup of this file so that you always have a version of the customizations for this application.

8. Extract the MAR to a temporary directory on the machine, for example /tmp/wc-cust.

9. Use the MDS WLST import command to import the task flow customizations to the application’s MDS repository.

Example 2. Command Line for Importing Customizations

```bash
wls:/weblogic/serverConfig>importMetadata(application='webcenter',
server='srg',
fromLocation='/tmp/wc-cust',
docs='/**')
```

For more information on MDS WLST commands, refer to the Oracle Fusion Middleware WebLogic Scripting Tool Command Reference on the Oracle Technology Network.

Removing Seeded Customizations from Deployed WebCenter Applications

You can remove seeded customizations from a deployed WebCenter application, including WebCenter Spaces. Once you remove the customizations from the application, the task flow behavior or look and feel will revert back to the original deployment.

Use the MDS WLST deleteMetadata command to remove the applied customizations. The deleteMetadata command needs to exercise with caution as incorrect use of this command may cause the loss of metadata documents.

Code Listing 3. Command to Delete the Customization Metadata from a Deployed WebCenter Application

```bash
deleteMetadata(application='webcenter',server='srg',docs='/oracle/webcenter/webcenterapp/view/taskflows/globalToolbar/**',excludeBaseDocs='true')
```

For more details on MDS WLST commands, refer to the Oracle Fusion Middleware WebLogic Scripting Tool Command Reference on the Oracle Technology Network.
Additional Scenarios

Some of the additional use cases that can be achieved by the customization process documented are:

1. Change labels including column names for task flows.
2. Change icons used in task flows, for example replacing the Edit and Refresh icons with new icons on the “Discussions – Group Space Forums” task flow.
3. Change the order of table columns in a task flow.
4. Remove an entire region or component, such as the “Search box” from primary tab.
5. Show additional attributes available by using Expression Language, for example customizing the People Picker task flow to show an additional user Profile attribute.

Catalog of WebCenter Task Flows

The following task flows have been validated for view-level customizations. You can find these task flows in the libraries and definition paths specified in the table.

<table>
<thead>
<tr>
<th>WEBCENTER TASK FLOWS</th>
<th>LIBRARY</th>
<th>DEFINITION PATH</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documents – Main View</td>
<td>WebCenter Document Library Service View</td>
<td>oracle/webcenter/doclib/view/jsf/taskflows/mainView.xml</td>
</tr>
<tr>
<td>Documents – Recent Documents</td>
<td>WebCenter Document Library Service View</td>
<td>oracle/webcenter/doclib/view/jsf/taskflows/recentDocuments.xml</td>
</tr>
<tr>
<td>Mail</td>
<td>WebCenter Mail Service View</td>
<td>oracle/webcenter/collab/mail/view/jsf/regions/mini-view-definition.xml</td>
</tr>
<tr>
<td>Discussions – Manager</td>
<td>WebCenter Discussions Service View</td>
<td>oracle/webcenter/collab/forum/view/taskflows/main-task-flow.xml</td>
</tr>
<tr>
<td>Tagging – Similar Items</td>
<td>WebCenter Tagging Service View</td>
<td>oracle/webcenter/tagging/controller/taskflows/related-links.xml</td>
</tr>
<tr>
<td>Tagging – Personal View</td>
<td>WebCenter Tagging Service View</td>
<td>oracle/webcenter/tagging/controller/taskflows/tagging-personal-view.xml</td>
</tr>
<tr>
<td>Worklist</td>
<td>WebCenter Worklist Service View</td>
<td>oracle/webcenter/worklist/view/jsf/taskFlowDefs/worklist.xml</td>
</tr>
<tr>
<td>Announcements</td>
<td>WebCenter Announcement Service View</td>
<td>oracle/webcenter/collab/announcement/view/taskflows/main-view-definition.xml</td>
</tr>
<tr>
<td>List – Main View</td>
<td>WebCenter List Service View</td>
<td>oracle/webcenter/list/view/jsf/regions/main-view-task-flow.xml</td>
</tr>
<tr>
<td>Group Spaces</td>
<td>WebCenter Spaces View</td>
<td>oracle/webcenter/community/view/taskflows/browsers/CommunityBrowserRegion.xml</td>
</tr>
<tr>
<td>Group Space Members</td>
<td>WebCenter Spaces View</td>
<td>oracle/webcenter/webcenterapp/view/taskflows/admin/table-of-</td>
</tr>
</tbody>
</table>
Conclusion

Oracle WebCenter enables you to customize the look and feel of the default Oracle ADF task flows provided by the WebCenter Services and WebCenter Spaces. You can customize these task flows at design time in Oracle JDeveloper and apply them to applications that are either in development or already deployed.
