Security Advisories and Notifications

Security Advisory: (BEA04-45.00)

From: Oracle Corporation

Minor Subject: Upgrade recommended to prevent Denial of Service

Product(s) Affected: WebLogic Server and Express

Threat level: High
A remote attack is possible.

Severity: High
A successful exploit results in the server crashing.

Recently a problem was identified that could potentially cause a security vulnerability in certain versions of WebLogic Server and Express. Patches are available to correct this problem (see section II below). BEA treats such possibilities with the highest degree of urgency and does everything possible to ensure the security of all customer assets. As a result, we strongly suggest the following action:

I. Read the following advisory.
II. Apply the suggested action.
III. If you know of any additional users interested in future security advisories, please forward them the registration instructions below.

I. Advisory
Due to a defect in the Sun JVM (see, certain XML parsing operations in WebLogic Server can result in the server crashing when erroneous XML is passed to them. While the JVM defect only affects locally installed code, in WebLogic Server, it is possible to exploit this defect remotely.

All installations, regardless of configuration, are susceptible to this vulnerability.

Sun has corrected this defect in JDK 1.3.1_09 and JDK 1.4.1_02. Some releases of WebLogic Server have been bundled with earlier versions of the Sun JDK, and therefore have this vulnerability.

The following versions of WebLogic Server and Express are affected by this vulnerability
  • WebLogic Server and Express 7.0, released, and Service Packs 1 through 4, on any Sun JDK prior to 1.3.1_09
  • WebLogic Server and Express 6.1, released, and Service Packs 1 through 5, on any Sun JDK prior to 1.3.1_09
  • WebLogic Server and Express 5.1, released, and Service Packs 1 though 13, on any Sun JDK prior to 1.3.1_09

Oracle strongly recommends the following course of actions:

  • For any installation of WebLogic Server and Express 5.1, 6.1, or 7.0 running on a Sun JDK prior to 1.3.1._09,

    Upgrade the JDK to Sun JDK 1.3.1_09 or later. The JDK can be downloaded from here.

    Improper code that was acceptable under JDKs before 1.3.1_09 may cause errors under JDK 1.3.1_09 and later. This failure occurs for JSPs and all beans that are subject to the Introspector API. Specifically, disagreement between a property's setter and getter types may cause startup errors after you migrate to JDK 1.3.1_09 or later. See for more information.


Oracle strongly suggests that customers apply the remedies recommended in all our security advisories. Oracle also urges customers to apply every Service/Maintenance Pack as they are released. Service/Maintenance Packs include a roll-up of all bug fixes for each version of the product, as well as each of the prior Service/Maintenance Packs. Service/Maintenance Packs and information about them can be found at:

Note: Information about securing WebLogic Server and WebLogic Express can be found at Specific lockdown information is provided at We strongly encourage you to review this documentation to ensure your server deployment is securely configured.

As a policy, if there are any security-related issues with any Oracle product, Oracle will distribute an advisory and instructions with the appropriate course of action. Because the security of your site, data, and code is our highest priority, we are committed to communicating all security-related issues clearly and openly.

All previous advisories can be viewed at:

Additional users who wish to register for product advisory distribution should follow the registration directions at:

Security issues can be reported to Oracle by following the directions at:

Thank you,
Oracle Corporation