Security Advisories and Notifications


Security Advisory: (BEA07-157.00)

From: Oracle Corporation

Minor Subject: Authorization checks may not be enforced in AquaLogic Service Bus proxy services

Product(s) Affected: AquaLogic Service Bus 2.5, AquaLogic Service Bus 2.1, and AquaLogic Service Bus 2.0.

Threat level: Medium
This vulnerability exists only in specific configurations. An attacker may able to exploit this vulnerability by sending malformed request messages to a proxy service.

Severity: Medium
In specific configurations, malformed request messages may bypass some authorization checks defined by the AquaLogic Service Bus administrator.

A problem was identified that could potentially cause a security vulnerability in certain versions of AquaLogic Service Bus. Patches are available to correct this problem. Oracle treats potential security problems with a high degree of urgency and endeavors to take appropriate steps to help ensure the security of our customers' systems. As a result, Oracle strongly suggests the following actions:
I. Read the following advisory.
II. Apply the suggested action.
III. If you know of any additional users interested in future security advisories, please forward them the registration instructions included in this advisory.

I. Advisory

Under special circumstances, malformed request messages to proxy services may bypass authorization policies defined by the AquaLogic Service Bus administrator. This vulnerability may exploited by an attacker to bypass security checks and potentially force routing of invalid requests to back-end services. Client applications may also send such requests by accident, unaware of the threat. This advisory solves the issue by rejecting such malformed request messages.

The following versions of AquaLogic Service Bus are affected by this vulnerability

  • AquaLogic Service Bus 2.0 on all platforms
  • AquaLogic Service Bus 2.1 on all platforms
  • AquaLogic Service Bus 2.5 on all platforms

II. SUGGESTED ACTION

Oracle strongly recommends the following course of actions.

AquaLogic Service Bus 2.0

  • Upgrade to ALSB 2.1 and then follow the instructions in the section below for applying the patch for AquaLogic Service Bus 2.1.

AquaLogic Service Bus 2.1

  1. Use the Smart Update tool to install the patch for CR297859.
  2. After applying the smart update patch, edit the setDomainEnv script to replace
                                                           
    set PRE_CLASSPATH=
                                                        

    with

                                                           
    set PRE_CLASSPATH=%PATCH_CLASSPATH%
                                                        

AquaLogic Service Bus 2.5

  • Use the Smart Update tool to install the patch for CR297859.

AquaLogic Service Bus 2.6 will include the functionality in this patch.



SECURITY COMMUNICATIONS

Oracle strongly suggests that customers apply the remedies recommended in all our security advisories. Oracle also urges customers to apply every Service/Maintenance Pack as they are released. Service/Maintenance Packs include a roll-up of all bug fixes for each version of the product, as well as each of the prior Service/Maintenance Packs. Service/Maintenance Packs and information about them can be found at: http://www.oracle.com/technology/software/products/ias/bea_main.html

Note: Information about securing WebLogic Server and WebLogic Express can be found at http://edocs.bea.com/wls/docs103/security.html. Specific lockdown information is provided at http://e-docs.bea.com/wls/docs103/lockdown/index.html. We strongly encourage you to review this documentation to ensure your server deployment is securely configured.

As a policy, if there are any security-related issues with any Oracle product, Oracle will distribute an advisory and instructions with the appropriate course of action. Because the security of your site, data, and code is our highest priority, we are committed to communicating all security-related issues clearly and openly.

All previous advisories can be viewed at: http://www.oracle.com/technology/deploy/security/wls-security.

Additional users who wish to register for product advisory distribution should follow the registration directions at: http://www.oracle.com/technology/deploy/security/alerts.htm.

Security issues can be reported to Oracle by following the directions at: http://www.oracle.com/technology/deploy/security/alerts.htm.

Thank you,
Oracle Corporation