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Introduction
Welcome to the User Guider MIMM .

Disclaimer

Some of the features detailed in this document may not apply and/or be available for
the particular [MIMM] edition you may have.

Metadata Overview
MIMM provides a comprigensive and well integrated set of Metadata Management (MM),
DataCatalogingdDC) and Data Governance (DG) solutions supporting on premise, cloud based
or hybrid Enterprise Architectures ranging from the classic Data Warehouse tddébeDeata
Lakes and Da Vaults:

Integrated Solutions: Metadata Management, Data Cataloging, and Data Governance

Multi-Deployments: On Premise, Cloud, or hybrid (Cloud with on premise harvesting)

Multi-Architectures from the Data Warehouse to the new Data Lake / Data Vault

Multi-Vendors from any Data Integration and Business Intelligence tools

Multi-Technologies from files and SQL based RDBMS, to the new NoSQL, JSON, Avro,

Parquet, XML and Hadoop big data technologies, REST API Data Services

Multi-Storage File Systems: Data dagéng by file crawling over Linux/Windows,

Hadoop HDFS, Amazon S3, Azure Blob Storage, OpenStack Swift, Apache Kafka, etc.

0 Multi-Configurations with Change Management and Incremental Metadata Harvesting,
Comparison, Version & Configuration Managemerd aotomatic stitching

o Multiple integrated tools for Search, Data Flow and Semantic Lineage, Data Modeling,

Data Mapping, Active Data Governance (generatiosetiserviceDI and Bl), Muki

Vendor Bl Web Portal

O O O 0o

o

MIMM provides solutions for &ull range of users:

0 Most business end users in need of a muthdor Business Intelligence (Bl) web Portal
with quick access to the rigihéport understand its content with proper business
definitionsfrom the enterprise business glossary.

0 Advanced busiess users andomplianceofficers looking for information traceability
(data lineage) and data privacy for General Data Protection Regulation (GDPR),
SarbanegOxley (SOX) regulations, and more.

o Data stewards, data modelers, and data quality experts wgrkimenterprise data
standardization, common vocabulary, data modeling and business rules with powerful
tools like the business glossary, semantic mapper, aetdeler.

o Data analysts in need stltservicedata integration, preparation, and business
intelligence using the data mapping design tool with active data governance (forward
engineering) to their actual DI/BI tools.
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(0]

Features

IT engineers, data scientists data Integration and business intelligence developers
looking complex mukvendor and multiarchitecure end to end linage in great details
down the design level information of each tool with support for change impact with full
detailed version and configuration management.

Metadata Harvesting

(0]

Data Stores

- Databases@racle, SQL Servdreradata, IBM DB2, PostgreSQL, MySQL, AWS
Redshift, GreenPlum, Netezza, SAP HANA, etc.)

- Big Data (Hadoop Hive, Hcatalog, Google Big query, etc.)

- NoSQL (Cassandra, HBase, MarkLogic, MongoDB, etc.)

- Flat Files (CSV, XLSX)

- HierarchicaFiles (JSON, Avro, Parquet, XML, XML XSD, etc.)

- File Systems ((Linux/Windows)

- Data Lake and Cloud Hadoop HDFS, Amazon S3, etc.)

- Data Services (Open API, etc.)

Metadata Stores

- Data Modeling Tools (Erwin, ER/Studio, PowerDesigner, etc.)
- Metadata ManagemengAtlas, Navigator, etc.)
- Semantic Web Ontology (OWL/RDF)

Data Integration

- DI/ETL Scripts (Oracle PL/SQL, Teradata BTEQ/FastLoad/BulkLoad, Hadoop HiveQL,
Sqgoop, SAS code, etc.)

- DI/ETL Tools (Informatica PowerCenter, IBM DataStage, Oracle ODI, Micrt&oft SS
SQP Data Services, SAS DI, Talend, etc.)

Business Intelligence (SAP BusinessObjects, IBM Cognos, Microsoft SSAS/SSRS, Azure
PowerBl, Oracle OBIEE, Microstrategy, Qlik, Tableau, ThoughSpot, TIBCO Spotfire, etc.)
Business Applications (SAP Business SB#P Business Warehouse, Salesforce, etc.)

Metadata Management (MM)

(0]

(0)
(0)

Model Manager (with automatic metadata stitching, and Enterprise Architecture
diagramming)

Metadata Search (metadata driven pre and post filters, semantic search language)
Metadata Browse (hierarchical metadata browsers with custom metadata profiles per
tool/technology)
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0 Metadata reporting capabilities where both search and browse end up to the same

reporting page which is also directly availabl&\ ODRKSHEE¥®&lanage

Metadata Tabular Aalyzer Reporter (with bulk editing capabilities)

Data Model Visualizer (ER Diagrams)

o Data Flow Lineage and Impact Analyzer (Data flow Lineage and impact analyzer down to
feature level, with data vs control flow)

o Multi-Configuration Management (multi cogfirations for different enterprise
architectures and groups)

o Multi-Version Management (efficient automatic incremental harvesting, with model
history/SOX compliance)

0 Metadata Comparator (comparison with previous versions for the impact of change)

o O

Data Govenance (DG)

0 Business Glossary (BG) (with customizable workflow automation)

0 Semantic Mapper (search driven, auto map, and meltels from glossaries to data
stores via design models)

0 Semantic Lineage Analyzer (term usage, and automatic glossary defomitabata pass
through)

0 Local Documentation (quick in place editing of business names and descriptions while
browsing harvested data stores)

0 Glossary Linking (quick in place semantic linking while browsing harvested data stores,
Dl jobs, and Bkports)

o Data Tagging (applying reusable Labels available in search)

o Comments and Reviews (collecting business user feedback and managing reviews)

DataCataloging@C)

File System Crawling (file type atdetection, partitioning autedetection)

Data Profihg (from data sampling to full data profiling with statistical results)
Semantic Discovery (semantic types, patterns/lists machine learning)
Relationship Discovery (data driven matching semantic types and metadata driven
inferred from usage in DI, Bl, S@Ic.)

Social Curation (endorsement, warnings, certifications with impact on search)
Data Modeling

o Data Store Documenter (automatic reverse engineering of naming standards with
supervised machine learning)

Data Store Modeler (with full data model diagrauiiting)

o Data Store Designer (new data store specifications and design)

o O OO

[olNe]

o

Data Mapping
o Data Mapper (from business user data mapping specifications to design for bulk and

feature/SQL with joins/filters/lookups)
0 Metadata Applications
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o BI Web Portal (Mukvenda Bl Web Portal with kilirectional integration, and glossary
generation)

Active Data Governance (Forward Engineering)

Data Modeling Tools (Erwin, ER/Studio, PowerDesigner, etc.)

Data Integration Scripts (PL/SQL, BTEQ, HiveQL, etc.)

Data Integration (tesdf-service/ data prep tools)

Business Intelligence (geltservicelike Tableau or design layers like BO Universes.)

© O O O

Administration, Customization, & Extensions

o

Custom Attribute Extensions (MyCompanyCertificationLevel, etc.)

Customizable Ul (menus, widdayout, etc.)

0 REST API (glossary lookups, linage trace, automatic harvesting, search, browse, update,
etc.)

o

Explore Mtadata

FundamentallyMIMM is a metadata management tool. Thus, a key aspect of the feature of
MIMM centersaround looking up, finding or discovering metadata thdiasvestedinto the
system.

In particular, you may use the search (both immediately as you typekhasva more advanced
search page) by contained text. In addition, you may browse directly by metadata category and
type. You may create worksheets to report on the metad&tmally, you may locate elements

by navigating the current configuration artdgture.

Customization: The search categories, results and available actions may all be customized and
new categories defined. Please see the Customization tutorial for this capability.

Signing In

Steps

In order to sign in, you must have a valid username ass$yword or already be authenticated
when usingexternal aithentication

Once authenticated, you will either be directly connectegéarr assigned configuratiocor will
be able to pick @onfiguration and version of that configuration

1. Enter the URL as defined fsiMM .

The Authentation page is shown

2. Enter yourUsernameandPasswordand clickoOGIN
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This may take you to thdIMM homepagef you have specified a default configuration seeting
(see below) or if you only have access to one configuraton version.

3. Select aonfiguration

4. Click Choose Version to selectaasion of that configuration

You may checthe Automatically use thisonfigurationby defaultcheckbox to alwaysnter
this configuration on signing in with this account.

Example
Open a web browser anchier the URL as defined fMIMM .

Administrator

PASSWORD

LOGIN

You are presented with the login page

Enter yourusernameand password

You are then presented with tiSelect a configurationlialog.
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Select a configuration
(© RECENT 1

[y Published

ALL 2

|& Enterprise Architecture from Enterprise Architecture

[y Published

Select thePublishedconfiguration in theEnterprise Architecturéolder by duble-clickngon
that entry.

You now are at the homepage for that configuration.

Published ~ &

£ Search

o=

The configuration is ideffied in the upper right of that banner.

Return to the Select a Configuration dialmgclicking on that configuration name in the banner
and going tdMiore.
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# Default
Mo default Configurations
® Recent

Publishead

Other

Published

More

Slect thePublishedconfiguration in theEnterprise Architecturgolder with a singleclick this
time, and clicHOOSE VERSION

Select a configuration

< Back Select a version for Published

Version Name Created Read Only
(® Development | Friday, the 22nd of November 2019 at 06:31:37 AM - 10 Hours Ago | No
“7) Published Monday, the 21t of October 2019 at 040053 PM - 1 Month Ago MNo

[] Automatically use this configuration by default CANCEL

There are two versi@of this configuration, onublishedwhat you are one now as it is the
default) and onddevelopment(used forglossary workflow actions
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Click on thebevelopmentversion and check thAutomatically use this configuration by
default checkbox. Then click OK.

Published (Development) ~ §

The configuration (and version) is identified in the upper right of that banner.

Click oryour avaar in the upper right of the banndrtog out Then, log back in.

Published (Development) ~ §

p Stuart Steward

(m]0]

= Edit user account

£ Preferences

[+ Logout

The configuration (and version) is identified in the upper right of that banner as you are returned
to your new default.

Edit My User Account Details
After signing in you may set or update the identifying details associated with the user account
you signed in with.

t
e 1. Click on the thumbnail picture of the signed in user in the upper igimd of the UI.
2. SelectEdituseraccount.
3. Enter or updatdJser account avatar
4. Enter or update the fields provided:
-  FULL NAME

-  EMAIL
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- DESCRIPTION

5. To reset the password (forrative usey enter thePASSWORDSdRETYPE PASSWORD
fields.

6. You may also resw and analyze details abotlite STATISTICS and ACIVITY STREAM

Example
Sign inas any user (Stu is used here).

Click on the thumbnail picture in the upper righénd and seledEdit user account

Administrator
= User Profile

£ Preferences

[= Log out

Enter the identifying informatiom place.

NFORMATION

XA Email: tu@metatintegration.com
Full Name: Stuart Steward

Description:  Stu the Steward

Click theEdit Avatarbutton @
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User Profile

'@ ACTIVITY STREAM <
Stuart Steward
Stu
@ < PREVIOUS WEEK  Apr |
Edit Avatar

2. Groups:  Business sers

INFORMATION
24 Email: stu@metatintegration.com

Full Mame:  Stuart Steward
Description:  Stu the Steward

CHAMNGE PASSWORD

STATISTICS
{® Certified Objects: & {& in configuration
!ﬁ Endorsed Objects: 0 (0 in configuration
© wamed Objects: 0 (0 in configuration

)
)
)
B Commented Objects: 0 (0 in configuration)
o» Stewardship Objects: 8 (8 in configuration)

)

«» Stewardship Models: 0 (0 in configuration

Collections: 0
Worksheets: 0
|E| Dashboards: 0
Object Worksheets: 0
[iZ) object Presentations: 0

Navigate to your image and cli€pen
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User Profile

'@ ACTIVITY STREAM < Ap
Stuart Steward
Stu

< PREVIOUSWEEK  Apr 21

& Groups: Business Users

INFORMATION

EX{ Email: stu@metatintegration.com
Full Mame:  Stuart Steward

Description:  Stu the Steward

CHAMNGE PASSWORD

STATISTICS
® Certified Objects: & (6 in configuration)
1l Endorsed Objects: 0 (0 in configuration)
© Wamed Objects: 0 {0 in configuration)
B commented Objects: 0 (0 in configuration)
o» Stewardship Objects: 8 (8 in configuration)
a» Stewardship Models: 0 (0 in configuration)
Collections: 0
Worksheets: 0
@ Dashboards: 0
Object Worksheets: O
| 7 I T n

The user account is contained insprenthesesnd the Full Name is displayed directly below
the avatar image. Groups that a specific user belongs to are displayed below the user accpunt.

You may also review and analyze details allbetSTATISTICS and ACIVITY STREAM
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Edit My User Preferences

After signing inyou may set or update the preferences associated with the user account you
signed in with.

Steps
1. Click on the thumbnail picture tfie signed in user in the upper rightand of the UI.
2. SelectPreferences
3. Use checkboxes to set or unset preferences.

Example

Sign inas any user (Stu is used here).

Click on the thumbnail picture in the upper righénd and selecPreferences

Administrator
= User Profile

£ Preferences

[~ Log out
Check the first checkbox.

i & Preferences x

Y Update the configuration automatically when importing new version of a model

[] Open Monitoring Dialog automatically when starting an operation

RESET TO DEFAULTS APPLY CANCEL

Explorer Panel

The explorer pnelis a Ul feature oMIMM whichemphasizes navigation using various

organizational structures presented as a tresset of flat search results or collections of
objects

There are several flavors of the explorer panel:
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Object
Collection
Worksheet
Dashboard

O O OO

The object explorer is theéefault explorer presentation and is always accessible simply by
clicking the OBJECTS menu on any pabere are several presentations available vtfita
objectexplorer panel

0 TheBrowsepresentationshows a limited number of siblings and alloyesito jump to
them all much lke a traditionalTreeinterface or aDrill presentationis useful when you
need to work with a longjst of siblings (e.g., 100Q@8bles in a database schema)

0 TheSearchbased Explorer Panel allows one to work with a flat lisextf search results.

Steps
1. Several options exist:
- Click theOBJECTI8enu
- ClickOBJECT&hd select entriesinder Explore
Example

Clickthe OBJECTi8enu. TheObjectsexplorer panel opens on the left
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OBJECTS COLLECTIONS

Explore

Search

® Recent =

)

Mo recent Objects
B Browse Categories 24
Glossary

Data Modeling

Datazet

Database

File

J50M Database

SAP BusinessObjects

Tableau

Data Mapping
S0L Script and Mapping

Talend Data Integration

Additional

My Term Changes
Architecture Diagram
Statistics

Click Explore, and Browse panel opens witlilters or search criteria (or the last ones you
entered).
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OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS

Browse Search g X
Mo filter applied Y

+,-j Accounting

+,-j Customer Management
+,-j Financial Analysis
+,-j Glossary

+,-j Perzonnel

- =7 Vendor Management

You may remove the panel by clickthg Close® ) icon Otherwise, it is pinned open as you
click on objects in the tree.

Explore Further

Browse Hierarchicallysingthe Explorer Panel
Once n the explorer panel, you maysethe Browsetab and navigate theibrarchical structures
in the configuration This Browseuhctionality provides a sgle hierarchy that may be
navigated down to the lowest level of granularity (e.qg., fieldsfiteaor columns in a table)
without stopping at the model (harvested) level.

Steps

1. Open the explorer panel

2. Click theBrowsetab at the top of the panel.
Example

Go toOBJECT > Explorén the menu.

OBJECTS COLLECTIONS

Explore

The default hiearchical presentation is a tree view based upon the configuration folder
structure.
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OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MANAGE

Browse  Search o IS 4
Mo filter applied b d

+- Accounting

+- Customer Management
+- Financial Analysis
+- Glossary

+- Personnel

+- Vendor Management
+- Warehouse

Explore Further
The explorer pandBrowsetab has several options in terms fesentation You may specify
displayPreferences

1. Click thePreferencesicon(':').

2. Select thespecificoptions.

DISPLAY MODE

There are two modes of navigating the resulting hierarchy.

0 Tree-TheTreepresentationshows a limited number of siblings and alloyesi to jump
to them all much like a traditional tree interface.

0 Drill - The Drill presentationis useful when you need to work with a long list of siblings
(e.g., 10K of tables in a database schema)

HIERARCHY TYPE

This options allows you to show the tree structure based upon one of the following hierarchical
structures, as they ardefined indifferent componentswithin MIMM :

o0 None¢ Simply a flat structure of the models in thenfiguration

o Configurationg Displays the tree using the structure of folders and contents defined in
the configurationitself.

o Repositoryg Displays the tree using the structure of folders and contents defined in the
repository.
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MAXIMUM OBJECTS PER LEVEL

Tree structures may be huge and tHgMM & LJF IA Y 6 S&a¢é¢ GKS NBadzZ Ga Ay
responsiveness over networks. This optadlows you to specify the number of elements to
display at a particular level.

SHOW ATTRIBUTES

Additional attributes may be shown in the tree, including all the curation icons as well as
Alternate Name.

Root Filters

Additional filters to apply from theoot on down in the hierarchy. These include:

o CATEGORY
o STEWARD
o LABEL

Example

DISPLAY MODE

Click thePreferencescon \’:') and tick Tree

DISPLAY MODE
To Tree "= Dril
HIERARCHY TYPE
Mone  Configuration = Repository
MAXIMUM OBIECTS PER LEVEL
100 W
SHOW ATTRIBUTES
] Alternate NamefRs] Endorsements
[ ] Description [ | Warnings

4] Certification [ ] Comments
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Tree Mode

Expand the Glossary folder.

+- Accounting

+- Custamer Management

+- Financial Analysis

—- Glossary

+| Enterprise

+ & Enterprise to Finance Glossary

+| Finance

+- & Finance Glos=ary to Tableau

Click theFinanceglossary item.

l Finance | clossary ONET BN !
Overview Categories Semantic Flow Comments Attachments Audit Log
Categories < 1-50f7 > + CREATE [ 7] Labels
Domains add value
Finance Dimensional DW
coon Collections
Relationships add value
Terminology

Attributes
Mame Finance
Model ... Development

Stewards = David (David)

LastM... (9 7 Hours Ago
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To restore the tree, simply click OBJECTS dfygou click on another item in the tree, you will
be takentothalS f S Y Sy (i Pagje. RoB/éver itte geverse is not true. If you navigate fron
the details pagdo an item, the Explorer Panel does not afad Instead, you may use ttghow
in Exploreroption in the upper right.

Click theGDPRategory in thedetails page Here, we navigate to th@DPRcategory, butwhen
you clickOBJECTi8e Explorer Panetloes not updatéo GDPR

OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MAMNAGE

E searen s x E GDPR | category from Finance

category = Glossary’ Y
Overview Categories Terms Semantic Flow
—- 7 Glossary
+ @ Enterprise Definition
—| Finance
JL..E Categories General Data Protection Regulation

https:/fen.wikipedia.org/wiki/General Data Protection_Regulation

Terms -50f 10 »

=| Address

=| eMail Address

=| Gender

=| General Data Protection Regulation

—| Last Mame

With the explorer pael opened it remains as you click outside and other panels are resized [to
accommodate it.

Now, selecShow in Explorefrom the More actionspull down in the upper right of thdetails
page and the Explorer Panel is updated.
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OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MANAGE

Browse Search # x E GDP‘R | Catﬂgﬂr}" from Finance
Mo filter applied Y

. Overview Categories Terms
+-[55 Accounting

+ Customer Management Definition

+ Financial Analysis
_ Glossary General Data Protection Regulation

https:/fen wikipedia.org/wiki/General Data_Protecti
+| Enterprise

+ & Enterprise to Finance Glossary
—| Finance
_E5 Categories =| Address

+-[F Domains =| eMail Address

Terms < 1-5of10 >

+ Finance Dimensional DW =| Gender
+ GDPR =| General Data Protection Regulation
+ Relationships =| Last Name
+ Terminology
+ User Data Types
+ Web Contact Naming Standards

+- @ Finance Glossary to Tableau

+-[E7 Personnel
+ Vendor Management

+- =7 Warehouse

Drill MODE

Click thePreferencesconin the Explorer Pane(‘:') and clickDrill.
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OBJECTS COLLECTIONS  WORKSHEETS DASHBOARDS MAMNAGE

Browse Search s X == RNPR | ratennn from Finance

Mo filter applied DISPLAY MODE I

~ ' s Tree = Dl Terms Serr
- . . HIERARCHY TYPE .

U FILTER TEXT
PE i Mone = Configuration | Repository
counting

MAXIMUM OBIECTS PER PAGE julation
Customer Management 100 ~ General Data_Protectis
Financial Analysis ICOMS
Glossary Small | Large

CHIM -'I.l"ﬂ'. . E'._
Personnel SHOW ATTRIBUTES

Vendor M Alternate Name[.s] Endorsements
endor Management
[ Description [ ] Warnings

Warehouse Regulation
[ Cerification [ ] Comments E

Click the caret”) to expand theGlossaryfolder.

Browse Search g X
Mo filter applied b d
# * Glossary

-

Q] FILTER TEXT

(@ Enterprise

& Enterprise to Finance Glossary
|@ Finance

45 Finance Glossary to Tableau

Click theFinanceglossary item.
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If you click on another item in the drill list, you will be taken to tedils page However, the
reverse is not true. If you navigate from thetails pageo an item, the Explorer Panel does npt
update.

Click theGDPRategory in thedetails page Here, we navigate to th&DPRcategory, but the
Explorer Panetloes not update.

OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MAMNAGE

m Seareh 2 x E GDPR | category from Finance
Mo filter applied Y
) iew Categories Terms Serr
# * Glossary * Finance
S Definition
o Categories

General Data Protection Regulation
hitps:/len.wikipedia.org/wiki/General_Data_Protecti

Terms < 1-5of 10 »

=| Address

=| eMail Address

=| Gender

= | General Data Protection Regulation

—| Last Mame

Now, selecShow in Explorefrom the More actionspull down in the upper right of thdetails
page and the Explorer Panel is updated.

In Drill mode, there is nioee to expand, so the drill level is changed.
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Hierarchy TYPE

Click thePreferencescon @:‘) and selecRepositoryfor the HERARCHY TYPE

DISPLAY MODE
To Tree "= Drill
| HIERARCHY TYPE
1 Mone  Configuration  Repository

4 MAXIMUM OBJECTS PER PAGE It
100 v F
COMNS
Small | Large

SHOW ATTRIBUTES
4] Alternate Namels] Endorsements
[ ] Description [] Warnings

4] Cerification [ ] Comments

The hierarchical structure now reflects what is defined within the Repository as a whole.

SHOW ATTRIBUTES

Clik the Preferencescon @:'),and clickTree and select all of the options undSHOW
ATTRIBUTES
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DISPLAY MODE
7o Tree | "= Dril
HIERARCHY TYPE
MNone = Configuration | Repository
MAXIMUM OBIECTS PER LEVEL It
100 W I
SHOW ATTRIBUTES
] Alternate Name[”] Endorsements
A Description [ Warnings

L Cerification 4 Comments

Now, we see all the curation icons and alternate names.

Navigating a Hyperlinked Tree
In some instances there are a number of relationships betwetements in a model that cannot
be represented by a simple tree structure. E.g., and index on a table relates to a specific set of
columns, but is not contained in any one column, so it is shown as contained with the table with
hyperlinks(represented bya curved arrow over its icomnd related columns.

Steps
1. Open the explorer panel

2. Click theBrowsetab at the top of the panel.

3. Expand to the following in the treand click on the VendorID reference (hyperlink)
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Browse Search

Mo filter applied

—- Vendor Management

+§ Accounts Payable

. Accounts Payable erwin
i--;m Tables - Entities

Jr P BillingAddress

+ Invoice

+ Invoiceltem

+ Payment

+ Paymentdddress

+ PaymentAssignment
+

POLineltem

ﬁﬁﬁﬁﬁﬁﬁ

i POLineltemInvoiceltem

-!-,:, Columns - Attributes

i--ﬁ Indexes

~=f8 XIE2POLineleminvoiceltem
~ &7 VendorlD

S X

:' YendorlD

®m  VendorlD (add business nam

ORACLE" Enteprise Metadata ManagementUser Guide

ell@ | ¢

from Accounts Payable erwin » POLineltemlnvoic

Overview Related Diagrams Inde

Business Description

Unique ID for a vendor

Description

Unique ID for a vendor

Comment

Unigue 1D for a vendor

Index Members =

£ VendorlD
=1 VendorlD

7 VendorlD

Semantic Usage

+-=B InvoiceNumber

+-+&7 LinaltemMumber
Mapped

B VendorlD
+-=f8 XIF1POLinelteminvoiceltem

+-=f& XIF2ZPOLinelteminvoiceltem
+-2f8 XPKPOLinelteminvoiceltem
-!---F:m Relationships

+-FH Related Tables - Entities - Views v

You may also rightlick the reference and sele@o to referenceand it will take you to that
element in the tree.
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~.=f8 XIE2POLineltemInvoiceltem
%--“En VendorlD

3y Refresh Children

48 InvoiceN
o8] InvoiceN = Show in Drill

+-=&7 Lineltem

= G0 to reference

-l---nlg ¥IEA DNl ino rarm e e ey

i--,:, Columns - Attributes
T PONumber

(=] -
InvoiceMumber

+- VendorlD

+
+
+ 7 POLineltemNumber
+
+

T LineltemNumber
-2l8 Indexes
~of8 XIE2POLineleminvoiceltem
—“E” VendoriD
: f' WendoriD

+-&] InvoiceNumber

+-+E7 LineltemNumber

When navigating in thMANAGE > Repositoryage, you may doublelick on a refeznce in the
tree of a model in order to go to the referred object, as well as-gltking and selectioGo to
reference

Organize the Configuration
You mayorganizethe contents presented for the partidar configuration

Steps
’ 1. Signin as a user with at least tBditor security roleto the configuration you wish to
organize.
2. Go to MANAGE> Repository
3. Clickthe configurationversion

4. In theconfiguraton manager lick New Folderto create folders.
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5. Drag any content in the configuration into a folder to organize.

Example
Sign in addministrator and go toMANAGE> Repository

In the Repositorypanel, expand the tree until you see tEaterprise Architecture
configuration.

Repository Manager < Enterprise Architecture | configuration Cont:
_J Architecture
£ Find

~B Repository
—- Enterprise Architecture
+- Business Intelligence (BI) add description o

+-[ Data Lake (DL) Last n
+- Data Warehouse (DW)

» B O

Overview Security Versions Log |

Description Prop

+- Information Management (Semantic)
+- Operational Data Stores (ODS) Stewards
+-2 AR and AP

+ #> Data Mapping .

+-2 erwin diagram issue Labels

+| Example Glossary

+|§j Enterprise Architecture add Labels(s) -

+ & SemanticMapping
+ *} Staging DW to AP AR

Expand the plus sign next tois configuration andlickthe Publishedversion.
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Repository Manager 4 2T\ Published | configuration version from Enterpris
Architecture/Enterprise Architecture
2L = ol 4 Overview Models Diagram Log
i--CE Repaository . m—
—- Enterprise Architecture P Fine
+- Business Intelligance (BI) iJ& Configuration
+- Data Lake (DL) +- Accounting
+- Data Warehouse (DW) +- Customer Management
+- Information Management (Semantic) +- Financial Analysis
+- Operational Data Stores (OD5) +- Glossary
+§ AR and AP +- Personnal
+ ®> Data Mapping ® +- Vendor Management
+§ erwin diagram issue +- Warehouse
+| Example Glossary : # Data Mapping - Development
—|;§_j Enterprise Architecture B Example Glossary - Development
(® Development & SemanticMapping - 2020-02-12 08:06:40
) Published

+- % SemanticMapping
+-#> Staging DW to AP AR

The configuration opens in the middle work panel.

Note, there is already a structure. Click on Mere Actions(E) icon,Add, New folder icon
and name iWarehouse
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D Finc

| ~.[Jj Configuration
+- Accounting 2+ Refresh = Model

o Add > | | Folder

+- Customer Management

+- Financial Analysis

+- Glossary

+- Personnel

+- Vendor Management

+- Warehouse

# Data Mapping - Development
| Example Glossary - Development

i T

----- ¥ SemanticMapping - 2020-02-12 020640

Drag the Dimensional DW model into that folder.

Close the configuration amight-click on it in the Repository panel and selS8utitch to this

configuration
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~.[B Repasitory
—- Enterprise Architecture
+- Business Intelligence (BI)
+- Data Lake (DL)
+- Data Warehouse (DW)
+- Information Management (Semantic)
+- Operational Data Stores (OD3)
+§ AR and AP

+ ®> Data Mapping

-[Bl) Enterprise Architecture

0 Development

& Unpublish

T & SetAs Read Only

+I Examp r=, Create a Copy @
+~Q’ Seman

-i---#) Staging
+- I Support

- = arwin ¢

9, Operations >

Switch to this configuration

Compare with previous versian

Compare with

&> Backup
< View Links

¥ Delets

Now, again look at the configuratdmierarchy in the Explorer.
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Browse  Search o

Mo filter applied h 4

+- M Accounting

+- Custarmer Management
+- Financial Analysis
+- Glossary

+- Personnel

+- Vendor Management
+- Warehouse

+#> Data Mapping

+|ﬂ Example Glossary
+-$ SemanticMapping

See the new folder and structure.

Organize the Repository
You mayorganizethe contents presented in thRepository Treefor the Repository as a vake.

Repositoryorganization is very important as you may schedule, assign permissions, and pgrform
actions (rightclick) by folder.

Searclusing the Explorer Panel
Once in the explorer panel, you may use 8earchab to presentasa flat list of text search
and filteringresults.

Steps
1. Open theobjectexplorer panel

2. Click theCollectionstab at the top of the panel.

3. Enter text in the SEARCH TEXT field to filter the results according to that text string.
4. Click CATEGORY to select ardliype to filter the results by.

5. Click+FILTER add additional filtercriteria, or clear these by clickirRESET FILTERS
6. Click any item in the results to display tihetailspagefor that item.

7. Clickthe Open as worksheelink to produce aworksheetout of the search results.
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Example
Click theSearchtab in the explorer panel header.

Browse  Search  Collections » 0O

Q SEARCH TEXT el

CATEGORY

S P

9y i SNJ alLySEARCHIEKTA Yy (KS

Browse  Search  Collections » 0O
O Invoice o |
CATEGORY Search text in:
e ' |4 Name
— ' |4 Physical Mame
) RESETFITERS  + FIl 3 pescription
== Invoice o [ Others

from 5taging DW > dbo

' -
—___ Invoice ,SE mantic Search

As you type the search already begins. You may use the seanutierstand what is available
in the configuration.

Click on thesearch text ir(z=) iconto specify the text search options.

By default, the search only includes Name and Physical Namgguutay extend that even to
include theSemantic Search rules

Click onrCATEGORMNd selecDatabase> Table
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Browse Search  Collections > 0O

O Invoice o=

CATEGORY

Database » Tables X W

i Q Filter Text

+ | | Glossary “

+ [ ] Data Modeling
+ | | Dataset

— [ ] Databass

E | | Databases

+ Tables
+ [ ] Columns

| | Procedures
[ ] Diagrams

) + [ Fila
from Accounts Recervable » dbo

e |nveiceltem

from A rcnonte Davushla s« dbn

1-19of1%9 1

And the results are now filtered to only show Tables and Views.
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Browse  Search Collections » O
O Invoice O
CATEGORY

Database » Tables X W
o RESET FILTERS  + FILTER
£ Invoice o -

from 5taging DW > dba

L Invoice
from Accounts Payable » dbo

E=E= Invoice
from Accounts Receivable » dbo

== CustomerPOInvoicelt=m
from Dimensional DW » dbo

== Inveoicelineltem
from 5taging DW > dbo

= POLinelteminveiceltem
from Accounts Payable > dbo

== Inveicelog
from Accounts Receivable » dbo

= Inveiceltem

From Arcnonde Davshlas Ak

1-15of19 1

Pin the explorer panel as we will havepen for a while.

Click thelnvoicetable inStaging DWt dbo.
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Browse & % Invoice (add business name) || | Table
) Invoice =
Overview Related Diagrams Colur
CATEGORY
Databs Tables x o . S
B — Business Description
| [
N A RESET FILTERS  + FILTER odd value
== CustomerPOlnvoiceltem -
from Dimensional OW > dbo
Columns < 1-50f7 >
E= Invoice
from Accounts Receivable » dbo E Invoice Mumber
B Invoice

InvoiceDescription
from Accounts Payable » dbo

. InvoiceAmount
0 Invoice o

from Staging DW > dbo InvoiceStatus

== InvoiceAssociationtoPurchaseOrder
from Accounts Receivable » dbo

e InveiceAssociationtoPurchaseOrder * Data Sampling and Pruﬁling
from Staging DW > dbo

InvoiceDate

On MO 0OOm Oom

E= InvoiceDate Data Profiling has never been run on this object. Re
from Dimensional DW > dbo

3 Invoiceltem
from Accounts Payable » dbo

E== [nveicelineltem
from Accounts Receivable » dbo

B Invaicelingltem
from Staging OW > dbo

£ Invoicelog
from Accounts Receivable » dbo

B Invoicelog
from Staging DW » dbo

= POLinelteminvoiceltem
from Accounts Payable » dbo -

1-19 of 19 1

If you click on another item in the search results, you will be taken tal#tails page
However, the reverse is not true. If you navigate fronditails pagdo an item, the Explorer
Panel does not update.

Click+FILTER
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Browse  Search  Collections 0O 2 nvoice (5
o Invoice B
. Overview
CATEGORY
Database » Tables x W . .

Business Descript

o B HERATALNES oL add Business Descriptic

= Invoice Q Filter Text

from 5taging DW > dbo
Common Attributes

= |nveice
B S

from Accounts Payable » dbo Content |
= Invoice Object Type

from Accounts Receivable » dbo

. Last Modified

= CustomerPOlnvoiceltam

from Dimensional DW > dbo Steward
== [nveicelineltem Label

from 5taging DW > dba Certified By
== POLinelteminveiceltem Endorsed By

from Accounts Payable » dbo
Commented By
B Invoicelog
from Accounts Receivable » dbo Warned By
B Invoiceltem Custom Attributes

From Accounnte Davahla « dbn

| Color
1-19o0f19 1

[ata Fxniration

Already we have one filter (shown above thEILTERk), the Content filter. You may add an|
number of filters on any of the attributes listed. You may clear all current filters wiREBET
FILTERSk.

ClickOpen in Workshee(E) and you have aeport based upon the same search criteria and
filters.

Explore Further
You may specify displ®references

1. Click thePreferencescon @:').

2. Select thespecificoptions.
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SORT DIRECTION

Ascending or descending.

ITEMS PER PAGE

Search result sets may be huge and tMUMM ¢ LIJF Ay | (G Sa ¢

G§KS NBadz Ga

responsiveness over networks. This option allows you to specify the number of elements to

display at a time..

ICONS

Small or Large.

SHOW ATTRIBUTES

Addtional attributes may be shown in the search results, including all the curation icons as well

as Alternate Name.

Example

Click thePreferencescon @:') and select all of the options undSHOW ATTRIBUTES

SORT DIRECTION

Ascending
ITEMS PER PAGE

500 W
ICONS

Small  Large
SHOW ATTRIBUTES

[ Alternate Name
Context

iA Description

Descending

Relevance

] Certification
4 Endorsements
(] Warnings

[] Comments

Now, we see all the curation icons and altemaames.
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Browse  Search  Collections > 0O
< Invoice .
CATEGORY

Database * Tables X e
¥4 RESET FILTERS  + FILTER
== Invoice o -

from 5taging DW » dbo

3 Invoice
from Accounts Payable » dbo

== |nvoice
from Accounts Receivable » dbo

= CustomerPOlnvoiceltam
from Dimensional DW > dbo

B Inveicelineltem
from 5taging DW » dbo

B POLinelteminveice|tem
from Accounts Payable » dbao

E= Inveicelog
from Accounts Receivable » dbo

== |mvaiceltem

From A rcoonte Davzshla « dho

1-19o0f 19 1

Search

Immediate 8arch
You may immediately perform searches from anywhere.

Steps
1. Click in theSearch text box in the upper right.
2. Enter any text.

Example

£ Search =
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You search for anyetadata elemenO2 y G F Ay Ay 3
O pur X 0

Search results
B2 PurchaseOrder (Purchase Order) o

|

l o

OO0 MO OO0 O [MOD0 OOn Om

1-100f 475

Relevance and Ordering of Resullsie firstmetadata elementn the list of results are Certified,
The presentation order of the search results are altered by actionselitification To learn

from 5taging DW » dbo

U5 Social Security number
from Finance > GDPR

PurchaseOrder
from Accounts Payable erwin

Purchase Order Line ltem Number (PO Vendor Invoice Item_ ...

from Tableau » Metadata Management » Financel » PO_Vendor_In...

Purchase Order Date Time Dimension ID (PO Vendor Invoice _..
from Tableau » Metadata Management » Financel » PO_Vendor_In...

Purchase Order Date Time Dimension ID (PO Vendor Invoice ...
from Tableau » Metadata Management » Finance? » PO_Vendor_In...

Purchase Order Date Time Dimension |D (PO Vendor Invoice ...
from Tableau * Metadata Management * Finance3 » PO_Vendor_In...

Purchase Order Number (PO Vendor Invoice Item_ Purchase...
from Tableau » Metadata Management * Financel » PO_Vendor_In._..

Purchase Order Description (PO Vendor Invoice Item_ Purch...
from Tableau » Metadata Management * Financel * PO_Vendor_In_..

Purchase Order Amount (PO Vendor Invoice Item_ Purchase...
from Tableau » Metadata Management * Financel » PO_Vendor_In._..

more go here.

Semantic Searcfihe search uses semantic search rules so that you may specify fairly
sophisticated queess within a simple syntax. This syntax is documenése

p SHOW MORE

K

S

g2 NR & LIZNOKI &S¢ «

Explore Further

Recent searches
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The Search will initially show recent search requests that you may select before you type
anything in the text box.

0 [pearch

(m]o]

Recently found objects

== Invoice 54 Minutes Ago
from 5taging OW » dbo

Open themetadataelementdetails page

Click anynetadata elemenbr any of the structures in its Context (or model path) to view the
details page

Show full results

Only the most relevariew results are listed in the immediate search dropdo Press Enter to
present the results asworksheet

Search in Text

Click(g) to specify what text to search in.

©
o=

Search text in:

] Name

A4 Physical Name
4 Description
4] Others

4] Semantic Search

@ Search Help
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If youpressenter, these options will be carried forward to the filier the results as a
worksheet

Searchin Model
Generally, the scope of searching is the current configuration. How¢wermay perform
searchedor just a gven model

Steps

1. NN@AIFdAYy3a G2 GKIFEG StSYSyidaQa i Af&a LI 3S

pu
(p))
(et

2. Click on theE More Actionsicon and selecSearch in Model

3. Enter any text.

Example
Go to the details page for tHeata Lakenodel.
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OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MANAGE

Browse  Search ¥ X B Data Lake (add business name) |J | DirectoryStructure
Mo filter applied Y
Overview Folders Related Processes Data Flow

+- M Accounting

+- Customer Management . T
; g Business Description

+- Financial Analysis

+ - Glossary add value
~ [ Personnel
+-[= Data Lake Folders 1
+- M Vendor Management DataCataloging
+1L3 Model

ClickMore Actionsand selecSearch in Model
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® s O :

T2 Show in Object Explorer
|.:,_j Show in Configuration Manager

L@ Show in Repository Manager

{3 Search in Model
| Open Business Glossary

Compare with

Compare with previous version
[ill Generate / Refresh Data Sampling and Profiling

Fresentatian >

SENOK F2NJ Fyé YSUlRFGI ssBfabYSy i O2ydtAyAy3d GKS
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Filters ADVANCED ¢ 1-10f1 1 Filters  Columns
O 580 x E WHERE text = 'ssn” WITHIM [Mame’,"Physical Mame?) AND content = 'Data Lake’ Of
CATEGOH User Tags Name Object Type | Context

Select categories - fl ssN | Field Data Lake > DataCataloging > Adh
CONTENT

|:| Data Lake = e

RESET FILTERS <= FILTER

All the same search options as for ihemediate searclare here

Search\WorksheetPage

Steps
1. You mayither:

o From theimmediate searchyou may simplglick enter
0 ClickOBJECT&d selecSearch
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1-50 of 5,482

1 > i

ORDER BY Mame ASC

User Tags

Name

“$ <No name>
B4 <No name>
[ <No name>
Ef <Moo name>
B4 <No name>
[E% <No name>
B <No name>
F% <MNo name>
[E% <No name>
F% <No name>
[ <No name>
E{ <No name>
B4 <No name>
[E% <No name>
B <No name>
B <No name>
[E% <No name>
B4 <No name>
[ <No name>
[E% <No name>
B4 <No name>
[E% <No name>
B <No name>

B <No name>

Filters  Columns

Object Type
Database Schema
Base Schema
Baze Schema
Database Schema
Base Schema
Baze Schema
Base Schema
Database Schema
Base Schema
Database Schema
Baze Schema
Baze Schema
Base Schema
Baze Schema
Base Schema
Base 5chema
Base Schema
Base Schema
Baze Schema
Baze Schema
Base Schema
Baze Schema
Base Schema

Basze Schema

ORACLE’ Enteprise Metadata ManagementUser Guide

Context

AP to 5taging » StagingDW

5taging to Dimensional » Job Design » CustomerBilli
Stagimg to Dimensional » Job Design » CustomerBilli
Staging to Dimensional » Dimensional

Stagimg to Dimensional » Job Design » BillingPOC » E
Staging to Dimensional » Job Design > BillingPOC » E
Stagimg to Dimensional » Job Design » PaymentPOC
Stagimg to Dimensional » Staging

Staging to Dimensional » Job Design > POVendorinwve
AR to 5taging » 5taging-DW

AR to Staging » Job Design * Mapping * Mapping » 51
AR to Staging » Job Design » Mapping » Mapping » A
Stagimg to Dimensional » Job Design » GLACCouNt » ¢
AP to 5taging » lob Design » Job_AP25taging » lob_A
AP to Staging » Job Design » Job_APZ5taging » lob A
Stagimg to Dimensional » Job Design » CustomerPayr
Staging to Dimensional » Job Design » CustomerPayr
5tagimg to Dimensional » Job Design » CustomerShip
Stagimg to Dimensional » Job Design » CustomerShip
Staging to Dimensional » Job Design » GLACcount » ¢
5taginmg to Dimensional » Job Design » PaymentPOC
Staging to Dimensional » Job Design » POVendorinwve
Stagimg to Dimensional » Job Design » CustomerPOIr

Stagimg to Dimensional » Job Design » CustomerPOIr

o0 ClickOpen in workshee(rfa) whensearching using the explorer panel

You are then presented witlhe common worksheepage
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Search Text

When searching, once you are on the results page, you may specify what fields to search for
text. By default only the name and physical name are sedtclidl options are:

o Name

o0 Physical name

o Description

o Others, which includes other text properties (like comment) anstom attributes

Q Search

Filters ADVANCED ¢ 1-500f921
invoice = WHERE semantic_si
TR Search text in: |
' ] Mame

B

- [ Physical Name
+ Fill LA Description
4] Others

L Semantic Search

o ] ]

Search ghtax
Before you type, a simple click will list ygarevious searches. Otherwise, search is
automatically activated as your type, offering you choices that you can select in the suggested
list, or type enter to get to the advanced search window.

You may search for very precise results by specifying a sesirgdpthe buikin query language.
This is quite similar to most other web based search engines.

Specific searches may be made for the following type of criteria:

To search for Example Result

Any words sales order Any result containing the
wordd & f S&¢ 2 NJ
a2 NRSNE

Exact phrase GalfSa 2 NRSNE| Any result containing the
SEF Ol LIKNI &S

All Words +sales +order Any result containing BOTH
0KS 62NRa& aal
a2 NRSNE
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Exclude Words

salescorder

Any result containing the
wordad al £ S&¢ 0 dz
O2y il Ay GKS ¢

Wild Card End

sale*

Any result containing part of
' 62NR 060S3AAYY

Parent and Child

sales.order

Any result where the parent
Aa YIYSR aalft
OKAfR A& Yyl YS
0KS | GG MINE dzi S
contained within the entity
GalfSaéo

Exact Name

.order

Any result only containing

0KS 62NR &2 NR

One can, of course, append these together into a search string. E.g.:

Sales +ordeidate property:physicalname type:column

When searching fawords with spaces or punctuation characters, such exact words must be

lj dz2 G SR

6 S @ 3 ® ByddefalR, BResardh is{oMy! baséddon the name.

Usethe text searchoptionsto search in descriptions and more).

Case sensitivity varies by object. Hearch is cassensitive search for objects, like Labels,
Stewards and Custom Attributes and caisgensitive for text, like name and description, by

default.

For system objects, like Labels, in general the Ul is defined to allow you to pick the object (no

the text of its name). You can define two Labels, web and Web, and search for any or all of

them. When you need to search for both web and Web labels you should uEsjtiad ANY

option.

The characters

(underscore), ":" (colon),

(single quote) ‘a" (dot) as well as white

space characters are treated as word breakers by the search tokenizer. Therefore the search
text "_end"' will be tokenized as "pllF y R
Furthermore, any search text that is nat@ted by the double quote character (") will be

surrounded by the wildcard character to match more objects. If you do not want wildcard
characters to be added, quote the search text with the double quote character, i.e. make the
search text " end". You wil find objects with only " end" not "append.

Semantic Search

0 K dza

gAtt

YIG§OK 024K

In addition, the smantic search offers the use of the following key words in your search:

o Object Typesterm, dataset attribute, entity, table, column file, field, database model,
data nodel, andreport. Such key words can be used in singular or plural (e.g. terms).
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(0]

Model Categories: glossary, glossaraetabase, databases, db, modeling, data
modeling, bi, reporting, tableau, bo, cognos, and obi.

Note that the above key words do notee to be quoted when space is used (e.g. data model).

Then such key words can be used in a user friendly convenient syntax with additional qualifier
key words as follows:

(0]
(0]

o

customertable: returns all database tables haviogstomerin the name.

datasetswith ssn: returns all tables (or files) with a column (or fields) hawsigin the
name.

tableswith sensitivdabel: returns all tables with a label applied to them having
sensitivan the name.

my terms: returns all terms for which | am the steward.

john Q& & @Navszall terms for whicjohnis the steward.

customerin tableau: returns any tableau Bl reportg&tingcustomerin the name of any
objects.

The search uses semantic search rules so that you may specify fairly sophisticated queries within
a simple syntax. This syntax is documented below.

Semantic Search BNF Syntax

<semantic search query> ::= <typexchildren> | <label> | <steward> | <category>
<type> ::= <name> <types>

<name> ::= <alphanumeric>+ | "<character>+"

<types> ::= "datasets" | "datasef
"attributes” | "attribute™ | "columns™ | "column” | "fields" | “field" |
"reports” | "report" |

"terms" | "term" |

"databases" | "database" |

"data models" | "data model" | "models" | "model"
<children> ::= <types> "with" <name>

<label> ::= <types> "with" <name> "label"
<steward> ::= "my terms&types> |[<name>t Qa (i

<category> ::= <name> "in" <categories>

entities" | "entity" | "tables" | "table™ | "files" | "file" |

(p))

NI & €
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<categories> ::= "glossary" | "glossaries" | "database" | "databases" | "db" | "modeling" |
"data modeling" | "bi" | "reporting” | "tableau” | "bo" | "cognos" | "obi"

Example
You searcif 2 dddasetg A G K Y I Af ¢ &

© dataset with mail]  x
Search results

= CustomerPOInvoiceltem
from Dimensional OW » dbo

| B=|= POC
from 5taging DW > dbo

| B3 ShippingAddress
from Accounts Payable » dbo

B/ PaymentAddress
from Accounts Payable > dbo

= POC
from Accounts Receivable » dbo

= ShippingAddress
from Accounts Payable erwin

== BllingAddress
from Accounts Payable erwin

= POVendorinvoiceltem
from Vendor Mart » dbo

=== BlllingAddress
from Accounts Payable » dbo

= Paymentaddress
from Accounts Payable erwin

1-10 of 14 p SHOW MORE

¢KS NBadzZ 6a O2yiatAy Fff dlrofSa GKIFIG O2ydal Ay

Now press theénterkey.
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OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MANAGE

Q Search

Filters ADVANCED ¢ 1-14 of 14 1 Filters  Columns
1 dataset with mail E WHERE semantic_search_text ='dataset with mail’ WITHIN [Mame; Physical Name’, Descriptiol
CATEGORY User Tags Name Object Type Context
Select categories N 7 CustomerPOInvoiceltem | Table Dimensional DW > dbo
RESET FILTERS 4 FILTER 7 poC Table Staging DW > dbo
ShippingAddress Table Accounts Payable » dbo
PaymentAddress Table Accounts Payable > dbo
7 POC Table Accounts Receivable » ¢
ShippingAddress Table Accounts Payable erwir
=2 BlllingAddress Table Accounts Payable erwir
FH povendorinvoiceltem Table Vendor Mart » dbo
22 BlllingAddress Table Accounts Payable » dbo
PaymentAddress Table Accounts Payable erwir
FH povendorinvoiceltem Table Dimensional DW > dbo

B Person.csv
B EmailAddress.csv

B ProductReview.csv

Delimited File
Delimited File

Delimited File

All the results are displayed aworksheetalong with the filter panel on the left.

Data Lake » DataCatalo

Data Lake » DataCatalo

Data Lake » DataCatalo

Collections

The collectioomanagement feature allows users to define and maogiectiors of metadata
objects. Just lik&abels collectiors are available anywhere in the Ul tddiremove objectsfor

bulk editing, andassisting irmanagement.

Collectiors can contain any type of metadata sucta ydawgoriteé O 2 { d&f @8, faldeg,

reports, etc

Collectiors can also can contain multiple typef content such usMy to doO 2 f f Swithii A 2 y €

terms, tables, reportsetc.,in that collection

Collectiors maybe shared with other users when marked as public, such s quarterly

reviewg collection
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Collectios are flat, therefore not hierarchical and with no saddlectionor include concepts. ‘

Explorer Collections
You may use theatlectionsexplorerto select and present results accordingthe userdefined
collectionsavailable.

Steps
1. Go toCOLLECTIONS > Explore
2. Select the colletion to use from thepick lists
o Favorites
0 Recent
o Personal
0 Sharedwith me
3. You may filter the worksheet lists by entering text
4. Click on any collection results ¢éalit and manage that collection.
5. Click on the Preference',:'j icon to set the Maximurnount for each presentation of
collections.
6. Click the Closex\) icon to close the explorer.
Example

Go toCOLLECTIONS > Explore
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OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MANAGE

Collection Explorer o X ‘EI 3rd Quarter Push

£ Filter 1-17 of 17 1 Columns
% Favorites 2 = User Tags Mame Object Type Context
Hot Reports =| Account Term Enterpris
New Tables Just Now H AccountAmountAvailable | Column Dimensic
A Personal 3 =] E AccountAmountAvailable | Column Staging [
2rd Ouarter Push T Fa AccountAmountAvailable | View Column | Dimensic
rd Quarter Pus ust Mow
Hot Reports H AccountAmountAvailable | Column Vendor M
New Tables LISt How f AccountAmountAvailable | View Column | Dimensic
ArcountAmountExpended | Column Staging [
2) Shared with Me 1 = i . o
B AccountAmountExpended | Column Vendor M
3rd Quarter Push Just Now
B AccountAmountExpended | Column Dimensic

EJ\AJ:muntAmDuntExpended View Column | Dimensic

f, AccountAmountExpended | View Column | Dimensic

H AccountBudgetAmount Column Staging [
EJ\ AccountBudgetAmount View Column | Dimensic
H AccountBudgetAmount Column Vendor M
B AccountBudgetAmount Column Dimensic
EJ\ AccountBudgetAmount View Column | Dimensic
= GL_Account Number Term Finance :

Select the3rd Quarter Pusttollection.
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]
— Account | Term from Enterprise » Enterprise Conceptual Model

Overview Relationships Related Reports Semantic Flow Comments

Definition

Finance account used to assign and track funds

Relationships CREATE

Click theAccountterm.

Create a Collection
The collectioomanagement feature llows users to define and mangellectiors of metadata
objects. Just likkabels collectiors are available anywhere in the Ul to add/remove objefcis,
bulk editing, andassisting imanagement.

Steps
1. Go toCOLLECTION®/anage This is th€ollectionManagementpage.

2. Click the plus sign tAdd a new collection.
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3. Provide a Name and Description.

Example
Go toCOLLECTION®Manage ClickCreateto add a new collection.

Manage Collections Recent (2) Favorites (2) My (3) Shared with Me
{2 Search Text o Create Delete Share
Name Created Last Modified = Last Viewed Shared With Description
3rd Quarter Push 11 Months Ago 5 Days Ago 2 Minutes Ago | 2% Business Users
Hot Reports 9 Months Ago 9 Months Ago
MNew Tables 9 Months Ago 9 Months Ago 4 Minutes Ago

Provide aNameandDescriptionr & d¢aé ¢2 52¢ | yR daé (2 R2 fAa

[@=N

Manage Collections Recent (2) Favorites (2) My (4) Shared with Me

) Search Text o Create ¥ Delete 2 Share
MName Created Last Modified = Last Viewed Shared With Description
3rd Quarter Push 11 Months Ago 5 Days Ago 4 Minutes Ago &% Business Users
My To Do Afewsecond... A few secon... My to do list
Hot Reports 9 Months Ago 9 Months Ago
Mew Tables 9 Months Ago 9 Months Ago 6 Minutes Ago

Add Metadata Elements to a Collection
Collectiors can contain any type of metadata sucli ydaworite€ O 2  df ®rd$, faldeg,
reports, etc

Collectiors can also can contain multiplgpies of content such ug g to doO2 f t Swithii A 2 v €
terms, tables, reportsetc., in that collection
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Add Metadata Elements to a Collection in the Collection Management Page
You may add items to the collection from tB®llection Management page

Steps
1. Either:
- Go toCOLLECTION®Manage This is the€ollectionManagementpage.
- Go toCOLLECTIONS > Explore
2. Click a collection to open it.
3. Click AddDbjects toan iterrsto the collection.
4. Use the search and filters to find elements to add to the ctdec
You may always add any object to a collection at any fiora the objects details page or fromr

a list or grid (worksheetshuinless yougroup assignment Properties restritie Edit Collections
Property

Example
Go toCOLLECTION®Manage

Click theMy tab.

Manage Collections Recent (2) Favorites (2) My (4) Shared with Me
£ Search Text o Create ¥ Delete &) Share
Name Created Last Modified Last Viewed Shared With
3rd Quarter Push 11 Months Ago 5 Days Ago 4 Minutes Ago | aA Business Users
My To Do A few seconds Ago A few seconds Ago
Hot Reports 9 Months Ago 9 Months Ago
MNew Tables 9 Months Ago 9 Months Ago 6 Minutes Ago

Click theHot Reportscollection (hyperlink that is its name).
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. ADD OBIECTS . .
C|IC_. You are presented witlhe explorer panetype presentation.

Select the model where yowant to pick elements from, in this case Staging DW.

Add objects to Collection

Browse Search Collections
Mo filter applied

+ Accounting

+ Customer Management

— Financial Analysis

+Eﬂg Bl Reporting

+ ® Data Lake to Staging
+ = Staging DW

+Eﬂg Staging to Dimensional
+-[E7 Glossary

+ Personnel

+ Vendor Management

+-[F5 Warehouse

Expand the tree until you can select several items usinecl@ikl and Shiftlick.
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Add objects to Collection

Browse Search Collections
Mo filter applied

+ Accounting
+ Customer Management
= . Financial Analysis
+ rﬂg Bl Reporting
+ %> Data Lake 10 Staging
-1 £= Staging DW
i--;:f Schemas

1 dbo

‘o 2 Tables

Accounttategur';
AccountProject
AccountStatuslog
Address
BillingAddress
Category

CategoryGroup

Custormer
CustomerBillingAddress

CustomerPayment

ﬁﬁﬁﬁﬁﬁﬁﬁﬁﬁ

cic I
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User Tags Name

E ACcountAmountAvailable

E AccountAmountdvailable
E:{ ACcountAmountAvailable
E ACcountAmountAvailable
E{ AccountAmountAvailable
EJ\ AccountAmountExpended
E AccountAmountExpended
& ACcountAmountExpended
AccountAmountExpended
AccountAmountExpended
AccountBudgetAmount

AccountBudgetAmount

OO Mn 0OON Om  O;m

AccountBudgetAmount
EJ\ AccountBudgetAmount
E—'{ AccountBudgetAmount
=2 AccountCategory

22 ACcountStatuslog

F BillingAddress

22 CategoryGroup

The items are added to the collection

L] Hot Reports

1-19 of 19 1 Columns

Object Type
Column
Columnn
Wiew Column
Columnn
Wiew Column
YWiew Column
Column
Yiew Column
Column
Columnn
Columnn
Columnn
Column
YWiew Column
Wiew Column
Table
Table
Table

Table

Add Metadata Elements to a Collection from the Details.Page

Steps

Context

Vendor Mart » dbo » GLACCount
Staging DW > dbo » GLAccount
Dimensional DW » dbo » PaidCustomerPOGLACcounty.._.
Dimensional OW > dbo » GLACCount

Dimensional DW > dbo » PaidPurchaseOrderGLACCou. ...
Dimensional DW » dbo » PaidPurchaseOrderGLACCOUW. ...
Vendor Mart » dbo » GLACcount

Dimensional DW » dbo » PaidCustomerPOGLACcounty...
Dimensional OW » dbo » GLACCount

Staging DW > dbo » GLAccount

Staging DW » dbo » GLACCOuNt

Vendor Mart » dbo » GLACCcount

Dimensional DW > dbo » GLACcount

Dimensional DW » dbo » PaidPurchaseOrderGLACCOUW. ...
Dimensional DW > dbo » PaidCustomerPOGLACcountV.._.
Staging DW » dbo
Staging DW » dbo
Staging DW » dbo

Staging DW » dbo

1. Navigateto the details pagdor the metadata element you wish to add to the collection.

2. Select a collection from th€ollectiors control.
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Example
Navigateto the details pageof the Adjtable.

In the Collections areaelect from thematchingcollectionnames

Ad] (add business name) |l | Table from Adjustments > dbo

Overview Related Diagrams Columns Data Sample

Business Description

add value

Columns -6of6 >

B AdjNum
TransDT
TransAmt

AdjTxt

OO0 0o OOm Ooom

Trans5etbm

Data Sampling and Profiling

Data Profiling has never been run on this object. Request now

You may add a metadata element to any numbecafections

ORNT B!
Relationships
Labels
add value
Collections

Hot Reports x

Collection X

3rd Quarter Push
Collection

Hot Reports

My To Do

Mew Tables

(R ITEE R L Erre TN

LastM... (2 1 Month ago

Add Metadata Elements to a Collection in a worksheet or search result.
Please see working witliorksheetor searchresults.

Share a Collection

Collectiors maybe shared vith other users when marked as public, suchiag& S Ga2 y i Kf &

w S @ AcBllgction

Steps
1. Go toCOLLECTION®/Manage This is th€ollectionManagementpage.

2. Click theMy tab.
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3. Select a collection.
4. Click=»Share
5. Pick one or more users and/or groups to shdre worksheet with.

6. To unshare a worksheet, simply remove the specific (or all of) users and/or groups.

Example
Go toCOLLECTION®anage Click theMy tab. Click the line foBrd Quarter Push.

Manage Collections Recent () Favarites (2) My (4 Shared with Me
£ Search Text & Create ¥ Delete 2! Share
Name | Created Last Modified Last Viewed = Shared With

3rd Quarter Push A few seconds Ago A few seconds Ago

Hot Reports 9 Months Ago 9 Months Ago
My To Do & Days Ago & Days Ago
New Tables 9 Months Ago 9 Months Ago

Now, click Share.
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Share Settings X

Users / Groups £ Filter > Shared With

! Groups 11

= Administrators <
o APl Users

= Application Administrators

= Business Users

= Data Lake Data Analyst

= Data Lake Metadata Explorer

= Glossary Approvers

= Glossary Editors

= Glossary Publishers

= Glossary Reviewers

& SeCUrity Administrators

o e

Move the Business Usegsoup to the right hand side show the collection is shared with those
users.
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Share %
Users / Groups £ Filter : Selected Users / Groups
Groups 10 - 2 = Business Users
= Administrators <<

an APl Users

= Application Administrators

an Data Lake Data Analyst

= Data Lake Metadata Explorer

= Glossary Approvers

= Glossary Editors

& Glossary Publishers

e Glossary Reviewers

& Security Administrators

Users 13

o

Log out and log in as Bob.

Go toCOLLECTION®Manage Click theShared with Metab. Click Search. Locate Bral
Quarter Pustcollection. Click the Favorite icon next to that collection.

Now, go to the Favorites tab and see this collection as Bob.

Manage Collections Recent (0) Favorites (1) My (0) Shared with Me

Mame

w=| 3rd Quarter Push  Administrator 2 Days Ago

Owner Last Modified = LastViewed = Description

You cannot add to this collection as Bob because Bob does not own it.
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Click Save As and enter the natne2 6 ©G@uarter Pushand Click OK.

Save as new Collection x
Mame: Bob’s 3rd Quarter Push|
Description:

o Je

You may now edit the list. You could also share it back with Administrator. ‘

Working with Collections
Just likdabels collectiors are available anywhere in the Ul to add/remove objdatisbulk
editing, andassisting ilmanagement.

Using Shared Worksheets
Simply because you have shared a worksheet does not mean that all those other users can see
it. They must first look it up in Shared with Me. Once they have done so, they may

o Viewit
o Favoriteit
0 Save Asheir own worksheet that they may edit.

Steps
7. Go toCOLLECTIOM®Manage.

8. Go to theShared with Metab.
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OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MANAGE

Manage Collections Recent (2) Favorites (1) My (5) Shared with Me

Q Search Text OWNER | All users hd m

Mame | Owner Last Modified | Last Viewed = Description

This list will be empty at first. You must search for worksheets that are shared with you.

9. Enter text or just cliclsearch
10. From here you may:

- Open/Edit the worksheet
- P Restrict the list by using th®earch Text
- Favoriteor un-Favoritea worksheet

Explore Further

Working on Elements in a Collection

Steps
1. Goto the CollectionManagement page

2. Click theMy tab.
3. Click a collection to open.

4. Results are aommonresults(reports)pagewhere you may operate on the items gmid

mode.

Example
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OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MANAGE

[T] Hot Reports

1-150f15 1 Columns

User Tags Mame Object Type Context
E AccountAmountAvailable | Column Vendor Mart > dbo » GLACcount
H AccountAmountAvailable | Column Staging DW » dbo > GLACCount

E‘J‘ AccountAmountAvailable | View Column | Dimensional DW » dbo » PaidCustomerPOGLACcountV...
E AccountAmountdvailable | Column Dimensicnal DW » dbo » GLAccount

E‘J\ AccountAmountAvailable | View Column | Dimensional DW » dbo » PaidPurchaseOrderGLACCou. .
fy, AccountAmountExpended | View Column | Dimensional DW > dbo > PaidPurchaseOrderGLACCOU...
B AccountAmountExpended | Column Vendor Mart » dbo » GLACCcount

E‘J\ AccountAmountExpended | View Column | Dimensional DW » dbo » FaidCustomerPOGLACCountY. ..

B AccountAmountExpended | Column Dimensional DW > dbo » GLAccount

H AccountAmountExpended | Column Staging DW » dbo > GLACCount

E AccountBudgetAmount Colummn Staging DW » dbo » GLACCount

E AccountBudgetAmount Column Vendor Mart » dbo » GLAccount

E AccountBudgetAmount Calumn Dimensional DW » dbo » GLACCount

E:{ AccountBudgetAmount View Column | Dimensional DW » dbo > PaidPurchaseOrderGLACCOU...
E; AccountBudgetAmount View Column | Dimensional DW > dbo > PaidCustomerPOGLACcountY. ..

Add a Public Collection to my Collections
Collectiosmaybe shared with other users when marked as public, such s quarterly
reviewg collection

Sters

1. Go to theCollectionManagement page

2. Click the Add plus sign and pick a collection from whRulsic
Worksheets

MIMM provides metadata reporting capabilities where both search and browse (as well as a
direct link in theOBJECTiSenu) lead toa commorworksheetpage
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Starting from search simply predefines the text filtering (augtamer), while browsing
predefines a category (e.g. database / tables), and direct acceswtoksheetloes not
predefine anything.

Theworksheetcapabilities offeryou the ability toselect multiple categories (e.g. database /
tables + Flat files) and subset by content (My Data lake + Sales DW database) before drilling
down with the following filters:

T

Then filtering is available for Last Modified, Stewards, Labels, Semantic Typasednd
By, Certified By, Created By, Warning By, and Commented By

More custom filtering per attribute (including custom attributes) common to the
metadata subset (e.g. SecurityLevel = Orange)

Worksheetscan be reused by saving the URL as favorites (fuvtiiesions will support
full report management within the application).

Explore Worksheets
You may use the collections explorer to select and present results according to the worksheets
available.

1. Go toWORKSHEE®EXplore

2. Select the worksheet to udeom the pick lists:

Favorites
Recent
Personal

Sharedwith me

3. You may filter the worksheet lists by entering text.

4. Click on any item results to edit and manage that worksheet.

5. Click on the Preference!:') icon to set the Maximum count for each presentation of

dashboards

6. Click the Closg ™) icon to close the explorer.

Steps
o]
o]
o]
o]
Example

Go toWORKSHEE®XEXplore
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OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MANAGE

Worksheet Explorer o %

# Favorites & & @ Worksheet Expl

Certified by Stuart Select 3 Worksheet on the left to display
Certified Terms

Mew Worksheet

Mon-Certified Critical Attribute Terms

Mon-Certified Critical Terms

Mon-Certified Terms

Warned

Worksheets

= Personal 10 =

another worksheet

Certified Terms

myshest

Mew Worksheet

Mon-Certified Terms

Recently Warned Certified Terms
Warned

What's new
Worksheetl
Worksheets

2 Shared with Me 3 =

Certified by Stuart
Mon-Certified Critical Terms

Warned

Select theCertified by Stuartvorksheet
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[Q Certified by Stuart ) SHARED  SAVEAS
1-60f6 1 Filters  Columns d o
Name

1972 Customer Number

Account Abbreviation

= | Account Mame

= | Account Status

=| AccountAmount Expended

=| Address ID

Create aNVorksheet
To build a worksheet, yogenerallybegin by searchingYou may also go straight to the create
option on the manage worksheets page.

Steps
1. There are several options available for creating as worksheet

- You may use theanmediate search to open a searphgeas a basis for a worksheet.
- You may also sele@BJECTSSearcho begin working on a workshewthere you
have the results of all objects in the configuration and may filter from there.
- You may also clidWORKSHEETSxd select any of the optionsder
T Favorites
T Recent
T Categories
- You may also clid®pen worksheetwith the current filter (E'u )when using the
explorer paneSearchab.
- You may alsmanage worksheetand click® Create

Example
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Manage Worksheets
£ Search Text
Name
another worksheet
* Certified by Stuart
¢ Certified Terms

* ¥ ¥ *»

w

Data Lake Documentation Coverage

Recent (1)

d= Create

Endorsed Mon-Certified Terms

mysheet

Mew Worksheet

MWon-Certified Critical Atribute Terms

MWon-Certified Critical Terms

Mon-Certified Terms

Recently Commented Terms

Recently Endorced Terms

Recently Warned Certified Terms

Recently Warmed Terms

Terms
Warned

What's new

Immediate Search

Favoarites (7)

¥ Delete ,:.PJ Share

Last Modified
& Months Ago
& Months Ago
7 Months Ago
& Months Ago
4 Weeks Ago
& Months Ago
7 Months Ago
6 Months Ago
& Months Ago
8 Months Ago
4 Weeks Ago
4 Weeks Ago
4 Weeks Ago
4 Weeks Ago
4 Weeks Ago

& Months Ago

& Months Ago

You maymmediately perform searches from anywhere.

Click in theSeach text box in the upper right ancheera A y g@&#. O S ¢
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My (17)

Shared With

Shared with Me

= Bob (Robert Robertson)

= Adam (Adam)

= Bob (Robert Robertson)
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Defaults (0)

Filters

category = 'Glossary.Ti
category ='Glossany.T
category = 'File.Fields
category = 'Glossary.Ti

category ='Data Mod

category = 'Glossary.Ti
category = 'Glossary.Ti
category = 'Glossary.Ti
category = 'Glossary.Ti
category = 'Glossany.Ti
category = 'Glossary.Ti
category = 'Glossary.Ti
category = 'Glossary.Ti
category = 'Glossary.Ti

category = 'Glossary.Ti
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£ invoice X 0

Search results
g
== |nvoice

from Staging DW > dbo

= [nvoice
from Accounts Payable erwin

= Invoice
from 5taging to Dimensional » lob Design » CustomerBilling » Cus...

I‘I_l

1 Invoice
| fram 5taging to Dimensional * Staging »

lﬂ Invoice
from Accounts Payable erwin » RS

Invoice
from Accounts Payable erwin » RE

Invoice
from Accounts Payable erwin » RY

Invoice
from Accounts Payable erwin » R21

Invoice
from Accounts Payable erwin » R15

=x4| Invoice
:_‘l from AP to Staging » lob Design » lob_AP25taging » lob_APZ5tagi. ..

1-100f921 p SHOW MORE |

Results are presented as soon as you start typing.

Press Enter or clicBGHOW MOREYou will then have a worksheet template with thense filter
criteria in the search.
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Q Search

} 1-500f921

1 > > | Filters

Columns

—
= WHERE semantic_search_text = imvoice” WITHIN (Name, Physical Name; 'Description’, 'Others]) ORDER BY RELEVANCE
1
ur
L

User Tags Name

o

= m H

= "m Ta

Pz

o R el B el B el R

1=}
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Invoice
Invoice
Invoice
Invoice
Invoice
Invoice
Invoice
Invoice
Invoice
Invoice
Invoice
Invoice
Invoice
Invoice
Invoice
Invoice
Invoice
Invoice
Invoice
Invoice
Invoice
CustomerPOInvoiceltem
"Invoice”
“lnvoice”
“Invoice”
"Invoice”
“lnvoice”

"Imvoice”

Object Type
Table
Table
Base Table
Table
Unnamed RelationshipEnd
Unnamed RelationshipEnd
Unnamed RelationshipEnd
Unnamed RelationshipEnd
Unnamed RelationshipEnd
Base Table
Table
Table
Table
Bace Table
Base Table
Table
Bace Table
Table
Base Table
Base Table
Term
Table
tM55glinput
tM55glinput
tMS5glinput
tM55glinput
tMS5glinput

tMS5glinput

Context

Staging DW » dbo

Accounts Payable erwin

Staging to Dimensional » Job Design
Staging to Dimensional » Staging »
Accounts Payable erwin » RS
Accounts Payable erwin » R8
Accounts Payable erwin » R7
Accounts Payable erwin » R21
Accounts Payable erwin » R15

AP to Staging » Job Design » Job_AP2
Accounts Payable » dbo

Accounts Receivable » dbo

AR to 5taging » AccountsReceivable :
Staging to Dimensional » Job Design
Staging to Dimensional » Job Design
AP to 5taging » AccountsPayable »
Staging to Dimensional » Job Design
AR to 5taging » Staging-DW »

AR to Staging » Job Design » Mappin
AR to 5taging » Job Design » Mappin
Enterprise » Enterprise Conceptual M
Dimensional DW » dbo

Staging to Dimensional » Job Design
Staging to Dimensional » Job Design
Staging to Dimensional » Job Design
Staging to Dimensional » Job Design
AR to Staging » Job Design » Mappin

AP to 5taging » lob Design » Job_AP2
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You now have a worksheet.

OBJECTSSearch

SelectOBJECTSSearch
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Copyrigh

Q Search

>

SENIE

1-50of 5,482

1 >

ORDER BY Mame ASC

User Tags

i}
ir=
i}
=}
i
i}
iF=
i}
i}
i
i}
il
i
il
1=}
il
i}
i

=Y
X
=

“AccountProject”
‘Address”
‘Address"
tMS5qlinput

‘Address”
‘Address”
‘Address”
‘Address”
"“Address"
‘Address”
“Address"/1
"Address"/1
“Address"/2
"Address” /3
"Address"/4
“Address"/5
"BillingAddrass®
"BillingAddress"
"BlllingAddress"
"Customer®

<Mo name>
<MNo name>
<Mo name>
<MNo name>
<MNo name>
<Mo name>
<MNo name>
<No name>
<Mo name>
<MNo name>

<Moo name>

Filters

Object Type
tMS5glinput
tMS5glinput
tMS5glinput
tMS5glinput
tMS55glinput
tMS55glinput
tMS5glinput
tM55glinput
tMS5glinput
tM55glOutput
tMS5glinput
tMS5qLOuTput
tMS55glinput
tM55glOutput
tMS5glinput
tM55glOutput
tMS5glinput
tM55glOutput
tMS5glinput

tMS5glinput

Database Schema

Base schema

Base Schema

Database Schema

Base Schema
Base Schema

Basze Schema

Database 5chema

Basze Schema

Database schema

Base Schema

Columns

Context

Staging to Dimensional » Job Design » GLACcount » Gl
Staging to Dimensional » Job Design » CustomerPaym
Staging to Dimensional » Job Design » CustomerBillin
Staging to Dimensional » Job Design » BillingPOC » Bi
AR to 5taging » Job Design » Mapping » Mapping
Staging to Dimensional * Job Design » PaymentPOC »
Staging to Dimensional » Job Design » CustomerShipp
Staging to Dimensional » Job Design » POVendorinvoi
Staging to Dimensional » Job Design » ShippingPOC »
AP to 5taging » Job Design » Job_AP25taging » lob AP
AP to 5taging » Job Design » Job_AP25taging » lob AP
AR to Staging > Job Design » Mapping » Mapping

AP to 5taging » Job Design » Job_APZ5taging » lob AP
AP to Staging » Job Design » Job_AP25taging » lob AP
AP to 5taging » lob Design » Job_AP25taging > lob AP
AP to 5taging » Job Design » Job_AP25taging » lob AP
Staging to Dimensional » Job Design » BillingPOC » Bi
AR to 5taging » Job Design » Mapping » Mapping

AP to 5taging » Job Design » Job_AP25taging » lob AP
AR to Staging > Job Design » Mapping » Mapping

AP o 5taging » StagingDvw

Staging to Dimensional » Job Design * CustomerBillin
Staging to Dimensional » Job Design » CustomerBillin
Staging to Dimensional * Dimensional

Staging to Dimensional » Job Design » BillingPOC » Bi
Staging to Dimensional » Job Design » BillingPOC » Bi
Staging to Dimensional » Job Design » PaymentPOC »
Staging to Dimensional » Staging

Staging to Dimensional » Job Design » POVendorinvoi
AR to Staging » Staging-DW

AR to Staging » Job Design » Mapping » Mapping » 5ta
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You will then have a worksheet template with filters defined.

WORKSHEETS Menu

Every entry in the menu opens a worksheetcept forlManage

ClickWORKSHEETSi»d underCATEGORIESI|ectDatabase >Tables
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O Tables
> 1-50 of 83 1 » > Filters Columns
1L
= WHERE category="Database Tables' ORDER BY Mame ASC
-
User Tags Name
=22 AccountCategory
[===]

/

o

/

o

AccountProject
AccountStatuslog
Address

Address

Ad

FH AdjType

BillingAddress

BlllingAddress

Category

Category

CategoryGroup
CategoryGroup

Customer

Customer

Customer
CustomerBillingAddress
CustomerBillingAddress
CustomerPayment
CustomerPaymentAssignment
CustomerPaymentDate
CustomerPODate
CustomerPOInvoiceltem
CustomerPurchaseOrder
CustomerPurchaseOrder
CustomerPurchaseOrderLineltem

CustomerPurchaseQrderLineltem

Object Type
Table
Table
Table
Table
Table
Table
Table
Table
Table
Table
Table
Table
Table
Table
Table
Table
Table
Table
Table
Table
Table
Table
Table
Table
Table
Table

Table
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Context

Staging DW » dbo

Staging DW > dbo

Staging DW > dbo

Staging DW » dbo
Accounts Receivable » dbo
Adjustments » dbo
Adjustments > dbo
Staging DW > dbo
Accounts Payable » dbo
Dimensional DW » dbo
Staging DW > dbo

Staging DW » dbo
Dimensional DW » dbo
Staging DW > dbo
Dimensional DW > dbo
Accounts Receivable » dbo
Staging DW » dbo
Accounts Receivable » dbo
Staging DW > dbo

Staging DW » dbo
Dimensional DW » dbo
Dimensional DW > dbo
Dimensional DW > dbo
Accounts Receivable » dbo
Staging DW » dbo
Accounts Receivable » dbo

Staging DW > dbo
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Categor

Categor

=| Custom

=| Custom
=| Custom

=| Custom
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You have a worksheet pifdtered for the categonyDatabase >Tables

Explorer Panel > Search

Open the explorer paneind click Openworksheet with the current fiIter(E'l). You will then
have a worksheet with the same filters defined.

Browse Search O
) cust 5
Database X '
-'_S T __ -f: + __--f
== =Wy -

u:' Open Workshest with the current filter

= Customer
from Dimensional DW » dbo

= Customer
from 5taging DW > dbo

= CustomerBillingAddress
from Accounts Receivable » dbo

= CustomerBillingAddress
from 5taging DW > dba

E CustomerBillingAddress|D

from 5taging DW > dba » CustomerPurchaseOrder

Create and new saved worksheet

Go toWORKSHEEP®®anage
Click theMy tab.

w
(o))
s
m

Click®" Createb 9YGSN) GKS yI YS dalEBer 2 2NJ &K I YR LJIN.
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Manage Worksheets Recent (3) Favorites (6) My (16) Shared with Me Defaults (0)
(8] e Create ¥ Delete 2 Share
Name Last Modified = Shared With Filters
E Recently Warned Terms 1 Month Ago category = "Glossary.T
E Terms 1 Month Ago category ="Glossary T
E Warned & Months Ago - Bob (Robert Robertson) category = 'GlossaryT
E What's new & Months Ago category = 'GlossanyT
New |Vorksheet Just Now

You have a worksheet template with no filters defined.

Edit a Worksheet

Whether editing a saved worksheet or simply working with a search result that is presented as a

worksheet, this is the common eimgnment for filtering and manipulating that worksheet.

Steps
1. Opena worksheet by any of thereate nethods detailed or go to

- WORKSHEETS > Manage
- WORKSHEET%avorites>,
- WORKSHEET®Recent>.

From here younay:

- Page through the resultssing the first, previous, next and last controls above the

results.

- ClickFilterto show the left side paneb filter the results in thevorksheet You may

hide the panel with the samEilter button or the left caretﬁ:). In the filter panel you
may:

T “ SpecifySearch Text Also, can speci§earch Text If—) options to
control which properties are a part of the search.

T Pick one or mor€ATEGORUY¥f metadata to filter by, such as Table or
Column.

T Click+FILTER> add additional filters
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ClickColumnsto add/remove columns from the worksheet as well as sort or ORDER

those columns.
- SpecifyPreferencedor the worksheet, including
T ITEMS PER PAGEker
T QUERY PANElIsplay toggldor the MOL display
T MISCELLANEOUSGcluding Word Wrap display toggle.

- & Downloadthe results of the worksheet to a CSV file.

- SAVE AS8saved (and sharable) worksheet

Editing cells
If you have sufficient permission, you may edit cells in the metadata results. To do this, either
doubleclick that ell or rightclick and select Edit. You may then use the Tab and Enter keys to
traverse the grid for editing further.

Curating rows

You may click the Certify, Endorse and/or Warn ic for any row.

Any user may Comment, Endorse or Warn. Userghé@tManager security role may edit or
removes those of other users. Only the steward and Administrators may certify.

Bulk Editing
Multi-select: You may select more than one row (SHiftk, Ctrclick, etc.). With this feature
one may apply an actiaoio all of the selected rows. Only those actions available to ALL of the
selected rows will be presented.
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1-190f19 1 Filters  Columns

MName Warnings
| =| Category Group Number 1)
| =| Billing Street Address 2 1) 1)
| =| Category Description 1)

=| Amount Paid

= Customer Payment Type
| =| Customer Payment POC Phone
=| Billing Street Address2
=| Customer Payment Date Customer Payment __.
= Customer Payment Amount
=| Account Encumbered Amount
=| Customer Payment Status
| = | Customer PO Amount
= Customer PO Invoice [tem Billing City
=| Customer PO Date Customer PO Date
| =| Customer Name
=| Category Name
= Customer Payment Description
=| Customer Payment Address Description

=| Customer Description

For all the selected objects, you may bulk edit:

Endorsements Comments

o Common Attributes that apply to all object types, includingation

0 Custom Attributesvailable to all the objects
0 BasidObject Attributesthat apply to all the objects.

You may also add muisielections to &ollection

Definition
A number uniguely
Second line of stree
Detailed descriptior
Amount Paid to Dat
Type of payment
Contact phone num
Second line of stree
Date and time of pa
Dollar amount of pz
Dollar amount of th
Status of payment
Total amount of the
City

Date on purchase ol
Name of a custome!
Category Mame
Detailed descriptive
Description of locat

Detailed descriptior

Columns an&ort Direction

ClickColumnsto add/remove columns from the worksheet as well as so®&DER BiYiose

columns.

Sort Direction
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You may specify the sort order, or direction, of the report resultss @pplies to all the results
of the search, not just the page you are viewing.

| DISPLAY MODE SORT ORDER

| | BEE Grd | = List Ascending | Descending Relevance
| COLUMNS

Available columns £ Filter tex Selected columns

Common Attributes 17 User Tags
Mame

nl

Semantic Types Object Type
Hide Data Context
Stewards

Labels

Collections

Certified

Endorsements

Warnings

Comments

Last Modified Date =

You may also simply click on a column header to toggle the sort on that column between
ascending and descendiagd the original order.

Ascending

Alpha order from lowest thighest.

Descending

Alpha order from highest to lowest.

Original

Restores back to the originally presented order.
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Relevance

Ordered from most to least relevant to the selected filters.

Grid vs. List Mode
One may toggle between presenting the results as a sigllectionor as a spreadshedike
grid. MIMM provides a rich set of features to manage the columns in a grid and allows for
editing of the cells just as with a spreadsheet.

DISPLAY MODE

LC

EEE Grid = List

Youmay also add and remove columns by including or removing them from the list at the right.

COLUMNS
Available columns | D Filie | | Selected columns

Common Attributes - | | User Tags

Mame

Semantic Types
Object Type

Stewards

Labels Context
Collections

Certified

Endorsements

Warnings

Comments

Last Modified Date

Object Id

o o wm

Paginated Display and Navigation
If the list of metadata elements is long, only a portion of that list is presented. This portion is
referred to as a PageMIMM provides a number of common display and navigation tools for
these lists.
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Filtering, sorting, etc., only applyg & page of the results at a time. Be sure to specify a large
enough Items per page to ensure that you are getting the results you expect.

Properties Panel
There is a Properties Panel on the right. If you show this panel then you may click on an object

and view its properties in the panel.

& - | |DQuickfind | | Properties 2
4 Mame Value
Data Cataloging and Data Governance
Mame Finance
[~ .
| Description
e Creation Time 2018-06-21 130...
."""I '~————«| Author

- N Last Modification.. | 2018-06-22 14:5_.

‘\Qf Qf Modifier

Metadata Filtering
A filter panel can be presented to the left of the resuNBMM provides a sophisticated set of

post filtering options.

Filters 4
€, SEARCH TEXT =
CATEGORY

CERTIFIED BY : equals any

L stuart Steward % W

+ FILTER

Filter by example by column

You may always filter theesults by what is already presented. E.g., if one wishes to only see
columns for Type View Column, you may simply raiick a cell in the grid that contains that
value and select that option.
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1-8of 8 1 Filters  Columns

User Tags Name
= 1972 Customer_Mumber
=| Account Abbreviation
=| Account Name
=| AcCcount Status
=| AccountAmount Expended
=| Address ID
=| Address 5tring
=| Amount Budgeted

Using the filter panel

Object Type @ Context

Term
Term
Term
Term
Term
Term
Term

Term

Labels

Finance * Domains

Finance » Terminalogy

Finance » Terminology

Finance » Terminology
Finance » Terminology
Finance » Terminology
Enterprise » Enterprise Conceptu

Enterprise » Enterprise Conceptu
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Distinct values.
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Export Glossar
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Delete



ORACLE" Enteprise Metadata ManagementUser Guide

O Worksheet

Filters 4 1 - 100 of 939
O Invoice G= | WHERE semantic_search
CATEGORY User Tags Nam
Select categories W B |
o r
RESET FILTERS 4 FILTER i
Q Filter Text I

Common Attributes

Content
Last Modified |
Steward |
Label ]
Semantic Type '
Certified By

Endorsed By

Commented By

Warned By

Custom Artributes
Average Mumber of Users
Color

Data Expiration |

Nata Risk | ewvel o !

You may also expan@) the Hlters panel on the left in order to limit the results based upon
advanced matching criteria.

FilterGiteria Description

Search Text Text to match against. One may select which properti
(e.g., name vs. description) to match against.

Category Filter by categories defined in the customization MM
installation file
/conf/resources/MetadataExplorer.xml, down to th
object type level.

Content Only those results in particul@ontents
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Last Modified Only those resulting objects which were lagidated in a
given date range

Steward Only those results with a particul&tewardassignment

Label Only those results tagged by particulzabels

Endorsed by Only those results endorsed and/or endorsed by a

particular individual or set ahdividuals

Certified by Only those results certified and/or certified by a
particular individual or set of individuals

Warned by Only those results warned and/or warned by a particu
individual or set of individuals

Commented by Only thoseresults commented on and/or commented 0
by a particular individual or set of individuals

Custom Attributes Additional properties specific to the type of metadata
element

Use+FILTER add addition filter criteriaRESET FILTBRSlear theall the filter criteriaor click
the x next to a specific filter to clear that one.

You may always filter the results by what is already presented. E.g., if one wishes to only [see
columns for Type View Column, you may simply itk a célin the grid that contains that
value and select that option.

Filter by Search Text
You may enter text to filter by, and the text will be matched to the properties specified, as
follows:
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O Worksheet

Filters £ 1 - 100 of 939
O Invoice B= | WHERE semantic_
[ Search text in:
LAl ElRY
A Name

- [ Physical Name
RESETFITERS + FI0 [ pescription

7] Others

4] Semantic Search

The semantic searchrguage is defined here.

Filter by Category
You may specify from a hierarchical pick list which metadata element types to include in the
results. Thus, you may include, e.g., both Terms and Database Columns in the search results.
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©O Worksheet

Filters £
O Invoice -
CATEGORY

Glossary » Terms X

Data Modeling > Entities

Q Filter Text

— | | Glossary -
.~ [ ] Glossaries

: | | Categories
— [ ] Data Modeling
[ ]| Data Models
- [ | Subject Areas

| | Diagrams
+ || Relationships
+ Entities

-;- . [ 1 Tahlac

Theorganization of categories in the pick list are defined in the customization MM installatipn
file /conf/resources/MetadataExplorer.xml. One may control the categories, results and
available actions using this file. You may Please see the Customiastrgal for this

capability.

Filter by Content
Use this filter to restrict the results to only those which are a contained within particular
contents (e.g., a specific model or glossary).

Filter byLastModified
Filter to only those results which havébate Modified value in a specific date range.
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O Worksheet

Filters 4

O Invoice o=

ol

LA CoUi

LAST MODIFIED 2 anytime
+/ anytime
today _hE up_
yesterday
last hour
last 7 days
la=t 30 days
la=t 60 days
la=t 90 days
last year
befare

after

between

Dates in Worksheets

Dates and times are stored and presented in UTC format in:

0 Log entries
0 Administration pages
o Etc.

In worksheets, one may also see the local time when viewing worksheets as a tbaktip
appear when a date/time is in focus:
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SENEE

1-50 of 299

Q@ What's new

Name 1

Customer Payment City
Customer Payment Check Number

Customer Payment Amount

1

Filters Columins

Context
Finance » Terminology
Finance » Terminology

Finance » Terminalogy

Labels

QuarterlyReview

=| Customer Payment Address Description | Finance » Terminology QuarterlyReview
=| Customer Payment Enterprise » Enterprise Conceptual Model

=| Customer Mame Finance » Terminology QuarterlyReview
=| Customer 1D 1 Finance > Terminology Obsolete

=| Customer ID Finance > Terminology

=| Customer Description Finance > Terminology QuarterlyReview

Customer

Finance > Terminology

=| Customer Enterprise » Enterprise Conceptual Model

Filter by Steward
Filter to only those results which are assigned to one or nStesvards

Filter by Label
Filter to only those results whidiiave one of the selected labedssigned

Filter by Curation Status
You may endorse, certify, warn and comment on any metadata element

You may then filter to only those results which have any of these or any of these from a specific
set ofindividuals.

Filter by Comment
You may filter by the existence or content of comments.

Other Filters
You may filter to only those results which have specific valusgenificproperties.
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©O Worksheet

Filters £ 1 - 100 of 5,551
Q SEARCH TEXT 8= | ODRDER BY RELEVAMCE

CATEGORY User Tags Nam

Select categories ot ==

Content ol
Last Modified .
Steward

Label

Semantic Type

Certified By

Endarsed By

Commented By

Warned By [

Custom Attributes [

Average Mumber of Users [
Color

Data Expiration f
Data Risk Level i

system.weburl -

Identify distinct values by column
You may quickly obtainlat of the distinct values available in the metadata. To do this,-right
click a cell in the grid and select that option.
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©O Worksheet
Filters £ 1 - 100 of 5,551 1 5% ™ Filters  Columns
O SEARCH TEXT o= ORDER BY RELEVAMCE
CATEGORY User Tags Mame Object Type
Select categories o x P PurchaseOrder Table
+ FILTER =| Account Identifier Term
=| Amount Budgeted Term
=| Address String Term
=| Account Mame Term
b o = Account Term
= 1972_Customer_Number Term

The result is statistics on the distinct values present according to the filters defined

Value Count Repartition
| Column 52 64%
. Wiew Column 14 28%
| Primary Key Column 4 8%
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Primary Key Column

Worksheet Preferences

l1selected 3 0, £ <
ITEMS PER PAGE Preferences
500 v M=

m

OUERY PANEL o

[ ] Show current query
MISCELLANEOUS
[] Enable Word Wrap

Here, yar may specify

o ITEMS PER PAGEpecify the number of items on a page.

Filtering, sorting, etc., only apply to a page of the results at a time. Be sure to specify a laige
enough Items per page to ensure that you are getting the results you expect.

0 QUERY PANELShow the current queryto toggle showing or hiding theetadata
guery language (MQlguery executed based upon your filter criteria.
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0 MISCELLANEOQUS > Enable Word Wrap: toggle the word wrap @frlted in the
cells.

You may specify larger limits on the number of items per page and items to export by updating
the Worksheet Export Maximum number of objecisid Worksheet Maximum number of
objects per Pagén Graup Preferencefor a group that the user is a member of.

Metadata Query Language
MQL allows users to define powerful and complex metadata queries with a familiar SQL syntax.

p Search

Filters < || 1-150f15 1 = |l COLUMNS (5) | .. | SORT

dataset with mail o [WHEF!E semantic_search_text = ‘dataset with mail’ WITHIN (Mame, "Physical M;

Select categories B POVendorinvoiceltem
from Dimensional DW > dbo

The MQL is available through the REST API and constitute the foundatiensefatfth /
worksheet page. For syntax details, refer to
http://www.metaintegration.com/Products/MIMM/RESAPI/mql.html

You may use theorksheet Preferencds toggle showing or hiding the metadata query
language (MQL) query.

Anything you do in thé&iltersis reflected in the MQL. You may also edit Hiltersfrom the
perspective of the MQL directly by using #hdvancedmodel.

Steps
1. Open a worksheet by any of tleeate nethods detailed or go to
- WORKSHEETS > Manage
- WORKSHEETS > RECENT >
- WORKSHEETS > FAVORITES >
2. ClickAdvancedn theFilters panel
You may now edit the query for the worksheet by editing the MQL.
Example

Click WORKSHEETS > FAVORITES > Certified Terms.
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ClickAdvancedn the Filters panel

[q Certified Terms*

Filters BASIC 1-90f9
category = 'Glossary Terms' AND certified_by User Tags
EXISTS AMD content = ANY(Enterprise;,

‘Fimance’}

EXECUTE

Update the MQL and clid&XECUTE
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Object Type

1 Filters  Columns
NMame t
=| 1972 Customer Number | Term
=| Account Abbreviation Term
=| Account Amount Available | Term
=| Account Budget Amount Term
=| Account Name Term
=| Account Status Term
=| AccountAmount Expended | Term
=| Address ID Term
=| US Social Security number | Term
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Finance :
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[qQ Certified Terms#*

Filters BAsIC £ 1-10of 10 1 Filters  Columns

category = ‘Glossary.Terms’ AMD certified_by WHERE category = ‘Glossary.Terms' AMD certified_by EXISTS AND content = AN
EXISTS AMD content = ANY(Enterp ORDER BY Name ASC

User Tags Name Object Type = Conte
oo | = Account Term Enterp

=| Account Abbreviation Term Financ

= Account Amount Available | Term Financ

= Account Budget Amount Term Financ
= Account Identifier Term Enterp

=| Account Mame Term Enterp

=| Account Mame Term Financ

= Account Status Term Financ

=| AccountAmount Expended | Term Financ

= Amount Budgeted Term Enterp

Save a Worksheet
You may save arworksheet you are working ozt any time, evening existing saved ones by be
saved as new worksheets.

Steps
1. Open a worksheet by any of tlieeate nethods detailed or go to

- WORKSHEETS > Manage
- WORKSHEETS > RECENT >
- WORKSHEETS > FAVORITES >

2. CickSaveto save the updated state of an existing saved worksheet or save and assign a

name to a not yet saved worksheet.
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3. ClickSaw Asto save the updated state of an existing saved worksheet and assign a name.

Example
ClickWORKSHEEPHFAVORITESCertified Terms

[qQ Certified Terms

> 1-90f9 1 Filters  Columns

L .

ﬁ Name Object Type @ Stewards Labels Context

z =| 1972 _Customer Number Term & Stu (Stuart Steward) Obsolete Finance > D
=| Account Abbreviation Term & Stu (Stuart Steward) QuarterlyReview | Finance > Te
=| Account Amount Available | Term 2 Adam (Adam) QuarterlyReview Finance > Te
=| Account Budget Amount Term = Adam (Adam) QuarterlyReview Finance : Te
=| Account Mame Term & Stu (Stuart Steward) QuarterlyReview Finance » Te
=| Account Status Term & Stu (Stuart Steward) QuarterlyReview Finance > Te
=| AccountAmount Expended | Term = Stu (Stuart Steward) QuarterlyReview Finance » Te
=| Address ID Term = Stu (Stuart Steward) QuarterlyReview Finance > Te
=| US Social Security number | Term & Adam (Adam) Finance > GI

Click+FILTER > Conteninclude both glossaries.
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Tq Certified Terms*

Filters ADVANCED £

M CEARCH TEX =
O SEARCH TEX &

CATEGORY

Glossary » Terms X e

CERTIFIED BY : exists

CONTENT

mFinanr_E x mEnterpr'lﬁe x W

RESET FILTERS < FILTER

1-110f11 1

Mame

1972 Customer_Mumber
Account Abbreviation
Account Amount Available
Account Budget Amoumnt
Account Name

AcCcount Status
AccountAmount Expended
Address ID

Late Payment Amount
Party Description

US Sodial Security number

TheMQL statemenhas changed and th8avebutton is enabled.

Filters
Object Type
Term
Term
Term
Term
Term
Term
Term
Term

Term
Term

Term

Columins
Stewards

& Stu (Stuart Steward)

5tu (Stuart Steward)

Adam (Adam)

Adam (Adam)

Stu (Stuart Steward)

S5tu (Stuart Steward)

5tu (Stuart Steward)

5t (Stuart Steward)

= Adam (Adam]

Click Save. You have now updated an existing worksheet.

Click+FILTER kast Modified Selectast 30 days
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Tq Certified Terms*

Filters ADVANCED 1-11 of 11 1 Filters Columns
Q SEARCH TEX & Name Object Type  Stewards
CATEGORY =| 1972_Customer Number | Term & Stu (Stuart Steward)
Glossary » Terms X N =| Account Abbreviation Term & Stu (Stuart Steward)
CERTIFIED BY 3 exists =| Account Amount Available | Term = Adam (Adam)
CONTENT =| Account Budget Amount Term = Adam (Adam)
|ﬂ Finance ® |ﬂ Enterprise X A =| Account Name Term 2 Stu (Stuart Steward)
LAST MODIFIED = last 30 days =| Account Status Term < Stu (Stuart Steward)
RESETFILTERS  +FILTER 1 [=] AccountAmount Expended | Term 2 Stu (Stuart Steward)
= Address ID Term & Stu (Stuart Steward)
= Late Payment Amount Term
= Party Description Term
= US Social Security number | Term = Adam (Adam)
TheMQL statemenhas changed and th8avebutton is enabled.
Click{  @S. ! aXx
s
. Save
| sovess
'_ Discard changes
Enterthenamea wS OSy (if &8 / SWIiGkIKA SR ¢ SN aé
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Save as new Worksheet x
Mame: Recently [Certified Terms
Description:

o

ManageWorkshees
You may also seletWORKSHEE®$1anageto manage your existinggorksheets

Steps
1. Go toWORKSHEE®®/anage

- You see the list dfavorites It is the default tab.

All the worksheets you have favorited are here.

- From here you may:
T Open/Edit the worksheet
T 2 Restrict the list by using thgearch Text
T Favoriteor un-Favoritea worksheet

2. Click theMy tab.

All the worksheets you have created are here.

- From here you may:
T Open/Edit the worksheet
© Restrict the list by using thgearch Text
" Create a new saved worksheet
X Delete and existing saved worksheet
Favoriteor un-Favoritea worksheet
=& Share this worksheet with groups and/or users
Edit theNameor Descriptionof a worksheet

A e e o o | -

3. Click theRecentTah

All the worksheets you have recently opened are here.
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- From here you may:
T Open/Edit the worksheet

T P Restrit the list by using th&earch Text
T Favoriteor un-Favoritea worksheet

Example

Create

Go toWorksheets> Manage

Click theMy tab.

Click® Createb 9YGSNI GKS yIYS alEBeér 2 2NJ] aKSSidé¢ | yR LN

Manage Worksheets Recent (4) Favorites (&) My (15) Shared with Me Defaults (0)

) Search Text o Create 3 Delete 2 Share
Name Last Modified Shared With Filters
E Recently Endorced Terms 1 Maonth Ago category = 'Gloss:
E Recently Warned Certified Terms 1 Maonth Ago category = ‘Gloss:
E Recently Warned Terms 1 Month Ago category = 'GLoss:
E Terms 1 Month Ago category = 'GLoss:
E Warned 8 Months Ago - Bob (Robert Robertson) category = 'Gloss;
E What's new 8 Months Ago category = 'Gloss;
Mew Worksheet A few seconds Ago

You will then have a worksheet actually sataetiwith no filters defined yet.

Delete

Go toWorksheets> Manage

Click theMy tab.
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Manage Worksheets Recent (4) Favorites (6) My (16)
{2 Search Text o Create ¥ Delete 2 Share

Click¥ Delete.
Confirm X

9 Are you sure you want to delete New Worksheet Worksheet?

[] Do not warn again MO

Confirm.

Favorite / UnFavorite

Go toWorksheets> Manage

Click theMy tab.

Manage Worksheets Recent (4) Favorites (6) My (16)

£ Search Text o Create ¥ Delete A Share

Click" next to New Worksheet t&avoritethat worksheet.

Clickw y SEG (2 20Km-Ra@rtethst Sarksheet
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Manage Worksheets Recent (4) Favorites (6) My (16) Shared with Me Defaults (0)

O Search Text o Create ¥ Delete 2 Share
Name Last Modified = Shared With Filters
E Warned 8 Months Ago - Bob (Robert Robertson) category = 'GlossaryT
ﬁ What's new 8 Months Ago category = 'Glossary T

Explorer Further

SharedWorksheet

Worksheets have aowner who is the creator of the worksheet. That owner may open, edit
and remove a worksheet. The worksheets that one owns may always be foundity tiad
underWORKSHEE®$/anage

In addition, a worksheet may be made public, or shared, with specific asdfer groups.
Once shared, users that are in the sharing criteria specified may view and favorite those
worksheets, as well

Sharing a Worksheet
The owner (creator) of a worksheet may share that worksheet with and users and/or groups.

Steps

1. Go toWORKSHEEP3/Manage.

2. Go to theMy tab.

3. Select a worksheet.

4. Click=s Share

5. Pick one or more users and/or groups to share the worksheet with.

6. To unshare a worksheet, simply remove the specific (or all of) users and/or groups.
Example

Go toWORKSHEE®3anage.
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Manage Worksheets Recent (4) Favorites (6)
Search Text e Create ¥ Delete 2 Share
MName Last Modified

w Mon-Certified Critical Attribute Terms 6 Months Ago
w Non-Certified Critical Terms & Months Ago
w Non-Certified Terms & Months Ago
Recently Commented Terms 1 Month Ago
Recently Endorced Terms 1 Month Ago
Recently Warned Certified Terms 1 Month Ago
Recently Warned Terms 1 Month Ago
Terms 1 Month Ago
Warned & Months Ago
# [[@ what's new & Months Ago

Go tothe My tab and select a worksheet in the list.
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My (16)

Shared With

= Adam (Adam)

= Bob (Robert Robertson)

Shared with Me

Defaults (0)

Filters

category ="Glossary T
category = "Glossary T
category = 'GlossanyT
category ="Glossary T
category ="Glossary T
category = 'GlossaryT
category ="Glossary T
category = 'GlossanyT
category = 'GlossanyT

category = 'GlossaryT
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| Share

Users / Groups £ Filter

Groups 11

an Administrators

= APl Users

& Application Administrators
an Business Users

an Data Lake Data Analyst

an Data Lake Metadata Explorer
= (lossary Approvers

= Glossary Editors

= Glossary Publishers

= Glossary Reviewers

& SECUrity Administrators

Selected Users / Groups

CAMNCEL

Click=~ Shareand you have shared that worksheet with those users.

x

You may save a shared worksheet before specifying whom to share it with. You may comge back
later and specify whom will be shared with.

Using Shared Worksheets

Steps

o View it
o Favorite it

0 Save As theown worksheet that they may edit.

1. Go toWORKSHEE®S$/anage

2. Go to theShared with Metab.
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This list will be empty at first. You must search for worksheets that are shared with you. ‘

3. Enter text or just clicSearch
4. From here you may:

- Open/Edit the worksheet
- P Restrict the list by using th®earch Text
- Favoriteor un-Favoritea worksheet

Default Worksheets

The details pagéor different types of olgcts (e.g.Tablesor Schemajcontains a number of
tabs which present the results of a default worksheet for that particular type of object
represented by the tab (e.gGolumnsfor Tablesor Tablesfor Schemas

When viewing the details page results, say @@umnstab for aTable you maydesignatean
existing worksheethat you savedr thatwas shared with yoasyour personal default

In addition,members of theApplicationAdministratols Groupmaydesignate default
worksheets for groups or users, which will be the systiafault, unless overidden, when one
the details page for that type of object.

However, it would be awkward to require that one go to each type of details page and tab in
order to manage defaults. Thus, you may manage all of your defabtANAGE> Default
Worksheets

System defaults are not shown on this page as you cannot edit them. It requires an
Administratorto do so.

Steps
1. Go toWORKSHEE®®efault Worksheets
2. Go to theDefaultstab.
3. Click anytem in the list and you may.
0 Click theNameor right-click and seledRenameand type a new name.
0 Click Delete orright-click and seledDeleteto delete.
Example

Go to the details page for th@L Accounterm in theTerminologycategory of theFinance
glossary and go to thRelationshipgab.
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— GL Account | Term from Finance > Terminology

Overview Relationships Related Reports Semantic Flow Comments Attact

1-11of11 1 Filters  Columns &= Create - Workshee

Account Abbreviation

=-| Account Amount Available

’I

; Account Budget Amount

; Account Encumbered Amount
= Account Mame

#I
=-| Account Status

”I

; AccountAmount Expended
= (Catego

o gory
= GLAccount ID

#I

ClickColumnsand switch toGridmode and includ&ypeas a column.
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User Tags Name

ACcount Abbreviation

B

kA1)

Account Amount Available

Account Budget Amount

kAT

Account Encumbered Amot

N

DISPLAY MODE S0ORT ORDER
EEE Grid | = List Ascending | Descending Relevance
| COLUMNS | Display Grid |

Available columns 0 Filter tex Selectec

Common Attributes 16 i - User Tags

f Aecount ame Last Viewed Date S;;: ot
4| Account Status | Last Modified Date N
4| AccountAmount Expended Certifiad —
| Category Endorsements
5| GL Account 1D Warnings
| GL Account Number Comments
5| PO Vendor Invoice Item Labels

Stewards

Collectinns

Click the background to remove the dialog.

Copyright © 2020, Oracle and/or its affiliates. All Rights Reserved. (12.2.1.2020/10/29) Pagell7| 764



ORACLE" Enteprise Metadata ManagementUser Guide

: GL Account | Term from Finance » Terminology
Overview Relationships Related Reports Semantic Flow Comments

1-11of11 1 Filters  Columns &= Create -
User Tags Name Context | Type

& Account Abbreviation Attribute

& Account Amount Available Artribute

| Account Budget Amount Attribute

@ Account Encumbered Amount Artribute

| Account Name Attribute

S| Account Status Attribute

@ AccountAmount Expended Attribute

& Category Entity

& GLAccount ID Attribute

o GLAccount Mumber Attribute

| PO Vendor Invoice Item Entity

Attach

Workshe

ClickSAVE A8nd create a system type worksheet and share it (make it a default for those

users)
Save As Default Worksheet x
Mame: Relationships with types
Diescription:
Type: () Personal (® System
= Business Users ® e

Kl o
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Nowthis default worksheets in the MANAGE > Default Worksheets and those users will see it

by default.
Manage Default Worksheets
) Search Te % Delete 2 Share
Scope Name T
Data Modeling (Business)
M DataModel » Tables- Entities  Layout 1

File System (File)

[*] Delimited File » Fields
[+ Delimited File » Fields
MM (Glossary)

= | Term > Relationships

=5 Category = Terms

Dashboards

System Default Worksheet

Fields System Default

Relationships with type

Default Terms

Last Modified

9 Months ago

2 Months ago

& Months ago

4 Minutes ago

2 Months ago

Shared With

- Administrators
- Administrators &% Data Lake [
= Data Lake Metadata Explorer

-w BUsiness Users &% Data Lake |

- Business Users

Dashboards are a way for you to completely customize the content presented on a page in
MIMM . They have full Bl reporting dashboard capabilitids igyout, widgets for containers,
numbers, statistics such as grids, bar or pie charts, etc.) basedMigi@adata Query Language
(MQL)along withworksheetsand collections

As with Collections and Worksheets, users have the ability to save/manage/share Dashboards.

Explore Dashboards

You may use thdashboardexplorer to select and present results according to the worksheets

available.

Steps

1. Go toDASHBOARDSExplore

2. Select the dashboard to use from the pick lists:
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o Favorites

0 Recent

o Personal

0 Sharedwith me

3. You may filter the dashboard lists by entering text.

4. Click on any item results to edit and manage that dashboard.

5. Click on the Preference',:'() icon to set the Maximum count for each presentation of

dashboards.

6. Click the Closex\) icon to close the explorer.

Example
ClickDASHBOAR®>Explore

OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS

Dashboard Explorer O

£ Filte

® Recent 1 =
My Dashboard 2 Days
= Personal 1 =]

My Dashboard

& shared with Me 1 =

My Dashboard

Click thePreferences':' icon.
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Maximum count:

EFAUL PERSONAL

10 S0 o
FAVORITES SHARED WITH ME

10 o110 o
RECENT

10 -

Here you may specify the different counts of dashboards wioiglwant to see in the explorer.

ClickintheFilteri SEG 62E F'yR (&L daéé¢od

Dashboard Explorer o
O Myl x
% Favorites 1 =]

My Renamed Dashboard
= Personal 1 =
My Renamed Dashboard
&) Shared with Me 1 =

My Renamed Dashboard

TheFilter applies to all five groupings of dashboards in the explorer.

Click the(* ) icon to clear theFilter. Click théData Catalog Management Dashboard

Copyright © 2020, Oracle and/or its affiliates. All Rights Reserved. (12.2.1.2020/10/29) Pagel2l| 764



ORACLE" Enteprise Metadata ManagementUser Guide

B} Data Catalog Management Dashboard

Endorsed Non-Certified Terms

Name Definition Endorsements  Stewards

=| Category Group Mumber A number uniquely identifying a group of categor... 1) = Adam (Ad:
=| Billing Street Address 2 Second line of street address, if needed 1) = Adam (Ad;
=| Category Description Detailed description for the Category 1) = Adam (Ad;
=| Category Group Grouping of Categories of General Ledger Accounts o & Adam (Ad

Click theCbse * icon to close the explorer.

Create a Dashboard
To build a dashboargpou will either start with an empty one (new) 8ave As.. from and

existing one

Steps
1. Go toDASHBOARDSMVianageto begin working on a dashboar®ou may also click

DASHBOAR®>and select any of the options under
T Explore
T Defaults
T Favorites
T Recent

2. For a new dashboardyeate itandspecify the Name, Layouth&ing andDescription.
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Example
Here, we will create a new dashboard from scratch.

Log in administrator Go toDASHBOARDSManageandclick ©* €5 9 v 1 SNJ ¢ a &
5 & Ko thth&lNaemetext field. Choose the threeolumnLayout

Layout the Dashboard

New Dashboard b 4
Mame: My Dashboard

55 1 T x
share With: | (I

Description: | |
] |
5 |
5 1 ] |
1 1 1 ] |

Whenlaying out the dashboard you will not be able to add containers above the first one.
Instead, you will have to copy the top one and then edit it to reflect the new design.

Share the Dashboard with Users and Groups
Share it with theAdministrators Group.

Share With: Select Users/Groups to share the default with hd
Description: O Filter text

Groups 3

[] && Administrators
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Enter aDescriptionand clickOK

New Dashboard x
Mame: My Dashboard

Layout: "
Share With: &t Administrators X hd
Description: Enter a description |

It is now in the list, and note it is shared.

Name Created | Last Modified @ LastViewed = Shared With Description

|E My Dashboard Just Now  Just Now

<% Administrators Enter a description.

Click on My Dashboard in the list to edit.

OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MAMNAGE

Manage Dashboards Recent (2) Favorites (1) My (2) Shared with Me

[%al

o

1]

al
T

o)

e Create ¥ Delete 2 Share

Name Created Last Modified = Last Viewed Shared With

@ Data Catalog Management Dashboard 3 Weeks Ago 3 Weeks Ago Just Now &% Administrators

@ My Dashboard & Days Ago 7 Minutes Ago 7 Minutes Ago &% Administrators
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Edit(Customizga Dashboard
Whether editing a saved dashboard or simply working with a search result {vasented as a
dashboard, this is the common environment for filtering and manipulating that dashboard.

Steps

1. For a new dashboard, specify the Name, Layddyi8g and Description.

2. For an existing dashboard goNore Actions > Customize start editing.

3. From here you may:

(0]

O O oo

Examples

Populat cells: Drag any widget from the right panel into the left portion of the
dashboard and then clicRONFIGURE

Add a container:

Rename a dashboard

Save

Save as a new dashboard

ClickbASHBOARD>Explore and pickMy Dashboard

Go toMore Actions( * ) > Customize
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B8 My Dashboard

Certi... 1-5ofd > Certified Terms
#user tags# MName 9
= 72 T .
L97E fusto Non-Certified Ter...
=| Account Abt 277
=| Account Am
=| Account But EIFogwritiges
=| Account MNai Lo

19 Drop wi

One may now edit the dashboard

Add a Container to a Dashboard
In order to place more horizontal structure into a cell in a dashboard, you may drag a container
into any location a widget can be placed.

Containers may be placed to any level of depth inside of cells which are themsleves inside a
container and so on.

Steps
1. Navigate tathe dashboard.

2. ClickMore Actionsand thenCustomize
3. Drag theContainerwidget into the right portion of the dashboard and below tNen

Certified Termsvorksheet counter widget.
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Example
Navigate toMy Dashboardand clickMore Actions>Customize Drag theContainerwidget into
the right portion of the dashboardldd Widgetsa a Dashboard

On the right you see the list widgets that may be included in the report.

OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MAMNAGE

B8 My Dashboard

Explorer Further

Add columns to a Container
Just asvith a dashboardyou may insert columns before or after. This maygeedied in the
settings of the container

Steps
1. Navigate tathe dashboard.

2. ClickMore Actionsand thenCustomize

3. Click theSettings®* icon for the container.

Copyright © 2020, Oracle and/or its affiliates. All Rights Reserved. (12.2.1.2020/10/29) Pagel27| 764



ORACLE’ Enteprise Metadata ManagementUser Guide

4. Selectinsert columnbefore or after.

Example
Drag a container at the bottom of treashboard.

My Dashboard & NOTSH

D\

Business

Attribute

Drop widgets

Click theSettings™ icon for the container.
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Width >
Children layout ?
Appearance ?
Edit Title

Move left

Move right

Insert column before

Insert column after

Copy content
Paste

Remove

Select Inser column before.

[E] My Dashboard* # & NOT

Business

Drop widgets Drop widgets

Wee have a new column.
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Add a Widget to a Dashboard
You may include a variety of widgets in a dashboandititin Containersn a dashboard

E Worksheets

@ Dashboards
Collections

E Worksheet

12 Counter
 Percentage

[l Attribute Statistics
Collection

12 Collection Counter
® Recent Objects

<f> HTML Text

# Embedded Webpage
M Iimage

& Link
[ml

& Links

Steps
1. Drag the widget from the pallet on the right into below an object or inside a container.

Examples
Common Widget Properties

Worksheets Dashboards and Collectionsdget

With one of these widgets you ma&mnbeda reproduction of the options under the
WORKSHEETSASHBOARDS COLLECTION&nuinside a dashboard.

Drag theDashboardsvidget into thecenterportion of the dashboard.
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1Y My Dashboard

Certifi... -Bof14 >

Name !
=| 1972_Customer Number T
=| Account Abbreviation T

=| Account Amount Available T
=| Account Budget Amount T

= Account Mame T

ClickSettingsand note the options:

I Width

Children layout

woow v [

Appearance

Edit Title

Move left

Maove right

Insert column befare

Insert column after

Copy content

Paste

Remove
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We have a reproduction of the options under DASHBOARDSenu.

WorksheetWidget
With this widget you may embed the results of a worksheet into the dashboard.

Drag theWorksheetwidget into the left portion of the dashboard.

Worksheet

Worksheet Widget is
not configured yet

CONFIGURE

Click CONFIGURE andckseNon-Certified Termdrom the list.

Worksheet Widget Settings

Settings Display Options
SELECT WORKSHEET *
Non-Certified Terms
e
5

<>

o | o

ClickAPPLY
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. Worksheet Widget Settings
Settings Display Options

| SELECT WORKSHEET *
| Non-Certified Terms

LM

~
1 5 LY

TheDashboard is updated in the background.

Click Display Options
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Worksheet Widget Settings

Settings Display Options

TITLE TITLE COLOR

x

edit ttle duto -

DESCRIPTION [/ Show only as tooltip

edit description

WIDGET MAXIMUM HEIGHT

Ll
dUTO g

AUTO REFRESH FREQUENCY

Select frequency o

k4 Hide widget when empty

T | o O

These are the options you may specify on the widget.

Qick CLOSE

CounterWidget
With this widget you may embed a counttbe elements in a worksheet into the dashboard.

Drag theCounterwidget into theright portion of the dashboar@nd clickCONFIGURESelect
the Non-Certified Ternsworksheet.
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Counter Widget Settings X
Settings Display Options

TOTAL COUNT FILTER *

Define the MOL where statement that will be used to compute the total count of objects

o

[@ Non-Certified Terms W

[ 1 Summarize Mumber

CLOSE

Click OK

Non-Certified ...
510

We have the total number of terms which have not beerified.

Percentage Widget

With this widget you may embed percentages based upon particular columns of a worksheet
into the dashboard.

Drag theWorksheetPercentage Statisticaidget into the bottom portion of the dashboard.

ClickDefinenext to theTARG&T COUTN FILTERIickEDITio create a query (worksheet
equivalent) which contains all terms.
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Edit Worksheet

Filters ADVANCED £

Q) SEARCH TEXT

CATEGORY

Glossary » Terms X

]

The Target is the set that designates completeness.

=
a

=+ FILTER

1-500f 520

1 % 2 Filters Columns

WHERE category = 'GlossaryTerms’ ORDER BY Mame ASC

User Tags

Mame

1972 Customer_Number
Account

Account Abbreviation
Account Amount Available
Account Budget Amount

Account Description

+ I

ClickeDIThext to ACTUAL COUNT FILT&Reate a query (worksheet equivalent) which will
provide the actual count of objects to report.

' Edit Worksheet

Filters ADVANCED ¢

O SEARCH TEXT

CATEGORY

Select categories

CERTIFIED BY = exists

] RESET FILTERS

=
[m]

+ FILTER

1-14 of 14

1 Filters  Columns

Object T
Term
Term
Term
Term
Term

Term

2

WHERE category = ‘Glossary. Terms’ AMD certified_by EXISTS ORDER BY Name ¢

User Tags

Mame

1972_Customer_Mumber Term
Account Abbreviation Term
Account Amount Available | Term
Arcount Budget Amoumnt Term
Account Name Term

AcCcount Status Term

« I
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ClickPercentage ClickOK Click SAVE. Click STOP EDITING.

Dashboards £ Filter

W Favorites 2 =

My Dashboard

My Dashboard 2
® Recent s =

My Dashboard
My Dashboard 2
simaon
Dashboard

Data Catalog Management Dashboard
= Personal & =
Dashboard

Data Catalog Management Dashboard

My Dashiboard

kv Nashhnard 7

Attribute Statistics Widget
With this widget you may embed statistics based uparticular columns of a worksheet into

the dashboard.
Drag theAttribute Statisticswidget into thebottom portion of the dashboard
Cick CONFIGURESelect théNon-Certified Terns worksheetand select the

o Certified Termsvorksheet
0 Typeattribute
o Piechat type.
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Attribute Statistics Widget Settings x
Settings Display Options

SELECT FILTER
Define the MOL where statement that will be used as a scope
Select Define

Certified Terms v
SELECT ATTRIBUTE *

Type v
PROFILING COUNT  LIMIT

10000 . 10

<r

CHART TYPE

Grid ﬂ Bar Line Tree Map
(o | o PR

Click APPLY.

APPLY applies the changes immediately in the background. ]

Go to the Display Options tab and:

0 9YUSNI &/ SNIATASR ¢SN¥a o0& ¢8LIsSé¢ Ay GKS GAGt
0 Uncheck the Hide widget when empty checkbox.

Copyright © 2020, Oracle and/or its affiliates. All Rights Reserved. (12.2.1.2020/10/29) Pagel38| 764



ORACLE’ Enteprise Metadata ManagementUser Guide

Attribute Statistics Widget Settings b 4
Settings Display Options

TITLE TITLE COLOR

Certified Terms by Type auto w

DESCRIPTION L4 Show only as tooltip

edit description i

WIDGET MAXIMUM HEIGHT

<>

auto

AUTO REFRESZH FREQUENCY

Select frequency b

[] Hide widget when empty

o | o R

Click OK
B8 My Dashboard* #* & NOTS
Certified Terms by Type o -

Dnn:lain

Attribute
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OK applies the changes addses the dialog. ‘

Now, lets Configure the widget again and specify a Tree Map, instead of the Pie.

Attribute Statistics Widget Settings %
Settings Display Options

SELECT FILTER

Define the MOL where statement that will be used as a scope

Select Define

Certified Terms v
SELECT ATTRIBUTE *

Type
PROFILING COUNT LIMIT
10000 = 10

L

CHART TYPE

Grid Pie Bar Line
(e | o PR

And the result is:
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Type Statistics

Domain

Attribute

Business

Collectionwidget
With this widget you may embed the contents of a collection into the dashboard.

Create &Containerat the bottom of the dashboardDrag theCollectionwidget into the
contanerand clickCONFIGURE

Select theHot Reportscollection. Set th&IMIT(number of lines) t@.
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Collection Widget Settings x
Settings Display Options

SELECT COLLECTION *

[=] Hot Reports w
LIMIT
?4 il
LT
ICOMNS
Small  Large

SHOW ATTRIBUTES

] Alternate Name [ Cerification
-] Context 1 Endorsements
Description [] Warnings

[] Comments

oo | o

Click OK.
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1% My Dashboard#* 2 NOT

Hot Reports < 1-30f21 > 7 &

E AccountAmountdvailable
from Yendor Mart » dbo » GLACCoUNt

E AccountAmountAvailable
q from Dimensional OW » dbo » PaidPurchaseOrderGLAccountView

E AccountAmountdvailable
q from Dimensional DW » dbo » PaidCustomerPOGLACCoUNTYiew

The top three Hot Reports are embedded in the dashboard.

CollectionCounter Widget
With this widget you may embed a count of the elements in a collection into the dashboard.

Drag theCollection Countemwidget into the bottom portion of the container thahe Hot
Reports Collection widget is dashboard and clicKONFIGURE

Select theHot Reportscollection.

| Collection Counter Widget Settings x |
[
Settings Display Options
SELECT COLLECTION *

=] Hot Reports w

[ ] Summarize Number
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Go to theDisplay Optiongi I 6 | YR Sy (G SNJ a¢ 2 LJTite. | 20 wSLI2 NI &

| Collection Counter Widget Settings x |
|

Settings Display Options

: TITLE TITLE COLOR
Top 3 Hot Reports of auto W

DESCRIPTION [~] Show only as tooltip

o
T

. WIDGET MAXIMUM HEIGHT

S Lal
A

AUTO REFRESH FREQUENCY

y

o

ect frequency W

| EA Hide widget when empty

Click OK.
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B8 My Dashboard & NOT SHA

F

Hot Reports < 1-30f21 >

E AccountAmountavailable
from Vendor Mart » dbo > GLACCoUNt

E AccountAmountAvailable
from Dimensional OW > dbo > PaidPurchase OrderGLACccountView

E AccountAmountdvailable
q. from Dimensional DW > dbo » PaidCustomerPOGLACCoUNTYiew

Top 3 Hot Reports of
21

The number of Hot Reports is now embedded in the dashboard.

Recent Objects Widget
With this widget you may embed apmduction of the OBJECTS > Recent menu list into the
dashboard.

Drag theRecent Objectsvidget into the bottom portion of dashboard.
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1% My Dashboard#* & NOT
21

Recent Objects © 1-50f92 >

Customer o
from Finance » Terminology

e= PurchaseOrder (Purchase Order) 1
from 5taging DW > dbo

= U5 Social Security number
= from Finance > GDPR

= 1972 Customer_Mumber
from Finance > Domains

Account Mame
from Finance » Terminology

A list of recently visited objects is now embedded in the dashboard.

HTML Text Widget
With this widget you magmbed HTML formatted text into the dashboard.
By default, the Tomcat server is configured to reject any image not hosted on the applicatipn
server. As a result, tHmk, html andimagewidgets do not allow referencing external images.
A simple change tde default tomcat configuration (in théomcat\confiweb.xml) can fix that.
Change:
<filter><filter> <filter - name>SecurityHeadersFilter</filter - name> <filter -
class>MITl.tomcat.filter.SecurityHeaders</filter - class> <init - param> <param -
name>Content - Security - Policy</param - name> <param - value>default - src 'self’;
child - src'self' *; img - src 'self' data:; script - src 'self' 'unsafe - eval'
‘unsafe - inline’; style - src 'self* 'unsafe - inline';</param - value> </init - param>
<init - param> <param - name>X- Content - Type- Options</ param- name> <param -
value>nosniff</param - value> </init - param> <init - param> <param - name>X- XSS
Protection</param - name> <param - value>1; mode=block</param - value> </init - param>
<ffilter>
To:
< filter><filter> <filter - name>SecurityHeadersFilter</filter - name> <filter -
class>MITl.tomcat.filter.SecurityHeaders</filter - class> <init - param> <param -
name>Content - Security - Policy</param - name> <param - value>default - src 'self’;
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child - src'self' *; img -src{c olor:#FF0000}*'self data: *; script - src
'self*{color} 'unsafe - eval' 'unsafe - inline’; style - src 'self' 'unsafe

inline';</param - value> </init - param><init - param> <param - name>X- Content - Type -
Options</param - name> <param - value>nosniff</param - value> </init - para m> <init
param> <param - name>X- XSS Protection</param - hame> <param - value>1;
mode=block</param - value> </init - param> </filter>

Create a&Containerat the bottom of the dashboard. Drag thErML Textvidget into the
contaner and clicCONFIGURE

O9YGiSN kS ®SBY¥Syia LRSYGAFTASR YyRk2NJ ¢ 33SRE

HTML Widget Settings xX

Settings Display Options

| vi[[B||I||[U|[|T|[T7|||Z~||T~||E

PIl Elements Identified and/or Tagged

Click OK.
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1% My Dashboard & NOTSH

= Lustomer 1]

from Finance * Terminology

e PurchaseOrder (Purchase Order
from 5taging DW > dbo

= U5 5ocial Security number
from Finance * GDPR

= Account Name
from Finance » Terminology

= Account Abbreviation
from Finance * Terminology

Pll Elements Identified and/or Tagged

The HTML text is now embedded in your dashboard.

Embedded WebageWidget
With this widget you may embeahy page referenced by a URLo the dashboard.

You may even use variablpertinent to your current session to customize the URL usingRhe
Builder.

Drag theEmbedded Wepagewidget into the bottom of the container with the HTML Text and
click CONFIGURE hen click URL BUILDER
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URL Builder
URL TEMPLATE VARIABLES
http://demo: 19988,/ MM/ #view=details&configld=-1_25&objectId=AAAACAAAAADEELED
=Overvien| D Filter text

Authentication Token
User Name
Configuration Version Id
Configuration Version N

URL PREVIEW - Co nfiguration Content |

httpy//demo:19980,/MM/#view=details &configld=-1_25 &objectid=AAAACAAAAADa&tab=0  Configuration Content k
verview Configuration Content F

Configuration Parent Fo

Click OK.

Copyright © 2020, Oracle and/or its affiliates. All Rights Reserved. (12.2.1.2020/10/29) Pageld9| 764



ORACLE" Enteprise Metadata ManagementUser Guide

B8 My Dashboard & NOTSH

Pl Elements Identified and/or Tagged

OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MANAGE 0 Search

=_| Personally Identifiable information (PIll) | Term &0
= from Finance > GDFR ! *
Overview Relationships Related Reports Semantic Flow G
Definition Labels
Personally ldentifiable information (alias PlI) add value
https:/fen.wikipedia.org/wiki/Personally_identifiable_infor
mation .
Collections
Documentation add value

Personal information, described in United States
legal fields as either personally identifiable
information (PIl), or sensitive personal
information (SPI),["213] a5 ysed in information
security and privacy laws, is information that can be

Attributes

Mame  Personally
|dentifiable

infarmatinn

An HTML page from tharoduct itself is embedded in the dashboard.

ImageWidget
With this widget you may embed an image into the dashboard.

The image must be referenced as a URL. The product does not store these images for yqu.

By default, the Tomcat server is configureddject any image not hosted on the application
server. As a result, tHimk, html andimagewidgets do not allow referencing external images.
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A simple change to the default tomcat configuration (in\tteencaf\confiweb.xml) can fix that.

Change:

<filter>< filter> <filter - name>SecurityHeadersFilter</filter - name> <filter -
class>MITl.tomcat.filter.SecurityHeaders</filter - class> <init - param> <param -
name>Content - Security - Policy</param - name> <param - value>default - src 'self’;

child - src 'self' *; img - src 'self' data: ; script - src 'self' 'unsafe - eval'

‘unsafe - inline’; style - src 'self' 'unsafe - inline';</param - value> </init - param>
<init - param> <param - name>X- Content - Type - Options</param - name> <param -
value>nosniff</param - value> </init - param> <init - param> <param - name>X- XSS

Pr otection</param - name> <param - value>1; mode=block</param - value> </init - param>
<[filter>

To:

< filter><filter> <filter - name>SecurityHeadersFilter</filter - name> <filter -
class>MITl.tomcat.filter.SecurityHeaders</filter - class> <init - param> <param -
name>Content - Security - Policy</param - name> <param - value>default - src 'self;

child - src 'self* *; img - src {color:#FF0000}*'self' data: *; script - src
'self*{color} 'unsafe - eval' 'unsafe - inline’; style - src 'self' 'unsafe -
inline";</param - value> </init - param> <init - param> <pa ram- name>X- Content - Type -
Options</param - name> <param - value>nosniff</param - value> </init - param> <init -
param> <param - name>X- XSS Protection</param - name> <param - value>1,;
mode=block</param - value> </init - param> <ffilter>

Drag the Image widget into the bottom dieé container with the HTML Text and click
CONFIGURE

Paste dMAGE URL

Image Widget Settings X
Settings Display Options

IMAGE URL *

https://en wikipedia org/wiki/File:PD_social_security_card png|

IMAGE WIDTH (IM PIXELS)

|0 o
|
[ IMAGE HEIGHT (IN PIXELS)
0 o
oo | o R
ClickOK
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Link Widget
With this widget you may embeal linkinto the dashboard.

Drag theLinkwidget into the bottom of the container with the HTML Text and dBE&NFIGURE
Thenclick URL BUILDER

You can build a link that works just like the embedded URL, but not embedded.

By default, the Tomcat server is configured to reject any image not hosted on the applicatipn
server. As a result, tHimk, html andimagewidgets do not allow referencing external images.,
A simple change to the default tomcat configuration (in\ttwencat\confiweb.xml) can fix that.
Change:

<filter><filter> <filter - name>SecurityHeadersFilter</filter - name> <filter -
class>MITl.tomcat.filter.SecurityHeaders</filter - class> <init - param> <param -
name>Content - Security - Policy</param - name> <param - value>default  -src ‘self’

child - src 'self* *; img - src 'self' data:; script - src 'self' ‘unsafe -eval

‘unsafe - inline’; style - src 'self' 'unsafe - inline';</param - value> </init - param>
<init - param> <param - name>X- Content - Type - Options</param - name> <param -
value>nosniff</param -value> </init - param><init - param> <param - name>X- XSS
Protection</param - name> <param - value>1; mode=block</param - value> </init - param>
<ffilter>

To:

< filter><filter> <filter - name>SecurityHeadersFilter</filter - name> <filter -
class>MITl.tomcat.filter.SecurityHeaders</ filter - class> <init - param> <param -
name>Content - Security - Policy</param - name> <param - value>default - src 'self

child - src'self' *; img - src {color:#FF0000}*'self' data: *; script - src

'self*{color} 'unsafe - eval' 'unsafe - inline’; style - src 'self' 'unsafe -

inlin  e';</param - value> </init - param><init - param> <param - name>X- Content - Type -
Options</param - name> <param - value>nosniff</param - value> </init - param> <init -
param> <param - name>X- XSS Protection</param - name> <param - value>1,;

mode=block</param - value> </init - param> </fi  Iter>

{25 t8GQa 3ISGE GKS adGNHOGINNBE 2F | !'w[® hLSy I

> Terms. Then specify a filter where Certified By does Not Exist.
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Q Terms

= | Account ldentifier
= | Acoount Mame
=| AccountAbbreviation

=| AccountAmountAvailable

Columns

Object Ty
Term
Term

Term

Filters ADVANCED 1 - 50 of 510 1 » 21  Filters
Q SEARCH TEXT E WHERE category = ‘Glossany.Terms' AMD certified_by NOT EXISTS ORDER BY Mar
CATEGORY User Tags Name
Glossary » Terms A =| Account
CERTIFIED BY $ not exists =| Account Description
RESETFILTERS 4 FILTER 1 =| Account Encumbered Amount

Term
Term
Term

Term

Now, paste that link back into tHenk Wdget Settingsdialog ClickJRLBUILDER

| URL Builder

URL TEMPLATE
http :f/demo: 19988 /MM #view=search&configld=-1_25&displayMode=GRID&sortOrder
=ASCENDINGEwhere=category®20%30%28 ' Glossary
Terms ' %28AND%28certified _by%2BNOT%2OEXISTSE&select
=%23User¥20Tags¥23%2C%X5BName¥50%2C%230bject®20Type®23%2CH23Context®23

URL PR

httpy//demo:19980,/MM/#view=search &configld=-1_25 &displayMode=GRID &=sortOrder=A
SCENDING&where=category®:20%3D%20'Glossary Terms'%2 0AND %2 Ocertified_by3620N0
T320EXISTS Eselec=%33User¥20Tags %2 3% 2CH5BNameX 5D %2 CH230bject®20Type™®
23%2C%23Context®23
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b2g> aSwmPBPpei W3 dBE D> (1 KS 02 yCorfigufatoiR Veksion ( KS | w] I
Identier.

The URL is replaced with variable. In this way, you may use this link in ANY configuraton,jand it
will always present the terms without ¢ification.

D2 (2 GKS 5AaLXle& hLAz2ya GF6o yR alCBIOATE a[AY
Save

ClickSavefor the dashboard.

Links Widget
With this widget you may embed a link into the dashboard.

Drag theLinkswidget into the bottom & the container with the HTML Text and click
CONFIGUREThen click URL BUILDER

You can build a link that works just like the embedded URL, but not embedded. ‘

{2z tSGQa 3ASH GKS A0 NHOGAZNB 2F | ! w[ ® hLISy
> Tems. Then specify a filter where Certified By does Not EXxist.

Q Terms

Filters ADVAMCED 1-500f 510 1 > 2 Filters  Columns

FARCH TEXT E WHERE category = ‘GlossaryTerms' AMD certified_by MOT EXISTS ORDER BY Nar

CATEGORY User Tags Name Object T
Glossary » Terms W = Account Term
CERTIFIED BY ® not exists = Account Description Term
RESETFILTERS  + FILTER \ = Account Encumbered Amount Term
=| Account Identifier ‘ Term
=| Account Mame Term
= AccountAbbreviation Term
=| AccountAmountAvailable Term

Now, paste that link back into tHeink Widget Settingslialog. ClickJRL BUILDER
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| URL Builder

http s/ fdemo: 19988 /MM #view=search&configld=-1_25&displayMode=GRID&sortOrder

=ASCENDINGE&where=Ccategory®20%30%28 "'0lossary 53

Terms ' %288ND%28certified _by¥2BNOTH2OEXISTSE&select

=%23User¥20Tags¥23%2CX5EName¥50%2C%230bject®2a8Type®¥23%2C%23Context®23 Authentication Token
User Mame

Configuration Version Ic

Configuration Version M

(]

EY * Configuration Content

http//demo:19980/MM/#view=search&configld=-1_25 &displayMode=GRID &sortOrder=A ~ Configuration Content |
SCEMDING&where=category?:20%3D%20'Glossany Terms %2 0AND 262 Ocertified_by3620N0 Configuration Content F
T%20EXISTS &select=%23User%20Tags%23%2C%5BName%5 D%2 (%23 0bject%20Type%

239%AC%I T Context%23 Configuration Parent Fo

b2¢> aSwPAPp eI W3 dBEd> (1 KS 02 yCorfiguratoiR Veksibn 0 KS | w[ |
Identier.

The URL is replaced with variable. In this way, you may use this link in ANY configuraton,|and it

will always present the terms without certification.

G (2 KS 5AaL)l e hLliAazya Glo yR ALISOATeEe G[AYy
Save

ClickSavefor the dashboard.

Renane a Dashboard

Steps

When on the dashboards details pagee may simply edit the name in place to rename a
Dashboard.

1. Navigate toMy Dashboardand click on its name.
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Example
Navigate toMy Dashboard- y R Of A O] GKS yIYS |yR (el dGae wSy

B2 [My Renamed Dashboard &) sHARED
WX
Certified Terms 7 Certified Terms
#user tags# MName 9
= 1972 Customer_Number Non-Certified Terms
= Account Abbreviation 277

= | Account Amount Available

= Non-Certified

=| Account Budget Amount

= Account Name 1 9

Copy a Dashboard Container
You may copy any contanor widget and then paste into another that you have already
included in a dashboard

Steps
1. Navigate toMy Dashboard

2. ClickMore Actionsand thenCustomize
3. Click theSettingsicon and selecCopyfor the container or widget you wish to copy from.

4. Includea new container or widgedh the dashboard

5. Click theSettingsicon and selecPastefor the new container or widget

Manage Dashboards
You may also seleBBASHBOARDS Manageto manage your existing dashboards.

Steps
1. Go toDASHBOARD&Manage.

- You see the list dfavorites It is the default tab.
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All the dashboards you have favorited are here. ‘

- From here you may:
T Open/Edit tle dashboard
T O Restrict the list by using thgearch Text
T Favoriteor un-Favoritea dashboard

2. Click theMy tab.

All the dashboards you have created are here.

- From here you may:
T Open/Edit thedashboard
2 Restrict the list by using theearch Text
“* Create a new saved dashboard
X Delete and existing saved dashboard
Favoriteor un-Favoritea dashboard
=& Share this dashboard with groups and/or users
Edit theNameor Descriptionof a dashboard

o e e

3. Click theRecentTah

All the dashboards you have recently opened are here.

- From here you may:
T Open/Edit thedashboard

T P Restrict the list by using th®earch Text
T Favoriteor un-Favoritea dashboard

Example
Go toDASHBOARDSVianage

Click theMy tab.
ClickFCreate 9y 1 SNJ 4 KS yIFYS abS¢ 5FakKoz2l NRé FyR LINBa:
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New Dashboard x
Mame: Mew Dashboard

Layout: "
Share With: Select Users/Groups are the defa h A
Description:

o Je

You will then have a dashboard actually saved but with no filters defined yet.

Click theMy tab.

Manage Dashboards

Recent (2) Favorites (0) My 3) Shared with Me
£ Search Tex o Create X Delete &Y Share
Name Created Last Modified Last Viewed
[3) pata Catalog Management Dashboard 2 Weeks Ago 2 Weeks Ago Just Mow
|E| My Renamed Dashboard 1 Day Ago 25 Minutes Ago 1 Hour Ago

|E| Mew Dashboard 3 Minutes Ago

3 Minutes Ago

4. Click theRecentTab.
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Manage Dashboards Recent (2) Favorites (D) My (3) Shared with Me

£ Search Text Clear history

Name Owner Last Modified Last Viewed Description

@ Data Catalog Management Dashboard | Administrator | 2 Weeks Ago 3 Minutes Ago

@ My Renamed Dashboard Administrator 28 Minutes Ago 1 Hour Ago Description goes

Deletea Dashboard
You may delete any dashboard that you created.

Youmay notd RSt S Sé¢ RI &Ko 2| NewaverQbBayisBnRly unfavorReiwka$ NBA &
is shared with you to remove them from your usual.lists

Steps
1. Go toDASHBOARD&Manage.

You mayclick theMy tab in order to only see dashboards you may delete.

2. Select the line of the dashboard to delete.
3. ClickDelete

4. ClickYes

Example
Go toDashboard > Manage

Click theMy tab.
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Manage Dashboards Recent (2) Favorites (0) My (3) Shared with Me
P Search Text ok Create 3 Delete A Share
Name Created Last Modified Last Viewed

@ Data Catalog Management Dashboard 2 Weeks Ago 2 Weeks Ago Just Now

@ My Renamed Dashboard 1 Day Ago 25 Minutes Ago 1 Hour Ago

| @ Mew Dashboard 3 Minutes Ago | 3 Minutes Ago

SelectNew Dashboardind dick () Delete.

Confirm x

9 Are you sure you want to delete New Dashboard Dashboard?

ClickYes

Explorer Further

Favorite a dashboard
You mayfavorite any dashboardhat you createdor is shared with you

,2dz YIe y20 GRSt S(iS¢ RIFrakKoz2l NRa ONBIGS
is shared with you toemove them from your usual lists.

Shared With
<L Administrator

<% Administrator

R |68 20K

Steps
1. Go toDASHBOARD&Manage.

2. Clickthe Favoriteicon.

3. To unfavorite, click theFavoriteicon.
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Example

Go toDASHBOARDSManage. Click the Favoriteicon next toNew Dashboard Then go to the
Favoritestab.

Manage Dashboards Recent (2) Favorites (1) My (3) Shared with Me

o)

Name Owner Last Modified Last Viewed  Description

|E|New Dashboard Administrator A few seconds Ago

Un-favorite New Dashboard by clicking th&avoriteicon again.

| |E New Dashboard

Now it is removed from thEavoritestab.

Shae a Dashboard

Steps

Dashboards have an owner who is the creator of the dashbddrel. owner (creator) of a
dashboard may share that dashboard withets and/or groupsThat owner may open, edit and
remove a dashboard. The dashboards that one owns may always be foundMy tae under
DASHBOARDSVanage

In addition, a dashboard may be made public, or shared, with specific users gnols.
Once shared, users that are in the sharing criteria specified may view and favorite those
dashboards, as well.

1. Go toDASHBOARD&Manage.
2. Go to theMy tab.

3. Select a dashboard.

4. ClickShare

5. Pick one or more users and/or groups to shire dashboard with.
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6. To unshare a dashboard, simply remove the specific (or all of) users and/or groups.

Example
Go toDASHBOARDSManage.
Manage Dashboards Recent (2) Favarites (1) My (3) Shared with Me
p Search Text = Create M Delete 2 Share
Mame Created Last Modified Last Viewed Shared With
|E| Dashboard 18 Hours Ago 18 Hours Ago
[18) Data Catalog Management Dashboard 3 Weeks Ago 3 Weeks Ago & Days Ago % Administrat
[@3) My Dashboard 7 Days Ago 10 Minutes Ago 11 Minutes AQo 2% Administrat

Go to theMy tab and select My Dashboardn the list.

Copyright © 2020, Oracle and/or its affiliates. All Rights Reserved. (12.2.1.2020/10/29) Pagel62| 764



ORACLE" Enteprise Metadata ManagementUser Guide

Share Settings X

Users / Groups £ Filte > Shared With

- - e Administrators

Groups 9
an Business Users

& APl Users <
& Application Administrators

= Data Lake Data Analyst

= Data Lake Metadata Explorer

= Glossary Approvers

= Glossary Editors

e Glossary Publishers

aw Glossary Reviewers

- Security Administrators
Users 13
- Adam -

CANCEL

ClickShare Then pick théBusiness Usergroupalong with AdministratorsandclickOK You
have shared that dashboard with those users.

You may save a shared dashboard before specifying whom to share it with. You may conje back
later and specify whom it will be shared with.

Using Shared Dashboards
Simply lecause you have shared a dashboard does not mean that all those other users can see

it. They must first look it up in Shared with Me. Once they have done so, they may
0 View it

o Favorite it
0 Save As their own dashboard that they may edit.

Steps
1. Signin as a user in the groAdministrators

2. Go toDASHBOARDSVanage.
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3. Go to theShared with Metab.

This list will be empty at first. You must search for dashboards that are shared with you.

4. Enter textin Search Textpick anOWNERQor just clickSearch
5. From here you may:

Open/Edit thedashboard

- P Restrict the list by using th®earch Text
Restrict the list by using tt@WNER

- Favoriteor un-Favoritea dashboard

Example
Sign is aBob. Go tcDASHBOARDSManage then go to theShared with Metab.

Manage Dashboards Recent (D) Favorites (0) My (D) Shared with Me

£ Search Text OWNER | All users - w

Mame  Owner Last Modified | LastViewed = Description

You may enter text, but in this case the list is short so just Skalch

Manage Dashboards Recent (D) Favorites (0) My (D) Shared with Me
£ Search Text OWMER | Al use vm

Name Owner Last Modified = Last Viewed = Description

11| My Dashboard  Administrator 2 Weeks Ago Description goes here.

Select the My Dashboard and click favoriteicon.
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I L'_;| My Dashboard Administrator 2 Weeks Ago Description goes here.

Go to theFavoritestab.

Manage Dashboards Recent (0) Favorites (1) My (0) Shared with Me
o)
Name Owner Last Modified = LastViewed  Description
',.'_gl My Dashboard  Administrator 2 Weeks Ago Description goes here.

TheMy Dashboards now a part of your favorites.

Default Dashboards
If you wish to customize the home page MMM , you may do so by defining default
dashboard.If youcreatea dashboardcisa Systemdashboard, then it may be used as the
default home page for specific users and groups of users. You then Share one or more system
dashboards with the users and groups of users you wish to make their homepage to be that
system dashboard. You mmanage thesystem dashboardss with any other dashboard.

You may manage the default dashboards uniquely usindlABIAGE > Default Dashboards
function.

Createa System Dashboard

Steps
1. Either Save As an existing dashboardreate a newdefaultdashboard

When youSave Ashe dashboard, you may set ti8ystenradio button at that time.

Example
Sign in again aAdministrator,

OpenMy Dashboardand clickSave As Specify the name and other details as follows:
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Save As Dashboard X
Mame: My System Dashboard

Type: () Personal (®) System

Share With: =% Business Users X W
Description: Default dashboard for Business Users|

o e

Then click the System radio button and cl@k

TheSystemradio button is only shown farsers who are members of the grodgministrators.

Now, refresh the browser to update the cache, sign in as Bob, who is a memberRiidimess
Usersgroup.
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OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS

Home
Certified Terms -50f 14 > Certified Ter
Mame Object Type  Stewards 14

1972_Customer_Mumber Term

= 5tu (Stuart Ster Worksheet (

= Account Abbreviation Term - Stu (Stuart Ste
=| Account Amount Available Term & Adam (Adam)
=| Account Budget Amount  Term & Adam (Adam)
Non-Certifie
= Account Name Term = SUU (Stuart Ste'
Collection

Because some of the collections and worksheets used in this dashboard are not shared w(th Bob,
or the Business Users grotipere are warning symbols.

Sign in again addministrator. Go toCOLLECTIONS > ManaggghiclickHot Reportsand
Sharethat report with Business Users
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o)

Now, sign in again &oband you see that th€ollectionlist is working.

Manage Collections

Ermcarris Eonrt
call =

(28]

Mame

3rd Quarter Push

Collection
Hot Reports

My To Do
MyList
MNew Tables

Recent (1)

J= Create

Created

4 Months ago

4 Months ago

1 Year ago

4 Months ago
2 Months ago

1 Year ago

Favoritas (1)

M Delewe

Last Modified = Last Viewed

4 Months ago

4 Months ago

1 Year ago

4 Months ago
2 Months ago

1 Year ago

My (6)

&) Share

3 Weeks ago
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Home
Certified Terms -50f 14 > Certified Ter
Mame Object Type  Stewards 14
=| 1972 Customer Number  Term & Stu (Stuart Ste Worksheet (
=| Account Abbreviation Term .

o StU (Stuart Ste’

=| Account Amount Available Term - Adam (Adam)

=| Account Budget Amount  Term & Adam (Adam)
= Account Name Term - STu (Stuart Ste
Hot Reports -50f 21 >

E ACcountAmountAvailable
from Vendor Mart » dbo » GLACCount

E ACcountAmountAvailable
q from Dimensional DW > dbo » PaidPurchaseOrdercLAccounty iew

MNon-Certifie

Enterprise Achitecture(Configuration)
Once stitched, the relationships amoRgpository Objestin aConfigurationcan be visualized
producing a data flow and semantic based architecture diagram. One may edit the layout and
annotate these diagrams usiitige Configuratiormanager.

Steps
1. Either
0 Go toOBJECT&Architecture Diagram
0 Go toMANAGE > Configuratiomnd click on thdiagramaction icon.
2. Either
- Doubleclick one of the objects
- Rightclick one of the objects and seledpen
Example

Copyright © 2020, Oracle and/or its affiliates. All Rights Reserved. (12.2.1.2020/10/29) Pagel69| 764



ORACLE" Enteprise Metadata ManagementUser Guide

Finance System Architecture
Master Configuration

DATA LAKE
DATA GOVERNANCE (DG]

L]
E Azure Data Lake & Blob Storage, AWS 53, Kalka, Swifl DATA CATALDGING (DC)
Hadoop HOFS [Cloudera, Hofonwarks, MapR) DATA MODELING (DM}

Linux / Windaws File Systems

Dt Laka
Business Glossary with Workflow, Social Cu

Semantic Mapping, Standard Complians
Semanlic Type Detection. Dala Curalio

OPERATIONAL DATA STORES (ODS) Data Modeling (builin, or extemal with Erwin, ER:

ROBMS: Oracle, SOL Server, |[BM OS2, Postigre30L, MyS0L, SAP HANA
MoS0L: MongoDE. DalaStax, Cassandra, CouchDBE, Hbase

Big Data: Hacop HIVE {Clowdera, Hortanworks, MapR)
Cloud: Azure S0OL Database, AWS Aurora
RAFTAAME . l
o,
ACLOURDE Rayebda af.. Enma
T
1

SAYTRAME w0 AR
- " - -
—— — —

Arceunts Recahabie Gerenal Lasger Ad|TIerTs Arenuns Payable

[ Flnar
L2 C R C R R Ch
Dwita L o STaging AR to Staging GL e Smeglrg Adjusmens to Sag... APt Staging
( —
—~ - h
| R

—+ Emigieyg DWW Eruging T Dieiale. . il
DATA INTEGRATION (DIFETL) and DATA MAPPINGS
Claszic ETL: Informatica PowerCenter, IBM DataStage, Micrasaft 5515, Orade 0D and OWE, SAP BODVDE = S
Mew D: Takend DI, Data Prep, Informatica Developer, Azure Dals Factary, AWS Glue Azure Dala Warshowse, AWS Redshif, Google
Classic Scrpting: SGL Server (Transact-50L), Ovacle (PL/SGL), 1BM DB2. Teradata (BTEQ. FastLoad, TFT) Dracla, & flake, Teradats, sl

Mew Soripling: Hadeap Hive OL (Cloudera, Hofonwarks, MapR), Sgoap, PaostgreS0L, Spark (with Pythan or Scala)

Explore Further

Properties Panel
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There is a Properties Panel on the right. If you show this panel then youlickagrcan object
and view its prperties in the panel.

= O Quick find Properties >
4 MName Value
Diata Cataloging and Data Governance
Mame Finance
B i
| Description
— Creation Time 2018-06-21 1310
; : . 3 Author

- - Last Modification.. | 2018-06-22 145

\?..f Qf Modifier

Overview

For especially large architecture diagram you may click o= t@verview) icon to show a
reduced view of the entire architecture. You may click anywhere on the overview to
immediately move to that portion of the diagram.

Zoom andFit to Content
Q | 75% | @ |

Use tle zoom and Fit to Content controls to zoom in and out or fit the ermtiohitecture
diagram to the page.

Quick find

Toquickly find an object in the diagram, tliguick Find feature will locate object that have a
name match with the text you type.
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() O sta

~ 7 results for sta x
o> Adjustments to Staging

& Staging DW
$x Staging to Dimensional

¥ AP to Staging
¥ GL Account to Staging

X AR to Staging

ah . - - - e

Print the diagram

You may print the architecture diagram as either a PNG or SVG document which is downloaded
to you.

Edit the diagram

With the appropriate permissions, you may edit the architecture diagram. To do so, simply drag
any element to a new locatigmight-click for a menu of editing options, add annotations, or
auto-layout the entire diagram. Cli&avein order to commit your changes.

Configuration management

The Architecture diagram also provides access to the configuration management features of
MIMM , including connection editing (stitching). For details go here.

0 Search for specific objects withinContentin the displayed diagram.
0 Rightclick on an element or select the Actions () icon for more options.
o Click on the Edit actioand edit the diagram.
Recently Viewed
You may always return to objects you have recently viewed.

Steps

All Objects
1. ClickOBJECTS > RECENT pick one of thentries
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2. ClickOBJECTSa>2 NJarX! you will have the complete history to pick from.

Worksheets
1. Any of the steps for all objects.

2. Click WORKSHEETS > RECENT and pick onerrfiize

Collections
1. Any of the steps for all objects.

2. ClickOBJECTS > Collectiorslick theRecenttab and pck one of theentries

Example
Clickh . W9/ ¢{ B w9/ 9b¢ B a2z2NBX
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OBJECTS WORKSHEETS

E Search
Collections
1

RECENT
Us TET d
= dizag
£% PhysicalDataModel
¢ AddressiD
7 Address

mMore...
EROWSE CATEGORIES
Glossary

Data Modeling
Dataset

Database

File

JSOM Database

SAP BusinessObjects
Tableau

Data Mapping

SQL Script and Mapping
Talend Data Integration |
ADDITIONAL

My Term Changes

Architecture Diagram

Statistics

You then have the complete history:
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Recent Objects
1-550f55 Columns
User Tags MName
Glossary
f AddressiD
fl AddressiD
&2 Staging DW
=22 ArcountCategory
o ] Invoice
o 7 PurchaseOrder
B ShippingPOC
S GLAccount
E PurchaseOrderAmount
=2 Dimensional DW
E InvoiceAmount

E ArccountAmountAvailable

Favorites

Object Type
Folder
Column
Column
Database
Table
Table
Table
Runtime Job
Query Mapping
Column
Database
Column

Column

You may always return to objects you have recently viewed.

Steps

Worksheets

1. ClickWORKSHEET%avoritesand pick one of thentries

Collections

1. ClickOBJECTS > Collectiorslick thd=avoritestab and pick one of the entries.

Dashboards
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Context

AR to Staging » AccountsR

AR to 5taging » Accountsk

Staging DW » dbo
Staging DW » dbo
Staging DW » dbo
5taging to Dimensional » .
Adjustments to 5taging

Dimensional DW > dbo » F

Dimensional DW » dbo » (

Dimensional DW » dbo » C
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2. ClickOBJECTSDashboards Click thd-avoritestab and pick one of the entries.

Example
ClickWORKSHEE®%avorites> More

Manage Worksheets Recent (4)

Name
E Certified by Stuart
E Certified Terms
E New Worksheet
E Mon-Certified Critical Atoribute Terms
E MNon-Certified Critical Terms
E MWon-Certified Terms

E Warned

Favorites (7)

Owner
Administrator
Administrator
Administrator
Administrator
Administrator
Administrator

Administrator

My (17)

Last Modified
& Months Ago
2 Hours Ago
7 Months Ago
6 Months Ago
& Months Ago
& Months Ago

& Months Ago

You then have the complete list of your favorite worksheets

Analyze Mtadata

MetadataDetails Pag®efault Presentation

Shared with Me

Last Viewed
5 Hours Ago
2 Hours Ago

4 Hours Ago

Eachmetadata elemenin MIMM has a dynamically constructei®tails page All the

information about thatmetadata elements available from theletails page

Identifying Informatiorsuch as sample data and profiling information mayhimiglen

Defaults (0)

Filters

category = 'Glossary

category ='Glossary’T

category = 'Glossary
category = 'Glossary’T
category = 'Glossary

category ='Glossary

In the top left, you will see thetysical nane, Business namanetadata elementype and
context or parent structure of where this element is in thodelit is contained in.

Social curation

In the top right you may curate thimetadata element You have the optioto Certify, Endorse
and/or providing aWarningfor thismetadata element
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Any user may Comment, Endorse or Warn. Users with the Manager security role may edif or
removes those of other users. Only the steward and Administrators may certify.

More details orsocial curation

Tabs

Several different tabs run across the top. Click on any of these tab to see details about the
metadata element The specific tabs will vary depending upon the typmetfadata element
you are looking at.

The presentation of elements in the object tabs, e.g. Tables in a schema, may be customized and
published using thdefaut worksheet capabilities

Overviewtab

The Overview tab contains general information about tinetadata elementincluding:

(0]

(0]

(0]

(0]
(0]

Business Descriptiowhich is determined by description information in a related
Business Glossary, or determined by semantic kmiksdata flow lineage dependencies.
Data Profilinginformationcollected when harvesting the model, if specified and
available

Labelsassigned to thenetadata element

Semantic Typeghat the metadata elements associated with
AdditionalPropertiesdefined for themetadata element

All of the contents of the Overview tab may be customized and published usihefaluét
dashboard capabilities

Steps

Thedetails pagdor a givenrmetadata elementmay be accessed lpgarch metadata category
browsingor browsing thearchitecture diagramin addition, anywhere a hyperlink with the
name of that element appears (e.g., in a diagram, lineage trace, or other list or disalalmk
will take you to thedetails pageGoing to thedetails pages the default action for any
hyperlinkedmetadata elementand is the default action for th®peniconand context (right
click) menu.

Example

Databasdable

9y (i SNJ at dzNDOK ISaafchextNadx 81 ke uppeyright. K S
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© Purchase 0rder| X 0
Search results

Purchase Order
from Enterprise » Enterprise Conceptual Model

= | Purchase Order Date Purchase Order Date
from Finance » Terminology

Purchase Order Mumber (PO Vendor Invoice ltem_ Purchase...
from Tableau * Metadata Management » Financel » PO Vendor_In

Purchase Order Description (PO Vendor Invoice Iterm_Purcha...
from Tableau > Metadata Management » Financel » PO _Vendor_In...

{ Purchase Order Amount (PO Vendor Invoice [tem__Purchase..
| from Tableau * Metadata Management * Financel * PO Vendor_In._..

o MW oo

Purchase Order Date
from Finance > Terminology

Customer Purchase Order
from Enterprise » Enterprise Conceptual Model

Purchase Order Amount
from Tableau > Metadata Management » Financel » Vendor Purcha...

Purchase Order Mumber
from Tableau » Metadata Management » Financel » Vendor Purcha...

E?,ﬂ Eﬁﬂ 1[0

Purchase Order Descripticn
_.ﬁc from Tableau » Metadata Management » Financel » Vendor Purcha...

1-10 of 499 p SHOW MORE

Select thePurchaseOrdetable indbo schema in theStaging DWnodel.
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PurchaseOrder (Purchase Order) | | Table from Staging DW > dbo

Overview Related Diagrams Columns Data Sample Relationships

Business Description

odd vialue

Columns -5of 7 »

H BillingAddressiD

§ PurchaseOrderAmount

H PurchaseOrderDate

B PurchaseOrderDescription

H PurchaseOrderNumber

Data Sampling and Profiling

Data Profiling has never been run on this object. Request now

Tablesn a database generally have a great deal of related informatiaabs.For example, we

have:
0 RelatedDiagrams(or just Diagrams) with data modeling diagrams where available
0 Columnscontained within this table
o Sample Data
o Relationshipsncluding PK/FK, inferred and us#fined relationships with other tables.

Especially important when joining this table with others, such as in @aeelice Bl tool.

The numbers next to the tab headings, e@plumns?, to indicate how rany items are under
that tab.

Field in a file with profiling information
Enterd OdzNNB y O& SeatcReStdox Inyhe uppesright.
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0 currency codel X 0
Search results

Currency Code

from Finance » Terminology

CurrencyCode
from Diata Lake » DataCataloging » AdventureWorks Data Lake » ...

CurrencyCode
from Diata Lake » DataCataloging » AdventureWorks Data Lake » 5...

ToCurrencyCode
from Diata Lake » DataCataloging » AdventureWorks Data Lake » 5...

FromCurrencyCode
from Diata Lake » DataCataloging » AdventureWorks Data Lake » 5...

CountryRegionCode
from Diata Lake » DataCataloging » AdventureWorks Data Lake » 5...

StateProvinceCode
from Data Lake » DataCataloging » AdventureWorks Data Lake > P...

CountryRegionCode
from Data Lake » DataCataloging » AdventureWorks Data Lake » P...

UnitMeasureCode
from Data Lake » DataCataloging » AdventureWorks Data Lake » Pr...

CountryRegionCode
from Diata Lake » DataCataloging » AdventureWorks Data Lake » P...

O Cb CoO CoO CoO o o o CDo

1-100f49 £ SHOW MORE

Select theCurrency Codé&eld in the CountryRegionCurrency.csie.
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ﬁ Curre nC}"C'DdE (add business name) || | Field from CountryRegionCurrency.csv

Overview Related Reports Related Processes Data Flow Semantic Flow Comm:
Business Description Lal
add virlue Ho
Inferred Datatypes ° Col

S5TRIMG 100% add
Inferred Semantic Types 5 Sel

Currency Code 73% Cu

Airport Code 64% Al

Continent Code 11% Att

Country Code 1503 4% N3

First Mame 2% Bu

Ter
Frequency 1-100f15
Ty

EUR 11% Po

UsD 2% St

EID 1% Hic

MXN 1% e

VL 1%

EBED 1%

GTQ 1%

CLP 1%

ZAR 1%

THD 1%

Patterns 1
100%

Copyrigh

Data Profiling Statistics
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Sample data is presented for the fielthis data is obtained by sampling a subset of the recofds
in the source. Sdwmarvesting and samplinfpr more details.

ClickCountryRegionCurrency.c$w the breadcrumb area to the right of the name of the field:
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CountryRegionCurrency.csv (add business name) | | Delimited File
from Data Lake » DataCataloging » AdventureWorks Data Lake » Sales

Overview Fields Data Sample Relationships Related Reports Related Pro
Business Description Lal
add value Qu
Fields = Co

fl CountryRegionCode add
|l CurrencyCode
fl ModifiedDate At
. - Dy
Data Profiling Statistics
Nz
Row count 109
Bu
Te
Ty
La
Fil
De
Mt
5w
La

Data Sample 1-30f 10

CountryReg...  CurrencyCode  ModifiedDate

MU MUR 2008-03-11 .
PL PLM 2008-03-11
LU EUR 2002-06-01 .

This is the file containing tf@urrency Codéeld. ‘
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Then click thddataSampletab.

CountryRegionCurrency.csV (add business name) ||| | Delimited File

from Data Lake » DataCataloging » AdventureWorks Data Lake » Sales

Overview Fields Data Sample Relationships Related Reports Related Pro

Click a column header to display its properties  Columns

CountryReg .. | CurrencyCode = ModifiedDate
[ |Hide Data |[ ]| Hide Data | [ ] Hide Data

1]LU EUR 2002-06-01
2 | TH THB 2008-03-11
3 |GR EUR 2002-06-01
4 [T EUR 2002-06-01
5 CcA CAD 2008-03-11
6 | KE KES 2008-03-11
7 BD BDT 2008-03-11 ...
8 | DO DoP 2008-03-11
9 | KW KWD 2008-03-11
10 | MX MXM 2008-03-11

Tables in a database or fields in a file generally have a great deal of related information in tabs.
For example, we have:

o Fieldscontained within this table

o Sample Data

o Relationshipsncluding PK/FK, inferred and us#fined relationships with other tables.
Especially important when joining this table with others, such as in @&eelice Bl tool.

Reports
Go toWORKSHEE®J abkau > Dashboardsand selecFinance

There is a preview image of the dashboafgdgecified when importirjg ‘
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Explore Further

EditBusines®lame and Description

You may edit thusinessNameand Descriptiondirectly (with the proper permission) or
classify thanetadata elementvith a new or existing term in thBusiness Glossaryou may
also semantically map thmetadata elemento any other object with a description to reuse by

clicking theSemantic Flowtab.

This is a function of the larger featuresdsita cataloging and data documentation

Steps

Direct Edit

1. Go to thedetails pagdor the data element.

2. Clck(add business name)ext to the name of the data element and enter a new name.

3. Click theBusiness Descriptiotext box and enter text.

Example

Direct Edit

Entera | @3 ¢ Searghext BoSin the upper right.

o=

O avg

Search results

e
Loading...

Select theavgfield in theSatisfaction.jsorfile.

Copyright © 2020, Oracle and/or its affiliates. All Rights Reserved. (12.2.1.2020/10/29)

Pagel85| 764



ORACLE" Enteprise Metadata ManagementUser Guide

O avg X 0
Search results

avg
| ﬂ from Data Lake » DataCataloging * Customer Satisfaction Datalak ..

avg
from Data Lake » DataCataloging » Customer Satisfaction Datalak ..

1-2of2

Click(add businessiame):
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n avqg (add business name) [ | Field from Supportjson

Overview Related Reports Related Processes Data Flow Semantic Flow Comm

Business Description

add value
Inferred Datatypes 2
INTEGER I
Histogram
1 9
Patterns 2
? I £

Data Profiling Statistics Last profiled 9 Months Ago
Count 4
Distinct 3
Duplicate 1
Valid 3
Copyrigh
Empty 0

Invalid

-
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lyR SydGSNI a! @SNI IS / dzad2YSNI {FGAaTIOGAZ2ZY wl Ay

Attributes
Mame avg
Business Name Average Customer Satisfaction Rating
Term add value
Type DOUBLE
Position 7
Stewards 2 David (David)
Hide Data false
Last Modified Date () 9 Months Ago

Click theBusiness Descriptiod SE( 62E | yR Sy G4SN a¢KS | gSNIF 3§ 2°
NELR2NISR o6& GKAA Odzali2YSNEO®

Business Description

The average of all the satisfaction scores reported by this customer

Cugom Attributes
Custom Attributes may béefined and associated witliny type ofmetadata element Once
defined, you mayaddit to any example of that type of metadata elemenrithus, acustom
attributre may be applied or not applied to an object.

Set a Custom Attribute on an Object

Steps
1. If not already definedcreatea new custom attribute

2. Go to thedetails pagédor the data element.
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3. Go to theOverviewtab.

4. Click on theMore Actionsicon next toAttributes and selectAdd custom attributgs).
5. Select the custom attribute(s) to include.

6. Edit their valuesn place

Unlike labels and comments, custom attributes may only be assigned or edited witiopies
permissions on the contetitat contains the metadata element.

You may also edit custom attributes using tbatext menu when you see an element in a list|{or

doso in bulk

Example
Create theVerified custom attribute as in the example add a new custom attribute

Go to WORKSHEETS > Hiliebels and click Actitdag orthe details page Go to theOverview
tab.
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Copyrigh

n ActiveFlag (add business name) || | Field from Vendorcsv

Overview Related Reports

Business Description

odd vialue

Inferred Datatypes 1

INTEGER

Histogram

Patterns 1

Data Profiling Statistics
Count

Distinct

Duplicate

Valid

Empty

Invalid

Min

Max

EAo=am

Related Processes

Data Flow

Semantic Flow

1

n Qg

Last profiled @ Months Ago

Comm

Mz

Te

Tyl
Fo

5u

Hii
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Click on theMore Actionsicon next toAttributes and selectAdd custom attributgs).

Attributes
Name ActiveFldy Add custom attribute(s)
Business Ma... add value
Term add value
Type STRING
Position B
Stewards & David (David)
Hide Data false

Last Modifie... (2 9 Months Ago

SelectVerified.
Add Custom Attribute(s) 0 Filter text
Mame Value

[] | Business Domain

L] | Verified Verified

CHECK ALL UNCHECK ALL “ CANCEL

Edit theValuein place by selectingerified.
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Remove a Custom Attribute Setting on an Object
Steps
1. Go to thedetails pagdor the data element.
2. Go to theOverviewtab.
3. Click on theMore Actionsicon next toAttributes and selecRemovecustom attribute(s).
4. Select the custom attribute(s) to remove.

You may also remove custom attributes using the context menu when you see an elemeniin a
list or doso in bulk

Exanple
Using theVerified custom attribute on the Active Flag field as in the exampl®daha Custom
Attribute on an Object

Go to WORKSHEETS > File > Fields and click ActiveFladaiaith@age Go to theDverview
tab.
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Copyrigh

n ActiveFlag (add business name) || | Field from Vendorcsv

Overview Related Reports

Business Description

odd vialue

Inferred Datatypes 1

INTEGER

Histogram

Patterns 1

Data Profiling Statistics
Count

Distinct

Duplicate

Valid

Empty

Invalid

Min

Max

EAo=am

Related Processes

Data Flow

Semantic Flow

1

n Qg

Last profiled @ Months Ago

Comm

Mz

Te

Tyl
Fo

5u

Hii
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Click on theMore Actionsicon next toAttributes and selecRemovecustom attribute(s).

Attributes
) Add custom attribute(s)
Name ActiveF
Remove custom attribute(s)
Business M... add valie |
Term add value
Type STRING
Position &
Verfied Verified
Stewards = David
Hide Data false

Last Modifi... (2 3 Months ago

SelectVerified.

Select Custom Attributes £ Filter text

X

YWerfied

SELECTALL “ CANCEL

ClickOK.

Comments tab
Enter comments to thimetadata elementn the Commentgab. Everyone has permissions to
comment.

Steps
1. Go to the details page for an object.
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2. Go to the Commentstab.

3. From here you may

- Add a new comment: Click in the text box labefetll Commententer your text and

clickSUBMIT

- Edit an existing comment: Click on tkere actionsicon () for that comment and

selectEdit enter your text and clicBUBMIT

- Delete an existing comment:li€k on theMore actionsicon () for that comment and

selectDeleteand clickYES

Example
Search for SSN.

o=

£ ssn x
Search results
55N

from Data Lake » DataCataloging » AdventureWorks Data Lake » H...

=_| U5 Social Security number
=_| from Fimance > GDPR

1-2o0f2

Select the term name US Social Security Number.

You are presented with tf@verviewtab.

Go to the Commentstab.

Add a new comment
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Click in he text box labeledhdd CommentSy i SNJ a ¢ KS ' { a20Alf &SOdzNR i
always conforming to the proper format as defined in the Semantic Type for this term. Indeed,

YIye aedaidisSvya dzasS aLISOALFf 2N &dfcliclSBMIT { bad F2NJ &L

OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MANAGE

—-| US Social Security number | Term from Finance > GDPR

Owverview Relationships Related Reports Semantic Flow Comments Attachm

Show | All | Comments Endorsements ‘Warnings = Cerification

The US social security numbers are not always conforming to the proper format as defined in the Semantic T
special or ‘fake’ SSMs for special coding purposes.

Administrator iﬂ
Certified
Administrator (1]

US 55K contains certain numbers which are reserved and should not be considered valid.

Edit an existing comment

Click on thevlore actionsicon 1\5) forthe abovecomment and seleddit, | LILJISY R A G K a2 S
aK2dzZ R R20dzySyid dGKAa FI OG0 Ay GKS hdchickOKNE o6& O
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Edit comment b4

The US social security numbers are not always conforming to
the proper format as defined in the Semantic Type for this
term. Indeed, many systems use special or fake’ S5Ns for
special coding purposes. We should document this fact in the
glossary by creating enumerations for this term.

o

Delete an existingomment

Click on theMore actionsicon @) forthe abovecomment and seledDeleteand clickYES

Confirm x

II H.E; ]I Dealste Comment

Related Reports
You may askIMM to interrogate the data flow and semantic lineage to determivieat
business reports a particular metadatgementis used on. Simply click tiRelated Reportgab.
For more details on the process bere.

Steps
1. Go to the details page for an object.

2. Go to theRelated Reportsab.
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Example
{ SFENDK FT2NJ a! 0O02dzy i ! Y2dzyii¢ o
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OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MANAGE

— Account Amount Available | Term from Finance » Terminology

Overview Relationships Related Reports Semantic Flow Comments Attac
Definition Lal
Diollar amount remaining in fund account, calculated as: Account Balance Amount - Account Amount ol

Expended - Account Encumbered Amount

Documentation

add
add value

Relationships 2 + CREATE [4] At

More Specific  |=| Account Budget Amount |= GL Account = Unified_Dollar_Amount
Ty

Al

Al

LUz

Sh

La

At

Audit Log 2

Administrator | 4 Weeks Ago
Comment was added:

test

Administrator | 4 Weeks Ago
Added Synonym Link to Account Budget Amount
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Select he term names Account Amount Available.
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OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MANAGE

— Account Amount Available | Term from Finance » Terminology

Overview Relationships Related Reports Semantic Flow Comments Attac
Definition Lal
Diollar amount remaining in fund account, calculated as: Account Balance Amount - Account Amount ol

Expended - Account Encumbered Amount

Documentation

add
add value

Relationships 2 + CREATE [4] At

More Specific  |=| Account Budget Amount |= GL Account = Unified_Dollar_Amount
Ty

Al

Al

LUz

Sh

La

At

Audit Log 2

Administrator | 4 Weeks Ago
Comment was added:

test

Administrator | 4 Weeks Ago
Added Synonym Link to Account Budget Amount

Copyright © 2020, Oracle and/or its affiliates. All Rights Reserved. (12.2.2.2020/10/29) Page201| 764



ORACLE" Enteprise Metadata ManagementUser Guide

You are presented with tf@verviewtab. ‘

Go to the Related Reportsab.

OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MANAGE

— | Account Amount Available | Term from Finance » Terminology

Overview Relationships Related Reports Semantic Flow Comments Attac
1-40f4d 1 Columns
User Tags Name Object Type Context
@ Financel Tableau Workbook Tableau > Metadata Management
@ Finance2 Tableau Workbook Tableau » Metadata Management
@ Finance3 Tableau Workbook Tableau » Metadata Management

@ Met Vendor Customer Invoices | Web Intelligence Model | Bl Reportimg » Public Folders » MITI » Tutor

There are four reports (three Tableau workbooks and one SAP Business Objecdts web intelligence
report) which have fields that havlee same meaning ague classified or inferred in
classificatiof this term.

Data Flow
Click the Data Flow tab to report on the different types of data flow lineage traces that may be
initiated from this element.Data flav traces look at how data moves through the inter
connected(stitched) systems from which metadata has been harvesBuath impact (forward)
and lineage (backward) data flow traces may be performesbgctingthe Typeof trace in the
top right pultdown.

More details and examples are providedzdta and Semantic Flow

Steps
1. Go to the details page for an object.

2. Go to the Data Flowtab.
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Example
{ SFENDK FT2NJ a! 0O02dzy i ! Y2dzyii¢ o

OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MANAGE

Home

Search results

Welcome to Metadata Management | Metadata Explore

.E. Enterprise Architecture .’:-‘. Metadata Browsing

o Supported Tools

Worksheets

W Favorites 6

Certified by Stuart

Certified Terms

Mon-Certified Critical Attribute Terms
Mon-Certified Critical Terms
Mon-Certified Terms

What's new

Dashboards

# Favorites 1

My Dashboard
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Account Amou

from Finance >

Account Amow
from Tableau >

from Tableau >

Account Amow
from Tableau »

B
E Account AmoL
B

Finance Accou
from Enterprise

Account Amow

3 Data Catalog of Files * Repository Management Eﬁ; from Tableau 3

Account AmoL
from Tableau »

E‘,II

Account Amow
_.ﬁs from Tableau »

ai

i1 Account Amol

from Tableau »

it Account Amol
from Tableau »

1-10of 676
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Select thecolumn name Account Amount\vailable.

OBJECTS ~ COLLECTIONS  WORKSHEETS  DASHBOARDS  MANAGE
nﬁ Account Amount Available (add business name) [ | Column from Finance2 » Prime Account

Overview Dimensions Related Processes Data Flow Semantic Flow Commer

Business Desc I'ipti on =| Account Amount Available

Dollar amount remaining in fund account, calculated as: Account Balance Amount - Account Amount
Expended - Account Encumbered Amount

Dimensions 1 [4

4] Account Amount Available

You are presented with th@verviewtab.

Go to theData Flowtab.
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OBJECTS  COLLECTIONS  WORKSHEETS  DASHBEOARDS  MANAGE
i add business name) |G olumn from Finance? » Prime Account
nﬁ Account Amount Available | C i

Overview Dimensions 1 Related Processes Data Flow Semantic Flow Comr

® Qex @ X Pl B B g =

End Objects

Diagram

1B Adjustments.dby =

=|’|ﬂ] —
Transdrmt

g Table

| Genaral Ledger -
{2 staging DW.dba = |2 Dimensional DW._dba - ) Fin
«../Generalledger/ GLACCOUNL. sy - - - -
GLAccount - GLAccount - T
ﬂ Accountimountivailabla Accountdmountivailable At

GLA-ACCOUNT-AMT-AVAIL

Overview

—- Asgsets

+ £= staging DW.dbo

+ 2 Dimensional DW.dbo
+Er General Ledger

+ !3 Adjustments.dbo
+Eﬂg Tableau

—--:ﬁ? Processes

&p GLACcount ChTempyModels\MetadataManagementFinance\MicrosoftExcel\GeneralLedgerToStaging DV

fip GLACcount
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The display shows the Data Lineage or Data Impact by default depending on if this element is at
the target or source end of the lineage.

SelectData Impactin the theType

OBJECTS  COLLECTIONS  WORKSHEETS  DASHBOARDS  MANAGE
nﬁ Account Amount Available (add business name) |l§ | Column from Finance2 > Prime Account

Orverview Dimensions Related Processes Data Flow Semantic Flow Comi

® Q 100% @ B o] i

8

a]

o

=

5

: t= Tableau -
=

=

a .4 Finance2 -

== Prime Account —

H Account Amount Available

Overview
—- Assets
—Eﬂg Tableau
— Finance?
e s= Prime Account

.. He Account Amount Available

You may also zoom in/out, expand and collapse objéaghlightpaths,show data flow
transformation operations, show properties for selected objeets,, by using the functions in
the common trace controls.

You may also choose fwesent the lineage as a set of end objects by usindetiek Objectdab
on the left.
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OBJECTS  COLLECTIONS  WORKSHEETS  DASHBOARDS  MANAGE
nﬁ Account Amount Available (add business name) [|§ | Column from Finance2 > Prime Account

Orverview Dimensions Related Processes Data Flow Semantic Flow Comi

Expand all Collapse all

—,j General Ledger

..... [#] Cy/Temp/Models/MetadataManagement/Finance/FileSystem/GeneralLedger/GLACCOUNT.Csv
. =2 Adjustments.dbo

End Objects

Diagram

You may alsdownload L that report to CSV format.

Semantic Flow

Click the Semantic Flow tab to report on the different types of semantic lineage traces that may
be nitiated from this element. Semantic flow traces look at hoetadata elemeng relate to

each other semantically and reflect relationships of similar meaning,
generalizations/specification, design vs. implementations, terminology to fields, etc.uBagé
(downward anddefinition lookup(upward) semantictraces may be performed by selectitige
Typeof trace in the top right puitdown.

Steps
1. Go to the details page for an object.
2. Go to the Semanic Flowab.
Example

{ SFNDK F2NJ a! 002dzy i ! Y2dzy (i é @
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|

2 account amuund X o
Search results
= | Account Amount Availabls
=_| from Finance » Terminology
E Account Amount Available (GL Account_AccountAmountiyval...
from Tableau » Metadata Management » Finance? » Customer PO ..
E Account Amount Available (GL Account_AccountAmountiyval...
from Tableau » Metadata Management » Finance3 » Customer PO ..
E Account Amount Available (GL Account_AccountAmountAval...
from Tableau * Metadata Management » Financel » Customer PO ___.
= | Finance Account Amount
=_| from Enterprise » Enterprise Conceptual Model
i1 Account Amount Available
Jx from Tableau » Metadata Management » Finance3 » PO-Invoice
i1 Account Amount Available
E's from Tableau » Metadata Management » Finance3 » PO-Invoice
it Account Amount Available
.;}: from Tableau » Metadata Management » Financel » Inveice less th...
it Account Amount Available
from Tableau » Metadata Management * Finance2 » Prime Account
it Account Amount Available
from Tableau * Metadata Management » Financel » Met Vendor Cu...
1-10 of 694 £ sHOW MORE

Selet the colomn namedAccount Amount Availablenside the tableGLAccountn the
Dimensional DWlatabase.
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OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MAMNAGE
E AccountAmountAvailable (| Account Amount Available) [l§ | Column from Dimensional DW >

Overview Related Reports Related Processes Data Flow Semantic Flow Comm

Business Descriptinn =| Account Amount Available

Dollar amount remaining in fund account, calculated as: Account Balance Amount - Account Amount
Expended - Account Encumbered Amount

Data Sampling and Profiling

Data Profiling has never been run on this object. Request now
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You are presented with th@verviewtab.

Go to the Semanic Flowab.

E AccountAmountAvailable (=] Account Amount Available) [l | Column from Dimensional DW >

Overview Related Reports Related Processes Data Flow Semantic Flow Cor
- Business Desc I'ipti on =| Account Amount Available
2
Dollar amount remaining in fund account, calculated as: Account Balance Amount - Account Amount Expenc
E
i
o
= iap Classi
& + K
Type Semantic Definition
Classified =| Account Amount Available from Finance » Terminology
Description: Dollar amount remaining in fund account, calculated as: Account Balance Amount - Account
Inferred =| Account Amount Available from Finance » Terminology
Description: Dollar amount remaining in fund account, calculated as: Account Balance Amount - Account
Inferred =| PaidCustomerPOGLACCountView AccountAmountAvailable from Finance » Terminology
Inferred =| PaidPurchaseOrderGLACcountView AccountAmountAvailable from Finance » Terminology
Inferred nf;p AccountAmountAvailable from Finance Universe » Classes » GLACCount
Description: Dollar amount remaining in fund account, calculated as: Account Balance Amount - Account
Inferred E Account Amount Available frem Finance3 » Customer PO _Invoice ltem FACT _Finance_Dimension:
Description: Dollar amount remaining in fund account, calculated as: Account Balance Amount - Account
Inferred B Account Amount Available from Finance2 > Customer_PO_Invoice_ltem_FACT_Finance_Dimension:
Description: Dollar amount remaining in fund account, calculated as: Account Balance Amount - Account
Inferred E Account Amount Available from Financel » Customer PO Invoice_ltem_FACT _Finance_Dimension:

Description: Dollar amount remaining in fund account, calculated as: Account Balance Amount - Account

The display shows a report of the objects in the semanticliih@age.

Select theDiagramtab on the left.
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® Q eax @ H |l B ¢ =

12 Dimensional DW.dba

|8 Finance - ===F}
B i o
+__ ., +__ . | )
= =] ) ., PaidPurchassOrdarGLAzzonlY..
L
Diarmaing Teminalogy Y )
v
=]
l'a._' ________ q+
. Y
e el FeoR =| |l Stnging Do Y PaidCustomer POGLACTURE i
B + ===} n [===IF §
_________
CaiTermp/Modek=Metad atabian, GLACoount GLACcoun

You now have a graphical representation of the same.

You may also zoom in/out, expand and collapse objects, highlight paths, show data flow
transformation operations, show properties for selected objects,,diy using the functions in
the common trace controls.

You may also downloe,'&' that report to CSV format.

Historytab
Review the changes that have occurred to thistadata elemenin the Audit Logtab.
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Steps
3. Go to the details page for an object.
4. Go to he Semanic Flowab.
Example

{ SFNDK F2NJ a! 0O02dzy i ! Y2dzyii¢ o

0 account amount] X o
Search results
| .
= | Account Amount Available
=_| from Finance » Terminology
1 . - :
E Account Amount Available (GL Account_ AccountAmountaval..
from Tableau » Metadata Management » Finance? » Customer PO ..
E Account Amount Available (GL Account_AccountAmountiyval...
from Tableau » Metadata Management » Finance3 » Customer PO ..
|
E Account Amount Available (GL Account_AccountAmountiyval...
from Tableau » Metadata Management » Financel » Customer PO ___.
= | Finance Account Amount
=_| from Enterprise > Enterprise Conceptual Model
i1 Account Amount Available
Jx from Tableau » Metadata Management » Finance3 » PO-Invoice
i1 Account Amount Available
Jx from Tableau » Metadata Management » Finance3 » PO-Invoice
i1 Account Amount Available
E'; from Tableau » Metadata Management » Financel » Invoice less th...
it Account Amount Available
from Tableau » Metadata Management * Finance2 » Prime Account
it Account Amount Available
from Tableau » Metadata Management » Financel » Met Vendor Cu...
1-10 of 694 £ SHOW MORE

Select the colomn namefliccount Amount Availablenside the tableGLAccountn the
Dimensional DWilatabase.
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You are presented with th®verviewtab.

Go to theHistorytab.

The display shows a report of the objects histogyof changeswhich is empty

Click toadd a comment, enter the text and commit

Go to theHistorytab.

E AccountAmountAvailable (= Account Amount Available) [l | Column from Dimensional DW

Overview Related Reports Related Processes Data Flow Semantic Flow Comn

Business Desc riptiun =| Account Amount Available

Dollar amount remaining in fund account, calculated as: Account Balance Amount - Account Amount
Expended - Account Encumbered Amount

Data Sampling and Profiling

Data Profiling has never been run on this object. Request now

The display shows the update with the comment.

Reharvest the content (Dimensional DW).
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OBJECTS COLLECTIONS WORKSHEETS DASHBOARDS MAMNAGE c

Manage Configuration UPDATE AND BUILD : Dimensional DW
d | Microsoft SOL Server Database
+ % Bl Diagam 3 W l.-.l_ [ :}r&T Enterprise Architecture/Dai
= Accounts Payable )
Overview Import Setup
Accounts Payable erwin
= Accounts Receivable Description
= Adjustments
> Adjustments to 5taging R
ﬁAP to Staging
QAR to Staging
%] BI Reporting Stewards
Data Lake
- Mike x o
®> Data Lake to Staging
= Dimensional DW Labels
® Dimensional DW to Vendor Mart
IB encerprise add Labels(s) W
& Enterprise to Finance Glossary Dpﬂ ons

@ Finance .
a [] Propagate documentation

& Finance Glossary to Tableau

Return to the colomn namefccount Amount Availablénside the tableGLAccountn the
Dimensional DWiatabase and go to thHistorytab.
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E AccountAmountAvailable (| Account Amount Available) [l§ | Column from Dimensional DW >

Overview Related Reports Related Processes Data Flow Semantic Flow Comme
1-10fl 1
Date,/Time User Object Name @ EventType @ Description
I3 Months ago | & Administrator | AccountAm... Comment Comment was ad...
Hello
World.

The istory for the new content version is migrated from the oldeforers

You may alspage through the results in the usual manner, and ynay downloa(,'g' that
report to CSV format.

Note, audit log history

Customization of tabs using Worksheets
The details page has many tabs and among theselalétabs. Each child tab shows a group of
related types of child objects. For example, a databeeddledetails page has th€olumnstab
that shows regular and PK column objects.

A child tab shows its dld objects using a worksheet. A worksheet allows you to change its filter
conditions and columns. The child tab lets you to save and recall the worksheet configuration
used.

MIMM supports system, personal and applicable worksheet views.

As®ciate a Worksheet with the tab on a Details Page
You may designate existing worksheets to be used for specific tabs in specific details pages by
object type.

Steps
1. Save a worksheetr use an existing one that youleér created or ishared with you It

must be filtered to the specific object type that you want to assign it to as the default.

2. Go to the details pagef an object that would have a tab that matches the object type of

the worksheet.

3. Go to the tab for that object type.
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4. Pick the worksheet from th@/orksheetpull-down list.

Example
Go toWORKSHEETS > File > Fieldseate a worksheet for thEieldstab in File Systeniiles.
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O Fields

Filters ADVANCED < 1-50 of 561 1 > > Fiters Columns

Q) SEARCH TEXT E WHERE category="File.Fields' ORDER BY Mame ASC

CATEGORY User Tags Name Object Type  Context

File » Flelas = - A _ia Field Data Lake > D:

] + FILTER ﬁ _id Field Data Lake » D
A a Field Data Lake > D
A a Field Data Lake > D
ﬁ AccountNumber Field Data Lake > Di
ﬁ AccountMumber Field Data Lake » D
ﬁ AccountNumber Field Data Lake > D
ﬁ AccountMumber Field Data Lake » D
0 ActiveFlag Field Data Lake > D:
A ActualCost Field Data Lake > D
A Actualcost Field Data Lake > D
| ActualCost Field Data Lake > D
ﬁ ActualEndDate Field Data Lake > Di
ﬁ ActuzlResourceHrs Field Data Lake » D
] ActualstartDate Field Data Lake > D
fl AdditionalContactinfo | Field Data Lake > D
ﬁ AddressID Field Data Lake » D
| AddressiD Field Data Lake > D
ﬁ AddressLinel Field Data Lake » D
ﬁ AddressLinel Field Data Lake » D
| AddressLine2 Field Data Lake > D
ﬁ AddressLine2 Field Data Lake » D

ClickColumnsand add Labels to the displayed columns
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| DISPLAY MODE SORT ORDER
| | BBE Grid | = List Ascending | Descending Relevance
i
| COLUMMNS
Available columns P Filter tex :] Selected columns
T - Uzer Tags
3 | Business Description
Mame
, Business Description Inferred
1 Object Type
Business Description Inferred Origin
2 Context
Term
| Labels
7 | Semantic Types
1 | Hide Data
Stewards
| collections
* | Statistics

2 | Histogram

Certified -

Save the workshedt & G CASf Ra ¢AGK [l 0Sfaéod

. Save as new Worksheet x
Mama: Fields with Labelg]
Description:

Now, search foCustomer.cswand click to god its details page. Go to tteldstab.

SelectFields with Labelérom the list ofApplicableworksheets.
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An the result is the worksheets is used for tieldstab.

This will now the default presentation. You may always restore the original by Befacttl
from theWorksheetspull-down.
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