Tips for Polishing Your Intelligent Advisor Policy Model

Oracle Intelligent Advisor
(formerly known as Oracle Policy Automation)

Jasmine Lee
Oracle Intelligent Advisor Specialist
Last updated: May 2020
Introduction

• **Audience** – People who work with Intelligent Advisor policy models. It is assumed the reader has already had training and is familiar with using OPM.

• **Purpose** – Provide ideas and suggestions for polishing your policy models, and direct you to relevant articles in the Intelligent Advisor Documentation.

• **Software version** – Deck prepared for Oracle Policy Modeling (20B).

• **Acronyms**
  – OPM – Oracle Policy Modeling

*Tip: Latest version of the Intelligent Advisor Documentation Library can be found online and via the question mark button in OPM*

*Intelligent Advisor previously called Policy Automation (OPA)*
Example Projects

- OPM includes Example Policy Models that demonstrate features discussed in this deck.

Filter examples by Industry and Feature.

Example projects available from the Project tab.

Example projects available from the Project tab.
Tips for Polishing Your Policy Model

• **Screen Configuration**
  – Labels on Interview Screens
  – Interview Stages
  – Navigation Strip
  – Containers
  – Entity Collect Screen
  – Adding Images to Interview Screens

• **User Input**
  – Default Values
  – Value Lists
  – Hint Text
  – Validating User Input – Event rules
  – Validating User Input – Data tab
  – Input Masks

• **Enhancing Interviews**
  – Look and Feel of Interviews
  – Document Generation using BI Publisher
  – Capture the User’s Location
  – Configuring Attribute Value Formats
  – Configuring Standard Message Strings

• **Substitution and Sentence Generation**
  – Name Substitution
  – Gender Pronoun Substitution
  – Second Person Sentence Generation
  – Substituting Names in Labels

• **Language Support**
  – Adding a Verb to the Default Verb List
  – Adding a Translation Layer
  – Writing Rules in Other Languages

• **Improving the Explanation**
  – Intermediate Attributes
  – Rule Tags
  – Trimming Explanations – Attributes
  – Trimming Explanations – Relationships
Screen Configuration
Labels on Interview Screens

• Labels can:
  – be added to provide context and additional info
  – be used as additional headings and subheadings
  – include raw text, as well as HTML
  – have conditional visibility
  – contain substitution

Example labels

Permit Types

Click 'Add Permit' to add further permits. Click the 'X' to delete a permit.

Please add all permits for which you are applying: building, electrical, fire suppression, gas, HVAC, mechanical, piping, plumbing.

Permit type

< please select >

Add Permit
Interview Stages

• Group related interview screens together in a folder
• Folder becomes a stage in the interview
Navigation Strip

- Left menu
- Ribbon
- Thermometer
- Train stops

- Configure the navigation strip
- Navigation strip may be displayed at the top or left of the page
- Many configuration options available, e.g. text color, text size, background color
Containers

• Containers may be used to lay out screen controls side-by-side
• Containers allow for responsive design in interviews, e.g. two columns which collapse to a single column in a small browser
• Labels and images may also be put in containers

Screen controls laid out in **two columns**. Efficient use of space on a larger screen.

Screen controls automatically collapse to **one column** in a narrow browser window. More readable on a small screen.

Documentation Library

• Change control layout for a screen
• Example project: myBenefits
Entity Collect Screen

- Entity collection layout can be ‘portrait’ or ‘tabular’ style
- Tabular will usually make more efficient use of screen space
- Containers can also be used inside the entity collect space to control layout

Documentation Library

- Collect entity instances
- Example project: myBenefits

Entity collect screen with tabular layout
Adding Images to Interview Screens

• Add images to interview screens as useful visual aids
• Many configuration options available for images, e.g. horizontal alignment (left, center, right), image size, conditional visibility, clickable link
• Images may be placed in containers for further layout control
• Use text substitution to insert different images depending on the value of a substituted attribute

Documentation Library

• Add images to screens
• Refer to images using HTML tags
• Place other controls within a container
• Example project: Energy Saver
Enhancing Interviews
Look and Feel of Interviews

• Many aspects of the interview look and feel can be set in the Styles section of the Interview tab, e.g. color scheme, banner graphic, heading styles, button location, footer and header.
Document Generation using BI Publisher

• Generate documents from interviews, e.g. letters, forms, etc. OPM supports creation of RTF, PDF, HTML, XML & Excel forms
• Forms may include text, images, charts, explanations, signatures
• Note: Requires installation of BI Publisher Desktop. This is a separate product. It is not part of Oracle Policy Modeling.

Healthy Eating Summary

Dear Jane,

Thank you for participating in the online child health assessment. Establishing healthy eating habits at an early age can provide your children with a lifetime of benefits.

Assessment

<table>
<thead>
<tr>
<th>Grains</th>
<th>Fruit</th>
<th>Dairy</th>
<th>Meat</th>
<th>Sweets</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Too Low) A</td>
<td>(Too Low) A</td>
<td>(Too Low) A</td>
<td>(Too Low) A</td>
<td>(Too High) A</td>
</tr>
<tr>
<td>Actual: 2</td>
<td>Actual: 1</td>
<td>Actual: 1</td>
<td>Actual: 1</td>
<td>Actual: 0</td>
</tr>
<tr>
<td>Recommended: 3</td>
<td>Recommended: 4</td>
<td>Recommended: 3</td>
<td>Recommended: 3</td>
<td>Recommended: 1</td>
</tr>
</tbody>
</table>

Download BI Publisher

Troubleshooting guide for forms

Example: Healthy Eating
Capture the User’s Location

- User’s location (latitude and longitude) may be captured during the interview using standard browser location support.
- Latitude and longitude may be used in rules, e.g.

**Documentation Library**

- Capture the user’s location
- Example projects: *My Store App*, *Emergency Response*
Configuring Attribute Value Formats

• Default attribute value formats are based on the project region (for non-Boolean attributes) and the project language (for Boolean attributes)

• E.g. If project language = ‘English (American)’ and region = ‘United States (English)’ then:
  – Default currency symbol: $
  – Default date out format: MM/dd/yyyy
  – Default Boolean values: Yes/No

• Default attribute value formats can be modified in: *Project > Language > Formatting*

• Generally will not need to edit default formats, but configuration options are there if needed
Configuring Standard Message Strings

• Default message strings and labels (e.g. standard error text, alt-text, button labels, etc.) can be modified in Interview > Styles > Strings

• Generally will not need to edit default message strings, but configuration options are there if needed

• Note: Button labels (e.g. Next, Back, Submit, Add New Instance, Remove) can also be modified on a per-button basis

• To change all occurrences of a message string → modify the default string, e.g. to use ‘Continue’ instead of ‘Next’ as the standard label on a Next button

• To change one occurrence of a button label → make the change on the individual screen
User Input
Default Values

• Can set default values for inputs on interview screens
  – Defaults can be specific values, or can be dynamically determined based on previously collected data, or inferred from rules
• Reduces the typing/clicking required to complete an interview

All currency values have been defaulted to $0. User only needs to edit the fields for which they have income. Reduces manual data entry.
Value Lists

• A **value list** is a way of managing lists of values for attributes
• A single value list can be attached to multiple attributes, e.g. the person’s home address, the person’s work address
• Value lists can be created manually, imported from another OPM project, or loaded in from a Service Cloud connection or web service connection.
• Value lists can be displayed as lists, radio buttons, text buttons, images, sliders
Hint Text

• Can supply **hint text** for inputs on interview screens
  – Hint text appears until the user clicks into the input field

• **Tip:** Always add hint text when the format of the input is important, for example:
  – Date fields
  – Any sort of ID number like SSN, TFN, NINO, PHN
Validating User Input – Event Rules

• **Error event** and **Warning event** rules may be used where there is conditional logic associated with the validation, e.g.
  – Display the message “Please check the dates of birth. You have indicated that your date of birth is after your child’s date of birth.” if the applicant’s date of birth > the child’s date of birth

• **Error event:** Error message is displayed and the user is prevented from continuing until the situation that triggered the event is no longer present.

• **Warning event:** Warning message is displayed, but the user is able to click past and continue the interview.
Validating User Input – Data Tab

• Validation with **regular expressions** and **min/max** can be done on the attribute in the Data tab
  – Error text may be configured on a per attribute basis

• Use **min/max values** if there is no conditional logic for triggering the error, e.g.
  – ‘the person’s age’ field could have a minimum allowable value of 0 and a maximum of 120

• Use **regular expressions** to validate the format of an input such as an email address, an SSN, a TFN, a NINO or a PHN, e.g.
  – ^[0-9]{3}-?[0-9]{2}-?[0-9]{4}$ is a basic SSN validation – allows for NNN-NN-NNNN and NNNNNNNNNN
Input Masks

• Masked input text boxes may be used to **auto-format data** entered into text fields, e.g. phone numbers, social security numbers, product codes, etc.

• Input masks can effectively act as a type of validation since the input field won’t allow the user to type offending characters, e.g. an input mask containing only numbers will not allow letters to be entered.

• Masked input text boxes can only be used with text attributes.
Substitution and Sentence Generation
Name Substitution

• Personalizes the interview for a more user-friendly experience

• Collect the person’s name early in the interview, then substitute the name in later questions, e.g. “Does the person have insurance?” becomes “Does John have insurance?”

• Particularly important when using entities, e.g. “Is the child a full-time student?” becomes “Is Emma a full-time student?”, “Is Joshua a full-time student?”, etc.

• Substituted name automatically appears in attribute text on interview screens and in explanations

• If first and last name collected separately, use concatenation to combine if full name needed for substitution in attributes

Documentation Library

• Personalize attribute text
  • Enable substitution in Policy Modeling
  • Understand text substitution principles

• Combine multiple text strings into a single text attribute
Gender Pronoun Substitution

• May be used in combination, or in isolation, with name substitution to personalize the interview for a more user-friendly experience, and to provide more natural language text
• Gender pronoun substitution requires collecting gender

Original rule generically refers to “the applicant”

In combination with name substitution, “Has the applicant submitted the applicant’s tax return?” becomes “Has Christopher submitted his tax return?”

Documentation Library

• Personalize attribute text
  • Enable substitution in Policy Modeling
  • Substitute a pronoun for a text attribute
• Understand text substitution principles
  • Collect the gender of a person
Second Person Sentence Generation

• Similar concept to name substitution, but sentences/questions generated in second person rather than third person
• Requires name substitution to be set up first
• Works with gender pronoun substitution if it has been set up

Example:

**Tax Return**

Have you submitted your tax return?

- Yes
- No

**Example:** Instead of “Has the applicant submitted the applicant’s tax return?” it displays “Have you submitted your tax return?”

**Insurance**

Do you have health insurance?

- Yes
- No

**Example:** Instead of “Does the applicant have health insurance?” it displays “Do you have health insurance?”

Documentation Library

• Display interview text in second person form
• Also see the articles for Name Substitution
Substituting Names in Labels

- Variable values (e.g. person’s name, age, etc.) can be substituted into labels on interview screens
- Requires name substitution to be set up first

Tip: For substitution in labels, make sure the substitution values will always be known in advance of the screen being displayed, otherwise “unknown” will appear in place of the substitution value

Example: The person’s name and age were collected on a previous screen, and those values have been substituted into label text on the School screen
Language Support
Adding a Verb to the Default Verb List

- Default verb list for the policy model is based on the Rule Language selected when creating the project.
- Occasionally you may need a new verb.
- If a Boolean won’t parse properly, it’s a sign the statement’s operative verb may not be in the verb list.
- Options are to re-word the attribute to use a different operative verb, or add the new verb to the list for the project.

This statement won’t parse as intended as the operative verb (love) is not in the default verb list.
Adding a Translation Layer

• Create one or more translation layers, e.g. policy model in English, interview in choice of English, Spanish or French
• Even a partial translation layer is sufficient to demo the concept. Google Translate can be used for basic demos. Use a (human) translation expert for real implementations
• Generated forms can also be created in different languages
Writing Rules in Other Languages

• Many languages available out-of-the-box for rule authoring
  – For additional languages, create a custom language parser
• Function Reference is available in out-of-the-box languages
• When creating a new project, select the desired Rule Language and Rule Region
• Rule Language:
  – Language in which rule documents are written
• Rule Region:
  – Affects currency, numeric and date formatting of data entered and displayed
  – Affects parsing of currency and number constants in rule docs

Documentation Library

• Write rules in other languages
• Change the user interface language for Policy Modeling
• Change the language of the Intelligent Advisor Hub
• Custom language support
• Function references in different languages
Improving the Explanation
Intermediate Attributes

• Intermediate attributes can be added to make the Explanation more meaningful
  - These two examples have identical core logic, but Example 2 has a more meaningful Explanation due to the inclusion of intermediate attributes
Rule Tags

• Structural elements in legislation (e.g. section, paragraph, article) and policy (e.g. chapter, guideline) can be captured in rules and displayed in explanations in an interview.

* Rule Tags previously called Structural Elements. Explanations previously called Decision Reports.*
Trimming Explanations – Attributes

• Explanations automatically generated based on the logic, language and structure of the rules can be extremely verbose

• Can trim Explanations using **Silent** and **Invisible** settings on the attribute in the Data tab
  – **Silent**: Hide all logic nested below a particular attribute
  – **Invisible**: Hide the attribute only

*Explanations previously called Decision Reports*
Trimming Explanations – Relationships

- **Silent** and **Invisible** can be applied to relationships
  - See examples below with a containment relationship (the household members) and an inferred relationship (the children)

*Explanations previously called Decision Reports*
Documentation and Further Information
Further Information

**Intelligent Advisor** on the Oracle Technology Network

– [Documentation Library](#)
– Best Practice Documentation
– Tutorials, whitepapers, datasheets

**Ask questions** on the [Intelligent Advisor Forum](#)

Follow on [Twitter](#) or the [Intelligent Advisor Blog](#)
Integrated Cloud
Applications & Platform Services