Oracle® Rdb Developer Tools for Visual Studio
Developer's Guide
V7.3
March 2010

Oracle Rdb Developer Tools for Visual Studio Developer’s Guide, Release 7.3 Copyright ©
2010 Oracle Corporation. All rights reserved.
The Programs (which include both the software and documentation) contain proprietary information of Oracle
Corporation; they are provided under a license agreement containing restrictions on use and disclosure and are
also protected by copyright, patent, and other intellectual and industrial property laws. Reverse engineering,
disassembly, or decompilation of the Programs is prohibited.
The information contained in this document is subject to change without notice. If you find any problems in the
documentation, please report them to us in writing. Oracle Corporation does not warrant that this document is
error free. Except as may be expressly permitted in your license agreement for these Programs, no part of these
Programs may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any
purpose, without the express written permission of Oracle Corporation.
If the Programs are delivered to the U.S. Government or anyone licensing or using the Programs on behalf of the
U.S. Government, the following notice is applicable:
U.S. GOVERNMENT RIGHTS Programs, software, databases, and related documentation and technical data
delivered to U.S. Government customers are "commercial technical data" pursuant to the applicable Federal
Acquisition Regulation and agency-specific supplemental regulations. As such, use, duplication, disclosure,
modification, and adaptation of the Programs, including documentation and technical data, shall be subject to the
licensing restrictions set forth in the applicable Oracle license agreement, and, to the extent applicable, the
additional rights set forth in FAR 52.227-19, Commercial Computer Software - Restricted Rights (June, 1987).
Oracle Corporation, 500 Oracle Parkway, Redwood City, CA 94065.
The Programs are not intended for use in any nuclear, aviation, mass transit, medical, or other inherently
dangerous applications. It shall be the licensee's responsibility to take all appropriate fail-safe, back up,
redundancy and other measures to ensure the safe use of such applications if the Programs are used for such
purposes, and Oracle Corporation disclaims liability for any damages caused by such use of the Programs.
Oracle is a registered trademark, and Oracle Rdb, Oracle RMU and Oracle SQL/Services are trademark or
registered trademarks of Oracle Corporation.
All other company or product names mentioned are used for identification purposes only and may be trademarks
of their respective owners.
The Programs may provide links to Web sites and access to content, products, and services from third parties.
Oracle is not responsible for the availability of, or any content provided on, third-party Web sites. You bear all
risks associated with the use of such content. If you choose to purchase any products or services from a third
party, the relationship is directly between you and the third party. Oracle is not responsible for: (a) the quality of
third-party products or services; or (b) fulfilling any of the terms of the agreement with the third party, including
delivery of products or services and warranty obligations related to purchased products or services. Oracle is not
responsible for any loss or damage of any sort that you may incur from dealing with any third party.

Contents
Preface
Chapter 1
Introducing Oracle Rdb Developer Tools for Visual Studio.
Chapter 2

Installing Oracle Rdb .NET Products

Chapter 3

Using Oracle Rdb Developer Tools for Visual Studio

3.1 Using Oracle Rdb Developer Tools
3.2 Connecting to the Oracle Rdb Database
Chapter 4

Building a Simple .NET Application Using ORDP.NET

4.1 Creating a New Project
4.2 Adding a Reference
4.3 Adding Namespace Directives
4.4 Designing the User Interface
4.5 Writing the Connection Code

Now we write the code that takes the information provided to the user interface and
connects to the database.
4.6 Compiling and Running the Application
4.7 Error Handling

4.7.1 Using Try-Catch-Finally Block Structure
4.7.2 Handling General Errors

Chapter 5

Retrieving and Updating with ORDP.NET

5.1 Using the Command Object
5.2 Retrieving Data: a Simple Query
5.3 Retrieving Data: Bind Variables
5.4 Retrieving Data: Multiple Values
5.5 Using the DataSet Class with Oracle Rdb Data Provider for .NET
5.6 Enabling Updates to the Database
Chapter 6

ORDP.NET and Visual Studio Wizards

6.1 Create a New application

2

6.2 Add connection to RDB database in MS server explorer
6.3 Create a datasource for the employees table
6.4 Design the windows application
Chapter 7

ORDP.NET and drag and drop

7.1 Create a New application

7.2 Add connection to RDB database in MS server explorer
7.3 Add a new Typed DataSet
7.4 Designing the windows application
7.5 Running the windows application
Chapter 8

Configuration wizard and generating queries

8.1 Using the Query Configuration Wizard
8.2 Using the Query Builder
8.3 Methods Generation
Chapter 9

Copying a Form

Chapter 10

Unsupported features

Glossary

3

Send Us Your Comments
Oracle Rdb Developer Tools for Visual Studio Developer’s Guide, V7.3
Oracle Corporation welcomes your comments and suggestions on the quality and usefulness of this
publication. Your input is an important part of the information used for revision.
•
•
•
•
•

Did you find any errors?
Is the information clearly presented?
Do you need more information? If so, where?
Are the examples correct? Do you need more examples?
What features did you like most about this manual?

If you find any errors or have any other suggestions for improvement, please indicate the title and part
number of the documentation and the chapter, section, and page number (if available). You can send
comments to us in the following ways:
• Electronic mail: nedc-doc_us@oracle.com
• FAX — 603-897-3825 Attn: Oracle Rdb
• Postal service:
Oracle Corporation
Oracle Rdb Documentation
One Oracle Drive
Nashua, NH 03062-2804
USA
If you would like a reply, please give your name, address, telephone number, and electronic mail
address (optional).
If you have problems with the software, please contact your local Oracle Support Services.

Preface
This document is your primary source of introductory and usage information for Oracle Rdb
Developer Tools for Visual Studio.
This preface contains these topics:
•
Audience
•
Organization
•
Related Documentation
•
Conventions

Audience
Oracle Rdb Developer Tools for Visual Studio Developer’s Guide is intended for developers who are
developing applications to access an Oracle Rdb database using Oracle Rdb Data Provider for .NET.
This documentation is also valuable to systems analysts, project managers, and others interested in the
development of database applications.
To use this document, you must be familiar with Microsoft .NET Framework classes and ADO.NET
and have a working knowledge of application programming using Microsoft C#, Visual Basic, or C++.
Users should also be familiar with the use of Structured Query Language (SQL) to access information
in relational database systems.
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Organization
This document contains:
•
Chapter 1, Introducing Oracle Rdb Developer Tools for Visual Studio.
Provides an overview of Oracle Rdb Developer Tools for Visual Studio.
•
Chapter 2, Installing Oracle Rdb .NET Products
Describes how to install Oracle Rdb Data Provider for .NET and provides system
requirements. Read this chapter before installing or using Oracle Rdb Developer Tools for
Visual Studio.
•
Chapter 3, Using Oracle Rdb Developer Tools for Visual Studio
Describes how to create a database connection using ORDP.NET within Visual Studio.
•
Chapter 4, Building a Simple .NET Application Using ORDP.NET
Provides an example on how you may build a simple application with database access using
ORDP.NET.
•
Chapter 5, Retrieving and Updating with ORDP.NET
Provides an example of data retrieval and update using the features of Visual Studio and data
access using ORDP.NET.
•
Chapter 6, ORDP.NET and Visual Studio Wizards
Provides an example on using standard Visual Studio wizards to automatically generate the
code to access data from your Rdb database.
•
Chapter 7, ORDP.NET and drag and drop
Provides an example of using the drag and drop features of Visual Studio to generate code for
your application.
•
Chapter 8, Configuration wizard and generating queries
Provides an example of using Table Adapter Query Configuration Wizard to generate queries
on your database.
•
Chapter 9, Copying a Form
Describes how to copy a form as required when following the examples provided in this
document.
•
Chapter 10. Unsupported features
Specifies what Visual Studio features are currently not supported by ORDT.
•
Glossary
Defines terms used in this document.

Related Documentation
For more information, see these Oracle Rdb resources:
•
Oracle Rdb7 Guide to Database Design and Definition
•
Oracle Rdb7 Guide to Database Performance and Tuning
•
Oracle Rdb Introduction to SQL
•
Oracle Rdb 7.2 SQL Reference Manual
•
Oracle Rdb Guide to SQL Programming
•
Oracle SQL/Services Server Configuration Guide
•
Guide to Using the Oracle Rdb7 Oracle SQL/Services (tm) Client API
•
Oracle Rdb JDBC Driver Users Guide
To download free release notes, installation documentation, white papers, or other collateral, please
visit the Oracle Rdb web site:
http://www.oracle.com/rdb
For additional information, see:
http://msdn.microsoft.com/netframework
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Conventions
Oracle Rdb Data Provider for .NET is often referred to as ORDP.NET.
Oracle Rdb is often referred to as Rdb.
Hewlett-Packard Company is often referred to as HP.
The following conventions are used in this document:
word A lowercase word in a format example indicates a syntax element that you supply.
[]

Brackets enclose optional clauses from which you can choose one or none.

{}

Braces enclose clauses from which you must choose one alternative.

...

A horizontal ellipsis means you can repeat the previous item

.
.
.

A vertical ellipsis in an example means that information not directly related to the example has been
omitted.

Conventions in Code Examples
Code examples illustrate SQL or other command-line statements. They are displayed in a monospace
(fixed-width) font and separated from normal text as shown in this example:
SELECT last_name FROM employees WHERE last_name = 'TOLIVER';
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Chapter 1
Introducing Oracle Rdb Developer Tools for
Visual Studio.
Oracle Rdb Developer Tools for Visual Studio (ORDT) is a set of application
tools that integrate with the Visual Studio environment. These tools provide
graphical user interface access to Oracle Rdb functionality, enable the user to
perform a wide range of application development tasks, and improve
development productivity and ease of use.
ORDT includes:
•

Oracle Rdb Data Provider for .NET ( ORDP.NET).
A standard .NET Data Provider that allows access to Oracle Rdb databases
from the .NET environment

•

Oracle Rdb DDEX Provider.
A standard .NET DDEX provider that integrates ORDP.NET functionality
into Visual Studio.

Chapter 2 Installing Oracle Rdb .NET
Products
See the Oracle Rdb Developer Tools for Visual Studio Release Notes for information on how
to install Oracle Rdb .NET products.

Chapter 3 Using Oracle Rdb Developer
Tools for Visual Studio
This chapter contains:
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•
•

Using Oracle Developer Tools
Connecting to the Oracle Database

3.1 Using Oracle Rdb Developer Tools
Oracle Rdb Developer Tools for Visual Studio (ORDT) is a tightly integrated
Add-in for Visual Studio. Using enhancements that ORDT brings to the Server
Explorer, you can automatically create tables, indexes, constraints, data
connections and other database schema objects. Additionally you can
automatically generate application code.

3.2 Connecting to the Oracle Rdb Database
This section shows you how to use the Server Explorer to connect to the
Oracle Rdb Database for the purpose of automatically creating or modifying
database schema objects.
To connect to the database:
1. From the View menu, select Server Explorer.
2. In Server Explorer, right-click Data Connections.
3. Select Add Connection.

4. When the Add Connection window appears, determine if the Data source
says Oracle Rdb Database (RdbClient).
If it does, skip to Step 6.
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If Data source does not say Oracle Rdb Database (RdbClient), select Change.
The Change Data Source window appears.

5. Choose Oracle Rdb Database and then select .NET Framework Data Provider
For Oracle Rdb.
6. On the Connection Details tab, in the Add Connection window, enter the
following information:
To connect to a database using a SQL/Services universal service:
For Server, enter the node address and a valid SQL/Services service that will
be running on the selected node. Remember to seperate the node address
and service name with a colon (:). In this example we assume that a
universal service called GENERIC is running on the selected node.
The node address must be valid TCP/IP node specification.
For User name, enter a valid username for the database you will select.
For Password, enter the password for that user
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To save the password for future sessions, check the Save password box.
For Database name, Enter a valid database file specification. Depending on
the setup of SQL/Services on the server node, this database specification may
include device and directory information as well as the database filename and
may use OpenVMS logical names.
The Connection name should be generated automatically from the
Database name.

To connect to a database using a SQL/Services database service:
For Server, enter the node address and a valid SQL/Services database service
that will be running on the selected node. Remember to seperate the node
address and service name with a colon (:).
In this example we assume that a database service called MF_PERS is
running on the selected node.
The node address must be valid TCP/IP node specification.
For User name, enter a valid username for the database you will select.
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For Password, enter the password for that user
To save the password for future sessions, check the Save password box.
Leave the Database name blank as this is not required when a database
service is used.
The Connection name should be generated automatically from the Database
name.

7. Click Test connection.

The test should succeed. Click OK.
If the test fails, it may be due to one or more of the following issues that you
must address before proceeding with further steps:
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o
o
o
o

The
The
The
You

database is not started.
database listener is not started.
database connectivity is not properly configured.
do not have the correct user name, password, or role.

8. In the Add Connection window, click OK.
9. In the Server Explorer, expand the database connection to show the contents
of the database . You should see Tables, Views, Procedures, Functions,
Packages, Synonyms, Sequences, and so on.
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Chapter 4 Building a Simple .NET
Application Using ORDP.NET
This chapter contains:
•
•
•
•
•
•
•

Creating a New Project
Adding a Reference
Adding Namespace Directives
Designing the User Interface
Writing the Connection Code
Compiling and Running the Application
Error Handling

4.1 Creating a New Project
Visual Studio groups all development code that you create into containers
known as projects. Simpler projects often contain only one file. In this section,
you will learn how to create a new development project.
The application you build in this chapter serves as a starting point for work in
subsequent chapters, so it is important to follow the order of this guide.
Note:

When necessary, instructions specify Visual C# or Visual Basic.
To start a new project:
1. Start Visual Studio.
Open the Start menu, select All Programs, and then select Microsoft Visual Studio
2005.
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The Microsoft Visual Studio IDE environment appears.
2. In the Start Page, under the Recent Projects heading, click Create: Project.
Alternatively, from the File menu, select New, and then select Project.
A New Project dialog box appears.
3. In Project Types, select the type of project you are creating:
Visual C#:
Visual C#: Windows
Visual Basic:
Other Languages: Visual Basic: Windows
4. In Templates, select Windows Forms Application.
5. In the Name field, enter the appropriate name.
Visual C#:
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PERS_Connect_CS
Visual Basic:
PERS_Connect_VB
The abbreviation CS indicates C# projects and VB indicates Visual Basic
projects.
6. In Location, enter the directory where you want to save the files.
For this guide, enter this directory C:\PERS_Projects.
7. In Solution Name, the appropriate name, PERS_Connect_CS or
PERS_Connect_VB should appear.
A solution can contain several projects; when it contains only one project, you
can use the same name for both.
8. Check Create directory for solution.
9. Click OK.

The project is created.
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The main window now displays a new title, either PERS_Connect_CS Microsoft Visual Studio or PERS_Connect_CS - Microsoft Visual
Studio, depending on the language, and contains Form1 shown below.
It is important to remember that many projects automatically name the first
form Form1. This is the name of the form control. Do not confuse this with
the actual name given to the code file, which is typically Form1.cs or
Form1.vb.
Both Form1 and Form1.xx can be renamed. For the purposes of this guide,
we will rename Form1.xx several times.

4.2 Adding a Reference
This section shows you how to add a reference to the
Oracle.DataAccess.Rdb.dll file, which contains the data provider,
Oracle Rdb Data Provider for .NET.
To add a reference:
1. From the Project menu, select Add Reference.
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The Add Reference windows appears.
2. In the Add Reference window, under the .NET tab, select
Oracle.DataAccess.Rdb Click OK.

Note that the new reference appears in the Solution Explorer.
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4.3 Adding Namespace Directives
You can add Oracle namespace directives that allow you to indicate an
assembly's namespaces within the module. To do this, add C# using
statements or Visual Basic Imports statements, at or near the top of a code
file.
Note:

Adding a reference makes the namespace available within the
application. Adding a namespace directive within the application code
makes the namespace more visible and allows for additional scoping.
To add Oracle Rdb namespace directives:
1. With Form1 active, from the View menu select Code.
Alternatively, you can use the F7 keyboard shortcut.
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2. Add the following statements to the list of declarations depending on the
language you are using.
Visual C#:
Add with other using statements, before the namespace.
using Oracle.DataAccess.RdbClient;

Visual Basic:
Add to the top of the file, in the declarations section.
Imports Oracle.DataAccess.RdbClient

3. Save the changes by selecting Save from the File menu, or using the Ctrl+S
keyboard shortcut.

4.4 Designing the User Interface
You can create a user interface by adding the toolbox controls to the design
form. This interface accepts connection information from the user.
To add toolbox controls:
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1. From the View menu, select Designer.
This opens Form1, in design view, if it is not already open.
You will toggle between Code and Designer a lot. The keyboard shortcuts are
F7 and shift- F7 respectively.
2. From the View menu, select Toolbox.
3. In the Toolbox, expand Common Controls.

4. In the Toolbox, select Label, and drag it onto the Form1.

5. On Form1, right-click label1.
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6. From the menu, select Properties, if the Properties Window is not already
visible.
The Properties Window appears.
7. In the Properties Window, change the Text property from label1 to User ID.

8. Repeat steps 4 through 7 three times, placing three more labels on Form 1
and changing their text properties to Password, Server and Database.
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9. In the Toolbox, select TextBox, and drag it onto the Form1, under the User
ID label.

10. In the Properties Window, change the Name property to userID.

11. Repeat steps 9 and 10 three times, positioning three more text boxes under
the existing labels, and setting the Name property to password, server and
dataSource.
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12. Select the text box under the Password label. In the Properties Window, scroll
to the PasswordChar property and set it to an asterisk (*).
This masks the password during entry.

13. From the Toolbox, select Button and drag it onto Form1.
In the Properties Window, change the Text property of the button from
button1 to Connect, and change the Name property to connect.

14. Save.
15. Close the Toolbox.

4.5 Writing the Connection Code
Now we write the code that takes the information provided to the user
interface and connects to the database.
To connect to the database, you must create a connection object.
To write code that connects to the database:
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These steps enable your application to connect to the database based on data
that the user enters into the Form1 control. See Compiling and Running the
Application.
From the View menu, select Code.
1. Add the code indicated to instantiate a database connection string.
Visual C#: Add the class variable conn to the Form1 class right after the
public Form1() block with this code.
private RdbConnection conn = new RdbConnection();

Visual Basic: Add the conn class variable in the Form1 class declaration,
using this code.
Public Class Form1
Dim conn As New RdbConnection
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2. Save your changes.
3. Change to Designer view by clicking on the View menu and selecting
Designer.
4. Double-click the Connect button on Form1 to open the code window to the
connect_Click() method.
Insert the code indicated into the connect_Click() method.
Visual C#:
conn.ConnectionString = "User Id=" + userID.Text +
";pwd=" + password.Text +
";server=" + server.Text +
";database=" + database.Text +
";type=Thin;";
conn.Open();

Visual Basic:
conn.ConnectionString = "User Id=" + userID.Text & _
";pwd=" + password.Text & _
";database=" + database.Text & _
";type=Thin;"
conn.Open()

Visual Basic Imports statements, at or near the top of a code file.

Before a connection can be opened, it must be built from user input for the
User Id, pwd, server, and database.
The Open() method makes the actual connection.
5. Set the Enabled attribute of the button to false by inserting the indicated
code at the end of the connect_Click() method.
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This disables the Connect button, which is a good practice once a
connection is successfully made.
Visual C#:
connect.Enabled = false;

Visual Basic:
connect.Enabled = false

You have now finished writing an application that can connect to the Oracle
Rdb database.
The following sections show how to use it.
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4.6 Compiling and Running the Application
This section shows how to compile and run the application you created in the
previous sections.
To compile and run the application:
1. From the Build menu, select Build Solution.

2. Ensure that there are no errors reported in the output window, available from
the View menu.
The following graphics shows a typical output result.

3. If there are any errors indicated, from the View menu, select Error List and
fix the errors.
4. From the Debug menu, select Start Without Debugging to run the
application.
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5. In the Form1 application, enter the User ID, Password , Server, and Database.
Click Connect.
Once the connection is opened, the Connect button is disabled. You have
succeeded in implementing a connection to an Oracle Rdb Database.

4.7 Error Handling
Applications must be able to handle run-time errors gracefully. For example, if
you try to log in using an incorrect password, the application you developed
so far cannot establish a connection to the database, and exits with the
following unhandled exception
%RDB-E-AUTH_FAIL: authentication failed for user
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You must reselect Start Without Debugging to try this with a different
password.
Error handling manages occurrences of conditions that change the normal
flow of program execution. Oracle Rdb Data Provider for .NET contains a
single classes for error handling and support:
•

The RdbException class represents an exception that is thrown when the
Oracle Rdb Data Provider for .NET encounters an error. Each
RdbException object contains a description and an error number that
describes the error or warning.

4.7.1 Using Try-Catch-Finally Block Structure
.NET languages use Try-Catch-Finally block structure for error handling. With
this structure, the Try code is the main code, the goal that the application
wants to accomplish. The Catch code catches errors of various types, as
shown in the next two section. The Finally block comes last and always
executes.
The Finally block frequently contains the Dispose method, which closes and
disposes of the connection. Having the Dispose method in the Finally block
ensures that the database connection is always closed after the Try-CatchFinally block completes. Closing database connections after the application no
longer requires database access is important for many reasons, especially data
security.
Attempting to close a closed database connection does not cause an error.
The attempt is irrelevant. Nonetheless, placing Dispose() in the Finally
code block guarantees that the connection is closed.
The next section shows how to use Try-Catch-Finally block structure with
general errors, and the section after that, with Oracle Rdb errors.
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4.7.2 Handling General Errors
This section shows how to handle general errors using a Try-Catch-Finally
block.
To handle general errors:
1. Change the code of the connect_Click() method in Form1 by adding an
implementation of the Try-Catch-Finally syntax.
New code is in bold font.
Visual C#:
private void connect_Click(object sender, EventArgs e)
{
conn.ConnectionString = "User Id=" + userID.Text +
";pwd=" + password.Text +
";server=" + server.Text +
";database=" + database.Text +
";type=Thin;";conn.Open();
try
{
conn.Open();
connect.Enabled = false;
}
catch (Exception ex)
{
MessageBox.Show(ex.Message.ToString());
}
finally
{
conn.Dispose();
}
}

Alternatively, you can use C# syntax that disposes of a connection when it
goes out of scope, with the using keyword, as follows:
using (RdbConnection conn = new RdbConnection())
{
conn.Open();
// application code
...
}

Visual Basic:
Try
conn.Open()
connect.Enabled = false
Catch ex As Exception
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MessageBox.Show(ex.Message.ToString())
Finally
conn.Dispose()
End Try

2. From the Build menu, select Rebuild Solution.
Ensure that there are no errors.
3. From the Debug menu, select Start Without Debugging.
4. Run the application again, as described in section Compiling and Running the
Application, and attempt to connect using an incorrect password.
This time, the application catches the error and displays it in a pop-up
window, %RDB-E-AUTH_FAIL: authentication failed for user.

Chapter 5 Retrieving and Updating with
ORDP.NET
This chapter contains:
•
•
•
•
•
•

Using the Command Object
Retrieving Data: a Simple Query
Retrieving Data: Bind Variables
Retrieving Data: Multiple Values
Using the DataSet Class with Oracle Rdb Data Provider for .NET
Enabling Updates to the Database

5.1 Using the Command Object
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To view, edit, insert or delete data in a database, you must encapsulate a
request in an RdbCommand object specifying a SQL command, stored
procedure, or table name. The RdbCommand object creates the request,
sends it to the database, and returns the result.
To use the command object:
1. Make two copies of Form1.xx, from application PERS_Connect_xx in
Building a Simple .NET Application Using ORDP.NET. To make copies, see the
instructions in Copying a Form.
Name the copies Form2.cs or Form2.vb and Form3.cs or Form3.vb.
The first copy is for the first part of the chapter, and the second copy for the
second part of the chapter
2. Open Form2.cs or Form2.vb.
Note that the actual form in the designer still says Form1, as you renamed
code files but not the actual form controls within the project.
3. Create a string that represents the SQL query and add to the body of the try
statement.
The new code is in bold typeface.
Visual C#:
try
{

}

conn.Open();
connect.Enabled = false;
// SQL Statement
string sql = "select department_name from departments"
+ " where department_code = ‘ENG’";

Visual Basic:
Try
conn.Open()
connect.Enabled = False
_

Dim sql As String = "select department_name from departments" &
"where department_code = ‘ENG’"

32

4. Use the new sql variable to create the RdbCommand object, and set the
CommandType property to run a text command.
Visual C#:
try
{
conn.Open();
connect.Enabled = false;
// SQL Statement
string sql = "select department_name from departments"
+ " where department_code = ‘ENG’";
RdbCommand cmd = new RdbCommand(sql, conn);
cmd.CommandType = CommandType.Text;
}

Visual Basic:
Try
conn.Open()
connect.Enabled = False
Dim sql As String = "select department_name from departments" &
_

"where department_code = ‘ENG’"
Dim cmd As New RdbCommand(sql, conn)
cmd.CommandType = CommandType.Text

5. Save your work.

5.2 Retrieving Data: a Simple Query
This section demonstrates retrieving data from the database.
The ExecuteReader() method of an RdbCommand object returns an
RdbDataReader object, which can be accessed to display the result on the
form. The application uses a ListBox to display the results.
To retrieve data:
1. Create an OracleDataReader object, by adding the code indicated to the
bottom of the Try block of the connect_Click() method.
This enables you to read the result of the query.
The new code is in bold typeface

33

Visual C#:
try
{
conn.Open();
connect.Enabled = false;
// SQL Statement
string sql = "select department_name from departments"
+ " where department_code = ‘ENG’";
RdbCommand cmd = new RdbCommand(sql, conn);
cmd.CommandType = CommandType.Text;
RdbDataReader dr = cmd.ExecuteReader();
dr.Read();
}

Visual Basic:
Try
conn.Open()
connect.Enabled = False
Dim sql As String = "select department_name from departments" &
_

"where department_code = ‘ENG’"
Dim cmd As New RdbCommand(sql, conn)
cmd.CommandType = CommandType.Text
Dim dr As RdbDataReader = cmd.ExecuteReader()
dr.Read()

2.
3.
4.
5.
6.
7.

Open Form1 in Design view. From the View menu, select Designer.
From the View menu, select Toolbox.
From the Toolbox, select a Label and drag it onto Form1.
From the View menu, select Properties Window.
In the Properties window, change the Text of the label to Department.
From the Toolbox, under Window forms, select a ListBox and drag it onto
Form1.
8. In the Properties window, under Design, change the Name to
departments.
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9. Add accessor type methods for retrieving data from the query result.
Double-click the connect button to edit the connect_click() method,
and add the code indicated to the bottom of the try block.
Visual C#:
departments.Items.Add(dr.GetString(0));

Visual Basic:
departments.Items.Add(dr.GetString(0))

Typed accessors, such as GetString, return native .NET data types and
native Oracle Rdb data types. Zero-based ordinals passed to the accessors
specify which column in the result set to return.
The try block should look like this now:
Visual C#:
try
{
conn.Open();
connect.Enabled = false;
// SQL Statement
string sql = "select department_name from departments"
+ " where department_code = ‘ENG’";
RdbCommand cmd = new RdbCommand(sql, conn);
cmd.CommandType = CommandType.Text;
RdbDataReader dr = cmd.ExecuteReader();
dr.Read();
departments.Items.Add(dr.GetString(0));
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}

Visual Basic:
Try
conn.Open()
connect.Enabled = False
Dim sql As String = "select department_name from departments" &
_

"where department_code = ‘ENG’"
Dim cmd As New RdbCommand(sql, conn)
cmd.CommandType = CommandType.Text
Dim dr As RdbDataReader = cmd.ExecuteReader()
dr.Read()
departments.Items.Add(dr.GetString(0))

10. Build and save the application.
11. Run the application. Enter the login server and database information.
After you connect, the departments list box shows Engineering, the
correct name for department with code ‘ ENG’ in the Departments table, as
requested by the SELECT statement.

5.3 Retrieving Data: Bind Variables
Bind variables are placeholders inside a SQL statement.
The following code shows a typical SELECT statement that does not use bind
variables, with the value 10 specified in the WHERE clause of the statement.
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SELECT department_name FROM departments WHERE department_code = ‘ENG’

The following code replaces the numerical value with a bind variable
:department_id. A bind variable identifier always begins with a single
colon ( :).
SELECT department_name FROM departments WHERE department_code =
:department_id

Note that bind variables can also be used with UPDATE, INSERT, and
DELETE statements, and also with stored procedures. The following code
illustrates how to use bind variables in an UPDATE statement:
UPDATE departments SET department_name = :department_name
WHERE departname_code = : department_id

You can use the RdbParameter class to represent each bind variable in
your .NET code. The RdbParameterCollection class contains the
RdbParameter objects associated with the RdbCommand object for each
statement. The RdbCommand class passes your SQL statement to the
database and returns the results to your application.
To retrieve data using bind variables:
1. Move the ListBox named Departments to the right.
2. From the View menu, select Toolbox.
3. From the Toolbox, select a TextBox and drag it onto Form1, under the label
that says Department.
4. From the View menu, select Properties Window.
5. In the Properties window, change Name to departmentID.
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6. Change the SELECT statement to use the bind variable by adding the code
indicated to the Try block of the connect_Click() method.
Changed or new code is in bold typeface.
Visual C#:
string sql = "select department_name from departments "+
"where department_code = :department_id";
RdbCommand cmd = new RdbCommand(sql, conn);
cmd.CommandType = CommandType.Text;
RdbParameter p_department_id = new RdbParameter("department_id",
DbType.String);
p_department_id.Value = departmentID.Text;
cmd.Parameters.Add(p_department_id);
RdbDataReader dr = cmd.ExecuteReader();
dr.Read();
departments.Items.Add(dr.GetString(0));

Visual Basic:
Dim sql As String = "select department_name from departments " & _
"where department_code = :department_id"
Dim cmd As RdbCommand = New RdbCommand(sql, conn)
cmd.CommandType = CommandType.Text
Dim p_department_id as RdbParameter = new
RdbParameter(“department_id”, DbType.String)
p_department_id.Value = departmentID.Text
cmd.Parameters.Add(p_department_id)
Dim dr As RdbDataReader = cmd.ExecuteReader()
dr.Read()
departments.Items.Add(dr.GetString(0))
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For this code, the parameter object sets the DbType property, but there is no
need to set the Direction property because it uses the default value,
Input. There is no need to set the Size property because the object is an
input parameter, and the data provider can determine the size from the value.
7. Save and run the application.
8. Enter the login information, and a typical department code, such as “MNFG”,
from the MF_PERSONNEL database.
9. Click Connect.
The application returns the name of the department that corresponds to the
department ID.

5.4 Retrieving Data: Multiple Values
You frequently need to retrieve more than just one value from the database. A
DataReader object can retrieve values for multiple columns and multiple
rows. Consider the multiple column, multiple row query in the following
example:
SELECT department_code, department_name, manager_id
departments
WHERE department_code < ‘ENG’

FROM

Processing multiple rows from the DataReader object requires a looping
construct. Also, a control that can display multiple rows is useful. Because the
RdbDataReader object is a forward-only, read-only cursor, it cannot be
bound to an updatable or backward scrollable control such as Windows Forms
DataGrid control. An RdbDataReader object is, however, compatible
with a ListBox control.
To retrieve multiple values:
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1. In the try block of the connect_Click() method, change the SQL query
to return a multiple row result set and add a while loop to enclose the read
method that displays the department names.
Visual C#:
try
{
...
string sql = "select department_name from departments " +
"where department_code < :department_id";
...
while (dr.Read())
{
departments.Items.Add(dr.GetString(0));
}
}

Visual Basic:
Try
...
Dim sql As String = "select department_name from departments " & _
"where department_code < :department_id"
...
While (dr.Read())
departments.Items.Add(dr.GetString(0))
End While

2. Save and run the application.
3. Enter the login information and enter “ENG” for the department.
4. Click Connect.
The application returns the name of the departments that correspond to the
query.
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5.5 Using the DataSet Class with Oracle Rdb Data Provider
for .NET
The DataSet class provides a memory-resident copy of database data. It
consists of one or more tables that store relational or XML data. Unlike an
RdbDataReader object, a DataSet is updatable and backward scrollable.
To use the DataSet class:
1. If you have not done so before, make another copy of the Form1 that you
completed in Chapter 3, and name it Form3.vb or .cs, as described in
Copying a Form
2. If Form1.xx does not appear in the Solution Explorer, from the Project
menu, select Show All Files.
3. From the View menu, select Designer view.
4. From the View menu, select Toolbox.
5. From the Toolbox, select a DataGridView and drag it onto Form1.
6. From the View menu, select Properties Window.
7. In the Properties window, change the Name of the data grid view to
departments.

8. From the View menu, select Code.
9. Immediately after the conn declaration in the code, add variable declarations
to the class variables, as indicated.
Visual C#:
public partial class Form1 : Form
{
public Form1()
{
InitializeComponent();
}
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private
private
private
private
private
...

OracleConnection conn = new OracleConnection();
OracleCommand cmd;
OracleDataAdapter da;
OracleCommandBuilder cb;
DataSet ds;

Visual Basic:
Public Class Form1
Dim conn As New OracleConnection
cmd As OracleCommand
Private da As OracleDataAdapter
Private cb As OracleCommandBuilder
Private ds As DataSet

Private

10. Within the connect_Click() method try block, add code to:
o Query the database
o Fill the DataSet with the result of the command query
o Bind the DataSet to the data grid (departments)
Visual C#:
conn.Open();
connect.Enabled = false;
string sql = "select * from departments where "+
"department_id < ‘ENG’";
cmd = new OracleCommand(sql, conn);
cmd.CommandType = CommandType.Text;
da = new OracleDataAdapter(cmd);
cb = new OracleCommandBuilder(da);
ds = new DataSet();
da.Fill(ds);
departments.DataSource = ds.Tables[0];

Visual Basic:
conn.Open()
connect.Enabled = False
Dim sql As String = "select * from departments where " + _
"department_id < ‘ENG’"
cmd = New OracleCommand(sql, conn)
cmd.CommandType = CommandType.Text
da = New OracleDataAdapter(cmd)
cb = New OracleCommandBuilder(da)
ds = New DataSet()
da.Fill(ds)
departments.DataSource = ds.Tables(0)

11. Build and save the application.
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12. Run the application, entering the login and data source.
After you successfully connect to the database, the data grid is populated with
the results of the query.

5.6 Enabling Updates to the Database
At this point, the DataSet contains a client copy of the database data. In
this section, you will add a button that enables client data changes to be
saved back to the database. The following section will show you how to test
updating, inserting, and deleting the data.
To enable saving data from the DataSet to the database:
1. From the Toolbox, drag and drop a Button onto Form1.
2. In the Properties window, change the Name of the button to save.
Change the Text property to Save.
3. At the top of the Properties Window, click Events (the lightning bolt). In the
list of events, select the click event. In the second column, enter the event
name, save_Click.
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4. From the View menu, select Code.
5. Add code that updates the data, to the body of the save_Click() method,
as indicated.
Visual C#:
da.Update(ds.Tables[0]);

Visual Basic:
da.Update(ds.Tables(0))

You may see some errors show up in the Error List. These will disappear after
you add the code in the next step.
6. Within the Form() method or Form1_Load method, add the code
indicated.
Visual C#:
public Form1()
{
InitializeComponent();
save.Enabled = false;
}

Visual Basic:
Private Sub Form1_Load(ByVal sender As System.Object, & _
ByVal e As System.EventArgs) Handles MyBase.Load
save.Enabled = false

7. Within the connect_Click() method try block, add code to enable the
Save button as indicated:
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Visual C#:
conn.Open();
...
departments.DataSource = ds.Tables[0];
save.Enabled = true;

Visual Basic:
conn.Open()
...
departments.DataSource = ds.Tables(0)
save.Enabled = True

8. Remove the conn.Dispose() call from the finally block in the
connect_Click() method.
Note: In the previous code used in this example, this method was necessary
to dispose or close the connection. However, with these changes to the code,
it is necessary to keep the connection open after the query result returns, so
that data changes made by the end user are propagated to the database. A
general override call, components.Dispose(), is already part of the
definition of Form1.
9. Build and save the application.
10. Run the application, entering the login and data source.
After you successfully connect to the database, the data grid is populated with
the results of the query.
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Chapter 6 ORDP.NET and Visual Studio
Wizards
In this section you will use the Visual Studio integrated development
environment (IDE), along with the standard Visual Studio wizards to
automatically generate the code to access data from your Rdb database
This chapter contains:
•
•
•
•

Create a New application
Add connection to RDB database in MS server explorer
Create a datasource for the employees table
Design the windows application

6.1 Create a New application
Create a new windows application using the File ÆNew Æproject menu.
Call it empapp.
See Creating a New Project for the steps to create a new project.

6.2 Add connection to RDB database in MS server explorer
See Connecting to the Oracle Rdb Database for steps to connect to your
database.

6.3 Create a datasource for the employees table
To create a new Data Source:
1. Using the top-level menu Data > Add New Data Source.
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2. In the wizard, keep the default selection for “Database.” Click Next
3. From the list of connection, select the connection to the sample that was
created that was created earlier, select the option to include the sensitive data
in connection string. Click Next
4. Check to save the connection string to the Application Configuration File Click
Next

5. A tree of available table swill be displayed, select the employees table from
the list of tables by checking the box next to it. Click finish
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6. A data source for employees will be added in the “Data Sources” window.
You can make the data source window visible using the top level menu
Data > Show Data sources

6.4 Design the windows application
1. Ensure that From1.cs is open in design mode.
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2. Drag and Drop the Employees data source from the data sources window
onto the form.

3. Run the windows application
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Chapter 7

ORDP.NET and drag and drop

In this section you will use the Visual Studio integrated development
environment (IDE), allong with drag and drop to automatically generate the
code to access data from your Rdb database.
This chapter contains:
•
•
•
•
•

Create a New application
Add connection to RDB database in MS server explorer
Add a new Typed DataSet
Designing the windows application
Running the windows application

7.1 Create a New application
Create a new windows application using the File ÆNew Æproject menu.
Call it empapp.
See Creating a New Project for the steps to create a new project.

7.2 Add connection to RDB database in MS server explorer
See Connecting to the Oracle Rdb Database for steps to connect to your
database if you do not already have a connection.

7.3 Add a new Typed DataSet
To add a new Typed DataSet to your project:
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1. Using the Microsoft Solution Explorer, right click on the EmpApp, and select
Add -> New Item

2. Select DataSet. Click Add. The Microsoft Dataset Designer will be opened.

3. From the Microsoft Server Explorer, drag and drop “Employees” table onto the
open designer.
This will create a datasource and an associated EMPLOYEESTableAdapter
that can you use in your application to access the employees table.
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4. Ensure the password is added to the connection string. Select
EMPLOYEESTableAdapter, and right click to view its properties. Append
the password in the below format Password=yourpassword

7.4 Designing the windows application
To design the application:
1. Ensure the Form1.cs is open in design mode.
2. Using the Microsoft data sources window, use the smart menu on the
Employees data source, and select Details
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3. Drag and drop the Employees data source from the data source window onto
the form.

A prototype form to access the employees data will be created for you.

7.5 Running the windows application
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Run the application using the top-level menu. You can insert, delete rows and
change the existing data.

Chapter 8 Configuration wizard and
generating queries
Wizards make it easy to perform many operations within Visual studio. The
Table Adapter Query Configuration Wizard simplifies the creation of queries
you may execute on your Rdb database.
This chapter contains:
•
•

Using the Query Configuration Wizard
Using the Query Builder
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•

Methods Generation

8.1 Using the Query Configuration Wizard
To use the Query Configuration Wizard:
1. Right click dataset and click add> Query

The Table Adapter Query Configuration Wizard will be shown.

2. Select Use SQL Statement
Clicking Next will bring up the query Type window. This window allows you to
choose form several types of standard SQL statements.
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3. Select the query type SELECT which returns rows.
4. Click Next to bring up the query specification window. This is where you may
enter a SQL query statement.. Use the “@” character pre-pended to
parameter names to specify parameters you wish to use.

For example to return details of employee on giving the employee_id:
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SELECT CITY, FIRST_NAME FROM EMPLOYEES WHERE
EMPLOYEE_ID=@EMPLOYEE_ID
5. Click Finish. We have just added a select functionality to the typed dataset
using TableAdapter writing a single line of code.
Repeat the above steps to produce other statements such as UPDATE and
DELETE .

8.2 Using the Query Builder
Visual Studio provides the Query Builder option within the configuration
Wizard that allows quick and easy creations of syntactically correct SQL
queries on your datasets.
Using Query Builder to generate queries:
1. Click Query Builder to bring up the builder window .

2. Select EMPLOYEE table and click ADD. This will bring up a window
allowing you to choose columns for your query .
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3. Click “Close” on ADD Table window to close this window.
4. Within the EMPLOYEES table check the columns name and Parameters to
the query (Filter) as shown below.

5. Click Execute Query to execute the generated query. The results of the
operation will be displayed in the results window.
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6. Click “OK” to accept the query .

7. Click “Finish”. Your query is now ready to use. The Query Configuration
Wizard will now display the Methods Generation window.
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8.3 Methods Generation
Once you have generated a query, this query may be used within the
TableAdapter . The next step is to choose what methods should be available
within your TableAdapter.
How to choose methods:

1. Select the Fill A DataTable and Return a DataTable .
2. Change the Return a DataTable method name to GetDataBy_EMPID
The final dataset in the designer show look like the following:
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3. To execute the above functionality in your code, instantiate the table adapter
as follows:
DataSet1TableAdapters.EMPLOYEESTableAdapter adapt = new
DataSet1TableAdapters.EMPLOYEESTableAdapter();
This new select function can now also be seen in the TableAdapter
intellisense.

4. The methods provide by the TableAdapter may be used within your code :

// Get Employee details by employee_id
dataGridView1.DataSource=adapt.GetDataBy_EMPID(00164);

Chapter 9 Copying a Form
Because you will be using this application to learn about various aspects of
application development with Oracle, you should make copies of your form for
reuse.
To create a copy of an existing form:
1. In the Solution Explorer, right-click on Form1.xx or any other file you need
to copy. Select Copy.
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If Form1.xx does not appear in the Solution Explorer, from the Project
menu, select Show All Files.

2. Right-click HR_Connect_CS or other project. Select Paste.

3. Right-click Copy of Form1.cs. Select Rename. Change the name of the form to
Form2.cs.
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4. Right-click on Form2.cs, and select Include In Project.

5. Right-click on Form1.cs, and select Exclude From Project.

You can include and exclude forms from the project just by reversing these steps.
Note:
This process generally works smoothly. If you encounter a problem, try
running Rebuild Solution from the Build menu.
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Chapter 10 Unsupported features
•
•
•
•
•

Foreign Key support
Open Table definition
Alter Procedure
Data View Designer
Import/export table data as XML.

Glossary
assembly
Assembly is Microsoft's term for the module that is created when a DLL or .EXE is
complied by a .NET compiler.
Binary Large Object (BLOB)
A large object datatype who's content consists of binary data. Additionally, this data is considered raw
as its structure is not recognized by the database.
Character Large Object (CLOB)
The LOB datatype whose value is composed of character data corresponding to the database character
set.
data provider
As the term is used with Rdb Data Provider for .NET, a data provider is the connected component in the
ADO.NET model and transfers data between a data source and the DataSet.
dirty writes
Dirty writes means writing uncommitted or dirty data.
DDL
DDL refers to data definition language, which includes statements defining or changing data structure.
DOM
Document Object Model (DOM) is an application program interface (API) for HTML and XML
documents. It defines the logical structure of documents and the way that a document is accessed and
manipulated.
flush
Flush or flushing refers to recording changes (that is, sending modified data) to the database.
instantiate
A term used in object-based languages such as C# to refer to the creation of an object of a specific class.
Large Object (LOB)
The class of SQL datatype that is further divided into internal LOBs and external LOBs. Internal LOBs
include BLOBs, CLOBs, and NCLOBs while external LOBs include BFILEs.
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Microsoft .NET Framework Class Library
The Microsoft .NET Framework Class Library provides the classes for the .NET
framework model.
namespace
•

.NET:
A namespace is naming device for grouping related types. More than one
namespace can be contained in an assembly.

•

XML Documents:
A namespace describes a set of related element names or attributes within an
XML document.

National Character Large Object (NCLOB)
The LOB datatype whose value is composed of character data corresponding to the
database national character set.
octet
An 8-bit unit, usually referred to as BYTE
RdbDataReader
An RdbDataReader is a read-only, forward-only result set.
primary key
The column or set of columns included in the definition of a table's PRIMARY KEY constraint.
reference semantics
Reference semantics indicates that assignment is to a reference (an address such as a pointer) rather
than to a value. See value semantics.
result set
The output of a SQL query, consisting of one or more rows of data.
savepoint
A point in the workspace to which operations can be rolled back.
stored procedure
A stored procedure is a block of SQL code that Rdb stores in the database and can be
executed from an application.
Unicode
Unicode is a universal encoded character set that enables information from any language to be stored
using a single character set.
URL
URL (Universal Resource Locator).
value semantics
Value semantics indicates that assignment copies the value, not the reference or address (such as a
pointer). See reference semantics.
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