An EDI Cookbook for: Oracle B2B
Contents

Introduction ........................................................................................................................ 3

What is EDI ......................................................................................................................... 4

EDI Document structure ................................................................................................. 4

EDI Support in Oracle B2B ............................................................................................... 5
  User Experience while configuring EDI protocol in Oracle B2B .................................. 5
  Create a Document Protocol Version ........................................................................... 6
  Create a Document Type ............................................................................................... 6
  Create a Document Definition ...................................................................................... 7
  Add Documents definitions for responder .................................................................... 9
  Outbound EDI Processing ............................................................................................. 11
  Inbound EDI Processing ............................................................................................... 12
  Agreement Identification .............................................................................................. 12
  Trading Partner Identification ...................................................................................... 12
  Functional Acknowledgement Support in Oracle B2B ............................................... 14
  Overriding the Document Protocol Parameter for FA ................................................. 15
  EDIEL Support ............................................................................................................ 15

Control Numbers .............................................................................................................. 16
  Control Number Generated by Back end Application ................................................. 16
  Control Number Generated by B2B .......................................................................... 16

EDI Batching ..................................................................................................................... 17
  Batching EDI Transaction Sets ................................................................................... 17
  De-batching EDI Transaction Sets ............................................................................. 18

Additional features, Tips and Tricks ................................................................................. 19
  Custom Code List – EDI ............................................................................................... 19
  Handling Positional Flat File ....................................................................................... 19
  Performance Best Practices ......................................................................................... 20
  Large Payload Configurations ..................................................................................... 20

Oracle B2B Document Editor .......................................................................................... 21
  CREATION of ECS files USING SPEC BUILDER 6.6.1 ........................................... 21
  CREATION of XML Schema Definition (xsd) for the ECS file ................................ 24
  DATA GENERATION USING ECS FILE ................................................................... 29
  ANALYSE THE DATA/VALIDATE THE GUIDE LINE ............................................... 37
  Print and Publish Specifications .................................................................................. 43
  Write and Test Business Rules Using Java Script ....................................................... 45
  Compare customized specification to the standard specification ............................... 47
  Reverse engineering specifications using existing data files ..................................... 48

Typical EDI Errors .......................................................................................................... 49

FAQ .................................................................................................................................. 50

Reference Information ..................................................................................................... 52
Introduction
EDI – Electronic Data Interchange is a structured Document standard and is one of the most widely used standard in Business-to-Business communication. The various modes of exchanging an EDI data are using the well-known exchange protocols such as AS1, AS2, and VAN.

Purpose
The main purpose of this book is to get basic understanding of the EDI standards, learn Oracle Fusion Middleware B2B EDI support, User experience while configuring EDI protocol using Oracle B2B, Various Error/Exception scenario and also to model the various EDI messages using Oracle B2B Document Editor.

After reading this book, users should be able to independently model Various EDI use cases such as batching, debatching and end-to-end scenario using various EDI message types and revisions.

Audience
EDI Cookbook is intended for B2B users who want to exchange EDI messages such as EDIFACT, X12 using Oracle B2B as an Integration Gateway product and would like to understand various use cases and implementation.

Prerequisite
Basic Knowledge of EDI Standard i.e. both X12 or EDIFACT is a must.

Assumptions
This document is based on Oracle Fusion Middleware B2B 11g R1
What is EDI

Electronic Data Interchange is a Structured Business to Business Document standard which can be Electronically exchanged between and with in the Enterprise. EDI standard define the structure of the Business document for e.g. Purchase Order, Invoice etc. Even though it is a flat file standard unlike the popular XML standard, it is difficult to replace EDI due to its wider adoption and customer base.

Advantages of EDI

- Well-defined structure for handling various Business processes.
- Matured standard as it addresses every complex use case in various Business domains.
- Wider adoption and increased customer base.
- Matured, well-defined, EDDINT standard such as AS1, AS2 for data exchange.

EDI Document structure

The below picture explains the EDI document structure by taking X12 and EDIFACT document.

EDI documents can be grouped based on some unique criterion and contain Group sender, Group recipient etc. Which is unique to the group. Multiple Group can be enclosed in an envelope called Interchange. Group is not mandatory in EDI world, and is possible to enclose the documents directly under Interchange.
EDI Support in Oracle B2B

Oracle B2B supports both the EDIFACT and X12 flavor of EDI. Oracle Integration B2B has teamed up with EDIFECSTM to provide their robust translation and validation engine as an integral part of Oracle Integration B2B. This solution provides:

- A library of ALL EDIFACT, X12, HL7, HIPAA, EANCOM, NCPDP Script transaction sets
- Data file validation
- Data Migration
- Tests data generation
- De-identification
- Dictionary generation
- Batching
- Guideline migration

User Experience while configuring EDI protocol in Oracle B2B

The following are the steps to configure an EDI document in Oracle B2B.

- Identify the Document to be exchanged with the Trading Partner; it includes EDI Standard, Document Type and Document Revision, e.g. Standard X12, Document Type : 850 Document Revision : 4010
  - Go to Administration
    - Select Document
    - Select Document Protocols
    - Select EDI_X12

- Create the ecs file based on the document to be exchanged using Oracle B2B Document Editor. Please refer to the Document Editor Section

- Export the ecs file to get an XML schema file. Schema is used by the application, whereas ecs file is used in B2B.

  ! Note: While exporting, select the option to export in Oracle B2B 2.0 format

- Define Document Revision, Document Type and Document Definition for configuring a specific EDI Document.

---

Sample X12 file

```
ISA~00~Authorization~00~Security I~01~Interchange
Sen~01~Interchange Rec~071105~2249~U~00401~849818414~0~I~¬
GS~PO~Ap~Ap~20071105~2249~83~T~004010
ST~850~2604
BG~00~AB~P~20071105
POI~123
SE~4~2604
GE~1~83
IEA~1~849818414
```
Create a Document Protocol Version

→ Click (+) icon in Document Protocol pane to Add Document Protocol Version

→ Provide the Version name (4010)

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Version Name</td>
<td>4010</td>
</tr>
</tbody>
</table>

→ Save the newly created Document Protocol version
→ Observe the confirmation message after save activity

Create a Document Type

→ Select newly created Document Protocol Version (4010) in Document Protocol pane
→ Click (+) icon to Add Document Type
→ Provide the Document Type Name (850)
→ Provide the Functional Group Identifier Code (PO)
→ Save the newly created document Type

**Create a Document Definition**

→ Select newly created Document Type (850) in Document Protocol pane
→ Click (+) icon to Add Document Definition
→ Provide the Document Definition Name

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Document Type Name</td>
<td>850</td>
</tr>
<tr>
<td>Functional Group Identifier Code</td>
<td>PO</td>
</tr>
</tbody>
</table>

→ You have the option of providing an xsd corresponding to the transaction set ecs, which can be used in the back end application such as BPEL for required transformation to edifecs.xml.

→ Provide the Transaction set ecs file, under “Transaction” tab. This is mandatory. It is best practice to create the ecs file using the document editor 6.6.1 However, both B2B and document is backward compatible. Refer to the section “Document Editor”

Enter the following information

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Document Definition Name</td>
<td>850def – a name of user choice</td>
</tr>
<tr>
<td>Definition</td>
<td>850.xsd</td>
</tr>
<tr>
<td>Transaction set ecs file</td>
<td>850.ecs</td>
</tr>
</tbody>
</table>

→ Click Save
→ Observe the confirmation message after save activity

If it is required to process a functional acknowledge, create another document definition for the document Type (997) with the following information
Observe the xsd and ecs files are already being uploaded. As this is a common document type, it has been made part of default configuration. However, it is also possible to upload the ecs and xsd files for 997 by clicking Update button with below mentioned:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Definition</td>
<td>997.xsd</td>
</tr>
<tr>
<td>The xsd file can be created using the Spec Builder 6.6.1 by exporting the ecs file in Oracle B2B 2.0 format</td>
<td></td>
</tr>
<tr>
<td>Transaction set ecs file</td>
<td>997.ecs</td>
</tr>
</tbody>
</table>

→ Save the newly created Document Definition

- As part of document definition, use ecs file and xsd files obtained from previous step.
  B2B uses only the ecs file for validation and translation; xsd can be used by BPEL process for payload validation and can be accessed by composite while configuring the communication between BPEL and B2B. Please refer to the EDI Tutorial for the detailed steps.

- Define Document Protocol Parameters
  Document Protocol Parameters are defined while creating the document protocol version, however it is possible to override it for a specific Trading partner

  For e.g. the list of delimiters, option to create the UNA segment etc while defining the Document Protocol Revision
- Document Type Parameters while defining the Document Type i.e. Transaction set.
- Standard Interchange and group ecs files are seeded in the product. Unless there is any change in the ecs file due to customization of any of the envelope segments, B2B will always refer to the seeded ecs files. For any change in the Interchange or group segments, it is required to redesign the respective ecs using the Document Editor, use it in B2B as group/Interchange ecs file.

⚠️ Note: It is required to validate and redeploy the agreement for any change in Document parameters.

- Add these documents to the trading partner with the respective role (initiator / responder). All the documents that are defined are available for Host by default. Just need to assign the proper role for the host

Add Documents definitions for responder

⇒ Click "Documents" tab to add the document definition
⇒ Click (+) icon in Document pane to add Document definition to the trading Partner
- Add the document to the trading partner
- Select appropriate role for 850def (sender / receiver), depending on the business usecase
- Click Save

Similarly,
- Select appropriate role for 997def (sender / receiver), depending on the business usecase
- Click Save
Outbound EDI Processing

B2B can receive 2 types of EDI documents from Back end Application.

- **Native EDI:**
  B2B acts as a gateway doing the validation of the document and forwards it to the respective trading partner using designated exchange protocol. This approach does not provide typical of the EDI features such as Batching and generation of the Interchange and group as appropriate. Hence it is required to send the complete envelope for B2B processing.

  This approach requires disabling the translation flag while creating the agreement, as B2B acts as a gateway, forwarding the document to the TP.

  In this mode no correlation will be done with respect to functional acknowledgment.

- **XML:** It is required by the back end application to get the data from downstream application and transform it to xml as defined by the schema.

  Back end application is required to send only one transaction set at a time to B2B as B2B generates the envelope using the pre-seeded envelop details. If the Back end application has an envelope with multiple Transaction Sets, it is required to split the same into multiple transaction and enqueue it to be processed by B2B.

  Alternatively, it is also possible to override the Document Protocol Parameter defined in B2B for a specific Document Type and Revision by specifying the Internal Property in the Edifecs XML. For e.g the elements with `<Lookup` tag will be used for validation

```xml
<Internal-Properties xmlns="http://www.edifecs.com/xdata/100">
  <Data-Structure Name="Interchange">
    <Lookup Name="InterchangeControlVersion">00401</Lookup>
    <Lookup Name="InterchangeReceiverID">Interchange Rec</Lookup>
    <Lookup Name="InterchangeReceiverQual">01</Lookup>
    <Lookup Name="InterchangeSenderID">Interchange Sen</Lookup>
    <Lookup Name="InterchangeSenderQual">01</Lookup>
    <Lookup Name="Standard">X12</Lookup>
    <Property Name="ElementDelimiter">0x7e</Property>
    <Property Name="InterchangeAckRequested">0</Property>
    <Property Name="InterchangeAuthorizationInfo">Authorizat</Property>
    <Property Name="InterchangeAuthorizationInfoQual">00</Property>
    <Property Name="InterchangeChildCount">1</Property>
    <Property Name="InterchangeComponentElementSep">0x5c</Property>
    <Property Name="InterchangeControlNumber">691244239</Property>
    <Property Name="InterchangeControlStandard_RepeatingSeparator">U</Property>
    <Property Name="InterchangeControlVersion">00401</Property>
    <Property Name="InterchangeSenderQual">01</Property>
    <Property Name="InterchangeTime">1525</Property>
    <Property Name="InterchangeTrailerControlNumber">691244239</Property>
    <Property Name="SegmentDelimiter">0x0d0x0a</Property>
    <Property Name="Standard">X12</Property>
    <Property Name="SubelementDelimiter">0x5c</Property>
  </Data-Structure>
</Internal-Properties>
```

Please refer to **EDI Batching** section for handling multiple Transaction Set in an Envelope.
Inbound EDI Processing
Depending on the translation flag, B2B translate the inbound native EDI documents to Edifecs XML to be consumed by the back end application. The Edifecs XML generated also has all the Document Protocol Parameters mapped to Internal Properties.

Agreement Identification
B2B uses 4 parameters for identifying the agreement From Party, To Party, document type and document protocol version

Trading Partner Identification
Trading partner Identification can be done in three different ways and order of identification.

- **Exchange**: this is the default way of identifying the trading partner by using the Exchange headers
  
  E.g. In AS2 protocol, it is by using AS2-From and AS2-To headers and comparing with the AS2 identifiers of the Trading Partners.

- **Interchange**: EDI has unique values in the interchange headers that can be used to identify the Trading Partner. (Optional)

- **Group**: EDI has unique values in the group headers that can be used to identify the Trading Partner. (Optional in EDIFACT)

<table>
<thead>
<tr>
<th>EDI</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interchange</td>
<td>Interchange Sender ID</td>
</tr>
<tr>
<td>Group</td>
<td>Application’s Sender Code</td>
</tr>
<tr>
<td>Exchange</td>
<td>Exchange identifier</td>
</tr>
</tbody>
</table>

**Note**: In order to identify the trading partner based on the Interchange, it is important to forcefully fail the exchange identification.
Similarly, in order to identify the trading partner based on the group, it is important to forcefully fail the exchange and interchange identification. This can be achieved by adding
<table>
<thead>
<tr>
<th>Identity From TP</th>
<th>Identification Criterion</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interchange</td>
<td>Interchange Sender ID</td>
</tr>
<tr>
<td>Group</td>
<td>Application's Sender Code</td>
</tr>
<tr>
<td>Exchange</td>
<td>Protocol Identification from party's exchange identifier</td>
</tr>
</tbody>
</table>

To support this configuration,

- Create a Trading Identification Type: EDI Interchange ID, EDI Group ID

Document Identification
Oracle B2B extracts the Document Type and revision from the transaction Set of the incoming EDI Document i.e from UNH Segment. It is required that the document to be well formed for the successful extraction of Document Type and Revision.

- X12 - identification based on Group and Transaction set
- EDIFACT – identification based on Transaction set

Validation and Translation
It is required to get the necessary ecs for translation and validation. Document protocol parameters of the Document is compared against the one defined during Document definition to extract the ecs file. Typically for inbound messages, Oracle B2B validates the document and then translates it into xml depending on the settings.

The below mentioned parameters are validated against the configured parameters to make sure that the data is from the right partner.

Document Protocol Parameters (Header):
- Interchange Receiver ID
- Interchange Receiver ID Qualifier
- Interchange Sender ID
- Interchange Sender ID Qualifier
- Application Receiver's Code
- Application Sender's Code
- Interchange Control Version Number

**Functional Acknowledgement Support in Oracle B2B**

Functional Acknowledgment is a confirmation sent by the recipient Application about
- Receipt of the message.
- Status of Validation of the message against the configured ecs file.

Functional Acknowledgement can be configured to be sent by either B2B or by the Back end application.

- **Functional acknowledgement required:** Functional Ack required or not. This option is available while creating the agreement as shown below

- **Functional Ack handled by B2B:** Generates FA in B2B or by the Back end Application. To enable this,
  - Go to Administration
  - Click Configuration tab
**Overriding the Document Protocol Parameter for FA.**

Consider a use case, which requires overriding the Interchange Sender ID in the Document Protocol Parameters using the Internal Properties in the Outbound Edifecs Document, or using the value present in inbound Business message such as 850. To enable the internal properties to be used in outbound processing, set the “Functional Ack Internal properties” to “true” in the below picture. This screen is available at:

- Go to Administration
- Click Configuration tab

![Configuration Tab](image)

This will override the Document protocol parameter value of Functional Acknowledgement with Internal Property in the generated Functional Acknowledgement.

**EDIEL Support**

Oracle B2B also supports another variant of EDIFACT, which is EDIEL, used in Electrical industry. In this case, in addition to all the features of EDIFACT, it is also possible to:

- Customise the **FA Message Version Number** and **FA Message Release Number**. The default value for this is D3.
- Provide the reference to the **MAP APPLICATION REF.** of the incoming message to be referred as part of FA.
Control Numbers

Control Numbers are included in all header and trailer segments as an additional means of tracking and confirming EDI transmissions. Control numbers issued in the header segments must match control numbers assigned in the trailer segments. An ISA control number must match the IEA control number, the GS control number must match the GE control number, and the ST control number must match the SE control number in each EDI transmission, or there could possibly be errors. Control numbers can be assigned in the following two ways.

Control Number along with the sender ID provides a unique identifier to identify incoming EDI data from a sender. Following are various control numbers,

- **Interchange Control Number**: Originated by the sender and is typically a sequence number. This together with the sender ID uniquely identifies the Interchange.
- **Functional Group Control Number**: This uniquely identifies Group.
- **Transaction Set Control Number**: This uniquely identifies Transaction Set.

Control Numbers are used for correlation at various stages; it may be correlation in the Back End application or correlation in the B2B application between the business document such as 850 and Functional Acknowledgement 997.

**Control Number Generated by Back end Application**

This is the most likely case as back end application uses the Interchange, Group and Transaction Set Control Number for correlation at various levels and also for correlating the control/Ack and business messages. However, if the translation is enabled B2B can correlate the business message and functional acknowledgement.

E.g. To correlate 850 EDI message with 997

**Control Number Generated by B2B**

In case of Outbound Messages, B2B Generates the control number only in case the Back end application send the EDI message with the macro `#controlNumber#` for e.g.

```xml
<Element-329>#{ControlNumber#}</Element-329>
```

Oracle B2B fills in the unique number for Interchange and Transaction set Control Number and uses it for correlating the incoming Control messages.

*Note: this is not a preferred approach, as most of the correlation has to happen in the back end application.*
**EDI Batching**

Batching of EDI messages allows the users to send all messages of particular criteria at a specified time. This can include, a set of messages with:

1. Same document type, can be sent to one or more trading partners
2. Multiple document type, can be sent to one or more trading partners

Batching concept is widely used in Retail industry, as the number of messages processed is high in number. As the Retail traders widely use EDI as the means of communication, the Batching suits well to EDI domain

**Batching EDI Transaction Sets**

Individual transactions are sent to the internal delivery channel one transaction at a time. For outbound messages received on the internal delivery channel, transaction sets can be batched based on criteria that you specify.

The following example shows how to batch the document type 850, revision 4010, to the trading partner named GlobalChips. The examples follow the scenario described in the EDI X12 tutorial

1. Go to Administration
2. Select Schedule Batch
3. Provide the batch name
4. Click on **Launch Scheduler** button to schedule the batch time
Provide the time range depending on “Non-Repeating Event” or “Repeating Event”

Click on “Search” button to get the deployed agreements

Click on to create the batch

De-batching EDI Transaction Sets

For inbound message, oracle B2B splits the interchange into individual Transaction Set and depending on the Translation flag translate it to Edifecs XML, this is a default behaviour and does not require any configuration.
Additional features, Tips and Tricks
This section explains few of the advanced topics as well as few of the tips and tricks to handle the some of the complex EDI scenarios

Custom Code List – EDI

In EDI world, Interchange receiver Id and Interchange sender Id has set of codelist, which is used to validate the EDI Message. However, it is possible to use the qualifier which is not there in the standard code list (e.g : ZZ) as part of the Document Protocol Parameter configuration. This is achieved by following the below steps.

1. Modify the interchange ecs file to add the “YZ” in the standard code list_1005.
2. This can be done by editing the Interchange ecs file in the spec builder and adding YZ in the ISAI05/ Interchange ID Qualifier/Standard Code List_1005. Use the updated ecs while configuring the X12 document protocol parameter as interchange ECS.
3. Re-deploy the agreement after validation.
4. Ensure Interchange ecs do not have any group/transaction set information.

This could be tested by exchanging an EDI document whose Interchange Receiver ID as ZZ. This also applicable to all the codelists

Handling Positional Flat File

Apart from the capability of Handling XML file and Traditional EDI file based on various XML and EDI Standard, Oracle AS B2B also provides an option to Handle positional Flat File.

1. Design the ecs file in spec builder depending on the Positional Flat file.

2. Provide the newly created Ecs file as part of the Document definition Parameter along with start position and End position while creating the new document for PositionalFlatFile.
Performance Best Practices

Following are the few of the Best practices for Oracle AS B2B Performance and can be tuned based on the system resources

Outbound processing:
b2b.outboundThreadCount= <no of threads to be spawned for outbound flow>
b2b.outboundSleepTime= 1000 Sleep time (in msec) for thread when there is no message.

Inbound process:
b2b.inboundThreadCount= <no of threads to be spawned for inbound flow>
b2b.inboundSleepTime= 1000

Default threads for process all the events:
b2b.defaultThreadCount= <no of threads to be spawned for all events such as delivery channel creation/updating, system parameter updation etc including the message flow in both the direction >
b2b.defaultSleepTime= 1000

Large Payload Configurations

Following steps need to be configured in case of large payload above 100Mb,

1. As a pre-requisite, the following properties need to be set in B2B
   In Admin -> Configuration,
   • Use JMS Queue as default property as true.
   • Logpayload property to be false
   • Large Payload Size property as <payload size>
   • Large Payload Directory eg. /tmp

2. jvm memory-args
   • Increase max heap size according to machine available RAM
     E.g. for 2GB -Xmx2048m and also change min heap size needy basis.

3. Database Configuration changes
   • DBA can tune the db appropriately based on the message flow
   • Increase the table space file size maxlimit

4. Transaction Timeout settings
   In Weblogic console
   • Increase JTA transaction timeout from
     weblogic console Services -> JTA Timeout Seconds=120 seconds
   • Increase SOADatasource XA timeout setting to 120-180seconds
     weblogic console Services -> JDBC->DataSources->SOADatasource

5. Fabric settings - For fabric based testing use streaming option incase of file-adaptor listener.

Comment [u1]: also, we can point to the performance tuning guide, which will be created for BT
Oracle B2B Document Editor

Oracle B2B - Document Editor (Powered by Edifecs™) is an integrated guideline creation and implementation application for business-to-business (B2B) electronic commerce (e-commerce). Use the Document Editor to simplify developing, migrating, testing, distributing, and printing your electronic business (e-business) guideline documents. You can create new guideline documents or use the Document Editor's comprehensive library of Standards as templates.

Using an existing standard as a template, you can create new transaction sets by changing the attributes of underlying segments, elements, and codes as well as create implementation guidelines from data files. Oracle B2B - Document Editor is also integrated with Edifecs CommerceDesk, the most complete solution available for data generation and guideline-compliance testing.

In order to use the EDIFACT, X12 and HL7 protocol in ORACLE integration B2B, it is mandatory to know below mentioned basic steps

- Creation of ECS files using (SPEC BUILDER 6.6.1)
- xsd generation using ecs file.
- Data generation using ecs file.
- Analyse the data

CREATION of ECS files USING SPEC BUILDER 6.6.1

Prerequisite: Install the spec builder 6.6.1

→ Open the spec Builder 6.6.1

→ Click “New document” to create the new ecs file

→ Select guideline as EDI, X12 Documents
→ Click on (+) to select the desired Document Protocol Version (V4010)

→ Select the Document Type (850 – Purchase Order)
Unselect the Envelop.

Oracle integration B2B is pre-seeded with all versions of the envelope and group ecs files. Hence no need to generate the envelope and group ecs files unless there is a deviation from the standard.

Click finish.
Edit the segment level details as per your requirement.

→ Save the generated ecs file.

CREATION of XML Schema Definition (xsd) for the ECS file

This step is used to create the XML Schema definition.
→ Open the newly created ecs file
→ Click on File→Export
→ Select Oracle B2B 2.0 as export format. This export routine will convert the guideline from the internal format to one that can be used with the Oracle B2B runtime software 2.0.

→ Click Next
→ Select the option of saving the guideline before exporting.
→ Select the location for saving the exported file
Select the option for namespace generation as "Custom namespace"

Provide the custom namespace as "urn:oracle:integration:b2b:X12/4010/850"

Click Next
→ Click Next

→ Click Next

→ Click Next
→ Click Next

→ Click Next
DATA GENERATION USING ECS FILE.

This step is used to create the test data.

→ Click on Data generator in the left pane of the below screen.

→ Click next
→ Click next
→ Since the data is generated for user defined guideline, select the option as “From a guideline file”

→ Select the newly created ecs file
→ Click Next
→ Click Next
Click Next
→ Click Next

→ Click Next
Provide the desired delimiters or select the segment separator as shown below.

Click next
Select the output data file name.
→ The data gets generated

→ Save the data file
ANALYSE THE DATA/ VALIDATE THE GUIDE LINE

This step is to analyze the test data.

➔ Click on Analyzer in the left pane of the below screen.

➔ Select the file to analyse

➔ Click Next
Click Next

Click Next
Select the guideline (ecs file) to check the correctness of data against the newly generated ecs file.

Click Next

Since the ecs file does not contains the envelope segments choose the below mentioned options

Click Next
Click Next
Select the option to "generate Xdata" as "Always or No Errors" in order to generate XML Data.

Click Next

Analyser will provide the analysis results with error messages (if any), in the bottom pane of the above screen. In case of error edit the data, save and execute analyzer.

Click on the button in the top right corner to view the XML Format of the data.
Print and Publish Specifications

The objective of this section is to create, customize and publish an implementation / companion guideline.

- Click "New document" to create the new ecs file
- Select guideline as EDI, X12 Documents
- Click on (+) to select the desired Document Protocol Version (V4010)
- Select the Document Type (850 - Purchase Order)
- Envelope Segments: Select → default, Click Finish

Note: either you can create a new guide line or use the existing one

1. **Include/Exclude Node**
   
   In the Guideline tree
   - Expand segment BEG Beginning segment fro Purchase Order.
   - Exclude element BEG06 Contact Number

2. **Adding user note for ISA segment, ISA08 element.**
   
   - Expand Segment ISA Interchange Control Header
   - Select element ISA08
   - Select ‘User Notes’ tab and then
     - User Note 1: Add Note
       - Value in this element must equal:
         - RealProcess       for real-time purchase orders
         - BatchProcess    for batch purchase orders
     - User Note 2: Add Note:
       - Ensure that values match either "REALProcess" or "BATCHProcess".
       - When value is "RealProcess" only 1 purchase order is in the data file.

3. **Modify User Note Labels.**
   
   - Select File → Document Options
   - Select "Notes" Tab.
   - Scroll down on the tree to find the entry for Element Notes.
   - Change label for User Note 1 to “TP Note”
   - Change label for User Note 2 to “Dev Note”
   - Click Apply
   - Select “Composite/Element” Tab
   - Scroll down to section “Print composite/element user notes”
   - Enable printing of TP Note and Dev Note
   - Click Ok

   ✔ Note: Label on the screen has also changed to “TP Note” and “Dev Note”

4. **Modify Cover Page**
   
   - Select File → Properties.
   - Change Title to “ABC: 850 Purchase Order”
   - Change Author to “ABC”
   - Click OK
   - Select File → Document Options
   - Select check box to “Print Cover Page”
   - Click OK
5. **Save Guideline**
   - File -> Save
   - File: Les7_X12_4010_850_Notes.ecs

6. **Print Preview**
   - Select File  Properties
   - Verify
   - Cover Page
   - Exclusion of BEG06
   - ISA08 notes

7. **Publish to HTML, PDF, RTF, Word XML, Excel XML (optional).**
   - Select File  Publish To.
   - Select “HTML”
     - File: Les7_X12_4010_850_Notes
   - Using Windows Explorer navigate to the location provided for the HTML page.
   - Double click to open the HTML page. And verify edits
   - Exit Specification
Write and Test Business Rules Using Java Script

The objective of this section is to write rule using java script for additional business rule validation

Note: JAVA Code is available in the attached sample.zip file under B2B_Class\Document_Editor\java_code.txt.

1. **Write rule that accumulates the line item quantities**
   If the total quantity does not match the count in the control segment then report an error.

2. **Create and initialize quantity accumulate variable.**
   - Select the root Transaction node in the guideline tree.
   - Click on the “Rules” tab on the detail pane.
   - Click on the icon to add a new Rule
   - Select “User Global Declaration Script”
   - Add java script variable declaration:
     ```java
     abc_totQuantity = 0;
     ```

3. **Write code to accumulate quantity for each line item loop**
   In the guideline tree
   - Expand Loop PO1
   - Select segment PO1
   - Select element PO102
   - Click on the “Rules” tab on the detail pane.
   - Click on the icon to add new script.
4. Write code to report error: Total quantity <> total quantity calculated.

In the guideline tree:
- Select segment CTT “Transaction Total”
- Select element CTT02 “Hash Total”
- Click on the “Rules” tab on the detail pane.
- Click on the icon to add new script.
- Select “OnUserNode Script”
- Add following code and save the .ecs file:

```javascript
abc_totQuantity = abc_totQuantity + parseFloat(ec_DataLink.m_sData);
```

```javascript
if (abc_totQuantity != + ec_DataLink.m_sData) {
    var ErrMsg = "Calculated total Qty: " + abc_totQuantity + " does not match the reported Qty: " + ec_DataLink.m_sData;
    ec_ErrorContainer.AddError2("_ec_CaseID", "9999", "_ec_DescriptionTemplate", ErrMsg);
}
```
Compare customized specification to the standard specification

The objective of this section is to compare and migrate customized specification to a newer version of the transaction.

1. **Launch Migrator**
   - Open the main toolbar to the left and click on the icon for Migrator

2. **Executing the comparison and migration wizard**
   - Migrator wizard is started.
   - Source guideline from the database or standard
     - Select Standard
       - EDI, X12, Version 4010, 850 Purchase Order
       - Click Next
   - Select Destination Guideline or Standard
     - File: Les7_Migrate_X12_401_850.ecs
     - Click Next
   - Comparison options
     - Allow customization of which guideline attributes should be compared and which should be skipped. By default user notes are skipped since they will most likely always be different. Use the default settings and click Next.
   - Migration options
     - Allow customization of which guideline attributes should be migrated from source to target. Use the default settings and click Next.
   - Match options
     - Allow customization of how the two guidelines should be linked to each other. By default node ID is used for linking but additional attributes such as Name and Position can also be used for linking. Use the default settings and click Next.
   - Click Finish to start the wizard.

3. **Viewing and navigating differences**
   - Use the scrollbars and the toolbar icons to navigate to next / previous differences
4. **Printing comparison reports.**
   - Using File->Print Preview view the:
     - Change summary report
     - Companion reports

**Reverse engineering specifications using existing data files**

The objective of this section is to demonstrate how to create specifications from existing data files.

5. **Launch SpecGenerator.**
   - Open the main toolbar to the left and click on the icon for SpecGenerator.

6. **Executing the SpecGenerator wizard**
   - SpecGenerator wizard is started.
   - Select the data file:
     - File: Les7_850_2.dat
     - Click Next
   - Clean up data files: Click next
   - Data Structure: Click next
   - Guideline Selection: Verify that the proper guideline from the database is automatically selected and click Next.
   - Envelope Segment
     - Please select Envelop Segments: Click next
     - Please select Envelop Segments from database Click next
     - Please select how to use the selected Envelop Segments
   - SpecGenerator Mode: Click next
   - Order specification based on the content.
   - Toggle the view to only view included items by clicking on the toolbar icon.
   - View the N101 code list to verify the code values are limited to those present in the data file.
   - Save the specification document as Lab7-850.ecs and close the guideline.
Typical EDI Errors

1. Unable to identify the Document
   Make sure the document EDI document is well formed by using B2B document editor

2. Agreement Identification which involves Document Identification and TP Identification
   Agreement not found for trading partners: FromTP GlobalChips, ToTP Acme with document type 850-4010-INBOUND
   Check: Make sure to verify Trading Partner Name, Trading Partner Parameters (Optional), Document Type Name, Document Type Revision, Trading Partner Id, Delivery Channel

3. Document Validation Error
   Proper ECS file is used for Validation

4. Connection Issues
   Transport error: [IPT_HttpSendConnectionRefused] HTTP connection is refused.
   Connection refused: connect
   Check : Make sure the information about delivery channel is correct and also the end point is active. Pinging the end points can do this.
FAQ

1. Is it always mandatory to send the Edifecs XML to B2B for EDI processing?
   It is possible to process Native EDI, Edifecs XML and any other flat file using Oracle B2B. Following are some of the features with native EDI/Flat File Processing.
   - Translation should be switched off with optional validation.
   - Oracle B2B would not provide features such as Batching, etc. with this configuration.
   - It is required to send the complete envelope, as Oracle B2B will not generate the envelope using Document Protocol Parameters like in case of Edifecs XML processing.

2. What if I have a native EDI file in the back end application can I process in B2B?
   Refer to Q1.

3. What if I have a EDI document with multiple transactions, how do I handle in B2B?
   Oracle B2B Processing is based on Transaction set, hence it is required to split the envelope into multiple transactions and send it to B2B. B2B translates the transaction set into native EDI and generates the envelope using the Document Protocol Parameters.

4. Can I receive EDI document with multiple transactions from a trading partner?
   Yes. Oracle B2B provides a feature of debatching for inbound messages. Refer to section EDI Debatching for more details.

5. Can I outbound batch a native EDI documents to be sent to B2B from Back end application?
   No, Refer Q1.

6. Can I customize the group and Interchange ecs files? How?
   Yes, it is possible to customize Group and Interchange ecs file using Oracle B2B Document editor and upload the same at the trading partner level.

7. What is the preferred Exchange protocol for EDI?
   EDI won't mandate any Exchange protocol as such. However AS1/AS2 are the most popular exchange protocol which go well with EDI.

8. Can I disable the validation of incoming data against the document protocol parameter? Is it possible to identify the incoming document only based on ecs file?
   Yes, it is possible to disable the validation of incoming document against Document protocol parameters by setting the value for ‘Ignore Validation on Envelop elements’

9. Is it mandatory to have Functional Acknowledgement in EDI.
   No it is optional
10. What happens when the Document related parameter are modified in the admin page when it is already being used in the trading partner level. Can the updated information propagate to all the trading partners?

NO
Reference Information

Links

Oracle B2B

Oracle B2B Forum

Fusion Middleware

Service-Oriented Architecture
http://www.oracle.com/technologies/soa/index.html