Oracle Critical Patch Update Advisory - January 2015


Description

A Critical Patch Update (CPU) is a collection of patches for multiple security vulnerabilities. Critical Patch Update patches are usually cumulative, but each advisory describes only the security fixes added since the previous Critical Patch Update advisory. Thus, prior Critical Patch Update advisories should be reviewed for information regarding earlier published security fixes. Please refer to:


Critical Patch Updates and Security Alerts for information about Oracle Security Advisories.


Oracle has received specific reports of malicious exploitation of vulnerabilities for which Oracle has already released fixes. In some instances, it has been reported that malicious attackers have been successful because customers had failed to apply these Oracle patches. Oracle therefore strongly recommends that customers remain on actively-supported versions and apply Critical Patch Update fixes without delay.


This Critical Patch Update contains 169 new security fixes across the product families listed below. Please note that a blog entry summarizing the content of this Critical Patch Update and other Oracle Software Security Assurance activities is located at https://blogs.oracle.com/security.


Please note that on October 16, 2014, Oracle released information for CVE-2014-3566 "POODLE". Customers of affected Oracle products are strongly advised to apply the fixes and/or configuration steps that were announced for CVE-2014-3566 in addition to the fixes announced in this CPU.


This Critical Patch Update advisory is also available in an XML format that conforms to the Common Vulnerability Reporting Format (CVRF) version 1.1. More information about Oracle's use of CVRF is available at: http://www.oracle.com/technetwork/topics/security/cpufaq-098434.html#CVRF.


Affected Products and Components

Security vulnerabilities addressed by this Critical Patch Update affect the products listed in the categories below.  The product area of the patches for the listed versions is shown in the Patch Availability column corresponding to the specified Products and Versions column.   Please click on the link in the Patch Availability column below or in the Patch Availability Table to access the documentation for those patches.


The list of affected product releases and versions that are in Premier Support or Extended Support, under the Oracle Lifetime Support Policy is as follows:


Affected Products and Versions Patch Availability
Oracle Database Server, version(s) 11.1.0.7, 11.2.0.3, 11.2.0.4, 12.1.0.1, 12.1.0.2 Database
Oracle Fusion Middleware, version(s) 10.1.3.5, 11.1.1.7, 11.1.2.1, 11.1.2.2, 12.1.2, 12.1.3 Fusion Middleware
Oracle Fusion Applications, versions 11.1.2 through 11.1.9 Fusion Applications
Oracle Access Manager, version(s) 11.1.1.5, 11.1.1.7, 11.1.2.1, 11.1.2.2 Fusion Middleware
Oracle Adaptive Access Manager, version(s) 11.1.1.5, 11.1.1.7, 11.1.2.1, 11.1.2.2 Fusion Middleware
Oracle BI Publisher, version(s) 10.1.3.4.2, 11.1.1.7 Fusion Middleware
Oracle Business Intelligence Enterprise Edition, version(s) 10.1.3.4.2, 11.1.1.7 Fusion Middleware
Oracle Containers for J2EE, version(s) 10.1.3.5 Fusion Middleware
Oracle Directory Server Enterprise Edition, version(s) 7.0, 11.1.1.7 Fusion Middleware
Oracle Exalogic Infrastructure, version(s) 2.0.6.2.0 (for all X2-2, X3-2, X4-2) Fusion Middleware
Oracle Forms, version(s) 11.1.1.7, 11.1.2.1, 11.1.2.2 Fusion Middleware
Oracle GlassFish Server, version(s) 3.0.1, 3.1.2 Fusion Middleware
Oracle HTTP Server, version(s) 10.1.3.5.0, 11.1.1.7.0, 12.1.2.0, 12.1.3.0 Fusion Middleware
Oracle OpenSSO, version(s) 8.0 Update 2 Patch 5 Fusion Middleware
Oracle Real-Time Decision Server, version(s) 11.1.1.7, RTD Platform 3.0.x Fusion Middleware
Oracle Reports Developer, version(s) 11.1.1.7, 11.1.2.2 Fusion Middleware
Oracle SOA Suite, version(s) 11.1.1.7, 12.1.3.0 Fusion Middleware
Oracle Waveset, version(s) 8.1.1 Fusion Middleware
Oracle WebCenter Content, version(s) 11.1.1.8.0 Fusion Middleware
Oracle WebLogic Portal, version(s) 10.0.1.0, 10.2.1.0, 10.3.6.0 Fusion Middleware
Oracle WebLogic Server, version(s) 10.0.2.0, 10.3.6.0, 12.1.1.0, 12.1.2.0, 12.1.3.0 Fusion Middleware
Enterprise Manager Base Platform, version(s) 12.1.0.3, 12.1.0.4 Enterprise Manager
Enterprise Manager Ops Center, version(s) 11.1, 11.1.3, 12.1, 12.1.4, 12.2 Enterprise Manager
Oracle E-Business Suite, version(s) 11.5.10.2, 12.0.4, 12.0.5, 12.0.6, 12.1.1, 12.1.2, 12.1.3, 12.2.2, 12.2.3, 12.2.4 E-Business Suite
Oracle Agile PLM, version(s) 9.3.3 Oracle Supply Chain
Oracle Agile PLM for Process, version(s) 6.1.0.3 Oracle Supply Chain
Oracle Transportation Management, version(s) 6.1, 6.2, 6.3.0, 6.3.1, 6.3.2, 6.3.3, 6.3.4, 6.3.5 Oracle Supply Chain
PeopleSoft Enterprise HRMS, version(s) 9.1 PeopleSoft
PeopleSoft Enterprise PeopleTools, version(s) 8.52, 8.53, 8.54 PeopleSoft
JD Edwards EnterpriseOne Tools, version(s) 9.1.5 JD Edwards
Oracle Enterprise Asset Management, version(s) 8.1.1, 8.2.2 Siebel
Siebel Applications, version(s) 8.1.1, 8.2.2 Siebel
Oracle iLearning, version(s) 6.0, 6.1 iLearning
Oracle Communications Diameter Signaling Router, version(s) 3.x, 4.x, 5.0 Communications
Oracle Communications Messaging Server, version(s) 7.0.5.33.0 and prior Communications
Oracle MICROS Retail, version(s) Xstore: 3.2.1, 3.4.2, 3.5.0, 4.0.1, 4.5.1, 4.8.0, 5.0.3, 5.5.3, 6.0.6, 6.5.2 Retail
Oracle Healthcare Master Person Index, version(s) 1.x, 2.x Health Sciences
Oracle Java SE, version(s) 5.0u75, 6u85, 7u72, 8u25 Oracle Java SE
Oracle Java SE Embedded, version(s) 7u71, 8u6 Oracle Java SE
Oracle JRockit, version(s) R27.8.4, R28.3.4 Oracle Java SE
Fujitsu M10-1, M10-4, M10-4S Servers, version(s) prior to XCP 2240 Oracle and Sun Systems Products Suite
Integrated Lights Out Manager(ILOM), version(s) prior to 3.2.4 Oracle and Sun Systems Products Suite
Solaris, version(s) 10, 11 Oracle and Sun Systems Products Suite
Solaris Cluster, version(s) 3.3, 4.1 Oracle and Sun Systems Products Suite
SPARC Enterprise M3000, M4000, M5000, M8000, M9000 Servers, version(s) before XCP 1119 Oracle and Sun Systems Products Suite
Oracle Secure Global Desktop, version(s) 4.63, 4.71, 5.0, 5.1 Oracle Linux and Virtualization
Oracle VM VirtualBox, version(s) prior to 3.2.26, 4.0.28, 4.1.36, 4.2.28, 4.3.20 Oracle Linux and Virtualization
MySQL Server, version(s) 5.5.40 and prior, 5.6.21 and prior Oracle MySQL Product Suite


Patch Availability Table and Risk Matrices


Patch Availability Table


For each administered Oracle product, consult the documentation for patch availability information and installation instructions referenced from the following table. For an overview of the Oracle product documentation related to this Critical Patch Update, please refer to the Oracle Critical Patch Update January 2015 Documentation Map, My Oracle Support Note 1935468.1.


Product Group Risk Matrix Patch Availability and Installation Information
Oracle Database Oracle Database Risk Matrix Patch Set Update and Critical Patch Update January 2015 Availability Document, My Oracle Support Note 1942215.1
Oracle Fusion Middleware Oracle Fusion Middleware Risk Matrix Patch Set Update and Critical Patch Update January 2015 Availability Document, My Oracle Support Note 1942215.1
Oracle Fusion Applications Oracle Database Risk Matrix and Oracle Fusion Middleware Risk Matrix Vulnerabilities affecting Oracle Database and Oracle Fusion Applications may affect Oracle Fusion Applications, so Oracle customers should refer to Oracle Fusion Applications Critical Patch Update Knowledge Document (January 2015) My Oracle Support Note 1955858.1 for information on patches to be applied to Fusion Application environments.
Oracle Enterprise Manager Oracle Enterprise Manage Risk Matrix Patch Set Update and Critical Patch Update January 2015 Availability Document, My Oracle Support Note 1942215.1
Oracle Applications - E-Business Suite Oracle E-Business Suite Risk Matrix Patch Set Update and Critical Patch Update January 2015 Availability Document, My Oracle Support Note 1954250.1
Oracle Applications - Oracle Supply Chain, PeopleSoft Enterprise, JD Edwards Product Suite, Siebel and iLearning Oracle Supply Chain Risk Matrix
Oracle PeopleSoft Enterprise Risk Matrix
Oracle JD Edwards Risk Matrix
Oracle Siebel Risk Matrix
Oracle iLearning Risk Matrix
Critical Patch Update Knowledge Document for Oracle Supply Chain, PeopleSoft Enterprise, JD Edwards, Siebel and iLearning Product SuiteMy Oracle Support Note 1955920.1
Oracle Communications Industry Suite Oracle Communications Applications Risk Matrix Patch Set Update and Critical Patch Update January 2015 Availability Document, My Oracle Support Note 1958369.1
Oracle Retail Industry Suite Oracle Retail Applications Risk Matrix Patch Set Update and Critical Patch Update January 2015 Availability Document, My Oracle Support Note 1955864.1
Oracle Health Sciences Industry Suite Oracle Health Sciences Applications Risk Matrix Patch Set Update and Critical Patch Update January 2015 Availability Document, My Oracle Support Note 1958531.1
Oracle Java SE Oracle SE Risk Matrix
  • Critical Patch Update January 2015 Patch Availability Document for Java SE, My Oracle Support Note 1948935.1
  • Users running Java SE with a browser can download the latest release from http://java.com. Users on the Windows and Mac OS X platforms can also use automatic updates to get the latest release.
  • The latest JavaFX release is included with the latest update of JDK and JRE 7 and 8.
Oracle and Sun Systems Products Suite Oracle and Sun Systems Products Suite Risk Matrix Critical Patch Update January 2015 Patch Delivery Document for Oracle and Sun Systems Product Suite, My Oracle Support Note 1956176.1
Oracle Linux and Virtualization Products Oracle Linux and Virtualization Products Risk Matrix Patch Set Update and Critical Patch Update January 2015 Availability Document, My Oracle Support Note 1955899.1
Oracle MySQL Oracle MySQL Risk Matrix Critical Patch Update January 2015 Patch Availability Document for Oracle MySQL Products, My Oracle Support Note 1956125.1

Risk Matrix Content


Risk matrices list only security vulnerabilities that are newly fixed by the patches associated with this advisory. Risk matrices for previous security fixes can be found in previous Critical Patch Update advisories. An English text version of the risk matrices provided in this document is available here.


Several vulnerabilities addressed in this Critical Patch Update affect multiple products. Each vulnerability is identified by a CVE# which is a unique identifier for a vulnerability. A vulnerability that affects multiple products will appear with the same CVE# in all risk matrices. A CVE# shown in italics indicates that this vulnerability impacts a different product, but also has impact on the product where the italicized CVE# is listed.


Security vulnerabilities are scored using CVSS version 2.0 (see Oracle CVSS Scoring for an explanation of how Oracle applies CVSS 2.0). Oracle conducts an analysis of each security vulnerability addressed by a Critical Patch Update (CPU). Oracle does not disclose information about the security analysis, but the resulting Risk Matrix and associated documentation provide information about the type of vulnerability, the conditions required to exploit it, and the potential impact of a successful exploit. Oracle provides this information, in part, so that customers may conduct their own risk analysis based on the particulars of their product usage. For more information, see Oracle vulnerability disclosure policies.


The protocol in the risk matrix implies that all of its secure variants (if applicable) are affected as well. For example, if HTTP is listed as an affected protocol, it implies that HTTPS (if applicable) is also affected. The secure variant of a protocol is listed in the risk matrix only if it is the only variant affected, e.g. HTTPS will typically be listed for vulnerabilities in SSL and TLS.


Workarounds

Due to the threat posed by a successful attack, Oracle strongly recommends that customers apply CPU fixes as soon as possible. Until you apply the CPU fixes, it may be possible to reduce the risk of successful attack by blocking network protocols required by an attack. For attacks that require certain privileges or access to certain packages, removing the privileges or the ability to access the packages from users that do not need the privileges may help reduce the risk of successful attack. Both approaches may break application functionality, so Oracle strongly recommends that customers test changes on non-production systems. Neither approach should be considered a long-term solution as neither corrects the underlying problem.


Skipped Critical Patch Updates

Oracle strongly recommends that customers apply security fixes as soon as possible. For customers that have skipped one or more Critical Patch Updates and are concerned about products that do not have security fixes announced in this CPU, please review previous Critical Patch Update advisories to determine appropriate actions.


Product Dependencies

Oracle products may have dependencies on other Oracle products. Hence security vulnerability fixes announced in this Critical Patch Update may affect one or more dependent Oracle products. For details regarding these dependencies and how to apply patches to dependent products, please refer to Patch Set Update and Critical Patch Update January 2015 Availability Document, My Oracle Support Note 1942215.1.


Critical Patch Update Supported Products and Versions

Patches released through the Critical Patch Update program are provided only for product versions that are covered under the Premier Support or Extended Support phases of the Lifetime Support Policy. We recommend that customers plan product upgrades to ensure that patches released through the Critical Patch Update program are available for the versions they are currently running.


Product releases that are not under Premier Support or Extended Support are not tested for the presence of vulnerabilities addressed by this Critical Patch Update. However, it is likely that earlier versions of affected releases are also affected by these vulnerabilities. As a result, Oracle recommends that customers upgrade to supported versions.


Supported Database, Fusion Middleware, Oracle Enterprise Manager Base Platform (formerly "Oracle Enterprise Manager Grid Control") and Collaboration Suite products are patched in accordance with the Software Error Correction Support Policy explained in My Oracle Support Note 209768.1. Please review the Technical Support Policies for further guidelines regarding support policies and phases of support.


Products in Extended Support

Patches released through the Critical Patch Update program are available to customers who have purchased Extended Support under the Lifetime Support Policy. Customers must have a valid Extended Support service contract to download patches released through the Critical Patch Update program for products in the Extended Support Phase.


Credit Statement

The following people or organizations reported security vulnerabilities addressed by this Critical Patch Update to Oracle: Adam Willard of Foreground Security; Advanced Threat Research Team, Intel Security; Alexander Chizhov; Alexey Makhmutov; Bart Kulach of NN Group N.V.; David Litchfield of Datacom TSS; Diego Matos of CIPHER Intelligence Lab; Edmund Goh of KPMG Management Consulting, Singapore; Edward Torkington of NCC Group; Frank Cozijnsen of KPN; Gabor Pesti; George Nosenko of Digital Security Research Group; Jeremy Brown of Microsoft; Joeri de Ruiter of Radboud University Nijmegen; Karthikeyan Bhargavan; Khai Tran of Netspi; Khalifa Al Shamsi of Help AG; Nicolas Ruff of the Google Security Team; Oliver Gruskovnjak of Portcullis Inc; Red Hat Product Security; Tor Erling Bjorstad of Mnemonic AS; Tudor Enache of Help AG; Vivek Singh of FINRA; and Wouter Coekaerts.


Security-In-Depth Contributors


Oracle provides recognition to people that have contributed to our Security-In-Depth program (see FAQ). People are recognized for Security-In-Depth contributions if they provide information, observations or suggestions pertaining to security vulnerability issues that result in significant modification of Oracle code or documentation in future releases, but are not of such a critical nature that they are distributed in Critical Patch Updates.

In this Critical Patch Update Advisory, Oracle recognizes Alexander Kornbrust of Red Database Security; Bruce Robb of J&B Computing Services; and Yasumasa Suenaga for contributions to Oracle's Security-In-Depth program.


On-Line Presence Security Contributors


Oracle provides recognition to people that have contributed to our On-Line Presence Security program (see FAQ). People are recognized for contributions relating to Oracle's on-line presence if they provide information, observations or suggestions pertaining to security-related issues that result in significant modification to Oracle's on-line external-facing systems.

For this quarter, Oracle recognizes Abdullah Erdem; Adam Willard of Foreground Security; Amir Sohail; Arjun V; Avik Sarkar; Ayoub Nait Lamine; Ben Khlifa Fahmi; Cameron Crowley; Christian Galeone; Gaurav Mishra; Gopal Bisht; Gurjant Singh Sadhra; Karthik E C; Koutrouss Naddara; M.Asim Shahzad; Mohammed Osman; Monendra Sahu; Mousab Elhag; Muhammad Sarmad Shafiq; Rakesh Singh of Zero Day Guys; Sandeep Venkatesan; Sky_BlaCk; Sreehari; Srikanth Y; and Yann CAM for contributions to Oracle's On-Line Presence Security program.


Critical Patch Update Schedule

Critical Patch Updates are released on the Tuesday closest to the 17th day of January, April, July and October. The next four dates are:

  • 14 April 2015
  • 14 July 2015
  • 20 October 2015
  • 19 January 2016

References


Modification History


2015-January-20 Rev 1. Initial Release
2015-March-10 Rev 2. Updated credit information.

 

Appendix - Oracle Database Server

 

 

Oracle Database Server Executive Summary

 

This Critical Patch Update contains 8 new security fixes for the Oracle Database Server.  None of these vulnerabilities may be remotely exploitable without authentication, i.e., none may be exploited over a network without the need for a username and password.  None of these fixes are applicable to client-only installations, i.e., installations that do not have the Oracle Database Server installed. The English text form of this Risk Matrix can be found here.

 

Oracle Database Server Risk Matrix


CVE# Component Protocol Package and/or Privilege Required Remote Exploit without Auth.? CVSS VERSION 2.0 RISK (see Risk Matrix Definitions) Supported Versions Affected Notes
Base Score Access Vector Access Complexity Authen-
tication
Confiden-
tiality
Integrity Avail-
ability
CVE-2014-6567 Core RDBMS Oracle Net Create Session No 9.0 Network Low Single Complete Complete Complete 11.1.0.7, 11.2.0.3, 11.2.0.4, 12.1.0.1, 12.1.0.2 See Note 1
CVE-2014-6577 XML Developer's Kit for C HTTP Valid account No 6.8 Network Low Single Complete None None 11.2.0.3, 11.2.0.4, 12.1.0.1, 12.1.0.2 See Note 2
CVE-2015-0373 OJVM Oracle Net Create Session No 6.5 Network Low Single Partial+ Partial+ Partial+ 11.1.0.7, 11.2.0.3, 11.2.0.4, 12.1.0.1, 12.1.0.2 See Note 3
CVE-2014-6578 Workspace Manager Oracle Net Create Table, Create Procedure, Execute on SDO_TOPO, Execute on WMSYS.LT No 6.5 Network Low Single Partial+ Partial+ Partial+ 11.1.0.7, 11.2.0.3, 11.2.0.4, 12.1.0.1  
CVE-2014-6541 Recovery Oracle Net Execute on DBMS_IR No 6.3 Network Medium Single Complete None None 11.1.0.7, 11.2.0.3, 11.2.0.4, 12.1.0.1, 12.1.0.2 See Note 4
CVE-2015-0371 Core RDBMS Oracle Net Create Session, Create Table No 4.9 Network Medium Single None Partial+ Partial 11.1.0.7, 11.2.0.3, 11.2.0.4, 12.1.0.1  
CVE-2014-6514 PL/SQL Oracle Net Create Session No 4.0 Network Low Single Partial+ None None 11.1.0.7, 11.2.0.3, 11.2.0.4, 12.1.0.1  
CVE-2015-0370 Core RDBMS Oracle Net Create Session No 3.5 Network Medium Single None Partial None 11.1.0.7, 11.2.0.3, 11.2.0.4, 12.1.0.1  
 

 

Notes:

  1. The CVSS Score is 9.0 only on Windows for Database versions prior to 12c. The CVSS Base Score is 6.5 (Confidentiality, Integrity and Availability are Partial+) for Database 12c on Windows and for all versions of Database on Linux, Unix and other platforms.
  2. The CVSS score is 6.8 only on Windows for Database versions prior to 12c. The CVSS is 4.0 (Confidentiality is "Partial+") for Database 12c on Windows and for all versions of Database on Linux, Unix and other platforms.
  3. This brings the OJVM component of Database in line with Java SE security fixes delivered as of January CPU 2015.
  4. This vulnerability is only applicable on a Windows operating system. The CVSS score is 6.3 for Database versions prior to 12c. The CVSS is 3.5 (Confidentiality is "Partial+") for Database 12c.

 

Appendix - Oracle Fusion Middleware

 

 

Oracle Fusion Middleware Executive Summary

 

This Critical Patch Update contains 36 new security fixes for Oracle Fusion Middleware.  28 of these vulnerabilities may be remotely exploitable without authentication, i.e., may be exploited over a network without the need for a username and password.  The English text form of this Risk Matrix can be found here.

Oracle Fusion Middleware products include Oracle Database components that are affected by the vulnerabilities listed in the Oracle Database section. The exposure of Oracle Fusion Middleware products is dependent on the Oracle Database version being used. Oracle Database security fixes are not listed in the Oracle Fusion Middleware risk matrix. However, since vulnerabilities affecting Oracle Database versions may affect Oracle Fusion Middleware products, Oracle recommends that customers apply the January 2015 Critical Patch Update to the Oracle Database components of Oracle Fusion Middleware products. For information on what patches need to be applied to your environments, refer to Critical Patch Update January 2015 Patch Availability Document for Oracle Products, My Oracle Support Note 1942215.1 1.

 

Oracle Fusion Middleware Risk Matrix


CVE# Component Protocol Sub-
component
Remote Exploit without Auth.? CVSS VERSION 2.0 RISK (see Risk Matrix Definitions) Supported Versions Affected Notes
Base Score Access Vector Access Complexity Authen-
tication
Confiden-
tiality
Integrity Avail-
ability
CVE-2011-1944 Oracle HTTP Server HTTP Web Listener Yes 9.3 Network Medium None Complete Complete Complete 11.1.1.7.0, 12.1.2.0, 12.1.3.0  
CVE-2014-0224 Oracle Exalogic Infrastructure HTTP Network Infra Framework Yes 7.6 Network High None Complete Complete Complete 2.0.6.2.0 (for all X2-2, X3-2, X4-2)  
CVE-2013-1741 Oracle Directory Server Enterprise Edition HTTPS Admin Server Yes 7.5 Network Low None Partial+ Partial+ Partial+ 7.0, 11.1.1.7 See Note 1
CVE-2015-0396 Oracle GlassFish Server HTTP Admin Console Yes 7.5 Network Low None Partial Partial Partial 3.0.1, 3.1.2  
CVE-2014-0114 Oracle Real-Time Decision Server HTTP Decision Server Yes 7.5 Network Low None Partial Partial Partial 11.1.1.7, RTD Platform 3.0.x  
CVE-2014-0114 Oracle Waveset HTTP Struts Yes 7.5 Network Low None Partial Partial Partial 8.1.1  
CVE-2014-0114 Oracle WebLogic Portal HTTP Third Party Tools Yes 7.5 Network Low None Partial+ Partial+ Partial+ 10.0.1.0, 10.2.1.0, 10.3.6.0  
CVE-2013-2186 Oracle WebLogic Server HTTP WLS Config, WLS Console Yes 7.5 Network Low None Partial Partial Partial 10.3.6.0, 12.1.1.0, 12.1.2.0, 12.1.3.0 See Note 2
CVE-2014-0226 Oracle HTTP Server HTTP Web Listener Yes 6.8 Network Medium None Partial Partial Partial 10.1.3.5.0, 11.1.1.7.0, 12.1.2.0, 12.1.3.0 See Note 3
CVE-2014-6571 Oracle HTTP Server HTTP Web Listener Yes 6.8 Network Medium None Partial Partial Partial 11.1.1.7.0, 12.1.2.0, 12.1.3.0  
CVE-2013-4286 BI Publisher (formerly XML Publisher) HTTP BI Publisher Security Yes 5.8 Network Medium None Partial Partial None 10.1.3.4.2, 11.1.1.7  
CVE-2014-6576 Oracle Adaptive Access Manager HTTP OAM Integration No 5.5 Network Low Single Partial Partial None 11.1.1.5, 11.1.1.7, 11.1.2.1, 11.1.2.2  
CVE-2015-0362 BI Publisher (formerly XML Publisher) HTTP BI Publisher Security Yes 5.0 Network Low None Partial None None 11.1.1.7  
CVE-2015-0367 Oracle Access Manager HTTP SSO Engine Yes 5.0 Network Low None None Partial None 11.1.1.5, 11.1.1.7, 11.1.2.1, 11.1.2.2 See Note 4
CVE-2015-0372 Oracle Containers for J2EE HTTP None Yes 5.0 Network Low None Partial+ None None 10.1.3.5  
CVE-2013-2877 Oracle HTTP Server HTTP Web Listener Yes 5.0 Network Low None None None Partial 11.1.1.7.0, 12.1.2.0, 12.1.3.0  
CVE-2014-0098 Oracle HTTP Server HTTP Web Listener Yes 5.0 Network Low None None None Partial 10.1.3.5.0, 11.1.1.7.0, 12.1.2.0, 12.1.3.0  
CVE-2013-6438 Oracle HTTP Server HTTP Web Listener Yes 5.0 Network Low None None None Partial 10.1.3.5.0, 11.1.1.7.0, 12.1.2.0, 12.1.3.0  
CVE-2013-5704 Oracle HTTP Server HTTP Web Listener Yes 5.0 Network Low None None Partial None 10.1.3.5.0, 11.1.1.7.0, 12.1.2.0, 12.1.3.0  
CVE-2014-6569 Oracle WebLogic Server HTTP CIE Related Components Yes 5.0 Network Low None Partial None None 10.0.2.0, 10.3.6.0, 12.1.1.0, 12.1.2.0  
CVE-2014-6548 Oracle SOA Suite HTTP B2B Engine No 4.6 Local Low None Partial+ Partial+ Partial+ 11.1.1.7 See Note 5
CVE-2011-3607 Oracle HTTP Server HTTP Web Listener No 4.4 Local Medium None Partial Partial Partial 10.1.3.5.0, 11.1.1.7.0, 12.1.2.0  
CVE-2015-0434 Oracle Access Manager HTTP Integration with OAM Yes 4.3 Network Medium None Partial None None 11.1.1.5, 11.1.1.7, 11.1.2.1, 11.1.2.2  
CVE-2014-6526 Oracle Directory Server Enterprise Edition HTTP Admin Console Yes 4.3 Network Medium None None Partial None 7.0  
CVE-2015-0420 Oracle Forms HTTP Forms Services Yes 4.3 Network Medium None Partial None None 11.1.1.7, 11.1.2.2  
CVE-2014-0191 Oracle HTTP Server HTTP Web Listener Yes 4.3 Network Medium None None None Partial 11.1.1.7.0, 12.1.2.0, 12.1.3.0  
CVE-2013-0338 Oracle HTTP Server HTTP Web Listener Yes 4.3 Network Medium None None None Partial 11.1.1.7.0, 12.1.2.0, 12.1.3.0  
CVE-2015-0386 Oracle HTTP Server HTTP Web Listener Yes 4.3 Network Medium None None None Partial 11.1.1.7.0, 12.1.2.0, 12.1.3.0  
CVE-2014-6580 Oracle Reports Developer HTTP None Yes 4.3 Network Medium None None Partial None 11.1.1.7, 11.1.2.2  
CVE-2011-3389 Oracle Security Service HTTPS None Yes 4.3 Network Medium None Partial None None OHS: 12.1.2, FMW: 12.1.3  
CVE-2015-0376 Oracle WebCenter Content HTTP Content Server Yes 4.3 Network Medium None None Partial None 11.1.1.8.0  
CVE-2015-0399 Oracle Business Intelligence Enterprise Edition HTTP Analytics Web General No 4.0 Network Low Single Partial None None 10.1.3.4.2, 11.1.1.7  
CVE-2015-0401 Oracle Directory Server Enterprise Edition HTTP Admin Console No 4.0 Network Low Single None Partial+ None 7.0, 11.1.1.7  
CVE-2015-0389 Oracle OpenSSO HTTP SAML No 3.5 Network Medium Single None Partial None 8.0 Update 2 Patch 5  
CVE-2014-6592 Oracle OpenSSO HTTP SAML No 3.5 Network Medium Single None Partial None 8.0 Update 2 Patch 5  
CVE-2015-0414 Oracle SOA Suite HTTP Fabric Layer No 3.5 Network Medium Single Partial+ None None 11.1.1.7, 12.1.3.0  
 

 

Notes:

  1. This fix also addresses CVE-2013-1620, CVE-2013-1739,CVE-2013-1740, CVE-2013-5605, CVE-2013-5606,CVE-2014-1490, CVE-2014-1491 and CVE-2014-1492.
  2. This fix also addresses CVE-2014-0050. The CVSS score is taken from http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2013-2186.
  3. This fix also addresses CVE-2014-0117, CVE-2014-0118 and CVE-2014-0231.
  4. Please refer to My Oracle Support Note 1952939.1 for instructions on how to address this issue.
  5. Please refer to My Oracle Support Note 1962206.1 for instructions on how to address this issue.

 

Appendix - Oracle Enterprise Manager Grid Control

 

 

Oracle Enterprise Manager Grid Control Executive Summary

 

This Critical Patch Update contains 10 new security fixes for Oracle Enterprise Manager Grid Control.  All of these vulnerabilities may be remotely exploitable without authentication, i.e., may be exploited over a network without the need for a username and password.  None of these fixes are applicable to client-only installations, i.e., installations that do not have Oracle Enterprise Manager Grid Control installed. The English text form of this Risk Matrix can be found here.

Oracle Enterprise Manager products include Oracle Database and Oracle Fusion Middleware components that are affected by the vulnerabilities listed in the Oracle Database and Oracle Fusion Middleware sections. The exposure of Oracle Enterprise Manager products is dependent on the Oracle Database and Oracle Fusion Middleware versions being used. Oracle Database and Oracle Fusion Middleware security fixes are not listed in the Oracle Enterprise Manager risk matrix. However, since vulnerabilities affecting Oracle Database and Oracle Fusion Middleware versions may affect Oracle Enterprise Manager products, Oracle recommends that customers apply the January 2015 Critical Patch Update to the Oracle Database and Oracle Fusion Middleware components of Enterprise Manager. For information on what patches need to be applied to your environments, refer to Critical Patch Update January 2015 Patch Availability Document for Oracle Products, My Oracle Support Note 1942215.1.

 

Oracle Enterprise Manager Grid Control Risk Matrix


CVE# Component Protocol Sub-
component
Remote Exploit without Auth.? CVSS VERSION 2.0 RISK (see Risk Matrix Definitions) Supported Versions Affected Notes
Base Score Access Vector Access Complexity Authen-
tication
Confiden-
tiality
Integrity Avail-
ability
CVE-2013-2186 Enterprise Manager Ops Center HTTP File Upload Utility Yes 7.5 Network Low None Partial Partial Partial 11.1.3, 12.1.4 See Note 1
CVE-2014-0226 Enterprise Manager Ops Center HTTP Update Provisioning Yes 6.8 Network Medium None Partial Partial Partial 11.1.3, 12.1.4 See Note 2
CVE-2014-0224 Enterprise Manager Ops Center SSL/TLS Networking Yes 6.8 Network Medium None Partial Partial Partial 11.1.3, 12.1.4  
CVE-2011-4461 Enterprise Manager Base Platform HTTP Agent Yes 5.0 Network Low None None None Partial 12.1.0.3  
CVE-2015-0426 Enterprise Manager Base Platform HTTP UI Framework Yes 5.0 Network Low None Partial None None 12.1.0.3, 12.1.0.4  
CVE-2014-4212 Enterprise Manager Base Platform HTTPS Process Management & Notification Yes 4.3 Network Medium None Partial None None 12.1.0.3, 12.1.0.4  
CVE-2014-6573 Enterprise Manager Ops Center HTTP User Interface Framework Yes 4.3 Network Medium None None Partial None 11.1.3, 12.1.4  
CVE-2013-1620 Enterprise Manager Ops Center SSL/TLS Network Yes 4.3 Network Medium None Partial None None 11.1, 12.1, 12.2  
CVE-2013-4545 Enterprise Manager Ops Center SSL/TLS Update Provisioning Yes 4.3 Network Medium None None Partial None 11.1.3, 12.1.4 See Note 3
CVE-2014-3566 Enterprise Manager Ops Center SSL/TLS Update Provisioning Yes 4.3 Network Medium None Partial None None 11.1.3, 12.1.4  
 

 

Notes:

  1. This fix also addresses CVE-2014-0050. The CVSS score is taken from http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2013-2186.
  2. This fix also addresses CVE-2014-0117, CVE-2014-0118 and CVE-2014-0231.
  3. This fix also addresses CVE-2014-0015.

 

Appendix - Oracle Applications

 

 

Oracle E-Business Suite Executive Summary

 

This Critical Patch Update contains 10 new security fixes for the Oracle E-Business Suite.  6 of these vulnerabilities may be remotely exploitable without authentication, i.e., may be exploited over a network without the need for a username and password.  The English text form of this Risk Matrix can be found here.

Oracle E-Business Suite products include Oracle Database and Oracle Fusion Middleware components that are affected by the vulnerabilities listed in the Oracle Database and Oracle Fusion Middleware sections. The exposure of Oracle E-Business Suite products is dependent on the Oracle Database and Oracle Fusion Middleware versions being used. Oracle Database and Oracle Fusion Middleware security fixes are not listed in the Oracle E-Business Suite risk matrix. However, since vulnerabilities affecting Oracle Database and Oracle Fusion Middleware versions may affect Oracle E-Business Suite products, Oracle recommends that customers apply the January 2015 Critical Patch Update to the Oracle Database and Oracle Fusion Middleware components of Oracle E-Business Suite. For information on what patches need to be applied to your environments, refer to Oracle E-Business Suite Releases 11i and 12 Critical Patch Update Knowledge Document (January 2015), My Oracle Support Note 1954250.1.

 

Oracle E-Business Suite Risk Matrix


CVE# Component Protocol Sub-
component
Remote Exploit without Auth.? CVSS VERSION 2.0 RISK (see Risk Matrix Definitions) Supported Versions Affected Notes
Base Score Access Vector Access Complexity Authen-
tication
Confiden-
tiality
Integrity Avail-
ability
CVE-2014-6581 Oracle Customer Intelligence HTTP Extract/Load Programs Yes 6.4 Network Low None Partial+ Partial+ None 11.5.10.2, 12.0.4, 12.0.5, 12.0.6, 12.1.1, 12.1.2, 12.1.3, 12.2.2, 12.2.3, 12.2.4  
CVE-2014-6572 Oracle Customer Interaction History HTTP List of Values Yes 6.4 Network Low None Partial Partial None 12.0.4, 12.0.5, 12.0.6, 12.1.1, 12.1.2, 12.1.3, 12.2.2, 12.2.3, 12.2.4  
CVE-2014-6583 Oracle Marketing HTTP Audience Yes 6.4 Network Low None Partial+ Partial+ None 11.5.10.2, 12.0.4, 12.0.5, 12.0.6, 12.1.1, 12.1.2, 12.1.3.  
CVE-2015-0393 Oracle Applications DBA Oracle Net DB Privileges No 6.0 Network Medium Single Partial+ Partial+ Partial+ 11.5.10.2, 12.0.6, 12.1.3, 12.2.2, 12.2.3, 12.2.4  
CVE-2014-6582 Oracle HCM Configuration Workbench HTTP Rapid Implementation Yes 5.0 Network Low None Partial None None 11.5.10.2, 12.0.4, 12.0.5, 12.0.6, 12.1.1, 12.1.2, 12.1.3, 12.2.2, 12.2.3, 12.2.4  
CVE-2014-6556 Oracle Applications DBA Oracle Net AD_DDL No 4.6 Network High Single Partial+ Partial+ Partial+ 11.5.10.2, 12.0.6, 12.1.3, 12.2.2, 12.2.3, 12.2.4  
CVE-2015-0404 Oracle Applications Framework HTTP Error Messages Yes 4.3 Network Medium None None Partial None 11.5.10.2, 12.0.6, 12.1.3, 12.2.2, 12.2.3, 12.2.4  
CVE-2015-0380 Oracle Telecommunications Billing Integrator HTTP OA Based UI for Bill Summary Yes 4.3 Network Medium None None Partial None 11.5.10.2, 12.0.4, 12.0.5, 12.0.6, 12.1.1, 12.1.2, 12.1.3, 12.2.2, 12.2.3, 12.2.4  
CVE-2015-0415 Oracle Application Object Library HTTP Session Management No 4.0 Network Low Single None Partial None 12.1.3  
CVE-2014-6525 Oracle Web Applications Desktop Integrator HTTP Templates No 3.5 Network Medium Single None Partial None 11.5.10.2, 12.0.6, 12.1.3, 12.2.2, 12.2.3, 12.2.4  
 

 



 

Oracle Supply Chain Products Suite Executive Summary

 

This Critical Patch Update contains 6 new security fixes for the Oracle Supply Chain Products Suite.  3 of these vulnerabilities may be remotely exploitable without authentication, i.e., may be exploited over a network without the need for a username and password.  The English text form of this Risk Matrix can be found here.

 

Oracle Supply Chain Products Suite Risk Matrix


CVE# Component Protocol Sub-
component
Remote Exploit without Auth.? CVSS VERSION 2.0 RISK (see Risk Matrix Definitions) Supported Versions Affected Notes
Base Score Access Vector Access Complexity Authen-
tication
Confiden-
tiality
Integrity Avail-
ability
CVE-2015-0435 Oracle Transportation Management HTTP Security No 6.8 Network Low Single Complete None None 6.1, 6.2, 6.3.0, 6.3.1, 6.3.2, 6.3.3, 6.3.4, 6.3.5  
CVE-2015-0368 Oracle Transportation Management HTTP Security Yes 5.0 Network Low None None None Partial 6.1, 6.2, 6.3, 6.3.1, 6.3.2, 6.3.3, 6.3.4, 6.3.5  
CVE-2014-6574 Oracle Agile PLM for Process HTTP Testing Protocol Library Yes 4.3 Network Medium None None Partial None 6.1.0.3  
CVE-2015-0431 Oracle Transportation Management HTTP UI Infrastructure Yes 4.3 Network Medium None None Partial None 6.1, 6.2, 6.3.0 6.3.1, 6.3.2, 6.3.4, 6.3.5  
CVE-2015-0422 Oracle Transportation Management HTTP UI Infrastructure No 4.0 Network Low Single Partial None None 6.1, 6.2, 6.3.0, 6.3.1, 6.3.2, 6.3.3, 6.3.4, 6.3.5  
CVE-2015-0416 Oracle Agile PLM HTTP Roles & Privileges No 3.5 Network Medium Single None Partial+ None 9.3.3  
 

 



 

Oracle PeopleSoft Products Executive Summary

 

This Critical Patch Update contains 7 new security fixes for Oracle PeopleSoft Products.  1 of these vulnerabilities may be remotely exploitable without authentication, i.e., may be exploited over a network without the need for a username and password.  The English text form of this Risk Matrix can be found here.

 

Oracle PeopleSoft Products Risk Matrix


CVE# Component Protocol Sub-
component
Remote Exploit without Auth.? CVSS VERSION 2.0 RISK (see Risk Matrix Definitions) Supported Versions Affected Notes
Base Score Access Vector Access Complexity Authen-
tication
Confiden-
tiality
Integrity Avail-
ability
CVE-2014-6586 PeopleSoft Enterprise HRMS HTTP Time and Labor No 5.5 Network Low Single Partial Partial None 9.1  
CVE-2015-0379 PeopleSoft Enterprise PeopleTools HTTP PIA Core Technology Yes 4.3 Network Medium None None Partial None 8.54  
CVE-2014-6579 PeopleSoft Enterprise PeopleTools HTTP Integration Broker No 4.0 Network Low Single Partial None None 8.52, 8.53  
CVE-2014-6597 PeopleSoft Enterprise PeopleTools HTTP PIA Core Technology No 4.0 Network Low Single None Partial None 8.52, 8.53, 8.54  
CVE-2014-6566 PeopleSoft Enterprise PeopleTools HTTP Portal No 4.0 Network Low Single None Partial None 8.53  
CVE-2015-0394 PeopleSoft Enterprise PeopleTools HTTP Report Distribution No 4.0 Network Low Single Partial None None 8.52, 8.53  
CVE-2014-4279 PeopleSoft Enterprise PeopleTools HTTP PIA Core Technology No 3.5 Network Medium Single None Partial None 8.53  
 

 



 

Oracle JD Edwards Products Executive Summary

 

This Critical Patch Update contains 1 new security fix for Oracle JD Edwards Products.  This vulnerability is remotely exploitable without authentication, i.e., may be exploited over a network without the need for a username and password.  The English text form of this Risk Matrix can be found here.

 

Oracle JD Edwards Products Risk Matrix


CVE# Component Protocol Sub-
component
Remote Exploit without Auth.? CVSS VERSION 2.0 RISK (see Risk Matrix Definitions) Supported Versions Affected Notes
Base Score Access Vector Access Complexity Authen-
tication
Confiden-
tiality
Integrity Avail-
ability
CVE-2014-6565 JD Edwards EnterpriseOne Tools HTTP Portal SEC Yes 7.5 Network Low None Partial Partial Partial 9.1.5  
 

 



 

Oracle Siebel CRM Executive Summary

 

This Critical Patch Update contains 17 new security fixes for Oracle Siebel CRM.  7 of these vulnerabilities may be remotely exploitable without authentication, i.e., may be exploited over a network without the need for a username and password.  The English text form of this Risk Matrix can be found here.

 

Oracle Siebel CRM Risk Matrix


CVE# Component Protocol Sub-
component
Remote Exploit without Auth.? CVSS VERSION 2.0 RISK (see Risk Matrix Definitions) Supported Versions Affected Notes
Base Score Access Vector Access Complexity Authen-
tication
Confiden-
tiality
Integrity Avail-
ability
CVE-2015-0366 Siebel Core - EAI HTTP Java Integration Yes 5.0 Network Low None Partial None None 8.1.1, 8.2.2  
CVE-2015-0392 Siebel Core - Server BizLogic Script HTTP Config - Scripting No 4.6 Network High Single Partial Partial Partial 8.1.1, 8.2.2  
CVE-2015-0425 Oracle Enterprise Asset Management HTTP Siebel Core - Unix/Windows Yes 4.3 Network Medium None Partial None None 8.1.1, 8.2.2  
CVE-2015-0402 Siebel Core - Server BizLogic Script HTTP Integration - COM Yes 4.3 Network Medium None None Partial None 8.1.1, 8.2.2  
CVE-2015-0365 Siebel Core - Server Infrastructure HTTP Security Yes 4.3 Network Medium None Partial None None 8.1.1, 8.2.2  
CVE-2015-0369 Siebel UI Framework HTTP AX/HI Web UI Yes 4.3 Network Medium None None Partial None 8.1.1, 8.2.2  
CVE-2014-6596 Siebel UI Framework HTTP Portal Framework Yes 4.3 Network Medium None None Partial None 8.1.1, 8.2.2  
CVE-2015-0419 Siebel UI Framework HTTP Portal Framework Yes 4.3 Network Medium None Partial None None 8.1.1, 8.2.2  
CVE-2015-0387 Siebel Core - Server OM Services HTTP Security - LDAP Security Adapter No 4.0 Network Low Single Partial None None 8.1.1, 8.2.2  
CVE-2014-6528 Siebel Core - System Management HTTP Server Infrastructure No 4.0 Network Low Single Partial None None 8.1.1, 8.2.2  
CVE-2015-0363 Siebel Core EAI HTTP Integration Business Services No 4.0 Network Low Single None None Partial 8.1.1, 8.2.2  
CVE-2015-0398 Siebel Life Sciences HTTP Clinical Trip Report No 4.0 Network Low Single Partial None None 8.1.1, 8.2.2  
CVE-2015-0388 Siebel UI Framework HTTP Portal Framework No 4.0 Network Low Single Partial None None 8.1.1, 8.2.2  
CVE-2015-0417 Siebel UI Framework HTTP Portal Framework No 4.0 Network Low Single Partial None None 8.1.1, 8.2.2  
CVE-2014-6599 Siebel Core - Common Components HTTP Email No 3.5 Network Medium Single Partial None None 8.1.1, 8.2.2  
CVE-2015-0364 Siebel Core - EAI HTTP Integration Business Services No 3.5 Network Medium Single None None Partial 8.1.1, 8.2.2  
CVE-2015-0384 Siebel Public Sector HTTP Public Sector Portal No 3.5 Network Medium Single None Partial None 8.1.1, 8.2.2  
 

 



 

Oracle iLearning Executive Summary

 

This Critical Patch Update contains 2 new security fixes for Oracle iLearning.  Both of these vulnerabilities may be remotely exploitable without authentication, i.e., may be exploited over a network without the need for a username and password.  The English text form of this Risk Matrix can be found here.

 

Oracle iLearning Risk Matrix


CVE# Component Protocol Sub-
component
Remote Exploit without Auth.? CVSS VERSION 2.0 RISK (see Risk Matrix Definitions) Supported Versions Affected Notes
Base Score Access Vector Access Complexity Authen-
tication
Confiden-
tiality
Integrity Avail-
ability
CVE-2014-6594 Oracle iLearning HTTP Learner Pages Yes 4.3 Network Medium None Partial None None 6.0, 6.1  
CVE-2015-0436 Oracle iLearning HTTP Login Yes 4.3 Network Medium None Partial None None 6.0, 6.1  
 

 


 

Appendix - Oracle Industry Applications

 

 

Oracle Communications Applications Executive Summary

 

This Critical Patch Update contains 2 new security fixes for Oracle Communications Applications.  Both of these vulnerabilities may be remotely exploitable without authentication, i.e., may be exploited over a network without the need for a username and password.  The English text form of this Risk Matrix can be found here.

 

Oracle Communications Applications Risk Matrix


CVE# Component Protocol Sub-
component
Remote Exploit without Auth.? CVSS VERSION 2.0 RISK (see Risk Matrix Definitions) Supported Versions Affected Notes
Base Score Access Vector Access Complexity Authen-
tication
Confiden-
tiality
Integrity Avail-
ability
CVE-2014-6598 Oracle Communications Diameter Signaling Router Diameter Signaling - DPI Yes 7.6 Network High None Complete Complete Complete 3.x, 4.x, 5.0  
CVE-2014-1568 Oracle Communications Messaging Server SSL/TLS Security Yes 7.5 Network Low None Partial Partial Partial 7.0.5.33.0 and earlier  
 

 



 

Oracle Retail Applications Executive Summary

 

This Critical Patch Update contains 1 new security fix for Oracle Retail Applications.  This vulnerability is remotely exploitable without authentication, i.e., may be exploited over a network without the need for a username and password.  The English text form of this Risk Matrix can be found here.

 

Oracle Retail Applications Risk Matrix


CVE# Component Protocol Sub-
component
Remote Exploit without Auth.? CVSS VERSION 2.0 RISK (see Risk Matrix Definitions) Supported Versions Affected Notes
Base Score Access Vector Access Complexity Authen-
tication
Confiden-
tiality
Integrity Avail-
ability
CVE-2015-0390 MICROS Retail Proprietary XML Xstore Point of Sale Yes 6.8 Network Medium None Partial Partial Partial Xstore: 3.2.1, 3.4.2, 3.5.0, 4.0.1, 4.5.1, 4.8.0, 5.0.3, 5.5.3, 6.0.6, 6.5.2  
 

 



 

Oracle Health Sciences Applications Executive Summary

 

This Critical Patch Update contains 1 new security fix for Oracle Health Sciences Applications.  This vulnerability is remotely exploitable without authentication, i.e., may be exploited over a network without the need for a username and password.  The English text form of this Risk Matrix can be found here.

 

Oracle Health Sciences Applications Risk Matrix


CVE# Component Protocol Sub-
component
Remote Exploit without Auth.? CVSS VERSION 2.0 RISK (see Risk Matrix Definitions) Supported Versions Affected Notes
Base Score Access Vector Access Complexity Authen-
tication
Confiden-
tiality
Integrity Avail-
ability
CVE-2013-2186 Oracle Healthcare Master Person Index HTTP Internal Operations Yes 7.5 Network Low None Partial Partial Partial 1.x, 2.x See Note 1
 

 

Notes:

  1. This fix also addresses CVE-2014-0050. The CVSS score is taken from http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2013-2186.

 

Appendix - Oracle Java SE

 

 

Oracle Java SE Executive Summary

 

This Critical Patch Update contains 19 new security fixes for Oracle Java SE.  14 of these vulnerabilities may be remotely exploitable without authentication, i.e., may be exploited over a network without the need for a username and password.  The English text form of this Risk Matrix can be found here.


The CVSS scores below assume that a user running a Java applet or Java Web Start application has administrator privileges (typical on Windows). When the user does not run with administrator privileges (typical on Solaris and Linux), the corresponding CVSS impact scores for Confidentiality, Integrity, and Availability are "Partial" instead of "Complete", lowering the CVSS Base Score. For example, a Base Score of 10.0 becomes 7.5.


Users should only use the default Java Plug-in and Java Web Start from the latest JDK or JRE 7 and 8 releases.


My Oracle Support Note 360870.1 explains the impact of Java security vulnerabilities on Oracle products that include an Oracle Java SE JDK or JRE.

 

Oracle Java SE Risk Matrix


CVE# Component Protocol Sub-
component
Remote Exploit without Auth.? CVSS VERSION 2.0 RISK (see Risk Matrix Definitions) Supported Versions Affected Notes
Base Score Access Vector Access Complexity Authen-
tication
Confiden-
tiality
Integrity Avail-
ability
CVE-2014-6601 Java SE Multiple Hotspot Yes 10.0 Network Low None Complete Complete Complete Java SE 6u85, Java SE 7u72, Java SE 8u25 See Note 1
CVE-2015-0412 Java SE Multiple JAX-WS Yes 10.0 Network Low None Complete Complete Complete Java SE 6u85, Java SE 7u72, Java SE 8u25 See Note 1
CVE-2014-6549 Java SE Multiple Libraries Yes 10.0 Network Low None Complete Complete Complete Java SE 8u25 See Note 1
CVE-2015-0408 Java SE Multiple RMI Yes 10.0 Network Low None Complete Complete Complete Java SE 5.0u75, Java SE 6u85, Java SE 7u72, Java SE 8u25 See Note 1
CVE-2015-0395 Java SE Multiple Hotspot Yes 9.3 Network Medium None Complete Complete Complete Java SE 5.0u75, Java SE 6u85, Java SE 7u72, Java SE 8u25 See Note 1
CVE-2015-0437 Java SE Multiple Hotspot Yes 9.3 Network Medium None Complete Complete Complete Java SE 8u25 See Note 1
CVE-2015-0403 Java SE None Deployment No 6.9 Local Medium None Complete Complete Complete Java SE 6u85, Java SE 7u72, Java SE 8u25 See Note 1
CVE-2015-0421 Java SE None Install No 6.9 Local Medium None Complete Complete Complete Java SE 8u25 See Note 2
CVE-2015-0406 Java SE Multiple Deployment Yes 5.8 Network Medium None Partial None Partial Java SE 6u85, Java SE 7u72, Java SE 8u25 See Note 1
CVE-2015-0383 Java SE, Java SE Embedded, JRockit None Hotspot No 5.4 Local Medium None None Partial Complete Java SE 5.0u75, Java SE 6u85, Java SE 7u72, Java SE 8u25, Java SE Embedded 7u71, Java SE Embedded 8u6, JRockit R27.8.4, JRockit R28.3.4 See Note 3
CVE-2015-0400 Java SE Multiple Libraries Yes 5.0 Network Low None Partial None None Java SE 6u85, Java SE 7u72, Java SE 8u25 See Note 1
CVE-2015-0407 Java SE Multiple Swing Yes 5.0 Network Low None Partial None None Java SE 5.0u75, Java SE 6u85, Java SE 7u72, Java SE 8u25 See Note 1
CVE-2015-0410 Java SE, Java SE Embedded, JRockit Multiple Security Yes 5.0 Network Low None None None Partial Java SE 5.0u75, Java SE 6u85, Java SE 7u72, Java SE 8u25, Java SE Embedded 7u71, Java SE Embedded 8u6, JRockit R27.8.4, JRockit R28.3.4 See Note 3
CVE-2014-6587 Java SE None Libraries No 4.3 Local Low Single Partial Partial Partial Java SE 6u85, Java SE 7u72, Java SE 8u25 See Note 1
CVE-2014-3566 Java SE, Java SE Embedded, JRockit SSL/TLS JSSE Yes 4.3 Network Medium None Partial None None Java SE 5.0u75, Java SE 6u85, Java SE 7u72, Java SE 8u25, Java SE Embedded 7u71, Java SE Embedded 8u6, JRockit 27.8.4, JRockit 28.3.4 See Note 4
CVE-2014-6593 Java SE, Java SE Embedded, JRockit SSL/TLS JSSE Yes 4.0 Network High None Partial Partial None Java SE 5.0u75, Java SE 6u85, Java SE 7u72, Java SE 8u25, Java SE Embedded 7u71, Java SE Embedded 8u6, JRockit 27.8.4, JRockit 28.3.4 See Note 4
CVE-2014-6585 Java SE Multiple 2D Yes 2.6 Network High None Partial None None Java SE 5.0u75, Java SE 6u85, Java SE 7u72, Java SE 8u25 See Note 1
CVE-2014-6591 Java SE Multiple 2D Yes 2.6 Network High None Partial None None Java SE 5.0u75, Java SE 6u85, Java SE 7u72, Java SE 8u25 See Note 1
CVE-2015-0413 Java SE None Serviceability No 1.9 Local Medium None None Partial None Java SE 7u72, Java SE 8u25 See Note 1
 

 

Notes:

  1. Applies to client deployment of Java only. This vulnerability can be exploited only through sandboxed Java Web Start applications and sandboxed Java applets.
  2. Applies to installation process on client deployment of Java.
  3. Applies to client and server deployment of Java. This vulnerability can be exploited through sandboxed Java Web Start applications and sandboxed Java applets. It can also be exploited by supplying data to APIs in the specified Component without using sandboxed Java Web Start applications or sandboxed Java applets, such as through a web service.
  4. Applies to client and server deployment of JSSE.

 

Appendix - Oracle Sun Systems Products Suite

 

 

Oracle Sun Systems Products Suite Executive Summary

 

This Critical Patch Update contains 29 new security fixes for the Oracle Sun Systems Products Suite.  10 of these vulnerabilities may be remotely exploitable without authentication, i.e., may be exploited over a network without the need for a username and password.  The English text form of this Risk Matrix can be found here.

Solaris 8 and Solaris 9 are no longer covered by the Oracle Extended Support For Software. Hence, fixes and security alerts are no longer provided for these releases. In addition, new security issues are no longer assessed for applicability to Solaris 8 and Solaris 9. More information about support levels can be found in the Lifetime Support Policy document at

http://www.oracle.com/us/support/library/lifetime-support-hardware-301321.pdf

 

Oracle Sun Systems Products Suite Risk Matrix


CVE# Component Protocol Sub-
component
Remote Exploit without Auth.? CVSS VERSION 2.0 RISK (see Risk Matrix Definitions) Supported Versions Affected Notes
Base Score Access Vector Access Complexity Authen-
tication
Confiden-
tiality
Integrity Avail-
ability
CVE-2013-4784 Fujitsu M10-1, M10-4, M10-4S Servers SSL/TLS XCP Firmware Yes 10.0 Network Low None Complete Complete Complete XCP prior to XCP 2232  
CVE-2014-4259 Solaris Cluster TCP/IP System management No 9.0 Network Low Single Complete Complete Complete 3.3, 4.1  
CVE-2015-0424 Integrated Lights Out Manager(ILOM) SSL/TLS IPMI No 7.5 Network Medium Single Partial Partial Complete ILOM prior to 3.2.4  
CVE-2014-6521 Solaris None CDE - Power Management Utility No 7.2 Local Low None Complete Complete Complete 10  
CVE-2014-6524 Solaris None Kernel No 7.2 Local Low None Complete Complete Complete 10  
CVE-2014-6510 Solaris None Power Management Utility No 7.2 Local Low None Complete Complete Complete 11  
CVE-2014-6518 Solaris None Unix File System(UFS) No 6.6 Local Low None None Complete Complete 10, 11  
CVE-2014-6480 Solaris Cluster None System management No 6.5 Local Low Multiple Complete Complete Complete 3.3, 4.1  
CVE-2011-3368 SPARC Enterprise M3000, M4000, M5000, M8000, M9000 Servers HTTP XCP Firmware Yes 5.0 Network Low None Partial None None XCP prior to XCP 1118 See Note 1
CVE-2010-5107 SPARC Enterprise M3000, M4000, M5000, M8000, M9000 Servers SSH XCP Firmware Yes 5.0 Network Low None None None Partial XCP prior to XCP 1118  
CVE-2003-0001 Solaris TCP/IP AMD pcnet driver Yes 5.0 Network Low None Partial None None 10, 11  
CVE-2004-0230 Solaris TCP/IP Network Yes 5.0 Network Low None None None Partial 10, 11  
CVE-2015-0375 Solaris TCP/IP Network Yes 5.0 Network Low None Partial None None 10, 11  
CVE-2014-6575 Solaris TCP/IP Network Yes 5.0 Network Low None None None Partial 10, 11  
CVE-2014-6570 Solaris None File System No 4.9 Local Low None None None Complete 11  
CVE-2014-6600 Solaris None File System No 4.9 Local Low None None None Complete 11  
CVE-2014-6509 Solaris None Kernel No 4.9 Local Low None None None Complete 10  
CVE-2015-0428 Solaris None Resource Control No 4.9 Local Low None None None Complete 10, 11  
CVE-2014-3566 Fujitsu M10-1, M10-4, M10-4S Servers SSL/TLS XCP Firmware Yes 4.3 Network Medium None Partial None None XCP prior to XCP 2240  
CVE-2014-3566 SPARC Enterprise M3000, M4000, M5000, M8000, M9000 Servers SSL/TLS XCP Firmware Yes 4.3 Network Medium None Partial None None XCP prior to XCP 1119  
CVE-2014-6481 Solaris SSL/TLS KSSL Yes 4.3 Network Medium None Partial None None 10, 11  
CVE-2014-6584 Integrated Lights Out Manager(ILOM) HTTP Backup Restore No 4.0 Network Low Single Partial None None ILOM prior to 3.2.4  
CVE-2014-0224 Integrated Lights Out Manager(ILOM) SSL/TLS OpenSSL No 3.6 Network High Single Partial Partial None ILOM prior to 3.2.4  
CVE-2014-0224 SPARC Enterprise M3000, M4000, M5000, M8000, M9000 Servers SSL/TLS XCP Firmware No 3.6 Network High Single Partial Partial None XCP prior to XCP 1118  
CVE-2015-0429 Solaris None RPC Utility No 3.3 Local Medium None None Partial Partial 10, 11  
CVE-2013-6450 Integrated Lights Out Manager(ILOM) SSL/TLS OpenSSL No 2.1 Network High Single None None Partial ILOM prior to 3.2.4 See Note 2
CVE-2015-0397 Solaris None File System No 2.1 Local Low None None None Partial 11  
CVE-2015-0378 Solaris None Libc No 2.1 Local Low None None None Partial 11  
CVE-2015-0430 Solaris None RPC Utility No 1.9 Local Medium None Partial None None 10, 11  
 

 

Notes:

  1. This fix also addresses CVE-2011-4317 and CVE-2012-0053.
  2. This fix also addresses CVE-2013-6449.

 

Appendix - Oracle Linux and Virtualization

 

 

Oracle Virtualization Executive Summary

 

This Critical Patch Update contains 11 new security fixes for Oracle Virtualization.  4 of these vulnerabilities may be remotely exploitable without authentication, i.e., may be exploited over a network without the need for a username and password.  The English text form of this Risk Matrix can be found here.

 

Oracle Virtualization Risk Matrix


CVE# Component Protocol Sub-
component
Remote Exploit without Auth.? CVSS VERSION 2.0 RISK (see Risk Matrix Definitions) Supported Versions Affected Notes
Base Score Access Vector Access Complexity Authen-
tication
Confiden-
tiality
Integrity Avail-
ability
CVE-2014-3567 Oracle Secure Global Desktop SSL/TLS OpenSSL Yes 7.1 Network Medium None None None Complete 4.63, 4.71, 5.0, 5.1  
CVE-2014-0226 Oracle Secure Global Desktop HTTP Apache HTTP Server Yes 6.8 Network Medium None Partial Partial Partial 4.63, 4.71, 5.0, 5.1 See Note 1
CVE-2014-0224 Oracle VM VirtualBox SSL/TLS OpenSSL Yes 6.8 Network Medium None Partial Partial Partial VirtualBox prior to 3.2.24, 4.0.26, 4.1.34, 4.2.26, 4.3.14 See Note 2
CVE-2015-0377 Oracle VM VirtualBox None Core No 4.4 Local Medium Single None None Complete VirtualBox prior to 3.2.26, 4.0.28, 4.1.36, 4.2.28  
CVE-2014-3566 Oracle Secure Global Desktop SSL/TLS Client, Gateway JARP module, Gateway Reverse Proxy, Print Servlet (only in 5.0 & 5.1), SSL Daemon (ttassl), Web Server Yes 4.3 Network Medium None Partial None None 4.63, 4.71, 5.0, 5.1  
CVE-2014-6595 Oracle VM VirtualBox None VMSVGA device No 3.2 Local Low Single None Partial+ Partial+ VirtualBox prior to 4.3.20 See Note 3
CVE-2014-6588 Oracle VM VirtualBox None VMSVGA device No 3.2 Local Low Single None Partial+ Partial+ VirtualBox prior to 4.3.20 See Note 3
CVE-2014-6589 Oracle VM VirtualBox None VMSVGA device No 3.2 Local Low Single None Partial+ Partial+ VirtualBox prior to 4.3.20 See Note 3
CVE-2014-6590 Oracle VM VirtualBox None VMSVGA device No 3.2 Local Low Single None Partial+ Partial+ VirtualBox prior to 4.3.20 See Note 3
CVE-2015-0427 Oracle VM VirtualBox None VMSVGA device No 3.2 Local Low Single None Partial+ Partial+ VirtualBox prior to 4.3.20 See Note 3
CVE-2015-0418 Oracle VM VirtualBox None Core No 2.1 Local Low None None None Partial+ VirtualBox prior to 3.2.26, 4.0.28, 4.1.36, 4.2.28  
 

 

Notes:

  1. This fix also addresses CVE-2014-0231, CVE-2014-0118 and CVE-2014-5704.
  2. This fix also addresses CVE-2014-0221, CVE-2014-0195, CVE-2014-0198, CVE-2010-5298, CVE-2014-3470 and CVE-2014-0076.
  3. VMSVGA virtual graphics device is not documented and is disabled by default.

 

Appendix - Oracle MySQL

 

 

Oracle MySQL Executive Summary

 

This Critical Patch Update contains 9 new security fixes for Oracle MySQL.  3 of these vulnerabilities may be remotely exploitable without authentication, i.e., may be exploited over a network without the need for a username and password.  The English text form of this Risk Matrix can be found here.

 

Oracle MySQL Risk Matrix


CVE# Component Protocol Sub-
component
Remote Exploit without Auth.? CVSS VERSION 2.0 RISK (see Risk Matrix Definitions) Supported Versions Affected Notes
Base Score Access Vector Access Complexity Authen-
tication
Confiden-
tiality
Integrity Avail-
ability
CVE-2015-0411 MySQL Server MySQL Protocol Server : Security : Encryption Yes 7.5 Network Low None Partial Partial Partial 5.5.40 and earlier, 5.6.21 and earlier  
CVE-2015-0382 MySQL Server MySQL Protocol Server : Replication Yes 4.3 Network Medium None None None Partial+ 5.5.40 and earlier, 5.6.21 and earlier  
CVE-2015-0381 MySQL Server MySQL Protocol Server : Replication Yes 4.3 Network Medium None None None Partial+ 5.5.40 and earlier, 5.6.21 and earlier  
CVE-2015-0391 MySQL Server MySQL Protocol Server : DDL No 4.0 Network Low Single None None Partial+ 5.5.38 and earlier, 5.6.19 and earlier  
CVE-2015-0432 MySQL Server MySQL Protocol Server : InnoDB : DDL : Foreign Key No 4.0 Network Low Single None None Partial+ 5.5.40 and earlier  
CVE-2015-0409 MySQL Server MySQL Protocol Server : Optimizer No 4.0 Network Low Single None None Partial+ 5.6.21 and earlier  
CVE-2014-6568 MySQL Server MySQL Protocol Server : InnoDB : DML No 3.5 Network Medium Single None None Partial+ 5.5.40 and earlier, 5.6.21 and earlier  
CVE-2015-0385 MySQL Server MySQL Protocol Server : Pluggable Auth No 3.5 Network Medium Single None None Partial+ 5.6.21 and earlier  
CVE-2015-0374 MySQL Server MySQL Protocol Server : Security : Privileges : Foreign Key No 3.5 Network Medium Single Partial None None 5.5.40 and earlier, 5.6.21 and earlier