JET v3.2.0 Release Notes

v3.2.0 revision #35665 (17 July 2017)


These release notes cover the following topics:

View the Release Notes for the prior release (v3.1.0)

New Features included in v3.2.0

The ojFilePicker has been introduced as a preview component. We would love to hear feedback from those that choose to use it. You can provide that feedback via our Twitter feed @oraclejet or on the JET Community Forum


Significant JET changes since 3.1.0

This section lists significant consumer-facing changes that have been made to JET since v3.1.0. Where bugs or ERs were used to track the change, they are included below. The following list does not include changes that are internal implementations, or changes made to samples, demos, or test collateral. It is expected that application code will not need to be modified to uptake v3.2.0.


Component Changes

No changes in this release

API Changes

No changes in this release

Theme Changes

No changes in this release

Framework Changes

No changes in this release

Library Changes

No changes in this release

Tooling Changes

The ojet CLI tool continues as a preview in this release, however we have been listening to your feedback and have made the following updates to provide a more clear and consistent experience. Please review the ojet cli GitHub page for details on the API. Please continue to provide feedback via our Twitter feed @oraclejet or on the JET Community Forum

  • Changed 'ojet add theme' to 'ojet create theme'
  • Added 'ojet clean'
  • Added 'ojet strip'

Known Issues

The following table calls out specific known issues, with workarounds where available.

Category Bug # Description Workaround (if available)
Tooling N/A npm version 5 does not install the oraclejet module when scaffolding a JET hybrid app and building the app reports:
Warning: ENOENT: no such file or directory, open 'node_modules/oraclejet/package.json' Use --force to continue
[sudo] npm install -g npm@latest-4
Tooling N/A ios-sim version 5.1.0 may be installed locally by cordova-ios and serving the app to iOS simulator reports:
"Error: Cannot read property 'replace' of undefined"
cd hybrid/platforms/ios/cordova; npm install ios-sim@latest