Oracle JDeveloper and Application Development Framework 11g Release 2

Last updated: March 6, 2014 

Certification and Support Matrix

This document identifies the various third party and Oracle products that are supported to work with the 11g Release 2 versions of JDeveloper and Application Development Framework (ADF). Oracle ADF may support or certify with a super set of products than required for Oracle Fusion Middleware and this document serves as a reference for those cases. Also, please see the Oracle Fusion Middleware certification documentation

The versions of JDeveloper and ADF covered in this document are:

  • Oracle JDeveloper and ADF 11g Release 2 (11.1.2.0.x)
  • Oracle JDeveloper and ADF 11g Release 2 (11.1.2.1.x)
  • Oracle JDeveloper and ADF 11g Release 2 (11.1.2.2.x)
  • Oracle JDeveloper and ADF 11g Release 2 (11.1.2.3.x)
  • Oracle JDeveloper and ADF 11g Release 2 (11.1.2.4.x)

In this document, the term Certified is used to denote a configuration that is tested in house by the Quality Assurance team. The term Supported indicates a configuration that has not been fully tested, but that Oracle believes to be functional. In both cases, customers may log bugs with Oracle Support, and the development team will evaluate them and fix them if feasible.

 

Operating Systems

The following operating systems are supported for the JDeveloper IDE. Note, the Oracle ADF runtime components are certified as part of Fusion Middleware.

Operating System Oracle JDK 1.6 JRockit JDK 1.6 Oracle JDK 1.7 Java for Mac OS
Microsoft Windows XP SP3, Windows 7  Certified Certified Certified N/A
RedHat Enterprise Linux 5.0 Certified Certified Certified N/A
Oracle Enterprise Linux 5.0 Certified Certified Certified N/A
SUSE Linux Enterprise Server 11 Certified Certified Certified N/A
Apple Mac OS X 10.6 N/A N/A N/A Certified 
Other operating systems Supported Supported Supported N/A
Notes: 
  • JDK 7 supported added in 11.1.2.4.0.
    • There is a known, serious issue with this version of JDeveloper running with Oracle JDK 1.7 Update 25. For more information, see the issue for JDK 1.7 Update 25 (16710919) in the release notes, 
    • JDeveloper bundles Integrated WLS 10.3.5, which does not support JDK 7. To use JDK 7 for JDeveloper and Integrated WLS, you can install WLS 10.3.6 separately and create an "Integrated Server" connection to it from JDeveloper. 
  • 32 bit JDK required for profiling features.
  • For JDK 6, update 39 or later is recommended; for JDK 7, update 10 or later is recommended
  • On Mac OS 10.5 Java for Mac OS X 10.5 Update 8 or later is recommended, on Mac OS 10.6 Java for Mac OS X 10.6 Update 3 or later is recommended

 

Databases

Oracle distinguishes between the database development features of the JDeveloper IDE (SQL Worksheet, online and offline database, database modeling, etc) and the Oracle ADF runtime libraries, notably ADF Business Components, in terms of supported databases. Please also see Oracle TopLink certification information.

Database JDeveloper  ADF 
Oracle 11g Release 1, Release 2 Certified Certified
Oracle 10g Release 1, Release 2 Certified Certified
Oracle 10g XE, 11g XE Certified Certified
Oracle TimesTen 11g Certified Supported
Oracle Lite 10g Release 3 Certified Supported
Microsoft SQL Server 2008 Certified Certified
MySQL 5.1 Certified Supported
IBM DB2 9.5 Certified Certified
Sybase ASE 15 Certified Supported
Informix DS 10, 11.5 Certified Not Supported
Apache Derby 10.5 Certified Supported
SQLite 3.6 Certified Supported
Other SQL92 databases Supported Supported

For third party databases, JDeveloper is certified with the vendor-provided JDBC drivers. ADF is certified with the same drivers as the rest of FMW runtime components, namely the WebLogic (Data Direct) JDBC drivers. See also the  Oracle Fusion Middleware certification documentation.

 

Application Servers

Please also see Oracle TopLink certification information. Refer to the Oracle Fusion Middleware certification documentation for more information regarding ADF (or JRF) support for third party application servers.

Application Server JDeveloper ADF
Oracle WebLogic 11g Release 1 (10.3.x) Supported See below
Oracle WebLogic 11g Release 1 (10.3.5) Certified with 11.1.2.0+ Certified with 11.1.2.0.x, 11.1.2.1.x
Certified with 11.1.2.2+
Oracle WebLogic 11g Release 1 (10.3.6) Certified with 11.1.2.2+ Certified with 11.1.2.2+
IBM WebSphere 7 Certified Certified with WebSphere 7.0.0.13 AS or ND
GlassFish 3.1 Certified Certified with GlassFish Server 3.1.2 Full Platform (ADF Essentials only)
Tomcat 6 Certified Not Supported
JBoss 5 Certified Not Supported
 Notes:
  • Installing the ADF 11.1.2 runtime libraries on WebLogic 10.3.5 or 10.3.6 requires applying the ADF 11.1.2 patches on top of an existing Application Development Runtime installation of 11.1.1.5 or 11.1.1.6. ADF 11.1.2.0 and 11.1.2.1 are patches on top of Application Development Runtime 11.1.1.5.0. ADF 11.1.2.2+ are patches on top of Application Development Runtime 11.1.1.6.0. See the release notes for information on the specific patches needed for each release.

Browsers

The Oracle ADF Faces rich client components are certified or supported with the following browsers. Please also see Apache MyFaces Trinidad supported platforms information.

Browser ADF (ADF Faces)
Firefox 2.x through 13+ Certified
Internet Explorer 7, 8, 9, 10, 11 Certified
Safari 3.1.2, 4, 5 Certified
Chrome 1 through 20+ Certified
Safari (iOS) 4.3.3, 5 Supported

 

Notes:

- IE 11 support added as a post-release certification for 11.1.2.4.0. IE 11 support requires a patch from Oracle Support (patch #18277436 for 11.1.2.4.0)
- For the ADF Faces components that render in Flash, Flash 10+ is required.
- For Internet Explorer 8, 9, and 10, only Native mode is supported. View Compatibility mode should be disabled.
- XMLHTTP  support must be enabled.
- JavaScript must be enabled.
- Style Sheets support must be enabled.
 

Mobile Devices and Operating Systems 

The following operating systems and devices are supported for use with ADF Mobile applications. Due to the rapid evolution of mobile devices it is strongly recommended to stay current with updates Oracle issues to the ADF Mobile framework and extension. This document describes the supported devices and operating systems for the most recent ADF Mobile update. 

Supported operating systems and devices for ADF Mobile version 11.1.2.4.39.64.62 (Jan 2014)
Mobile Operating System Version Certified Devices Additional Supported Devices
iOS 6.x
iPad3 (6.1.3)
iPhone5 (6.0.1)
iPhone (4, 4S, 5)
iPad (2nd and 3rd generation)
iPod Touch (4th, and 5th generation) 
iPad Mini
iPad 4

iPhone (3Gs)
iPod (3rd generation)
iOS 7.x iPad Mini (7.0.4)
iPad (7.0.4)
iPhone (4, 4S, 5, 5S and 5C)
iPad (2nd, 3rd, and 4th generation)
iPod Touch (4th, and 5th generation) 
iPad Mini
Android 2.3.x   Any 2.3.x or above device with 1 Ghz processor (minimum)/1 Ghz Dual Core or better(Recommended) and 1 GB of total RAM. 
Android 3.x Asus Tablet (3.0) Any 3.x or above tablets with 1 Ghz processor (minimum)/1 Ghz Dual Core or better(Recommended) and 1 GB of total RAM. 
Android 4.x ´╗┐Asus EE Pad TF101 (4.0.3)
Acer Iconia (4.0.3)
Samsung Tab (4.0.3)
Samsung Galaxy S2 (4.1.2)
Motorola Xoom (4.1.2)
Asus Transformer TF700T (4.2.1)
Samsung Galaxy Note 8.0 (4.2.2)
Nexus 7 (4.2.2)
Nexus 7 (4.3)
Any 4.x or above device with 1 Ghz processor (minimum)/1 Ghz Dual Core or better(Recommended) and 1 GB of total RAM. 

 

Mobile SDK

The following environments are supported for developing ADF Mobile applications. Due to the rapid evolution of mobile devices it is strongly recommended to stay current with updates Oracle issues to the ADF Mobile framework and extension. This document describes the supported development kits for the most recent ADF Mobile update. 

Supported development kits for ADF Mobile version 11.1.2.4.39.64.51 (Oct 4, 2013)
Target Mobile Platform Mobile SDK Version Native Development Tools Version
iOS iOS SDK 6.x, iOS SDK 7.x xCode 5.0.0 minimum
Android Android SDK API Level 9 (minimum), API Level 17 (Android SDK 4.2) - Recommended, API Level 17 - Maximum Android SDK Tools 19.x (minimum) and 21.x (Recommended)

 

Mobile Browsers

The following mobile browsers are certified or supported for use with Oracle ADF Mobile Browser client. Oracle ADF Mobile Browser client uses Apache MyFaces Trinidad components. Please also see Apache MyFaces Trinidad supported platforms information.

Browser ADF Mobile
BlackBerry Browser 4 Certified
WebKit-based mobile browsers (iPhone Safari, Android Chrome, Nokia S60) Certified
Access NetFront 3 Certified
OpenWave (UP Browser) 7 Certified
Opera Mini 8 Certified
Pocket Internet Explorer for Windows Mobile 5, 6 Certified
Mobile Internet Browser 2.0 (Motorola) Certified
Other Basic XHTML mobile browsers Supported

 

Source Control Systems

Source Control System JDeveloper IDE
IBM ClearCase SCM 7.0 Certified
GNU CVS 1.11 Certified
Serena Dimensions 10.1 Certified
Perforce 2008 Certified
Subversion 1.6, SVNKit 1.3 Certified
Microsoft Visual Studio Team System 2008 TFS Certified

 

Desktop Clients

The following Windows desktop client applications are supported or certified with Oracle ADF Desktop Integration. ADF Desktop Integration also requires Internet Explorer.

Operating System ADF Runtime (ADF Desktop Integration)
Microsoft Windows XP Certified
Microsoft Windows Vista Supported
Microsoft Windows 7 Certified
Microsoft Office Products ADF Runtime (ADF Desktop Integration)
Excel 2007, 2010 (.xlsx, .xlsm) Certified

 

Team Productivity Center

The following provides details on certification information for Oracle Team Productivity Center.

Application Server Team Productivity Center Server
Apache Tomcat 7.0.12 Certified
Oracle Glassfish 3.0  Certified
Oracle WebLogic Server 10.3.x Certified
Database Team Productivity Center Server
Oracle Database 11g Certified
Oracle Database 10g Certified
MySQL 5.5 Certified
Repository Team Productivity Center Connectors
Atlassian JIRA 4.1.2 Certified
Bugzilla 3.6.2 Certified
IBM Rational Team Concert 2.0.0.2 iFix3 Certified
Microsoft Project Server 2007 Certified

 

Migration Support Matrix

         To >
v From

11.1.2.0 11.1.2.1 11.1.2.2 11.1.2.3 11.1.2.4
10.1.3.x Not Supported Not Supported Not Supported Not Supported Not Supported
11.1.1.0 Not Supported Not Supported Not Supported Not Supported Not Supported
11.1.1.1 Supported Supported Supported Supported Supported
11.1.1.2 Supported Supported Supported Supported Supported
11.1.1.3 Supported Supported Supported Supported Supported
11.1.1.4 Certified Certified Supported Supported Supported
11.1.1.5 Supported Supported Certified Supported Supported
11.1.1.6 Not Supported Not Supported Supported Certified Certified
11.1.1.7 Not Supported Not Supported Not Supported Not Supported Supported
11.1.2.0 N/A Certified Supported Supported Supported
11.1.2.1 N/A N/A Certified Supported Supported
11.1.2.2 N/A N/A N/A Certified Supported
11.1.2.3 N/A N/A N/A N/A Certified

 

 

 

false ,,,,,,,,,,,,,,,,