DMU Logo

Oracle Database Migration Assistant for Unicode:
Supported Configurations

Updated: July 2013

 

DMU Client Platform
 

The DMU user interface is supported to run on the following client platforms:

  • Microsoft Windows 7
  • Microsoft Windows Vista
  • Microsoft Windows XP with Service Pack 2
  • Microsoft Windows Server 2008
  • Microsoft Windows Server 2003 R2
  • Red Hat Enterprise Linux 5.x
  • Red Hat Enterprise Linux 4.x
  • Oracle Enterprise Linux 5.x
  • Oracle Enterprise Linux 4.x
  • SUSE Linux Enterprise Server (SLES) 10
  • SUSE Linux Enterprise Server (SLES) 11
  • Oracle Solaris SPARC
  • Oracle Solaris Intel
  • Hewlett-Packard HP-UX PA-RISC
  • Hewlett-Packard HP-UX Itanium

Both the 32-bit and 64-bit versions of the operating systems are supported. Use the JDK architecture that matches the operating system architecture.

The client platform must also meet the operating system version and desktop manager requirements of the Java SE Development Kit 6 as listed here. For additional HP-UX requirements, contact the vendor.

The requirements for the display device setup are:

  • Colors: 65536 or more
  • Resolution: 1024x768 or more
 
Database to Be Migrated
 

The DMU is supported to migrate databases in version 11.2.0.3 and later on all platforms on which the patch set 11.2.0.3 is available. No additional database patches need to be installed on top of version 11.2.0.3 or later for this purpose.

The database support information for older releases is provided below, separately for the Unix-like platforms and for the Microsoft Windows platforms.

 
 

Unix-like Platforms

 

On Unix-like platforms, the DMU is currently supported to migrate databases whose combination of version number and platform is marked with 'Yes' in the matrix below. Furthermore, patch #9825461 must be installed in a database older than 11.2.0.3 before you can connect to it with the DMU. See the Getting Started page for further details.

 
  Linux x86-64
(64 bit)
Linux IA64
(64 bit)
Solaris SPARC
(64 bit)
Solaris x86-64
(64 bit)
HP-UX Itanium
(64 bit)
HP-UX PA-RISC
(64 bit)
IBM AIX POWER
(64 bit)
10.2.0.4.4 Yes Yes Yes Yes Yes
10.2.0.5.0* Yes Yes Yes Yes Yes
10.2.0.5.1* Yes Yes Yes Yes Yes
10.2.0.5.2* Yes Yes Yes Yes Yes
10.2.0.5.3* Yes Yes Yes Yes Yes
11.1.0.7.5 Yes Yes Yes
11.2.0.1.3 Yes Yes Yes
11.2.0.2.0 Yes Yes Yes Yes Yes
11.2.0.2.1** Yes Yes Yes Yes Yes
11.2.0.2.2** Yes Yes Yes Yes Yes
11.2.0.2.3** Yes Yes Yes Yes Yes
11.2.0.2.5 Yes
11.2.0.2.7 Yes Yes
11.2.0.2.8*** Yes Yes
11.2.0.2.9*** Yes Yes
11.2.0.2.10*** Yes Yes
11.2.0.2.11*** Yes Yes
11.2.0.3 or later All platforms
 
 

* Use the 10.2.0.5 version of the patch #9825461.
** Use the 11.2.0.2.0 version of the patch #9825461.
*** Use the 11.2.0.2.7 version of the patch #9825461.

Do not install the patch #9825461:

  • on any database version not explicitly listed above, or
  • if the opatch patch installation utility reports a patch conflict.

You may be able to force the opatch utility to install the patch #9825461 in the above situations, but opatch will roll back any patches conflicting with the patch #9825461 potentially causing already fixed code defects to reappear. If your database version does not allow you to install the patch #9825461, contact Oracle Support to discuss your options.

 
 

Microsoft Windows Platforms

 

The DMU is currently supported on the Microsoft Windows operating systems, Intel/AMD 32-bit and 64-bit platforms, to migrate the following database releases:

  • 10.2.0.4 Patch 46 or later
  • 10.2.0.5 Patch 10 or later
  • 11.1.0.7 Patch 39 or later
  • 11.2.0.1 Patch 12 or later
  • 11.2.0.2 Patch 6 or later
  • 11.2.0.3 or later on any patch level
 

No additional database patches need to be installed on Microsoft Windows.