Oracle® Identity Management Certification Information
Oracle Identity Management (10.1.4)
 

 

Oracle® Identity Management

Certification Information

Oracle Identity Management (10.1.4)

June 20, 2014

This document outlines the certified hardware and software configurations for Oracle Identity Management.

1 General Oracle Identity Management Certification Information

This document contains the overall certification information for Oracle Identity Management (10.1.4). It is organized into the following main areas:

For additional information about Oracle Identity Management, refer to the Oracle Identity Management page on Oracle Technology Network:

http://www.oracle.com/technology/products/id_mgmt/index.html

For general information on supported non-Oracle Virtualization and Partitioning technologies, refer to http://www.oracle.com/technology/products/ias/hi_av/oracleas_supported_virtualization.html

 

Oracle Fusion Middleware is supported on ZFS on Solaris SPARC 64 platform running Solaris10. For details, refer to MetaLink note number 879491.1 on My Oracle Support.

Note: Oracle VM is supported where the operating system reference is followed by "/ Oracle VM".Oracle Application Server supports only those browsers that are supported by Vendors.

Note:

For important information on the support status of VMWare and Oracle Identity Management, please refer to MetaLink note number 249212.1 on My Oracle Support.
Oracle Application Server supports only those browsers that are supported by Vendors.

2 Oracle Identity Manager Certification

General certification information for Oracle Identity Manager:

  • Sun JDK 1.4.2 has extended support for Oracle customers. Use Patch 8453300, if you require the latest JDK 1.4.2 from Sun (for Solaris,
    Linux and Windows).
    You can obtain this patch from http://myoraclesupport.com. 
  • Oracle Identity Manager was previously known as Oracle Xellerate Identity Provisioning.

  • Oracle Identity Manager Design Console requires Windows 2003 SP1, Windows 2003 R2, or Windows XP SP1 or SP2.

  • Oracle Identity Manager Administrative and User Console requires Microsoft Internet Explorer 6.0.x or 7.0.

  • Oracle Identity Manager Release 9.0.1.3.x requires Sun JDK 1.4.2 minor version 09 or higher. Oracle Identity Manager Release 9.0.3.1 requires Sun JDK 1.4.2 minor version 11 or higher. 

  • Oracle Identity Manager Release 9.0.3 is an international version. Upgrade from non-internationalized releases (including Release 9.0.1.x) is not supported.

The information in this section is grouped as follows:

2.1 Oracle Identity Manager Solaris Certification

Table 1 lists the Oracle Identity Manager (OIM) certification information for Solaris.

Table 1 Oracle Identity Manager Certification for Solaris

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? Web Container Certified OIM Version JDK              
SPARC 64 bit Solaris 9 64 bit WebSphere 5.1.1.12 9.0.1 IBM JDK 1.5.0 or higher              
WebLogic 8.1 SP6 9.0.1 Sun JDK 1.4.2_09 or higher              
SPARC 64 bit Solaris 10 64 bit WebSphere 5.1.1.12 9.0.1 IBM JDK 1.5.0 or higher              
9.0.3 IBM JDK 1.5.0 or higher              
WebLogic 8.1 SP6 9.0.1 Sun JDK 1.4.2_09 or higher              
9.0.3 Sun JDK 1.4.2_11 or higher              
9.1.0.0 only Sun JDK 1.4.2_11 or higher                
WebLogic 10.3.0 9.1.0.1 or higher Sun JDK 1.6.0_10 or higher
JRockit 1.6.0_05 or higher
             
WebLogic 10.3.1 or later patchsets (including 10.3.2) 9.1.0.2 or higher Sun JDK 1.6.0_10 or higher   JRockit 1.6.0_05 or higher              
JBoss 4.0.2 9.0.1 Sun JDK 1.4.2_09 or higher              
JBoss 4.0.3 SP1 9.0.3 Sun JDK 1.4.2_11 or higher              
9.1.0.0 only Sun JDK 1.4.2_15 or higher in 1.4.2_xx series.              
Oracle Containers for J2EE 10.1.3.3 or higher 9.0.3 Sun JDK 1.5.0_06 or higher              
9.1.0.0 or higher Sun JDK 1.5.0_06 and higher                

2.2 Oracle Identity Manager Linux Certification

Table 2 lists the Oracle Identity Manager certification information for Oracle Enterprise Linux and Red Hat Linux.

Table 2 Oracle Identity Manager Certification for Linux

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? Web Container Certified OIM Version JDK                    
AMD/Intel Pentium AMD (64 bit)
Intel (32 and 64 bit)
OEL/Red Hat EL 5.3 or higher
 / Oracle VM
Both WebLogic 10.3.0 9.1.0.1 or higher Sun JDK 1.6.0_10 or higher
JRockit 1.6.0_05 or higher
                   
WebLogic 10.3.1 or later patchsets (including 10.3.2) 9.1.0.2 or higher Sun JDK 1.6.0_10 or higher  JRockit 1.6.0_05 or higher                    
JBoss 4.2.3 9.1.0.1 or higher Sun JDK 1.6.0_10 or higher                    
WebSphere 7.0.0.13 9.1.0.2 BP13 or later IBM JDK 1.6.0 or higher                    
WebSphere 6.1.0.9 and higher fixpacks 9.1.0.1 or higher IBM JDK 1.5.0 or higher                    
AMD/Intel Pentium AMD (64 bit)
Intel (32 and 64 bit)
OEL 4.x, Red Hat EL 4.x / Oracle VM Both JBoss 4.0.2 9.0.1 Sun JDK 1.4.2_09 or higher                    
JBoss 4.0.3 SP1 9.0.3 Sun JDK 1.4.2_11 or higher                    
9.1.0.0 only Sun JDK 1.4.2_11 or higher in 1.4.2_xx series.                    
JBoss 4.2.3 9.1.0.1 or higher Sun JDK 1.6.0_10 or higher                    
Oracle Containers for J2EE 10.1.3.3 or higher 9.0.3 Sun JDK 1.5.0_06 or higher                    
9.1.0.0 or higher Sun jdk 1.5.0_06 or higher                    
WebLogic 8.1 SP6 9.0.3 Sun JDK 1.4.2_11 or higher                    
9.1.0.0 only Sun JDK 1.4.2_11 or higher                    
WebLogic 10.3.0 9.1.0.1 or higher Sun JDK 1.6.0_10 or higher
JRockit 1.6.0_05 or higher
                   
WebLogic 10.3.1 or later patchsets (including 10.3.2) 9.1.0.2 or higher Sun JDK 1.6.0_10 or higher  JRockit 1.6.0_05 or higher                    
WebSphere 5.1.1.12 9.0.1 IBM JDK 1.5.0 or higher                    
9.0.3 IBM JDK 1.5.0 or higher                    
WebSphere 6.1.0.9 and higher fixpacks 9.1.0.0 or higher IBM JDK 1.5.0 or higher                    
WebSphere 7.0.0.13 9.1.0.2 BP13 or later IBM JDK 1.6.0 or higher                    

Table 3 lists the Oracle Identity Manager certification information for SLES.

Table 3 Oracle Identity Manager Certification for SLES

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? Web Container Certified OIM Version JDK            
Pentium
Core 2 Duo
32 bit and 64 bit SLES 10 32 bit JBoss 4.0.3 SP1 9.0.3 Sun JDK 1.4.2_11 or higher            
9.1.0.0 only Sun JDK 1.4.2_11 or higher in 1.4.2_xx series.            
JBoss 4.2.3 9.1.0.1 or higher Sun JDK 1.6.0_10 or higher            
Oracle Containers for J2EE 10.1.3.3 or higher 9.1.0.0 or higher Sun JDK 1.5.0_06 or higher            
WebLogic 10.3.0 9.1.0.1 or higher Sun JDK 1.6.0_10 or higher
JRockit 1.6.0_05 or higher
           
WebLogic 10.3.1 or later patchsets (including 10.3.2) 9.1.0.2 or higher Sun JDK 1.6.0_10 or higher   JRockit 1.6.0_05 or higher            
WebSphere 6.1.0_21 9.1.0.1 or higher IBM JDK 1.5.0 or higher            
Pentium 64 bit SLES 10 64 bit JBoss 4.2.3 9.1.0.1 or higher Sun JDK 1.6.0_10 or higher            
WebLogic 10.3.0 9.1.0.1 or higher Sun JDK 1.6.0_10 or higher
JRockit 1.6.0_05 or higher
           
WebLogic 10.3.1 or later patchsets (including 10.3.2) 9.1.0.2 or higher Sun JDK 1.6.0_10 or higher   JRockit 1.6.0_05 or higher            
WebSphere 6.1.0_21 9.1.0.1 or higher IBM JDK 1.5.0 or higher            

2.3 Oracle Identity Manager Windows Certification

Table 4 lists the Oracle Identity Manager certification information for Windows.

Table 4 Oracle Identity Manager Certification for Windows

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? Web Container Certified OIM Version JDK
AMD/Intel AMD (64 bit)
Intel (32 and 64 bit)
Windows 2008 Both JBoss 4.2.3 9.1.0.1 or higher Sun JDK 1.6.0_10 or higher
WebLogic 10.3.1 or later patchsets (including 10.3.2) 9.1.0.2 or higher Sun JDK 1.6.0_10 or higher
JRockit 1.6.0_05 or higher
WebSphere 6.1.0_21 9.1.0.1 or higher IBM JDK 1.5.0 or higher
Intel 64 bit Windows 2008 R2 64 bit JBoss 4.2.3 9.1.0.2 or higher Sun JDK6 Update 17 or higher
WebLogic 10.3.2 or later patchsets 9.1.0.2 or higher Sun JDK6 Update 17 or higher
WebSphere 6.1.0_27 9.1.0.2 or higher IBM JDK 1.5.0 or higher
Intel 32 bit Windows 2003 R2 32 bit JBoss 4.0.2 9.0.1 Sun JDK 1.4.2_09 or higher
JBoss 4.0.3 SP1 9.0.3 Sun JDK1.4.2_11 or higher
9.1.0.0 only Sun JDK 1.4.2_11 or higher in 1.4.2_xx series.
JBoss 4.2.3 9.1.0.1 or higher Sun JDK 1.6.0_10 or higher
WebSphere 5.1.1.12 9.0.1 IBM JDK 1.5.0 or higher
9.0.3 IBM JDK 1.5.0 or higher
WebSphere 6.1.0.9 and higher fixpacks 9.1.0.0 or higher IBM JDK 1.5.0 or higher
WebSphere 7.0.0.13 or higher 9.1.0.2 BP13 or later IBM JDK 1.6.0 or higher
WebLogic 8.1 SP6 9.0.1 Sun JDK 1.4.2_09 or higher
9.0.3 Sun JDK 1.4.2_11 or higher
9.1.0.0 only Sun JDK 1.4.2_15 or higher or BEA jrockit_R27.3.1-jdk 1.4.2_14 or higher
WebLogic 10.3.0 9.1.0.1 or higher Sun JDK 1.6.0_10 or higher
JRockit 1.6.0_05 or higher
WebLogic 10.3.1 or later patchsets (including 10.3.2) 9.1.0.2 or higher Sun JDK 1.6.0_10 or higher JRockit 1.6.0_05 or higher
Oracle Containers for J2EE 10.1.3.3 or higher 9.0.3 Sun jdk 1.5.0_06 or higher
9.1.0.0 or higher Sun jdk 1.5.0_06 and higher
AMD/Intel 64 bit Windows 2003 R2 64 bit Oracle Containers for J2EE 10.1.3.3 or higher 9.0.3 Sun jdk 1.5.0_06 or higher
9.1.0.0 or higher Sun jdk 1.5.0_06 and higher
WebLogic 8.1 SP6 9.1.0.0 only Sun jdk 1.4.2_15 or higher or BEA jrockit_R27.3.1-jdk 1.4.2_14 or higher
JBoss 4.2.3 9.1.0.1 or higher Sun JDK 1.6.0_10 or higher
WebLogic 10.3 9.1.0.1 or higher Sun JDK 1.6.0_10 or higher
JRockit 1.6.0_05 or higher
WebLogic 10.3.1 or later patchsets (including 10.3.2) 9.1.0.2 or higher Sun JDK 1.6.0_10 or higher
JRockit   1.6.0_05 or higher
WebSphere 6.1.0.9 and higher fixpacks 9.1.0.0 or higher IBM JDK 1.5.0 or higher
WebSphere 7.0.0.13 or higher 9.1.0.2 BP13 or later IBM JDK 1.6.0 or higher
Intel 32 bit Windows 2003 SP1 32 bit JBoss 4.0.2 9.0.1 Sun JDK 1.4.2_09 or higher
AMD/Intel 32 bit Windows Vista Ultimate 32 bit JBoss 4.0.3 SP1 9.1.0.0 only Sun JDK 1.4.2_15 or higher
WebLogic 8.1 SP6 9.1.0.0 only Sun JDK 1.4.2_15 or higher or BEA jrockit_R27.3.1-jdk 1.4.2_14 or higher
Oracle Containers for J2EE 10.1.3.3 or higher 9.1.0.0 only Sun JDK 1.5.0_12 or higher
Intel 32 bit Windows 7 Both JBoss4.2.3 9.1.0.1 or higher Sun JDK 1.6.0_10 or higher
Weblogic 10.3.1 or later patchsets (including 10.3.2) 9.1.0.1 or higher Sun JDK 1.6.0_10 or higher
JRockit 1.6.0_05 or higher

2.4 Oracle Identity Manager AIX Certification

Table 5 lists the Oracle Identity Manager certification information for AIX.

Table 5 Oracle Identity Manager Certification for AIX

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? Web Container Certified OIM Version JDK
PowerPC/RISC 64 bit AIX 5.3 32 bit WebSphere 5.1.1.12 9.0.1 IBM JDK 1.5.0 or higher
Oracle Containers for J2EE 10.1.3.3 or higher 9.0.3 IBM JDK 1.5.0 or higher
PowerPC/RISC 64 bit AIX 5.3 64 bit WebSphere 5.1.1.12 9.0.3 IBM JDK 1.5.0 or higher
WebSphere 6.1.0.9 and higher fixpacks 9.1.0 IBM JDK 1.5.0 or higher
WebSphere 6.1.0.19 and higher fixpacks 9.1.0.1 or higher IBM JDK 1.5.0 or higher    
WebLogic 10.3.0 9.1.0.1 or higher IBM JDK 1.6.0 or higher
   
WebLogic 10.3.1 or later patchsets (including 10.3.2) 9.1.0.2 or higher IBM JDK 1.6.0 higher    
Oracle Containers for J2EE 10.1.3.3 or higher 9.1.0.0 or higher IBM JDK 1.5.0 or higher    
PowerPC/RISC 64 bit AIX 6.1 64 bit WebLogic 10.3.2 9.1.0.2 BP10A IBM JDK 1.6.0    

2.5 Oracle Identity Manager HP-UX Certification

Table 6 lists the Oracle Identity Manager certification information for HP-UX.

Table 6 Oracle Identity Manager Certification for HP-UX

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? Web Container Certified OIM Version JDK
PA-RISC 64 bit HP-UX 11.x 64 bit Oracle Containers for J2EE 10.1.3.3 or higher 9.0.3 HP JDK 1.5.0 or higher
9.1.0.0 or higher HP JDK 1.5.0 or higher
PA-RISC 64 bit HP-UX 11i v2 (11.23) 64 bit WebLogic 10.3.0 9.1.0.1 or higher HP JDK 1.6.0_02
        WebLogic 10.3.1 or later patchsets (including 10.3.2) 9.1.0.2 or higher HP JDK 1.6.0_02
Itanium 64 bit HP-UX 11i v2 (11.23) 64 bit WebLogic 10.3.0 9.1.0.1 or higher HP JDK 1.6.0_02
        WebLogic 10.3.1 or later patchsets (including 10.3.2) 9.1.0.2 or higher HP JDK 1.6.0_02

2.6 Oracle Identity Manager Database Certification

Table 7 lists the Oracle Identity Manager certification information for Databases.

Table 7 Oracle Identity Manager Certification Databases

Vendor Version OIM 9.1.0.0 or Higher OIM 9.0.3 OIM 9.0.1 Notes
Oracle 9i (9.2.0.8 and higher) Database Database Database Database  
10g (10.1.0.5 and higher) Database Database Database    
10g (10.2.0.1 and higher) Database Database Database    
10g (10.2.0.2 and higher) Database
RAC
Database
RAC
Database
RAC
   
11gR1 (11.1.0.6 and higher) Database
RAC
Not supported Not supported    
11gR2 (11.2 and higher) Database
RAC
Not supported Not supported    
Microsoft SQL Server 2000 SP3a Not supported Database Database  
Microsoft SQL Server 2005 SP2 Database (OIM 9.1.0.0 is not supported) Not supported Not supported OIM 9.1.0.1 or higher  

2.7 Oracle Identity Manager Additional Certifications

Table 8 lists the Oracle Identity Manager Additional Certifications.

Table 8 Oracle Identity Manager Additional Certifications

Category Vendor Product Vendor Version Platforms OIM Version(s) Notes            
SSO RSA Cleartrust (single byte) 5.5 All 9.1.0, 9.0.3, 9.0.1              
OAM (single and multi-byte) 10.1.4.0.1 and higher All 9.1.0, 9.0.3, 9.0.1 Supports ASCII and non-ASCII logins.   Non-ASCII logins require patch 5552617.            
Oracle SSO 10.1.4.0.1 and higher All 9.1.0, 9.0.3, 9.0.1 Supports ASCII and non-ASCII logins.            
Browser Microsoft Internet Explorer 6.0 SP2 with Sun Java Plug-in 1.4.2 Windows clients 9.1.0,  9.0.3, 9.0.1              
6.0 SP2 with Sun Java Plug-in 1.6.0_07 Windows clients 9.1.0.1 or higher              
7.0 with Sun Java Plug-in 1.4.2 Windows clients 9.1.0, 9.0.3, 9.0.1              
7.0 with Sun Java Plug-in 1.6.0_07 Windows clients 9.1.0.1 or higher              
8.0 with Sun Java Plug-in 1.6.0_07 Windows clients 9.1.0.1 or higher              
Design Console OS Microsoft Windows 2003 R2   9.1.0, 9.0.3, 9.0.1              
Microsoft Windows XP   9.1.0              
Microsoft Windows Vista Ultimate   9.1.0              
Microsoft Windows Windows 7   9.1.0.1 or higher              
Remote Manager OS IBM AIX 5L 5.3 PPC 32 and 64 bit 9.1.0, 9.0.3, 9.0.1              
PPC 64 bit 9.1.0, 9.0.3, 9.0.1              
OEL/Red Hat EL
 / Oracle VM
5.3 or higher Intel x86 32-bit and EM64T/AMD 64-bit 9.1.0.1 or higher              
OEL/Red Hat EL
 / Oracle VM
4 Intel x86 32-bit and EM64T/AMD/Itanium 64-bit 9.1.0.1 or higher              
HP HP-UX 11i PA RISC 64 bit 9.1.0, 9.0.3, 9.0.1              
Micorsoft Windows 2003 R2 Intel/Xeon 32 bit 9.1.0, 9.0.3, 9.0.1              
Intel/AMD/Itanium 64 bit 9.1.0, 9.0.3, 9.0.1              
Sun Solaris 10 SPARC 64 bit 9.1.0, 9.0.3, 9.0.1              
SLES 10 Intel/Xeon 32 bit 9.1.0, 9.0.3, 9.0.1              
Intel/AMD/Itanium 64 bit 9.1.0, 9.0.3, 9.0.1              
Design Console JDK         See server JDK supported for Windows 2003 R2            
Remote Manager JDK         See server JDK on the same OS as Remote Manger            


3 Oracle Identity Manager Connectors Certification

Table 9 contains the certification information for Oracle Identity Manager Connectors.
Table 10 contains the certification information for ICF Connectors.

Table 9 Oracle Identity Manager Connectors Target and Version Information

Oracle Identity Manager Connector Connector Version (minimum) Oracle Identity Manager 9.x Version (minimum) Oracle Identity Manager 11g Version (minimum) JDK Requirement (minimum) Target System and Version
BMC Remedy Ticket Management 9.0.4.12 9.1.0.2 11.1.1 1.4.2 BMC Remedy AR System 7.0 and 7.1
BMC Remedy User Management 9.0.4.12 9.1.0.2 11.1.1 1.4.2 BMC Remedy AR System 7.0 and 7.1
CA ACF2 Advanced 9.0.4.14 9.1.0.1 11.1.1 1.5 CA ACF2 r6.2, r8.0 SP4 or higher, r9.0 SP1 or higher, r12, r14, r15
CA Top Secret Advanced 9.0.4.13 9.1.0.1 11.1.1 1.5 CA Top Secret r8, r9, r12, r14
Database Application Tables 9.1.0.5 9.1.0.1 BP03 11.1.1
1.5 IBM DB2/UDB Version 9.x running on Microsoft Windows, UNIX, and IBM z/OS platforms
Microsoft SQL Server 2005, 2008
Oracle Database 10g, 11gR1, 11g Release 2 (11.2.0.x) as either single database or Oracle RAC implementation.
Sybase Adaptive Server Enterprise 15.x
MySQL 5.1.30, 5.3, 5.5
Database User Management 9.1.0.4 9.1.0.2 BP 08 11.1.1 1.5 IBM DB2/UDB Version 9.x
Microsoft SQL Server 2000, 2005, 2008
Oracle9i Database, Oracle Database 10g, 11gR1 in RAC or non-RAC mode
Sybase Adaptive Server Enterprise 15.x
MySQL 5.1.30
IBM Lotus Notes/Domino 9.0.4.14 9.1.0.2 11.1.1 The JDK version can be one of the following:
- For Oracle Identity Manager release 9.1.0.x, use JDK 1.5 or a later release in the 1.5 series.
- For Oracle Identity Manager release 11.1.1, use JDK 1.6 or later release in the 1.6 series
IBM Lotus Notes/Domino 6.5, 7.x, 8.0.x, 8.5, 8.5.1, 8.5.2
IBM i5/OS (AS/400) Advanced 9.0.4.14 9.1.0.1 11.1.1 1.5 IBM i5/OS and OS/400 releases V5R2, V5R3, V5R4, V6R1
IBM RACF Advanced 9.0.4.15 9.1.0.1 11.1.1 1.5 IBM RACF on z/OS V1.9 and above
IBM RACF Standard 9.0.4.12 9.1.0.1 11.1.1 1.4.2 IBM RACF on z/OS 1.9
JDEdwards EnterpriseOne 9.0.4.12 9.1.0.1 11.1.1 1.4.2 JD Edwards EnterpriseOne Tools 8.96, 8.98, and Application 8.12
Microsoft Active Directory 9.1.1.7 9.1.0.2 11.1.1 1.5 Microsoft Active Directory installed on Windows Server 2003 Active Directory or Windows Server 2003 Active Directory Application Mode on Windows Server 2003 SP1 or higher
Microsoft Active Directory installed on Windows Server 2008 Active Directory on
Microsoft Active Directory installed on Windows Server 2008 R2
Microsoft Active Directory Password Sync 9.1.1.5 Oracle Identity Manager release 9.1.0.0 and any later BP in this release track
Note: In this guide, Oracle Identity Manager release 9.1.0.x has been used to denote Oracle Identity Manager release 9.1.0.0 and future releases in the 9.1.0.x series that the connector supports.
 
- Oracle Identity Manager 11g release 1 (11.1.1.3.0) and any later BP in this release track
Note: In this guide, Oracle Identity Manager release 11.1.1 has been used to denote Oracle Identity Manager 11g Release 1 (11.1.1).
- Oracle Identity Manager 11g release 1 PS1 (11.1.1.5.0) and any later BP in this release track
- Oracle Identity Manager 11g release 1 PS2 (11.1.1.7.0) and any later BP in this release track
- Oracle Identity Manager 11g release 2 BP02 (11.1.2.0.2) and any later BP in this release track
Note: In this guide, Oracle Identity Manager release 11.1.2.x has been used to denote all releases in the Release 2 track listed here, and future releases in the 11.1.2.x series that the connector supports.
- Oracle Identity Manager 11g release 2 PS1 (11.1.2.1.0) and any later BP in this release track
- Oracle Identity Manager 11g release 2 PS2 (11.1.2.2.0) and any later BP in this release track
1.5 Windows Server 2003 Active Directory on Windows Server 2003 SP2 or later (x86 or x64)
Windows Server 2008 Active Directory on Windows Server 2008 SP2 or later (x86 or x64)
Windows Server 2008 Active Directory on Windows Server 2008 R2 (x86 or x64)
Windows 2008 Server Core
Windows Server 2012 Active Directory installed on Microsoft Windows Server 2012 (x64)
Windows Server 2012 Active Directory installed on Microsoft Windows Server 2012 R2 (X64)
Microsoft Exchange 9.1.1.7 9.1.0.2 11.1.1 1.5 Microsoft Exchange Server 2003 on Windows Server 2003
Microsoft Exchange Server 2007 on Windows Server 2008
Microsoft Exchange Server 2007 on Windows Server 2008 R2
Microsoft Exchange Server 2010 on Windows Server 2008 R2
Microsoft Windows 9.0.4.12 9.1.0.1 11.1.1 1.6 Microsoft Windows Server 2003, 2008
Novell eDirectory 9.0.4.14 9.1.0.1 11.1.1 1.4.2 Novell eDirectory 8.7.3, 8.8
Novell GroupWise 9.0.4.12 9.1.0.1 11.1.1 1.4.2 Novell GroupWise 6.5, 7.0, 8.0

Note: This connector can be installed and used only if Oracle Identity Manager is deployed on a computer that is running Microsoft Windows. This is because the target supports only Windows APIs.
Oracle e-Business Employee Reconciliation 9.1.0.7 9.1.0.2 BP02 11.1.1 1.5 Oracle E-Business Suite 11.5.10, 12.0.x, or 12.1.x . These applications may run on Oracle Database 10g or Oracle Database 11gR1, in either RAC or non-RAC mode.
Oracle e-Business User Management 9.1.0.7 9.1.0.2 BP02 11.1.1 1.5 Oracle E-Business Suite 11.5.10, 12.0.x, or 12.1.x. These applications may run on Oracle Database 10g or Oracle Database 11gR1, in either RAC or non-RAC mode.
Oracle Internet Directory 9.0.4.14 9.1.0.1 11.1.1.3 1.4.2 Oracle Internet Directory release 10.1.x, or 11gR1
Oracle Retail Warehouse Management System 9.0.4.12 9.1.0.1 11.1.1 1.4.2 Oracle Retail Warehouse Management System Release 12.0
PeopleSoft Employee Reconciliation 9.1.1.6 9.1.0.2 BP05 11.1.1 1.5 HCM 8.9 with PeopleTools 8.49
HCM 9.0 with PeopleTools 8.49, 8.50
HCM 9.1 with PeopleTools 8.50, 8.51, 8.52
PeopleSoft User Management 9.1.1.6 9.1.0.2 BP05 11.1.1 1.5 PeopleTools 8.49, 8.50, 8.51, 8.52
RSA Authentication Manager 9.1.0.7 9.1.0.2 BP05 You can use one of the following releases of Oracle Identity Manager:
- Oracle Identity Manager 11g release 1 (11.1.1)
- Oracle Identity Manager 11g release 2 BP04 (11.1.2.0.4) or later.
The JDK version can be one of the following:
- For Oracle Identity Manager release 9.1.0.x, use JDK 1.5 or a later release in the 1.5 series.
- For Oracle Identity Manager release 11.1.1 and 11.1.2.x, use JDK 1.6 update 18 or later or JRockit JDK 1.6 update 17 or later.
RSA Authentication Manager 7.1 with SP3 or later
RSA ClearTrust 9.0.4.12 9.1.0.1 11.1.1 1.4.2 RSA ClearTrust 5.5.x, 6.0.x, 6.1.x
SAP Employee Reconciliation 9.1.2.2 9.1.0.2 BP04 11.1.1 1.5 SAP R/3 4.7 SP 45 (running on WAS 6.20) BASIS SP 48 or later
mySAP ERP 2004 (ECC 5.0 running on WAS 6.40) BASIS SP 22 or later
mySAP ERP 2005 (ECC 6.0 running on WAS 7.00) BASIS SP 13 or later
SAP Enterprise Portal 9.0.4.12 9.1.0.1 11.1.1 1.4.2 SAP Enterprise Portal 7.0
SAP User Management 9.1.2.2 9.1.0.2  BP04 11.1.1 1.5 SAP R/3 4.7 SP 45 (running on WAS 6.20) BASIS SP 48 or later
mySAP ERP 2004 (ECC 5.0 running on WAS 6.40) BASIS SP 22 or later
mySAP ERP 2005 (ECC 6.0 running on WAS 7.00) BASIS SP 13 or later
GRC 5.2 SP4 or later, 5.3 SP 5 or later
CUA is supported.
Siebel Enterprise Applications 9.0.4.15 9.1.0.2 11.1.1 1.5 Siebel 7.5 through Siebel CRM 8.1.1
Sun Java System Directory 9.0.4.12 9.1.0.1 11.1.1 1.4.2 Sun ONE Directory Server 5.2
Sun Java System Directory Server Enterprise Edition 6.3 and DSEE 7.0
UNIX SSH 9.0.4.15 9.1.0.1 11.1.1 1.4.2 HP-UX 11.11, 11.20, and 11.31
IBM AIX 5L Version 5.2, 5.3 (IBM AIX 5.2 has been deprecated. Oracle Fusion Middleware 10.1.4 support has ended on AIX 5.2, as it reached end of life on April 30, 2009. For more information on IBM’s support policy, refer to http://www-01.ibm.com/software/support/systemsp/lifecycle/index.html)
Oracle Enterprise Linux 5.2
Red Hat Enterprise Linux AS 2.1, 3, 4.x, Red Hat Enterprise Linux ES 3, 4.x
Solaris 8, 9, 10
UNIX Telnet 9.0.4.15 9.1.0.1 11.1.1 1.4.2 HP-UX 11.11 and 11.20
IBM AIX 5L Version 5.2, 5.3, and 6.1
Note: IBM AIX 5.2 has been deprecated. Oracle Fusion Middleware 10.1.4 support has ended on AIX 5.2, as it reached end of life on April 30, 2009. For more information on IBM’s support policy, refer to http://www-01.ibm.com/software/support/systemsp/lifecycle/index.html
Oracle Enterprise Linux 5.2
Red Hat Enterprise Linux AS 2.1, 3, 4.x, Red Hat Enterprise Linux ES 3, 4.x
Solaris 8, 9, 10

Note: The minimum JDK version is the threshold for Oracle Identity Manager connectors. If the Oracle Identity Manager server requires a higher version, that higher JDK version overrides the Connector minimum version.

Table 10 ICF Connectors Target and Version Information

Oracle Identity Manager Connector Connector Version (minimum) Connector Server Version (minimum) Oracle Identity Manager 11g Version (minimum) JDK Requirement (minimum) Target System and Version External Code Other
Software/
Systems
AS400 11.1.1.5.0 - You can use one of the following releases of Oracle Identity Manager:
-
Oracle Identity Manager 11g Release 1 (11.1.1.5.0) or later
- Oracle Identity Manager 11g Release 2 BP04 (11.1.2.0.4) or later
- AS400 (also known as OS/400, i5/OS, and IBM i) v5r4, IBM i 6.1, and IBM i 7.1 JTOpen library version 6.2 -
BMC Remedy User Management 11.1.1.5.0 11.1.2.0.0 You can use one of the following releases of Oracle Identity Manager:

•Oracle Identity Manager 11g Release 1 PS1 BP07 (11.1.1.5.7) or later
•Oracle Identity Manager 11g Release 2 BP04 (11.1.2.0.4) or later
JDK 1.6 update 24 or later, or JRockit JDK 1.6 update 17 or later

 
BMC Remedy AR System 7.1 through 8.1

Note: The target system does not support SSL communication.
- -
Database User Management 11.1.1.5.0 - 11.1.1.5.3 with patches 14163597 and 13897038 1.6 The target system can be any one of the following:
- Exadata V2
- Oracle9i Database
- Oracle Database 10g, 11g, as either single database or Oracle RAC implementation
- Oracle Database 12c as single database, pluggable database (PDB), or Oracle RAC implementation
- Microsoft SQL Server 2005, 2008, 2012
- MySQL 5.x
- IBM DB2 UDB 9.x
- Sybase 15.x
- -
Flat File 11.1.1.5.0 11.1.1.5.0 or later You can use one of the following releases of Oracle Identity Manager:
- Oracle Identity Manager 11g Release 2 PS2 (11.1.2.2.0)
- Oracle Identity Manager 11g Release 2 BP13 (11.1.2.0.13)
- Oracle Identity Manager 11g Release 2 PS1 BP04 (11.1.2.1.4)

- Any enterprise target system that can export users, accounts, or entitlements to a flat file. - -
Google Apps 11.1.1.5.0 - You can use one of the following releases of Oracle Identity Manager:
- Oracle Identity Manager 11g Release 1 (11.1.1.5.0)
- Oracle Identity Manager 11g Release 2 (11.1.2.0.4) or later

- Google Apps (Google Data Java Client 1.33 and Google Collections 1.0-rc1) - -
IBM Lotus Notes and Domino 11.1.1.5.0 - 11.1.1.5.0 1.6 IBM Lotus Notes/Domino 8, 8.5.x, 9.0, 9.0.1 Notes.jar
IBM Lotus Notes
-
JD Edwards User Management 11.1.1.5.0 11.1.1.5.0 11.1.1.5.0 JDK 1.6 update 18 or later, or JRockit JDK 1.6 update 17 or later The target system be any one of the following:
- JD Edwards EnterpriseOne Tools 8.98 and Application 8.12
- JD Edwards EnterpriseOne Tools 9.1.2 and Application 9.0.2
- JD Edwards EnterpriseOne Tools 9.1.2 and Application 9.1
- -
Microsoft Active Directory User Management 11.1.1.6.0 1.2.0.6195 You can use one of the following releases of Oracle Identity Manager:
-Oracle Identity Manager 11g Release 1 (11.1.1.5.6)
-Oracle Identity Manager 11g Release 2 (11.1.2.0.6)
- Oracle Identity Manager 11g Release 2 PS2 (11.1.2.2.0)
- The target system can be any one of the following:
- Microsoft Active Directory installed on Microsoft Windows Server 2003, both 32-bit and 64-bit platforms
- Microsoft Active Directory installed on Microsoft Windows Server 2003 R2, both 32-bit and 64-bit platforms
- Microsoft Active Directory installed on Microsoft Windows Server 2008, both 32-bit and 64-bit platforms
- Microsoft Active Directory installed on Microsoft Windows Server 2008 R2, both 32-bit and 64-bit platforms
- Microsoft Active Directory installed on Microsoft Windows Server 2012
- Microsoft Active Directory Application Mode installed on Microsoft Windows Server 2003, both 32-bit and 64-bit platforms
- Microsoft Active Directory Application Mode installed on Microsoft Windows Server 2003 R2, both 32-bit and 64-bit platforms
- Microsoft Active Directory Lightweight Directory Services installed on Microsoft Windows Server 2008, both 32-bit and 64-bit platforms
- Microsoft Active Directory Lightweight Directory Services installed on Microsoft Windows Server 2008 R2, both 32-bit and 64-bit platforms
-Microsoft Active Directory Lightweight Directory Services installed on Microsoft Windows Server 2012
- Certificate
Services
and
IIS Web
Server
Microsoft Exchange 11.1.1.6.0 - You can use one of the following releases of Oracle Identity Manager:
- Oracle Identity Manager 11g Release 1 (11.1.1.5.6) or later
- Oracle Identity Manager 11g Release 2 (11.1.2.0.6) or later
- Oracle Identity Manager 11g Release 2 PS2 (11.1.2.2.0)
1.6 update 24 or later The target system can be any one or the combination of the following:
- Microsoft Exchange 2007 SP1, SP2, SP3 (64-bit)
- Microsoft Exchange 2010 RTM, SP1, SP2, SP3 (64-bit)
- Microsoft Exchange 2013 RTM (64-bit)
Note: For the Exchange 2013 support, Patch 17239236 must be applied on Release 11.1.1.6.0 of the Exchange connector. This Patch can be obtained from My Oracle Support under Patches and Updates.
- - Active
Directory
- Active
Directory
UM
connector
11.1.1.5.0A
You must
deploy the
Active Directory
UM connector
before you can
deploy
and use the Exchange
connector.
See Oracle Identity Manager
Connector
Guide
for
Active
Directory
UM for
instructions
to deploy
the
Active
Directory
connector
The Exchange
connector
operates
in the
context
of the
- .NET
Connector
Framework.
The
.NET
Connector
Server
can be
downloaded
from
the
following
page:
http://www.
oracle.com
/technetwork
/middleware/
id-mgmt
/downloads/
connectors
-101674.html
Oracle CRM On Demand 11.1.1.5.0 - 11.1.1.5.1 1.6 Update 24 Oracle CRM On Demand Release 19 - -
Oracle Internet Directory 11.1.1.5.0 1.3.0 You can use one of the following releases of Oracle Identity Manager:
- Oracle Identity Manager (11.1.1.5.3) BP03 or later with patches 14163597 and 13897038
- Oracle Identity Manager 11g Release 2 (11.1.2.0.4) or later
-
Oracle Identity Manager 11g Release 2 PS1 (11.1.2.1.0) or later
- Oracle Identity Manager 11g Release 2 PS2 (11.1.2.2.0)

1.6 The target system can be any one of the following:
- Oracle Directory Server Enterprise Edition 11g release 1 (11.1.1.5.0)
- Oracle Unified Directory 11g release 2 (11.1.1.5.0 and 11.1.2.0.0)
- Oracle Internet Directory release 9.x, 10.1.4.x, and 11g release 1 (11.1.1.6.0)
- Oracle Virtual Directory 10g and 11g release 1 (11.1.1.5.0)
- Novell eDirectory 8.7.3 and 8.8
- Sun Java System Directory Server Enterprise Edition 6.3 and 7.0
- Sun ONE Directory Server 5.2
- An LDAPv3 compliant directory server
- -
PeopleSoft Campus 11.1.1.5.0 - You can use one of the following releases of Oracle Identity Manager:
- Oracle Identity Manager 11g Release 1 (11.1.1.5.0) BP06 or later
- Oracle Identity Manager 11g Release 2 (11.1.2.0.0)
JDK 1.6 or later, or JRockit 1.6 or later PeopleSoft Campus Solutions Maintenance Pack 9.0 Bundle 27 with PeopleTools 8.50 - You must ensure that the following components are installed and configured in the target system environment:
- Tuxedo and Jolt (the application server)
- PeopleSoft Internet Architecture
- PeopleSoft Application Designer (2-tier mode)
The following standard PeopleSoft messages are available:
- SCC_CONSITTUENT_SYNC
- SCC_CONSTITUENT_FULLSYNC
PeopleSoft Employee Reconciliation 11.1.1.5.0 - You can use one of the following releases of Oracle Identity Manager:
- Oracle Identity Manager release 11.1.1.5 BP02
 - Oracle Identity Manager 11g Release 2 PS2 (11.1.2.2.0)
1.6 The target system can be any one of the following:
- PeopleSoft HRMS 8.9 with PeopleTools 8.49
- PeopleSoft HRMS 8.9 with PeopleTools 8.50
- PeopleSoft HRMS 9.0 with PeopleTools 8.49
- PeopleSoft HRMS 9.0 with PeopleTools 8.50
- PeopleSoft HRMS 9.1 with PeopleTools 8.50
- PeopleSoft HRMS 9.1 with PeopleTools 8.51
- PeopleSoft HRMS 9.1 with PeopleTools 8.52
- PeopleSoft HRMS 9.2 with PeopleTools 8.53
- You
must
ensure
that
the
following
components
are
installed
and
configured
in the
target
system
environment:
Tuxedo
and Jolt
PeopleSoft
Internet
Architecture
PeopleSoft
Application
Designer
(2-tier mode)
PeopleSoft User Management 11.1.1.5.0 - You can use one of the following releases of Oracle Identity Manager:
- Oracle Identity Manager 11g Release 1 BP06 (11.1.1.5.6) or later
- Oracle Identity Manager 11g Release 2 BP04 (11.1.2.0.4) or later
- Oracle Identity Manager 11g Release 2 PS2 (11.1.2.2.0)

1.6 Update 24 The target system can be any one of the following:
- PeopleTools 8.48
- PeopleTools 8.49
- PeopleTools 8.50
- PeopleTools 8.51
- PeopleTools 8.52
- PeopleTools 8.53
- You must
ensure that
the
following
components
are
installed
and
configured
in the
target
system
environment:
Tuxedo
and Jolt
PeopleSoft
Internet
Architecture
PeopleSoft
Application
Designer
(2-tier mode
If you
want
to enable
and
use
the SoD
feature of
Oracle
Identity
Manager
release
11.1.1.5 BP01
with this
target system,
then install
Oracle
Applications
Access
Controls
Governor
(OAACG)
release
8.6.
SAP User Management 11.1.1.5.0 - You can use one of the following releases of  Oracle Identity Manager:
- Oracle Identity Manager 11g Release 1 PS1 BP07 (11.1.1.5.7) with patch 16627402 or later
- Oracle Identity Manager 11g Release 2 BP05 (11.1.2.0.5) with patch 16627415
- Oracle Identity Manager 11g Release 2 PS2 (11.1.2.2.0)
Sun/IBM JDK 1.6 update 18 or later The target system can be any one of the following: SAP R/3 4.7 SP 45 (running on WAS 6.20) BASIS SP 48 or later mySAP ERP 2004 (ECC 5.0 running on WAS 6.40) BASIS SP 22 or later mySAP ERP 2005 (ECC 6.0 running on WAS 7.00) BASIS SP 13 or later Note: From version 6.40 onward, SAP WAS is also known as "SAP NetWeaver." SAP NetWeaver 7.0 with SAP BASIS 7.00 and SAP Business Suite release: BS 2005 with the following constituents: SAP ERP 6.0 (EHP2 and EHP3) SAP CRM 5.0, 6.0) SAP SRM 5.0, 6.0 SAP SCM 5.0, 5.1 SAP NetWeaver 7.0 EHP1 with SAP BASIS 7.01 and SAP Business Suite release: BS 2007 with the following constituents: SAP ERP 6.0 EHP 4 (EHP 4) SAP CRM 7.0 SAP SRM 7.0 SAP SCM 7.0 SAP NetWeaver 7.0 EHP2 with SAP BASIS 7.20 and SAP Business Suite release: BS 7i 2010 with the following constituents: SAP ERP 6.0 EHP 5 (EHP 5) SAP CRM 7.0 EHP1 SAP SRM 7.0 EHP1 SAP SCM 7.0 EHP1 SAP NetWeaver 7.0 EHP3 with SAP BASIS 7.31 and SAP Business Suite release: BS 7i 2011 with the following constituents: SAP ERP 6.0 EHP 6 (EHP 6) SAP CRM 7.0 EHP2 SAP SRM 7.0 EHP2 SAP SCM 7.0 EHP2 In general: SAP applications installed on the ABAP stack are supported. Applications installed on the JAVA stack are not supported. Some SAP applications can be installed on the ABAP+JAVA stack. While installing such an application, you specify either ABAP or JAVA as the data source. The connector supports SAP applications that use the ABAP data source. - - The connector works with SAP JCo 3.0.2 or later. The following SAP custom code files are required: sapjco3.jar version 3.0.2 or later Additional file for Microsoft Windows: sapjco3.dll version 3.0 Additional file for AIX, Solaris, and Linux: libsapjco3.so version 3.0 Note: There are different distribution packages (JCo) 3.0 available for various supported platforms and processors. See, JCo documentation for more information about using JCo 3.0 packages as per your environment.
- SAP Governance, Risk and Compliance Access Control (GRC AC): If you want to configure and use the Access Risk Analysis or Access Request Management feature of this target system, then install one of the following:
- SAP BusinessObjects Access Control 5.3 on SAP NetWeaver AS ABAP 7.00 Support Pack 14 Install the VIRACLP 530_700_19, VIRAE 530_700_19, VIRCC 530_700_19, VIRFF 530_700_19, and VIRRE 530_700_19 components. Use ECC 6.0 with RTA components VIRSAHR SP 10 and VIRSANH SP 10. Note: If you are using any other SAP application, then you must install the RTA component which is compatible with that SAP application.
- SAP BusinessObjects Access Control 10 on SAP NetWeaver AS ABAP 7.02 Support Pack 7 Install the GRCFND_A SP 10 component. Use ECC 6.0 with RTA component GRCPIERP SP 9. Note: If you are using any other SAP application, then you must install the RTA component which is compatible with that SAP application.
SAP User Management Engine 11.1.1.5.0 - You can use one of the following releases of Oracle Identity Manager:
- Oracle Identity Manager 11g Release 1 PS1 BP07 (11.1.1.5.7) with patch 16627402 or later
- Oracle Identity Manager 11g Release 2 BP05 (11.1.2.0.5) with patch 16627415
- Oracle Identity Manager 11g Release 2 PS2 (11.1.2.2.0)
Sun/IBM JDK 1.6 update 18 or later The target system can be any one of the following
- SAP User Management Engine running on SAP NetWeaver '04 SPS 14 or later
- SAP User Management Engine running on SAP NetWeaver 7.0 SPS 05 or later
- - OpenSPML
Toolkit
version 0.6
(included
with
the
connector
bundle).
- SAP Governance, Risk and Compliance Access Control (GRC AC): If you want to configure and use the Access Risk Analysis or Access Request Management feature of this target system, then install one of the following:
- SAP BusinessObjects Access Control 5.3 on SAP NetWeaver AS ABAP 7.00 Support Pack 14 Install the VIRACLP 530_700_19, VIRAE 530_700_19, VIRCC 530_700_19, VIRFF 530_700_19, and VIRRE 530_700_19 components. To use the connector with Java data source, use SAP NetWeaver AS ABAP 7.00 Support Pack 14 with EP RTA component VIREPRTA SP 19. To use the connector with ABAP or LDAP data source, use SAP NetWeaver AS ABAP 7.01 Support Pack 10 with EP RTA component VIREPRTA SP 19.
- SAP BusinessObjects Access Control 10 on SAP NetWeaver AS ABAP 7.02 Support Pack 7 Install the GRCFND_A SP 10 component. To use the connector with Java, ABAP, or LDAP data source, use SAP NetWeaver AS ABAP 7.01 Support Pack 10 with EP RTA component GRCPIEP SP 10 patch 2.
Siebel User Management 11.1.1.5.0 - 11.1.1.5.0 1.6 Update 18 Siebel 7.5 through Siebel CRM 8.2.2 Siebel 7.5 through 7.7:
SiebelJI_Common.jar, SiebelJI_enu.jar, and SiebelJI.jar

Siebel 7.8 through 8.2.2:
Siebel.jar and SiebelJI_enu.jar
-
UNIX 11.1.1.5.0 - You can use one of the following releases of Oracle Identity Manager:
- Oracle Identity Manager 11g Release 1 BP02 (11.1.1.5.2) or later

- Oracle Identity Manager 11g Release 2 BP04 (11.1.2.0.4) or later
1.6 Update 24 The target system can be any one of the following:
- Exadata V2, ExaLogic X2-2
- HP-UX 11.11, 11.20, 11.31
- IBM AIX 5L Version 5.2, 5.3, 6.1, 7.1
- Oracle Enterprise Linux 5.2+(32-bit) and 64-bit versions of 5.2, 5.3, 5.4, 5.5, 5.6
- Red Hat Enterprise Linux AS 2.1, 3, 4.x
- Red Hat Enterprise Linux ES 3, 4.x
- Red Hat Linux 5.5+ Enterprise Edition (64-bit)
- Solaris 9, 10, 11
Note: You can also configure and use the connector on any other UNIX-based operating system that supports SSH and Telnet protocols.
Expect4j (expect4j-1.0.jar) is a third-party API used to connect and run commands or scripts on the target systems. It is included with the connector installation bundle, along with the following dependent libraries:
- commons-net-3.0.1.jar
- jakarta-oro-2.0.8.jar
- jsch-0.1.41.jar
OpenSSH,
OpenSSL,
operating
system
patches
(HP-UX),
and
SUDO
software
(only
if
the SUDO
Admin
mode
is
required)
Webservices 11.1.1.5.0 - You can use one of the following releases of Oracle Identity Manager:

- Oracle Identity Manager 11g Release 1 (11.1.1.5.6) BP06 (with patch 15971939) or later

- Oracle Identity Manager 11g Release 2 (11.1.2.0.7) BP07 or later

JDK 1.6 or later, or JRockit 1.6 or later The target system can be any that exposes webservice endpoints. - -


4 Oracle Identity Federation Certification

The information in this section is grouped as follows:

Note: Sun JDK 1.4.2 has extended support for Oracle customers. Use Patch 8453300, if you require the latest JDK 1.4.2 from Sun (for Solaris,
Linux and Windows). 
You can obtain this patch from http://myoraclesupport.com.

4.1 Oracle Identity Federation Certification for all Platforms

Table 11 contains Oracle Identity Federation certification information.

Table 11 Oracle Identity Federation Certification

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? Oracle Identity Federation will run as 32 or 64 bit Application? Application Server Web Proxy Server

AMD Opteron

64 bit

Oracle Enterprise Linux (OEL) 5 / Oracle VM
(See footnote 5)

both

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10Release 2

AMD Opteron

64 bit

Red Hat Linux EL 5 / Oracle VM
 (See footnote 5)

both

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10Release 2

AMD Opteron

64 bit

Oracle Enterprise Linux (OEL) 4 /Oracle VM
(See footnote 3)

both

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

AMD Opteron

64 bit

Red Hat Linux EL 3.0 (UL3 or higher)

64 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

AMD Opteron

64 bit

Red Hat Linux EL 4.0 (UL1 or higher) / Oracle VM

64 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

AMD Opteron

64 bit

Solaris 10

Both

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

AMD Opteron 64 bit SLES 10 (See footnote 2) 64 bit or 32 bit 32 bit Oracle Application Server 10g Release 2 (10.1.2.0.2) Oracle HTTP Server 10g Release 2

AMD Opteron

64 bit

SLES 9

64 bit or 32 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

AMD Opteron 64 bit Microsoft Windows 2008 (See footnote 5) both 32 bit Oracle Application Server 10g Release 2 (10.1.2.0.2) Oracle HTTP Server 10Release 2
AMD Opteron 64 bit Microsoft Windows 2008 R2 (See footnote 5) 64 bit 32 bit Oracle Application Server 10g Release 2 (10.1.2.0.2) Oracle HTTP Server 10g Release 2

AMD Opteron

64 bit

Microsoft Windows Vista (See footnote 1)

both

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

AMD Opteron

64 bit

Windows 2003 R1 with SP1 or higher

32 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

AMD Opteron

64 bit

Windows 2003 R1 with SP1

64 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

AMD Opteron

64 bit

Windows 2000 with SP3 or higher

32 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

AMD Opteron

64 bit

Windows XP Professional

64 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

AMD Opteron

64 bit

Windows XP Professional with SP2

32 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

AMD Opteron

64 bit

Windows XP Professional

32 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

IBM zSeries

64 bit

Red Hat Linux AS 4.0 Update 2

64 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

IBM zSeries

64 bit

SLES 9 SP2

64 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel

32 bit

Oracle Enterprise Linux (OEL) 4.0 / Oracle VM

(See footnote 3)
 

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel

32 bit

Asianux 2.0

 

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel

32 bit

Oracle Enterprise Linux (OEL) 5 / Oracle VM
(See footnote 5)

32 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10Release 2

Intel

32 bit

Red Hat Linux 5 / Oracle VM
(See footnote 5)

32 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10Release 2

Intel

32 bit

Red Hat Linux EL 3.0 (UL3 or higher)

64 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel

32 bit

Red Hat Linux EL 4.0 (UL1 or higher) / Oracle VM

64 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel

32 bit

Red Hat Linux AS 2.1 UL5 with Errata 49 kernel or higher

 

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel

32 bit

Red Hat AS 4.0 (UL1 or UL2)

 

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel

32 bit

SLES 10
(See footnote 2)

 

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel

32 bit

SLES 9

 

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel

32 bit

SLES 8 SP3

 

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel

32 bit

Solaris 2.9

32 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel

32 bit

Solaris 10

32 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel 32 bit Microsoft Windows
2008
(See footnote 5)
32 bit 32 bit Oracle Application Server 10g Release 2 (10.1.2.0.2) Oracle HTTP Server 10g Release 2

Intel

32 bit

Microsoft Windows Vista (See footnote 1)

32 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel

32 bit

Windows 2003 R1 (with SP1 or higher) and R2

 

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel

32 bit

Windows 2003 with SP3 or higher

 

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel

32 bit

Windows XP with SP2 or higherThe
information in this section is grouped as
follows:

 

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel EM64T

64 bit

Oracle Enterprise Linux (OEL) 5 / Oracle VM
(See footnote 5)

both

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10Release 2

Intel EM64T

64 bit

Red Hat Linux 5 / Oracle VM
(See footnote 5)

both

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10Release 2

Intel EM64T

64 bit

Oracle Enterprise Linux (OEL) 4.0 / Oracle VM

(See footnote 3)

both

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel EM64T

64 bit

Red Hat Linux EL 3.0 (UL3 or higher)

64 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel EM64T

64 bit

Red Hat Linux EL 4.0 (UL1 or higher) / Oracle VM

64 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel EM64T

64 bit

SLES 10
(See footnote 2)

64 bit or 32 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel EM64T

64 bit

SLES 9

64 bit or 32 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel EM64T 64 bit Microsoft Windows 2008 (See footnote 5) both 32 bit Oracle Application Server 10g Release 2 (10.1.2.0.2) Oracle HTTP Server 10g Release 2
Intel EM64T 64 bit Microsoft Windows 2008 R2 (See footnote 5) 64 bit 32 bit Oracle Application Server 10g Release 2 (10.1.2.0.2) Oracle HTTP Server 10g Release 2

Intel EM64T

64 bit

Microsoft Windows Vista (See footnote 1)

both

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel EM64T

64 bit

Windows 2003 R! with SP1 or higher

64 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel EM64T

64 bit

Windows 2000 with SP3 or higher

32 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel EM64T

64 bit

Windows XP Professional

32 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel EM64T

64 bit

Windows XP Professional

64 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Intel EM64T

64 bit

Windows XP Professional with SP2

32 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Itanium-2

64 bit

HP-UX 11i (11.23)

64 bit

64 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Itanium-2 64 bit HP-UX 11iV3 (11.31) 64 bit 64 bit Oracle Application Server 10g Release 2 (10.1.2.0.2) Oracle HTTP Server 10g Release 2

Itanium-2

64 bit

Red Hat Linux EL3.0 (UL6)

 

64 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Itanium-2

64 bit

Red Hat Linux EL4.0 (UL1)

 

64 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Itanium-2

64 bit

SLES 9 SP3

 

64 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Itanium-2

64 bit

Windows 2003 Server 64 bit Itanium

64 bit

64 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

PA-RISC

64 bit

HP-UX 11i (11.11)

64 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

PA-RISC

64 bit

HP-UX 11i (11.23)

64 bit

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

PA-RISC 64 bit HP-UX 11iV3 (11.31) 64 bit 32 bit Oracle Application Server 10g Release 2 (10.1.2.0.2) Oracle HTTP Server 10g Release 2

Power

64 bit

AIX 5L (5.2 ML04 or higher) (See footnote 4)

IBM AIX 5.2 has been deprecated. Oracle Fusion Middleware 10.1.4 support has ended on AIX 5.2, as it reached end of life on April 30, 2009. For more information on IBM’s support policy, refer to http://www-01.ibm.com/software/support/systemsp/lifecycle/index.html

 

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Power

64 bit

AIX 5L (5.3 ML02 or higher) (See footnote 4)

 

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Power 64 bit AIX 6.1(See footnote 4)   32 bit Oracle Application Server 10g Release 2 (10.1.2.0.2) Oracle HTTP Server 10g Release 2

Power

64 bit

Red Hat Linux EL4.0 (UL1 or higher)

 

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

Power

64 bit

SLES 9 (SP2 or higher)

 

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

SPARC

64 bit

Solaris 2.8

 

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

SPARC

64 bit

Solaris 2.9

 

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2

SPARC

64 bit

Solaris 10

 

32 bit

Oracle Application Server 10g Release 2 (10.1.2.0.2)

Oracle HTTP Server 10g Release 2


Footnote 1 - Microsoft Vista support requires Patch Set 10.1.4.2. For more information, please refer to MetaLink note number 465847.1 on My Oracle Support.

Footnote 2 - SLES support requires Patch Set 10.1.4.2. For more information, please refer to MetaLink note number 465847.1 on My Oracle Support.

Footnote 3 - Before installing, please refer to Table 2-4 of the Oracle Application Server Installation Guide 10g (10.1.4.0.1) for Linux x86 for a list of required OS packages. Also, apply patch 6198537 following the instructions in the included README file in order to start the 10.1.4.0.1 installer.

Footnote 4- There is a known issue with IBM platforms and the 10.1.4.2 patchset. For additional information, please refer to MetaLink Note 466039.1 on My Oracle Support.

Footnote 5 - Oracle Enterprise Linux (OEL)/Red Hat Linux EL 5, Microsoft Windows 2008, and Microsoft Windows 2008 R2 support requires Patch Set 10.1.4.3. For more information, please refer to MetaLink note number 465847.1 on My Oracle Support.

4.2 Oracle Identity Federation Third Party Certification

Table 12 lists the third party certification details for Oracle Identity Federation.

Table 12 Oracle Identity Federation Third Party Certification

  Certification Details Additional Information (See Table 12)

Customer Directory ServiceFoot 1 

Microsoft AD 2000

 

Microsoft AD 2003

 

Oracle Internet Directory 10.1.4.0.1

 

Oracle Virtual Directory 10.1.4.0.1

 

Sun Java Directory Server 5.2

 

Customer Database

MS SQL Server 2000

 

Oracle Database 9.2.0.8, 10.1.0.5, 10.2.0.2+, 11.1.0.6+Foot 2 , 11.2.0.1+Foot 3

3

Web Proxy Server

Sun Java System WebServer 6.1

2

Browsers

Microsoft Internet Explorer 8.0 4

Microsoft Internet Explorer 7.0

1

Microsoft Internet Explorer 6.0

 

Mozilla 1.7 (Deprecated, Oracle recommends moving to a supported version of Firefox listed.)

 

Firefox 1.5 (Deprecated, Oracle recommends moving to a supported version of the browsers listed.) 

 

Firefox 3.5 4

Third Party Integration

Oracle Access Manager 10.1.4

 

Oracle COREid Access 7.0.4

 

Oracle Application Server Single Sign-On 10.1.4

 

CA Siteminder Policy Server 5.5

 

Active Directory Federation Services (ADFS) via WS-Federation Passive Requester Profile (for Windows 2003 EE R2)

 

Footnote 1 Please refer to the Directory Server vendor's platform certification for OS platform support.

Footnote 2 For additional information about Oracle Database 11gR1 Certification for Oracle Application Server 10g (10.1.2.x), please refer to MetaLink Note 740417.1 on My Oracle Support.

Footnote 3 For additional information about Oracle Database 11gR2 Certification for Oracle Application Server 10g (10.1.2.x), please refer to MetaLink Note 887365.1 on My Oracle Support.

 

Table 13 Additional Information for Oracle Identity Federation Third Party Certification

Number Description

1

Certified with 10.1.4.2 Patch Set.

2

Certified as a web proxy server front-ending Oracle Identity Federation.

3

Customers planning to upgrade their database to 11.1.0.6 and apply Oracle Identity Federation patch set 10.1.4.2 must apply the 10.1.4.2 patch set prior to upgrading the database to avoid installation problems.

4 Certified with 10.1.2.3 Patch Set.



This section contains certification information for Oracle Enterprise Single Sign-On products. The following components are certified on Windows only:

Table 14 lists the Oracle Enterprise Single Sign-On Suite certification information for Windows.

Table 14 Oracle Enterprise Single Sign-On Suite Certification for Windows

Operating System Thick Client Supported Browsers Java Support Host Emulators Directory Servers

Windows

Windows 2000 with SP4

Windows XP Professional with SP3, SP2 

Windows Server 2003 with SP1

Windows Vista with Business Edition, v2 (see note 1 in the following table)

Microsoft Windows Server 2008 with Enterprise Edition

 

Microsoft Internet Explorer 7.0, 6.0 with SP1 (see note 2 in the following table)

Firefox 3.0, 2.0

JRE 1.3 or higher

JInitiator 1.3.x or higher

 

IBM DB2 Database 8.1.6

IBM Tivoli Directory Server 5.2

MS AD 2008, 2003, 2000

MS AD Application Mode 2003 SP1

MS SQL Server 2000

Novell eDirectory  8.8 SP1

Open LDAP Directory Server 2.2, 2.0.27

Oracle Database Management System 10g

Oracle Internet Directory 10.1.4.0.1

Siemens DirX Directory-NEW 8.0

Sun Java System Directory Server 5.2, 5.1


Table 14 Additional Information for Oracle Enterprise Single Sign-On Suite Certification for Windows

Number Description

1

Vista Business Edition for Logon Manager is supported with 10.1.4.0.3 and later .

 

Table 15 lists the Oracle Enterprise Single Sign-On Password Reset Server certification information for Windows.

Table 15 Oracle Enterprise Single Sign-On Password Reset Server Certification for Windows

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? .Net Framework Web Server Directory Servers as Repository Database as Repository

Any

32 bit

Windows 2000 SP4

Windows XP (client only) SP2, SP3

Windows Server 2003 SP2

Windows Server 2003 R2 SP2

Vista  (client only) Business Edition, Business Edition with SP1

32 bit

V2.0 or higher

IIS 5.0 or higher

MS AD 2000 verson 5.0 or higher

MS AD 2003 verson 5.2 or higher

MS ADAM 1.0

Oracle 10.1.3 or higher

MS SQL Server 2000


Table 16 Additional Information for Oracle Enterprise Single Sign-On Password Reset Server Certification for Windows

Number Description

1

Vista Business Edition is supported with 10.1.4.0.4 and later.



6 Oracle Access Manager Certification

The Oracle Access Manager Certification Information for 10gR3 has moved to a new location and format. To access the certification information, please click here.

If you do not have Microsoft Excel installed, please download Excel Viewer to open, view, and print Excel workbooks.

7 Oracle Virtual Directory Certification

This section contains certification information for Oracle Virtual Directory version 10.1.4.0.1.

The information in this section is grouped as follows:

7.1 Oracle Virtual Directory Solaris Certification

Table 25 lists the Oracle Virtual Directory certification information for Solaris.

Table 25 Oracle Virtual Directory Certification for Solaris

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? Oracle Virtual Directory will run as 32 or 64 bit Application? Server or Client?Foot 1  Directory ServersFoot 2  DatabaseFoot 3 

SPARC

32 bit

Solaris 2.9

Solaris 10

Solaris 10 LDOM

Solaris 10 Containers

32 bit

32 bit

Server

Oracle Internet Directory 10.1.2.1.0

Oracle Internet Directory 10.1.4.0.1

Sun Java System Directory Server 5.2

Sun Directory Server Enterprise Edition 6.2

Siemens DirX v2.0B

Novell eDirectory 8.7.3

IBM Directory Server 5.1

MS AD 2000

MS AD 2003

MS AD 2008

MS ADAM 1.0

MS ADAM 2003

MS ADAM 2008

Oracle 10.1.0.5

Oracle 10.2.0.1

MS SQL Server 2000

Oracle 9.2.0.8

Oracle 10.2.0.2 (RAC and non-RAC configurations)

Oracle DB 11gR1

Oracle DB 11gR2

Oracle TimesTen

IBM DB2


Footnote 1 Only the Virtual Directory Server has been certified for Solaris 2.9. Refer to Section 7.2, "Oracle Virtual Directory Linux Certification" and Section 7.3, "Oracle Virtual Directory Windows Certification" for Virtual Directory client certifications.

Footnote 2 Refer to the appropriate Directory Server certification matrices for platform certification information.

Footnote 3 Refer to the appropriate Database certification matrices for platform certification information for Oracle and MS SQL Server 2000.

7.2 Oracle Virtual Directory Linux Certification

Table 26 lists the Oracle Virtual Directory certification information for Linux.

Table 26 Oracle Virtual Directory Certification for Linux

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? Oracle Virtual Directory will run as 32 or 64 bit Application? Server or Client? Directory ServersFoot 1  DatabaseFoot 2 

Any

32 bit

Red Hat Linux EL 3.0 UL3

OEL 4.0 / Oracle VM

Red Hat Linux EL 4.0 / Oracle VM

OEL 5.0 (Both 32-bit and 64-bit)

Red Hat Linux EL 5.0 (Both 32-bit and 64-bit)

32 bit

32 bit

Both

Oracle Internet Directory 10.1.2.1.0

Oracle Internet Directory 10.1.4.0.1

Sun Java System Directory Server 5.2

Sun Directory Server Enterprise Edition 6.2

Siemens DirX v2.0B

Novell eDirectory 8.7.3

IBM Directory Server 5.1

MS AD 2000

MS AD 2003

MS AD 2008

MS ADAM 1.0

MS ADAM 2003

MS ADAM 2008

Oracle 10.1.0.5

Oracle 10.2.0.1

MS SQL Server 2000

Oracle 9.2.0.8

Oracle 10.2.0.2 (RAC and non-RAC configurations)

Oracle DB 11gR1

Oracle DB 11gR2

Oracle TimesTen

IBM DB2


Footnote 1 Refer to the appropriate Directory Server certification matrices for platform certification information.

Footnote 2 Refer to the appropriate Database certification matrices for platform certification information for Oracle and MS SQL Server 2000.

7.3 Oracle Virtual Directory Windows Certification

Table 27 lists the Oracle Virtual Directory certification information for Windows.

Table 27 Oracle Virtual Directory Certification for Windows

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? Oracle Virtual Directory will run as 32 or 64 bit Application? Server or Client? Directory ServersFoot 1  DatabaseFoot 2 

Any

32 bit

Windows 2003 EE SP1

Windows 2003 EE SP3

Windows 2003 R2

Windows 2000

Windows WP

Windows Vista (Client Only)

Windows 2008

32 bit

32 bit

Both

Oracle Internet Directory 10.1.2.1.0

Oracle Internet Directory 10.1.4.0.1

Sun Java System Directory Server 5.2

Sun Directory Server Enterprise Edition 6.2

Siemens DirX v2.0B

Novell eDirectory 8.7.3

IBM Directory Server 5.1

MS AD 2000

MS AD 2003

MS AD 2008

MS ADAM 1.0

MS ADAM 2003

MS ADAM 2008

Oracle 10.1.0.5

Oracle 10.2.0.1

MS SQL Server 2000

Oracle 9.2.0.8

Oracle 10.2.0.2 (RAC and non-RAC configurations)

Oracle DB 11gR1

Oracle DB 11gR2

Oracle TimesTen

IBM DB2


Footnote 1 Refer to the appropriate Directory Server certification matrices for platform certification information.

Footnote 2 Refer to the appropriate Database certification matrices for platform certification information for Oracle and MS SQL Server 2000.

7.4 Oracle Virtual Directory SLES Certification

Table 28 lists the Oracle Virtual Directory certification information for SLES.

Table 28 Oracle Virtual Directory Certification for SLES

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? Oracle Virtual Directory will run as 32 or 64 bit Application? Server or Client? Directory ServersFoot 1  DatabaseFoot 2 

Any

32 bit

SLES 9.0

SLES 10.0

32 bit

32 bit

Both

Oracle Internet Directory 10.1.2.1.0

Oracle Internet Directory 10.1.4.0.1

Sun Java System Directory Server 5.2

Sun Directory Server Enterprise Edition 6.2

Siemens DirX v2.0B

Novell eDirectory 8.7.3

IBM Directory Server 5.1

MS AD 2000

MS AD 2003

MS AD 2008

MS ADAM 1.0

MS ADAM 2003

MS ADAM 2008

Oracle 10.1.0.5

Oracle 10.2.0.1

MS SQL Server 2000

Oracle 9.2.0.8

Oracle 10.2.0.2 (RAC and non-RAC configurations)

Oracle DB 11gR1

Oracle DB 11gR2

Oracle TimesTen

IBM DB2


Footnote 1 Refer to the appropriate Directory Server certification matrices for platform certification information.

Footnote 2 Refer to the appropriate Database certification matrices for platform certification information for Oracle and MS SQL Server 2000.

7.5 Oracle Virtual Directory AIX Certification

Table 29 lists the Oracle Virtual Directory certification information for AIX.

Table 29 Oracle Virtual Directory Certification for AIX

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? Oracle Virtual Directory will run as 32 or 64 bit Application? Server or Client?Foot 1  Directory ServersFoot 2  DatabaseFoot 3 

Any

64 bit

IBM AIX 5.3

64 bit

64 bit

Server

Oracle Internet Directory 10.1.2.1.0

Oracle Internet Directory 10.1.4.0.1

Sun Java System Directory Server 5.2

Sun Directory Server Enterprise Edition 6.2

Siemens DirX v2.0B

Novell eDirectory 8.7.3

IBM Directory Server 5.1

MS AD 2000

MS AD 2003

MS AD 2008

MS ADAM 1.0

MS ADAM 2003

MS ADAM 2008

Oracle 10.1.0.5

Oracle 10.2.0.1

MS SQL Server 2000

Oracle 9.2.0.8

Oracle 10.2.0.2 (RAC and non-RAC configurations)

Oracle DB 11gR1

Oracle DB 11gR2

Oracle TimesTen

IBM DB2


Footnote 1 Only the Virtual Directory Server has been certified for AIX 5.3. Refer to Section 7.2, "Oracle Virtual Directory Linux Certification" and Section 7.3, "Oracle Virtual Directory Windows Certification" for Virtual Directory client certifications.

Footnote 2 Refer to the appropriate Directory Server certification matrices for platform certification information.

Footnote 3 Refer to the appropriate Database certification matrices for platform certification information for Oracle and MS SQL Server 2000.

7.6 Oracle Virtual Directory HP Certification

Table 30 lists the Oracle Virtual Directory certification information for HP.

Table 30 Oracle Virtual Directory Certification for HP

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? Oracle Virtual Directory will run as 32 or 64 bit Application? Server or Client?Foot 1  Directory ServersFoot 2  DatabaseFoot 3 

Any

32 bit

HP-UX 11i (11.11)

32 bit

32 bit

Server

Oracle Internet Directory 10.1.2.1.0

Oracle Internet Directory 10.1.4.0.1

Sun Java System Directory Server 5.2

Sun Directory Server Enterprise Edition 6.2

Siemens DirX v2.0B

Novell eDirectory 8.7.3

IBM Directory Server 5.1

MS AD 2000

MS AD 2003

MS AD 2008

MS ADAM 1.0

MS ADAM 2003

MS ADAM 2008

Oracle 10.1.0.5

Oracle 10.2.0.1

MS SQL Server 2000

Oracle 9.2.0.8

Oracle 10.2.0.2 (RAC and non-RAC configurations)

Oracle DB 11gR1

Oracle DB 11gR2

Oracle TimesTen

IBM DB2


Footnote 1 Only the Virtual Directory Server has been certified for AIX 5.3. Refer to Section 7.2, "Oracle Virtual Directory Linux Certification" and Section 7.3, "Oracle Virtual Directory Windows Certification" for Virtual Directory client certifications.

Footnote 2 Refer to the appropriate Directory Server certification matrices for platform certification information.

Footnote 3 Refer to the appropriate Database certification matrices for platform certification information for Oracle and MS SQL Server 2000.

7.7 Additional Java Certifications

  • Oracle Virtual Directory is certified with JRE 1.6 now.

8 Oracle Internet Directory and Oracle Application Server Single Sign-On Certification

Table 31 through Table 34 contain the overall certification information for Oracle Application Server, which is applicable for Oracle Internet Directory and Oracle Application Server Single Sign-On.

The information in this section is grouped as follows:

Oracle Identity Management (10.1.4.0.1) and higher are supported on Montecito based servers for Linux. Montecito (Dual-Core) and later Itanium-2 based servers are not supported for Windows.

8.1 Oracle Application Server Platform Certification

Table 31 Oracle Application Server Certified Platforms

Processor Bus Architecture Operating System JDK CertificationFoot 1  Additional Information (see Table 32)

AMD Opteron

64 bit

Oracle Enterprise Linux (OEL) 5 (64 bit OS) / Oracle VM

Sun 32-bit JDK 1.4.2_(18+)

2,4,5,6,7,8,16, 21, 22

AMD Opteron

64 bit

Red Hat Linux EL 5 (64 bit OS) / Oracle VM

Sun 32-bit JDK 1.4.2_(18+)

2,4,5,6,7,8, 16, 21, 22

AMD Opteron

64 bit

Oracle Enterprise Linux (OEL) 4.0 (64 bit OS) / Oracle VM

Sun 32-bit JDK 1.4.2_(06+)

2,4,5,6,7,8,12, 22

AMD Opteron

64 bit

Red Hat Linux EL 3.0 (UL3 or higher) (64 bit OS)

Sun 32-bit JDK 1.4.2_(06+)

2,4,5,6,7,8, 22

AMD Opteron

64 bit

Red Hat Linux EL 4.0 (UL1 or higher) (64 bit OS) / Oracle VM

Sun 32-bit JDK 1.4.2_(06+)

2,4,5,6,7,8, 22

AMD Opteron

64 bit

Solaris 10 (32 bit and 64 bit OS)

Sun 32-bit JDK 1.4.2_(12+)

4,5,6,7,8, 22

AMD Opteron

64 bit

SLES 9 (64 bit OS or 32 bit OS)

Sun 32-bit JDK 1.4.2_(06+)

2,4,5,6,7,8, 22

AMD Opteron

64 bit

SLES 10 (64 bit OS or 32 bit OS)

Sun 32-bit JDK 1.4.2_(06+)

2,4,5,6,7,8,10,16, 22

AMD Opteron

64 bit

Microsoft Windows 2008 (32 and 64
bit OS)
Sun 32-bit JDK 1.4.2_(18+) 2,4,5,6,7,8,16, 21, 22
AMD Opteron 64 bit Microsoft Windows 2008 R2 (64 bit OS) Sun 32-bit JDK 1.4.2_(18+) 2,4,5,6,7,8,16, 21, 22

AMD Opteron

64 bit

Microsoft Windows Vista (32 and 64 bit OS)

Sun 32-bit JDK 1.4.2_(14+)

2,4,5,6,7,8,10,16, 22

AMD Opteron

64 bit

Windows 2003 R1 with SP1 or higher (32 bit OS)

Sun 32-bit JDK 1.4.2_(06+)

2,4,5,6,7,8, 22

AMD Opteron

64 bit

Windows 2003 R1 with SP1 (64 bit OS)

Sun 32-bit JDK 1.4.2_(06+)

2,4,5,6,7,8, 22

AMD Opteron

64 bit

Windows 2000 with SP3 or higher (32 bit OS)

Sun 32-bit JDK 1.4.2_(06+)

2,4,5,6,7,8, 22

AMD Opteron

64 bit

Windows XP Professional (64 bit OS)

Sun 32-bit JDK 1.4.2_(06+)

2,4,5,6,7,8, 22

AMD Opteron

64 bit

Windows XP Professional with SP2 (32 bit OS)

Sun 32-bit JDK 1.4.2_(06+)

2,3,4,5,6,7,8, 22

AMD Opteron

64 bit

Windows XP Professional (32 bit OS)

Sun 32-bit JDK 1.4.2_(06+)

2,4,5,6,7,8, 22

IBM zSeries

64 bit

Red Hat Linux AS 4.0 Update 2

JDK 1.4.2 SR5 (cx390142-20060421) or higher

JDK 1.4.2 SR5 (cxz64142-20060421) or higher

4,5,6,7,8,9, 22

IBM zSeries

64 bit

SLES 9 SP 2

JDK 1.4.2 SR5 (cx390142-20060421) or higher

JDK 1.4.2 SR5 (cxz64142-20060421) or higher

4,5,6,7,8,9, 22

Intel

32 bit

Asianux 2.0

Sun 32-bit JDK 1.4.2_(06+)

4,5,6,7,8, 22

Intel

32-bit

Oracle Enterprise Linux (OEL) 5 / Oracle VM

Sun 32-bit JDK 1.4.2_(18+)

16, 21, 22

Intel

32-bit

Red Hat Linux 5 / Oracle VM

Sun 32-bit JDK 1.4.2_(18+)

16, 21, 22

Intel

32 bit

Oracle Enterprise Linux (OEL) 4.0 / Oracle VM

Sun 32-bit JDK 1.4.2_(06+)

12, 22

Intel

32 bit

Red Hat Linux EL 3.0 (UL3 or higher)

Sun 32-bit JDK 1.4.2_(06+)

22

Intel

32 bit

Red Hat Linux EL 4.0 (UL1 or higher) / Oracle VM

Sun 32-bit JDK 1.4.2_(06+)

22

Intel

32 bit

Red Hat AS 2.1 UL5 with Errata 49 kernel or higher

Sun 32-bit JDK 1.4.2_(06+)

22

Intel

32 bit

Red Hat AS 4.0 (UL1 or UL2)

Sun 32-bit JDK 1.4.2_(06+)

22

Intel

32 bit

Solaris 9 (32 bit OS)

Sun 32-bit JDK 1.4.2_(12+)

4,5,6,7,8, 22

Intel

32 bit

Solaris 10 (32 bit OS)

Sun 32-bit JDK 1.4.2_(12+)

4,5,6,7,8, 22

Intel

32 bit

SLES 10

Sun 32-bit JDK 1.4.2_(06+)

4,5,6,7,8,10,16, 22

Intel

32 bit

SLES 9

Sun 32-bit JDK 1.4.2_(06+)

4,5,6,7,8, 22

Intel

32 bit

SLES 8 SP3

Sun 32-bit JDK 1.4.2_(06+)

4,5,6,7,8, 22

Intel 32 bit Microsoft Windows 2008 Sun 32-bit JDK 1.4.2_(18+) 16, 21, 22

Intel

32 bit

Microsoft Windows Vista

Sun 32-bit JDK 1.4.2_(14+)

10,16, 22

Intel

32 bit

Windows 2003 R1 (with SP1 or higher) and R2

Sun 32-bit JDK 1.4.2_(06+)

22

Intel

32 bit

Windows 2000 with SP3 or higher

Sun 32-bit JDK 1.4.2_(06+)

22

Intel

32 bit

Windows XP with SP2 or higher

Sun 32-bit JDK 1.4.2_(06+)

22

Intel EM64T

64 bit

Oracle Enterprise Linux (OEL) 5 (64 bit OS) / Oracle VM

Sun 32-bit JDK 1.4.2_(18+)

2, 16, 21, 22

Intel EM64T

64 bit

Red Hat Linux 5 (64 bit OS) / Oracle VM

Sun 32-bit JDK 1.4.2_(18+)

2, 16, 21, 22

Intel EM64T

64 bit

Oracle Enterprise Linux (OEL) 4.0 / Oracle VM

Sun 32-bit JDK 1.4.2_(06+)

2,12, 22

Intel EM64T

64 bit

Red Hat Linux EL 3.0 (UL3 or higher) (64 bit OS)

Sun 32-bit JDK 1.4.2_(06+)

2, 22

Intel EM64T

64 bit

Red Hat Linux EL 4.0 (UL1 or higher) (64 bit OS) / Oracle VM

Sun 32-bit JDK 1.4.2_(06+)

2, 22

Intel EM64T

64 bit

SLES 10 (64 bit OS or 32 bit OS)

Sun 32-bit JDK 1.4.2_(06+)

2,4,5,6,7,8,10,16, 22

Intel EM64T

64 bit

SLES 9 (64 bit OS or 32 bit OS)

Sun 32-bit JDK 1.4.2_(06+)

2,4,5,6,7,8, 22

Intel EM64T 64 bit Microsoft Windows 2008 (64 bit OS) Sun 32-bit JDK 1.4.2_(18+) 2, 16, 21, 22
Intel EM64T 64 bit Microsoft Windows 2008 R2 (64 bit OS) Sun 32-bit JDK 1.4.2_(18+) 2, 16, 21, 22

Intel EM64T

64 bit

Microsoft Windows Vista (64 bit OS)

Sun 32-bit JDK 1.4.2_(14+)

2,10,16, 22

Intel EM64T

64 bit

Windows 2003 R1 with SP1 or higher (64 bit OS)

Sun 32-bit JDK 1.4.2_(06+)

2, 22

Intel EM64T

64 bit

Windows 2000 with SP3 or higher (32 bit OS)

Sun 32-bit JDK 1.4.2_(06+)

2, 22

Intel EM64T

64 bit

Windows XP Professional (64 bit OS)

Sun 32-bit JDK 1.4.2_(06+)

2, 22

Intel EM64T

64 bit

Windows XP Professional (32 bit OS)

Sun 32-bit JDK 1.4.2_(06+)

2, 22

Intel EM64T

64 bit

Windows XP Professional with SP2 (32 bit OS)

Sun 32-bit JDK 1.4.2_(06+)

2, 22

Itanium-2

64 bit

HP-UX 11i (11.23)

HP 64-bit JDK 1.4.2.(07+)

4,5,6,7,8,15

Itanium-2 64 bit HP-UX 11iV3 (11.31) HP 64-bit JDK 1.4.2.(07+) 4,5,6,7,8,15,20

Itanium-2

64 bit

Red Hat Linux EL 3.0 (UL6)

BEA JRockit 64-bit JDK 1.4.2_(10-b03+)

4,5,6,7,8,17

Itanium-2

64 bit

Red Hat Linux EL 4.0 (UL1)

BEA JRockit 64-bit JDK 1.4.2_(10-b03+)

4,5,6,7,8,17

Itanium-2

64 bit

SLES 9 SP3

BEA JRockit 64-bit JDK 1.4.2_(10-b03+)

4,5,6,7,8,17

Itanium-2

64 bit

Windows 2003 Server 64 bit Itanium

BEA JRockit 64-bit JDK 1.4.2_(05+)

4,5,6,7,8,18, 19

PA-RISC

64 bit

HP-UX 11i (11.11)

HP 64-bit JDK 1.4.2.(06+)

4,5,6,7,8

PA-RISC

64 bit

HP-UX 11i (11.23)

HP 64-bit JDK 1.4.2.(06+)

4,5,6,7,8

PA-RISC 64 bit HP-UX 11iV3 (11.31) HP 64-bit JDK 1.4.2.(06+) 4,5,6,7,8,13

Power

64 bit

AIX 5L (5.2 ML04 or higher)

IBM AIX 5.2 has been deprecated. Oracle Fusion Middleware 10.1.4 support has ended on AIX 5.2, as it reached end of life on April 30, 2009. For more information on IBM’s support policy, refer to http://www-01.ibm.com/software/support/systemsp/lifecycle/index.html

IBM 32-bit SDK 1.4.2 ca142ifx-20060209 (SR4-1) or higher

IBM 64-bit SDK 1.4.2 caix64142-20060421 (SR5) or higher

4,5,6,7,8,9,11

Power

64 bit

AIX 5L (5.3 ML02 or higher)

IBM 32-bit SDK 1.4.2 ca142ifx-20060209 (SR4-1) or higher

IBM 64-bit SDK 1.4.2 caix64142-20060421 (SR5) or higher

4,5,6,7,8,9,11

Power

64 bit

AIX 6.1

IBM 32-bit SDK 1.4.2 ca142ifx-20060209 (SR4-1) or higher

IBM 64-bit SDK 1.4.2 caix64142-20060421 (SR5) or higher

4,5,6,7,8,9,11,14,16

Power

64 bit

Red Hat Linux EL 4.0 (UL1 or higher)

IBM 32-bit SDK 1.4.2 cxppc32142ifx-20060209 (SR4-1) or higher

IBM 64-bit SDK 1.4.2 cxp64142-20060824 (SR6) or higher

4,5,6,7,8,9

Power

64 bit

SLES 9 (SP2 or higher)

IBM 32-bit SDK 1.4.2 cxppc32142ifx-20060209 (SR4-1) or higher

IBM 64-bit SDK 1.4.2 cxp64142-20060824 (SR6) or higher

4,5,6,7,8,9

SPARC

64 bit

Solaris 8

Sun 64-bit JDK 1.4.2_(08+)

2,4,5,6,7,8, 22

SPARC

64 bit

Solaris 9

Sun 64-bit JDK 1.4.2_(08+)

2,4,5,6,7,8, 22

SPARC

64 bit

Solaris 10

Sun 64-bit JDK 1.4.2_(08+)

1,2,4,5,6,7,8, 22


Footnote 1 A plus sign (+) after the fourth digit in the version number indicates that this and all higher versions of the JRE/JINIT/JDK extensions are certified. For example, 1.4.2_(06+) means that 1.4.2_06, 1.4.1_07, and any  1.4.2_xx versions are certified. See Table 31 for vendors supported for your platform.

Table 32 Additional Information for Certified Platforms

Number Description

1

Please see OracleMetaLink Note 330016.1, "Installation Requirements for Solaris10 Operating System (SPARC)."

2

Oracle Application Server will run as a 32-bit application although the processor is 64 bit.

3

Oracle Application Server Support for Windows XP is only applicable for J2EE and Web Cache and OracleAS Developer Kits.

4

Oracle Web Services Manager is not certified on this platform.

5

Oracle Web Services Manager Gatewayis not certified on this platform.

6

Oracle Web Services Manager Agent is not certified on this platform.

7

Oracle Web Services Manager Monitor is not certified on this platform.

8

Oracle Web Services Manager Policy Server is not certified on this platform.

9

Only OID Server uses 64-bit JDK (from the $ORACLE_HOME/jdk64 directory). All other Java applications are certified to use 32-bit JDK (from the $ORACLE_HOME/jdk directory).

10

Certified with Patch Set 10.1.4.2. For additional information, please refer to MetaLink Note 465847.1

11

There is a known issue with IBM platforms and the 10.1.4.2 patchset. For additional information, please refer to MetaLink Note 466039.1

12

Before installing, please refer to Table 2-4 of the Oracle Application Server Installation Guide 10g (10.1.4.0.1) for Linux x86 for a list of required OS packages. Also, apply patch 6198537 following the instructions in the included README file in order to start the 10.1.4.0.1 installer. Refer to Oracle Identity Management 10g (10.1.4.0.1) Release Notes Addendum, Oracle Enterprise Linux (OEL) 5 or Red Hat Enterprise Linux (RHEL) 5 (DOC ID 465847.1), which can be found via the Knowledge Tab Page in My Oracle Support

13 HP patch PHKL_35936 is required.
The following Oracle patch must also be applied:
  • 6522391 (http://updates.oracle.com/download/6522391.html)
14 The following patches must be applied to install on AIX 6.1:
  • 6806473 (http://updates.oracle.com/download/6806473.html) must be applied for 10.1.4.0.1
  • 6806478 (http://updates.oracle.com/download/6806478.html) must be applied for 10.1.4.2
15

HP-UX Itanium Servers containing the Montecito chip are supported. The following HP patches are required:

  • HP-UX 11.23 Hardware Enablement Patches for HP-UX 11i v2, September 2006

  • Feature Enablement Patches for HP-UX 11i v2, September 2006

16 "Oracle Identity Management and OracleAS Metadata Repository" and "OracleAS Metadata Repository" installation types are not supported due to the fact that the 10gR1 database that comes with seeded Metadata Repository is not supported on this platform. Instead, use the 10.1.4.0.1 Metadata Repository Creation Assistant(MRCA) to install the 10.1.4.0.1 Metadata Repository into an Oracle Server 10gR2 (10.2.x) Database. Please refer to Oracle Application Server Metadata Repository Creation Assistant User's Guide 10g (10.1.4.0.1) for UNIX.

Note: The 10.1.4.0.1 MRCA is a piece of software which must be installed before it can run against a database. It is supported/certified to install 10.1.4.0.1 MRCA software on the OEL/RHEL 5.x machine. Refer to the README file to apply patch 7391245 and to start the 10.1.4.0.1 MRCA installer.

Alternatively, download MRCA for a different platform such as MS Windows. Once installed, run the MRCA from the chosen platform against the database
which resides on the remote machine. The MRCA simply uses SQL*Net to load the database objects into the database. Therefore this approach will work as long as there is network connectivity between the machine hosting the MRCA and the machine hosting the database.
17 Oracle Identity Management (10.1.4.0.1) and higher are supported on Montecito based servers for Linux.
18 Oracle Identity Management (10.1.4.0.1) and higher are supported on Single-Core Itanium-2 processors (like, McKinley and Madison).
19 Montecito (Dual-Core) and later Itanium-2 based servers are not supported for Windows
20 Oracle patch for 6257816 must be applied
21 Certified with Patch Set 10.1.4.3. For additional information, please refer to MetaLink Note 465847.1
22 Sun JDK 1.4.2 has extended support for Oracle customers. Use Patch 8453300, if you require the latest JDK 1.4.2 from Sun (for Solaris,
Linux and Windows). 
You can obtain this patch from http://myoraclesupport.com.

8.2 Oracle Application Server Database Certification

The following database terms are used in this section:

  • customer database: The original and primary database for storing your application data. Unless otherwise noted, the customer databases listed in this chapter are Oracle databases.

  • see database: The Oracle Database that is installed when you perform an Oracle Application Server Infrastructure installation.

  • metadata repository: A database containing schemas and objects needed by Oracle Application Server components. The metadata repository can be the seed database or can be loaded into an existing database. Unless otherwise noted, the metadata repositories listed in this chapter are Oracle databases.

Support to download the ARU patch to be applied to a 9.2.0.x database. Please use the Oracle Database 10g (10.1.0.4.2) Patch Set CD-ROM to patch a 10.1.x database.

You can create the Metadata Repository on platforms on which Oracle Application Server Metadata Repository Creation Assistant is not certified. To do so, run OracleAS Metadata Repository Creation Assistant on a certified platform and use the Remote Load feature to load the Metadata Repository on an Oracle Database certified for use as the Metadata Repository.

Oracle Application Server does not support a subset of the configurations supported by the Oracle Database. Wherever we certify a specific version of the Oracle Database for creating the Oracle Application Server Metadata Repository, it is certified in all the configurations that the Oracle Database itself supports (such as a single instance, RAC, RAC with ASM) unless otherwise indicated.

Please refer to Metalink note 740417.1 for details on Oracle Database 11gR1 Certification for Oracle Identitiy Management 10g (10.1.4). 

Please refer to Metalink note 887365.1 for details on Oracle Database 11gR2 Certification for Oracle Identity Management 10g (10.1.4).

Oracle Database 10g and earlier Certification for Customer Data, and for Use with Oracle Application Server Metadata Repository Creation Assistant

Table 33 Oracle Application Server Certified Oracle Databases (10g and earlier)

Platform Customer Database Metadata Repository Database Created Using Metadata Repository Creation Assistant Additional Information (see Table 34)
  9.2.0.8 or higher (in the 9.2 product line) 10.1.0.4 or higher (in the 10.1 product line) 10.2.0.1.0 or higher (in the 10.2 product line) 9.2.0.8 or higher (in the 9.2 product line) 10.1.0.5 or higher (in the 10.1 product line) 10.2.0.2.0 or higher (in the 10.2 product line)  

AMD Opteron 64 bit Oracle Enterprise Linux 4.0 (64 bit OS) / Oracle VM

Y

Y

Y

Y

Y

Y

1,2,3,5

AMD Opteron 64 bit Red Hat Linux EL 3.0 UL3 (64 bit OS)

Y

Y

Y

Y

Y

Y

1,2,3,5

AMD Opteron 64 bit OEL 4.0 and Red Hat Linux EL 4.0 UL1 (64 bit OS) / Oracle VM

Y

Y

Y

Y

Y

Y

1,2,3,5

AMD Opteron 64 bit Solaris 10 (32 bit and 64 bit OS)

Y

Y

Y

Y

Y

Y

 

AMD Opteron 64 bit SLES 10 (64 bit OS)

Y

Y

Y

Y

Y

Y

1,2,3,5

AMD Opteron 64 bit SLES 9 (64 bit OS)

Y

Y

Y

Y

Y

Y

1,2,3,5

AMD Opteron 64 bit Windows 2003 R1 (64 bit OS)

Y

Y

Projected

Y

Y

Projected

 

AMD Opteron 64 bit Windows 2003 R1 (32 bit OS)

Y

Y

Projected

Y

Y

Projected

 

AMD Opteron 64 bit Windows 2000 with SP3 or higher (32 bit OS)

Y

Y

Projected

Y

Y

Projected

 

AMD Opteron 64 bit Windows XP Professional (64 bit OS)

             

AMD Opteron 64 bit Windows XP Professional with SP2 (32 bit OS)

             

AMD Opteron 64 bit Windows XP Professional (32 bit OS)

             

IBM zSeries 64 bit Red Hat Linux As 4.0 Update 2

             

IBM zSeries 64 bit SLES 9 SP2

             

Intel 32 bit Asianux 2.0

N

Y

Y

N

Y

Y

2,5,7

Oracle Enterprise Linux (OEL 4.0) / Oracle VM

Y

Y

Y

Y

Y

Y

1,2,3

Intel 32 bit Red Hat Linux EL 3.0 UL3

Y

Y

Y

Y

Y

Y

1,2,3

Intel 32 bit OEL 4.0 and Red Hat Linux EL 4.0 UL1 / Oracle VM

Y

Y

Y

Y

Y

Y

1,2,3

Intel 32 bit Red Hat AS 2.1 UL5 with Errata 49 kernel or higher

Y

Y

Y

Y

Y

NA

3,4

Intel 32 bit OEL 4.0 and Red Hat AS 4.0 (UL1 or UL2)

             

Intel 32 bit Solaris 2.9 (32 bit OS)

             

Intel 32 bit Solaris 10 (32 bit OS)

             

Intel 32 bit SLES 9

Y

Y

Y

Y

Y

Y

1,2,3

Intel 32 bit SLES 8 SP3

Y

Y

Y

Y

Y

NA

3,4

Intel 32 bit Microsoft Vista

Y

Y

Y

Y

Y

Y

 

Intel 32 bit Windows 2003 R1 (with SP1 or higher) and R2

Y

Y

Y

Y

Y

Y

 

Intel 32 bit Windows 2000 with SP3 or higher

Y

Y

Y

Y

Y

Y

 

Intel 32 bit Windows XP with SP2 or higher

NA

NA

NA

NA

NA

NA

 

Oracle Enterprise Linux (OEL) 4.0 (64 bit OS) / Oracle VM

Y

Y

Y

Y

Y

Y

1,2,3,5

Intel EM64T 64 bit Red Hat Linux EL 3.0 UL3 (64 bit OS)

Y

Y

Y

Y

Y

Y

1,2,3,5

Intel EM64T 64 bit OEL 4.0 and Red Hat Linux EL 4.0 UL1 (64 bit OS) / Oracle VM

Y

Y

Y

Y

Y

Y

1,2,3,5

Intel EM64T 64 bit SLES 9 (64 bit OS)

Y

Y

Y

Y

Y

Y

1,2,3,5

Intel EM64T 64 bit Windows 2003 R1 (64 bit OS)

Y

Y

Projected

Y

Y

Y

 

Intel EM64T 64 bit Windows 2000 with SP3 or higher (32 bit OS)

Y

Y

Projected

Y

Y

Projected

 

Intel EM64T 64 bit Windows XP Professional (64 bit OS)

             

Intel EM64T 64 bit Windows XP Professional (32 bit OS)

             

Intel EM64T 64 bit Windows XP Professional with SP2 (32 bit OS)

             

Itanium-2 64 bit hp-ux 11i (11.23) hp

Y

Y

Y

Y

Y

Y

1,2,3,6,7

Itanium-2 64 bit Red Hat EL 3.0 (UL6)

Y

Y

Y

Y

Y

Y

6,7

Itanium-2 64 bit Red Hat EL 4.0 (UL1)

Y

Y

Y

Y

Y

Y

6,7

Itanium-2 64 bit SLES 9 SP3

Y

Y

Y

Y

Y

Y

6,7

Itanium-2 64 bit Windows 2003 Server 64 bit Itanium

Y

Y

Y

Y

Y

Y

6,7

PA-RISC 64 bit hp-ux 11i (11.11)

Y

Y

Y

Y

Y

Y

1,2,3,6,7

PA-RISC 64 bit hp-ux 11i (11.23)

Y

Y

Y

Y

Y

Y

1,2,3,6,7

Power 64 bit AIX 5L (5.2 ML04 or higher)

IBM AIX 5.2 has been deprecated. Oracle Fusion Middleware 10.1.4 support has ended on AIX 5.2, as it reached end of life on April 30, 2009. For more information on IBM’s support policy, refer to http://www-01.ibm.com/software/support/systemsp/lifecycle/index.html

Y

N

Y

Y

Y

Y

1,2,3,6,7

Power 64 bit AIX 5L (5.3 ML02 or higher)

 

Y

Y

Y

Y

Y

1,2,3,6,7

Power 64 bit AIX 6.1 N N Y N N Y 1,2,3,6,7,8,9

Power 64 bit Red Hat 4.0 (UL1 or higher)

N

N

Y

N

N

Y

7

Power 64 bit SLES 9 (SP2 or higher)

N

N

Y

N

N

Y

7

SPARC 64 bit Solaris 2.8

Y

Y

Y

Y

Y

Y

1,2,3,6,7

SPARC 64 bit Solaris 2.9

Y

Y

Y

Y

Y

Y

1,2,3,6,7

SPARC 64 bit Solaris 10

Y

Y

Y

Y

Y

Y

6,7


Table 34 Additional Information for Oracle Application Server Certified Oracle Databases

Number Category Description

1

Customer Database

If using 10.2.0.1 database as a customer database, please see bug 4551356.

2

Metadata Repository

If using 10.2.0.2 or higher database as a metadata repository database, please see bugs 4545305, 4924758, 4544465, 5041641, 4687475, and 4563434.

3

Metadata Repository

If using 10.2.0.2 or higher database as a metadata repository database and Portal 10.1.4, please see bugs 4933310 and 4924758.

4

Metadata Repository

Please run linux32 bash before installing Metadata Repository Creation Assistant 10g (10.1.2.0.3).

5

Metadata Repository

In the 10.1 product line, certification is for 10.1.0.4.2 or higher, or 10.1.0.5 or higher.

6

Customer Database

In the 10.1 product line, certification is for 10.1.0.5 or higher.

7

Customer Database

In the 10.2 product line, certification is for 10.2.0.2 or higher.

8 Metadata
Repository
10.2.0.3 or higher database as a metadata repository database is required for Power 64 bit AIX 6.1. Please see bug 8980500.
9 Customer
Database
10.2.0.3 or higher database as a customer database is required for Power 64 bit AIX 6.1. Please see bug 8980500.

8.3 Oracle Application Server Browser Certification

Table 6, "Oracle Application Server Certified Browsers and Thick Clients" in Oracle AS 10g (10.1.2) Certification Matrix lists the certified browsers

Note:
  • OracleAS Single Sign-On Windows Native Authentication is supported from Microsoft Internet Explorer 7.0, 8.0, after following the instructions in Metalink note 418234.1 on My Oracle Support.
  • OracleAS Single Sign-On 10.1.4.3 is certified with Safari 4.x. For additional information, please refer to Oracle Fusion Middleware Release Notes 11gR1 http://download.oracle.com/docs/cd/E14571_01/doc.1111/e14774/install.htm#BABCJGBJ on the following: Rerouting to Original URL After SSO Authentication in Firefox and Safari Browsers.

9 Oracle Role Manager Certification

General certification information for Oracle Role Manager:

  • ORole Manager was previously known as Bridgestream SmartRoles.
  • The Oracle Rracle ole Manager User Interface requires Microsoft Internet Explorer 6.0.x or 7.0.
  • Oracle Role Manager Release 10.1.4.x is a non-internationalized version.
     

The information in this section is grouped as follows:

9.1 Oracle Role Manager Linux Certification

Table 35 lists the Oracle Role Manager certification information for Linux.

Table 35 Oracle Role Manager Certification for Linux

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? Web Container Certified ORM Version
JDK Additional Information
(see Table 38-1)
Intel Pentium 32 bit and 64 bit RedHat EL (RHEL) 4/
Oracle Enterprise Linux (OEL) 4
Both JBoss 4.2.3 10.1.4.2 Sun JDK 1.6.0 1, 2, 3, 6, 7,8
WebSphere 6.1.0.21  10.1.4.2 IBM JDK 1.5.0   1, 2, 3,6, 7
WebLogic 10.3 10.1.4.2 JRockit 1.6.0_05 1, 2, 3, 4,6, 7
RHEL 5/OEL 5/ Oracle VM Both JBoss 4.2.3GA 10.1.4.2 Sun JDK 1.6.0 1, 2, 3, 6, 7,8
WebLogic 10.3 10.1.4.2 JRockit 1.6.0_05 1, 2, 3, 4, 6, 7
SLES 10 32 bit WebLogic 10.3 10.1.4.2 JRockit 1.6.0_05



9.2 Oracle Role Manager Windows Certification

Table 36 lists the Oracle Role Manager certification information for Windows.

Table 36 Oracle Role Manager Certification for Windows

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? Web Container Certified ORM Version
JDK Additional Information
(see Table 38-1)
Intel Pentium 32 bit and 64 bit Windows Sever                     Both            
2003 SP1 and   
Windows 2008
               


Windows 2008 R2                 64 bit
JBoss 4.2.3GA 10.1.4.2 Sun JDK 1.6.0 1, 2, 3,8
WebSphere 6.1.0.21 10.1.4.2 IBM JDK 1.5.0 1, 2, 3
WebLogic 10.3.2 10.1.4.2 JRockit 1.6.0_05 1,2,3,4
JBoss 4.2.3 10.1.4.2 Sun JDK6 Update 17 1,2,3,9

9.3 Oracle Role Manager AIX Certification

Table 37 lists the Oracle Role Manager certification information for AIX.

Table 37 Oracle Role Manager Certification for AIX

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? Web Container Certified ORM Version JDK Additional Information
(see Table 38-1)
Power PC   64 bit                  AIX 5.3
/ RISC  
32 bit JBoss 4.0.5 10.1.4.0
 
Sun JDK 1.5.0_08 1, 5
64 bit WebSphere 6.1.0.13 10.1.4.2 IBM JDK 1.5.0 1
           


9.4 Oracle Role Manager Solaris Certification

Table 38 lists the Oracle Role Manager certification information for Solaris.  

Table 38 Oracle Role Manager Certification for Solaris

Processor Bus Architecture Operating System Name and Version Operating System 32 or 64 bits? Web Container Certified ORM Version JDK Additional Information
(see Table 38-1)
SPARC 64 bit Solaris 10 64 bit WebLogic 10.3 10.1.4.2 Sun JDK 1.6.0_10 1,2,3


Table 38-1 lists the additional information for Oracle Role Manager certification.

Table 38-1 Additional Information for Oracle Role Manager certification

Number Category Description

1

Database

No RAC support is available for Oracle Role Manager 10.1.4.0

2

Database

Oracle Database 11.1.0.6 is not supported for Oracle Role Manager  10.1.4.0

3

Database

Oracle Role Manager supports RAC database environments for general purpose operation only. High-availability scenarios, such as load balancing and failover, are not officially supported.

4 Web Container WebLogic is not supported for Oracle Role Manager 10.1.4.0
5 Operating System AIX (32 bit) is only supported for Oracle Role Manager 10.1.4.0
6 Operating System ORM 10.1.4.0 and 10.1.4.1 are not supported on OEL 5/RedHat 5
7 Operating System ORM-OIM Integration 10.1.4.1 and earlier are not supported on OEL 5/RedHat 5
8 Web Container WebSphere is not supported for Oracle Role Manager on RHEL 5/OEL5
9 Operating System You must run the "setup.exe -ignoreSysPrereqs" command to ignore the Operating System requirement of 5.1 or 5.2


9.5 Oracle Role Manager Database Certifications

Table 39 lists the Oracle Role Manager certification information for Databases.

Table 39 Oracle Role Manager Certification Databases

Vendor Version ORM 10.1.4.0 ORM 10.1.4.1 ORM 10.1.4.2
Oracle 10.2.0.3 Database Database
RAC
Not
supported
10.2.0.4 Not supported Not supported Database
RAC
11.1.0.6  Not supported Not
supported
11.1.0.7 Not supported Not supported Database
RAC
11.2.0.1 Not supported Not supported Database
RAC
Footnote 1The Oracle Role Manager supports RAC database environments for general purpose operation only. High-availability scenarios, such as loadbalancing and failover, are not officially supported.

9.6 Oracle Role Manager Additional Certifications

Table 40 lists the Oracle Role Manager Additional Certifications.

Table 40 Oracle Role Manager Additional Certifications

Category Product/Version Notes
Browser Microsoft Internet Explorer
6 SP2
Microsoft Internet Explorer 7
 

Single sign on Authentication

OAM 10.1.4.0.1

ORM-OAM Single Sign On Authentication
is not supported for
Oracle Role Manager 10.1.4.0

ORM Integration Library - 
Supported container versions

ORM/WLS 10.3 - OIM/WLS 10.3
ORM/JBoss 4.2.3 - OIM/JBoss 4.2.3
ORM/WS 6.1.0.21 - OIM/WS 6.1.0.21


 

ORM-OIM integration is not supported
for Oracle Role Manager 10.1.4.0 on WebLogic.



10 Oracle Authentication Services for Operating Systems

This section contains certification information for Oracle Authentication Services for Operating Systems.

Table 41 Oracle Internet Directory 10.1.4.2 
    Server Operating System Name and Version            
   

- Oracle Enterprise Linux (OEL) 4.0

- Red Hat Linux EL 4.0 (UL1 or higher)

- Solaris8/Solaris9/Solaris10 (SPARC 64 bit)

         

 


Table 42   Client Operating Systems

    Client Operating System Name and Version            
   

- Oracle Enterprise Linux (OEL) 4.0 

- Red Hat Linux EL 4.0 (UL1 or higher) 

- Oracle Enterprise Linux (OEL) 5.0 

- Red Hat Linux EL 5.0 

- SLES 9

- SLES 10

- Solaris 9

- Solaris 10

- HP-UX 11.23

- IBM 5.3

11 Oracle Adaptive Access Manager Certification

The Oracle Adaptive Access Manager Certification Information for 10gR3 has moved to a new location and format. To access the certification information, please click here.

If you do not have Microsoft Excel installed, please download Excel Viewer to open, view, and print Excel workbooks.