Downloads

JavaMail 1.4.5

March 23, 2012

The JavaMail 1.4.5 release contains several bug fixes and enhancements, including:

  • SOCKS5 support (requires JDK 1.5 or newer)
  • authentication information (e.g., passwords) is no longer included in debug output by default

Note: Unless you're using Java SE 6 or newer, you will also need the JavaBeans Activation Framework (JAF) extension that provides the javax.activation package. We suggest you use version 1.1.1 of JAF, the latest release. JAF is included with Java SE 6 and 7.

Send feedback to javamail_ww@oracle.com

Download JavaMail 1.4.5

Download

README | CHANGES | NOTES | SSLNOTES | FAQ

JavaMail Documentation

The JavaMail documentation is included in the download bundle (above), and can also be accessed online here.

JavaMail Service Provider Guide

(February 11, 1999)

We are pleased to present the final version of the JavaMail Service Provider Guide. Please send comments to javamail_ww@oracle.com


Previous Releases

JavaMail 1.4.4

JavaMail API 1.4.4, you can find it   here

JavaMail 1.4.3

JavaMail API 1.4.3, you can find it   here

JavaMail 1.4.2

JavaMail API 1.4.2, you can find it   here

JavaMail 1.4.1

JavaMail API 1.4.1, you can find it   here

JavaMail 1.4

JavaMail API 1.4, you can find it   here

JavaMail 1.3.3

JavaMail API 1.3.3, you can find it   here

JavaMail 1.3.2

JavaMail API 1.3.2, you can find it   here

JavaMail 1.3.1

JavaMail API 1.3.1, you can find it   here

JavaMail 1.3

JavaMail API 1.3, you can find it   here

JavaMail 1.2

JavaMail API 1.2, you can find it   here

JavaMail 1.1.3

JavaMail API 1.1.3, you can find it   here

See Also
API Specification | FAQ | Feedback


Left Curve
JavaMail Resources
Right Curve