Oracle SQL Developer 19.x: Certified Databases and Platforms

 

Date: August 22, 2019

Oracle SQL Developer is certified on the following platforms and for the following production Oracle and non-Oracle (third-party) databases. Any issues on platforms or databases not listed will only be considered when reproduced on a certified combination.

Oracle SQL Developer supported operating systems is defined by those platforms that support the approved Oracle Java Development Kit (JDK) required for said release.

Versions 4.2, 17.x, ,18.x, and 19.1 all require Oracle JDK 8.
Version 19.2 and higher require at least Oracle JDK8 or Oracle JDK 11.

The following are the common operating systems that officially support Oracle JDK 8

Platform Certification

Microsoft Windows

  • Windows 2008, 2008 R2, 2012, 2012 R2, 2016 Server
  • Windows Vista, 7, 8.x, 10

Apple MAC

  • OS X 10.8.3, 10.8.9 or above

For Linux and Solaris platforms see the official listing

Oracle Database Certification

  • Oracle Database 18, 19c
  • Oracle Database 12cR1, 12cR2
  • Oracle Database 11g Release 2
  • Oracle Database Express Edition 11g & 18c
  • Oracle TimesTen In-Memory Database 11g & 12c

Multi-user Environments

Oracle SQL Developer is supported in the following multi-user environments:

  • Microsoft Terminal Server
  • Citrix MetaFrame and MetaFrame XP (for Windows)
  • MetaFrame 1.1 for UNIX environments

Third Party Database Certification

Oracle SQL Developer can be used to browse and migrate objects and data from a number of third-party databases, and is certified against the following third-party databases.

JDK Support

Oracle SQL Developer is certified against JDK 1.8.

Oracle SQL Developer version 19.2 also supports Oracle JDK 11. 

Further Information

For other details, refer to the Oracle SQL Developer Documentation.

Discuss any SQL Developer issues on the OTN Oracle SQL Developer Forum.