Java Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy Files Download


The Java Cryptography Extension enables applications to use stronger versions of standard algorithms.

Current versions of the JDK do not require these policy files. They are provided here for use with older version of the JDK.


JDK 9 and later ship with, and use by default, the unlimited policy files.

The unlimited policy files for earlier releases available here are required only for JDK 8, 7, and 6 updates earlier than 8u161, 7u171, and 6u16. On those versions and later the policy files are included, but not enabled by default.

See JDK-8170157 for details.

The software download options are being created...
Left Curve
Java SDKs and Tools
Right Curve
Left Curve
Java Resources
Right Curve