Oracle Solaris Third Party Bulletin - April 2017


Description

The Oracle Solaris Third Party Bulletin announces patches for one or more security vulnerabilities fixed in third party software that is included in Oracle Solaris distributions. Starting January 20, 2015, Third Party Bulletins are released on the same day when Oracle Critical Patch Updates are released. These bulletins will also be updated on the Tuesday closest to the 17th of the following two months after their release (i.e. the two months between the normal quarterly Critical Patch Update publication dates). In addition, Third Party Bulletins may also be updated for vulnerability fixes deemed too critical to wait for the next monthly update.

Due to the threat posed by a successful attack, Oracle strongly recommends that customers apply Third Party Bulletin fixes as soon as possible.


Patch Availability

Please see My Oracle Support Note 1448883.1


Third Party Bulletin Schedule

Third Party Bulletins are released on the Tuesday closest to the 17th day of January, April, July and October. The next four dates are:

  • 18 July 2017
  • 17 October 2017
  • 16 January 2018
  • 17 April 2018

References


Modification History


2017-June-19 Rev 4. Added all CVEs fixed in Solaris 11.3 SRU 21
2017-June-07 Rev 3. Added CVE-2017-7494
2017-May-26 Rev 2. Added all CVEs fixed in Solaris 11.3 SRU 20
2017-April-18 Rev 1. Initial Release

 

 

Oracle Solaris Executive Summary

 

This Third Party Bulletin contains 55 new security fixes for the Oracle Solaris.  18 of these vulnerabilities may be remotely exploitable without authentication, i.e., may be exploited over a network without the need for a username and password. 

 

Oracle Solaris Third Party Bulletin Risk Matrix

 




Revision 4: Published on 2017-06-19



CVE# Product Third
Party
component
Protocol Remote
Exploit
without
Auth.?
CVSS VERSION 3.0 RISK (see Risk Matrix Definitions) Supported
Versions
Affected
Notes
Base
Score
Attack
Vector
Attack
Complexity
Privs
Req'd
User
Interact
Scope Confid-
entiality
Inte-
grity
Avail-
ability
CVE-2016-1238 Solaris Perl None No 8.2 Local Low Low Required Changed High High High 11.3, 10  
CVE-2016-1248 Solaris VIM None No 8.2 Local Low None Required Changed High High None 11.3  
CVE-2015-4756 Solaris MySQL Multiple No 7.7 Network Low Low None Changed None None High 11.3 See
Note 6
CVE-2017-3600 Solaris MySQL Multiple No 7.7 Network Low Low None Changed None None High 11.3 See
Note 27
CVE-2016-6321 Solaris Gtar Multiple Yes 7.5 Network Low None None Un
changed
None High None 11.3, 10  
CVE-2017-5647 Solaris Apache Tomcat HTTP Yes 7.5 Network Low None None Un
changed
High None None 11.3 See
Note 26
CVE-2017-6014 Solaris Wireshark Multiple Yes 5.9 Network High None None Un
changed
None None High 11.3 See
Note 24
CVE-2017-8343 Solaris ImageMagick None No 5.1 Local High None None Un
changed
High None None 11.3, 10 See
Note 25
CVE-2017-8386 Solaris Git Multiple No 5 Network High Low None Un
changed
Low Low Low 11.3  
CVE-2016-9243 Solaris Python cryptographic standard library Multiple Yes 4.8 Network High None None Un
changed
Low Low None 11.3  
CVE-2016-3120 Solaris Kerberos Kerberos Yes 3.1 Network High None Required Un
changed
None None Low 11.3  
CVE-2017-4965 Solaris RabbitMQ Multiple No 3.1 Network High High Required Un
changed
Low Low None 11.3 See
Note 28


Revision 3: Published on 2017-06-07



CVE# Product Third
Party
component
Protocol Remote
Exploit
without
Auth.?
CVSS VERSION 3.0 RISK (see Risk Matrix Definitions) Supported
Versions
Affected
Notes
Base
Score
Attack
Vector
Attack
Complexity
Privs
Req'd
User
Interact
Scope Confid-
entiality
Inte-
grity
Avail-
ability
CVE-2017-7494 Solaris Samba SMB No 7.5 Network High Low None Un
changed
High High High 11.3, 10  


Revision 2: Published on 2017-05-26



CVE# Product Third
Party
component
Protocol Remote
Exploit
without
Auth.?
CVSS VERSION 3.0 RISK (see Risk Matrix Definitions) Supported
Versions
Affected
Notes
Base
Score
Attack
Vector
Attack
Complexity
Privs
Req'd
User
Interact
Scope Confid-
entiality
Inte-
grity
Avail-
ability
CVE-2016-3105 Solaris Mercurial source code management Multiple Yes 8.8 Network Low None Required Un
changed
High High High 11.3 See
Note 12
CVE-2017-0309 Solaris NVIDIA-GFX Kernel driver None No 8.8 Local Low Low None Changed High High High 11.3  
CVE-2017-0311 Solaris NVIDIA-GFX Kernel driver None No 8.8 Local Low Low None Changed High High High 11.3  
CVE-2017-0321 Solaris NVIDIA-GFX Kernel driver None No 8.8 Local Low Low None Changed High High High 11.3  
CVE-2017-5462 Solaris Firefox Multiple Yes 8.8 Network Low None Required Un
changed
High High High 11.3 See
Note 19
CVE-2016-7382 Solaris NVIDIA-GFX Kernel driver None No 8.2 Local Low Low Required Changed High High High 11.3  
CVE-2016-7389 Solaris NVIDIA-GFX Kernel driver None No 8.2 Local Low Low Required Changed High High High 11.3  
CVE-2013-0292 Solaris DBus Multiple No 7.8 Local Low Low None Un
changed
High High High 10  
CVE-2015-8107 Solaris A2ps Print Filter Multiple No 7.8 Local Low None Required Un
changed
High High High 11.3, 10  
CVE-2016-10012 Solaris OpenSSH None No 7.8 Local Low Low None Un
changed
High High High 11.3  
CVE-2016-10164 Solaris X.Org Multiple Yes 7.5 Network High None Required Un
changed
High High High 11.3, 10  
CVE-2017-5647 Solaris Apache Tomcat Multiple Yes 7.5 Network Low None None Un
changed
High None None 11.3, 10 See
Note 18
CVE-2016-10010 Solaris OpenSSH Multiple Yes 7.3 Network Low None None Un
changed
Low Low Low 11.3 See
Note 14
CVE-2017-5405 Solaris Thunderbird Multiple Yes 7.3 Network Low None None Un
changed
Low Low Low 11.3 See
Note 17
CVE-2015-5950 Solaris NVIDIA-GFX Kernel driver Multiple No 7 Local High Low None Un
changed
High High High 11.3  
CVE-2016-10010 Solaris OpenSSH None No 7 Local High Low None Un
changed
High High High 11.3  
CVE-2017-5618 Solaris GNU Screen None No 7 Local High Low None Un
changed
High High High 11.3  
CVE-2016-8826 Solaris NVIDIA-GFX Kernel driver None No 6.5 Local Low Low None Changed None None High 11.3  
CVE-2017-0310 Solaris NVIDIA-GFX Kernel driver None No 6.5 Local Low Low None Changed None None High 11.3  
CVE-2017-0318 Solaris NVIDIA-GFX Kernel driver None No 6.5 Local Low Low None Changed None None High 11.3  
CVE-2017-2619 Solaris Samba Multiple No 5.9 Network High Low Required Un
changed
High Low Low 11.3, 10  
CVE-2017-7214 Solaris OpenStack Compute (Nova) Multiple No 5.7 Adjacent
Network
Low Low None Un
changed
High None None 11.3  
CVE-2016-10011 Solaris OpenSSH None No 5.5 Local Low Low None Un
changed
High None None 11.3  
CVE-2016-10349 Solaris Libarchive None No 5.5 Local Low None Required Un
changed
None None High 11.3 See
Note 16
CVE-2017-8361 Solaris Libsndfile None No 5.5 Local Low None Required Un
changed
None None High 11.3 See
Note 15
CVE-2016-8747 Solaris Apache Tomcat Multiple Yes 4.7 Network Low None Required Changed Low None None 11.3, 10  
CVE-2016-6855 Solaris EOG None No 4.4 Local Low None Required Un
changed
None Low Low 11.3  
CVE-2017-6452 Solaris NTP Multiple No 4.4 Network High High None Un
changed
None None High 11.3, 10 See
Note 21
CVE-2016-9841 Solaris Zlib None No 3.3 Local Low None Required Un
changed
None None Low 11.3 See
Note 20
CVE-2017-7742 Solaris Libsndfile None No 3.3 Local Low None Required Un
changed
None None Low 11.3 See
Note 22




Revision 1: Published on 2017-04-18



CVE# Product Third
Party
component
Protocol Remote
Exploit
without
Auth.?
CVSS VERSION 3.0 RISK (see Risk Matrix Definitions) Supported
Versions
Affected
Notes
Base
Score
Attack
Vector
Attack
Complexity
Privs
Req'd
User
Interact
Scope Confid-
entiality
Inte-
grity
Avail-
ability
CVE-2016-2179 Solaris MySQL None No 8.1 Local High None None Changed High High High 11.3 See
Note 5
CVE-2015-4756 Solaris MySQL None No 8.1 Local High None None Changed High High High 11.3 See
Note 6
CVE-2017-6471 Solaris Wireshark Multiple Yes 7.5 Network Low None None Un
changed
None None High 11.3 See
Note 2
CVE-2015-8607 Solaris Perl 5.12 Multiple Yes 7.3 Network Low None None Un
changed
Low Low Low 11.3  
CVE-2017-5405 Solaris Firefox Multiple Yes 7.3 Network Low None None Un
changed
Low Low Low 11.3 See
Note 7
CVE-2016-5626 Solaris MySQL None No 7.2 Local High High Required Changed High High High 11.3 See
Note 8
CVE-2017-3258 Solaris MySQL Multiple No 6.8 Network Low Low Required Changed None None High 11.3 See
Note 4
CVE-2017-3320 Solaris MySQL Multiple No 6.8 Network Low Low Required Changed None None High 11.3 See
Note 9
CVE-2017-3258 Solaris MySQL None No 6.7 Local High Low Required Un
changed
High High High 11.3 See
Note 3
CVE-2012-3461 Solaris Pidgin Multiple Yes 5.9 Network High None None Un
changed
None None High 10 See
Note 11
CVE-2017-3732 Solaris OpenSSL/WanBoot Multiple Yes 5.9 Network High None None Un
changed
None None High 10 See
Note 10
CVE-2016-8574 Solaris TCPdump Multiple Yes 5.3 Network Low None None Un
changed
None None Low 11.3 See
Note 1

 

Notes:

  1. This fix also addresses CVE-2016-7922 CVE-2016-7923 CVE-2016-7924 CVE-2016-7925 CVE-2016-7926 CVE-2016-7927 CVE-2016-7928 CVE-2016-7929 CVE-2016-7930 CVE-2016-7931 CVE-2016-7932 CVE-2016-7933 CVE-2016-7934 CVE-2016-7935 CVE-2016-7936 CVE-2016-7937 CVE-2016-7938 CVE-2016-7939 CVE-2016-7940 CVE-2016-7973 CVE-2016-7974 CVE-2016-7975 CVE-2016-7983 CVE-2016-7984 CVE-2016-7985 CVE-2016-7986 CVE-2016-7992 CVE-2016-7993 CVE-2016-8575 CVE-2017-5202 CVE-2017-5203 CVE-2017-5204 CVE-2017-5205 CVE-2017-5341 CVE-2017-5342 CVE-2017-5482 CVE-2017-5483 CVE-2017-5484 CVE-2017-5485 CVE-2017-5486.
  2. This fix also addresses CVE-2017-6467 CVE-2017-6468 CVE-2017-6469 CVE-2017-6470 CVE-2017-6472 CVE-2017-6473 CVE-2017-6474.
  3. This fix also addresses CVE-2017-3238 CVE-2017-3243 CVE-2017-3244 CVE-2017-3265 CVE-2017-3291 CVE-2017-3312 CVE-2017-3313 CVE-2017-3317 CVE-2017-3318.
  4. This fix also addresses CVE-2016-8318 CVE-2016-8327 CVE-2017-3238 CVE-2017-3244 CVE-2017-3257 CVE-2017-3265 CVE-2017-3273 CVE-2017-3291 CVE-2017-3312 CVE-2017-3313 CVE-2017-3317 CVE-2017-3318.
  5. This fix also addresses CVE-2014-6464 CVE-2014-6469 CVE-2014-6491 CVE-2014-6494 CVE-2014-6500 CVE-2014-6507 CVE-2014-6555 CVE-2014-6559 CVE-2014-6568 CVE-2015-0374 CVE-2015-0382 CVE-2015-0411 CVE-2015-0432 CVE-2015-0433 CVE-2015-0499 CVE-2015-0505 CVE-2015-2568 CVE-2015-2571 CVE-2015-2573 CVE-2015-2643 CVE-2015-2648 CVE-2015-4752 CVE-2016-2105 CVE-2016-2106 CVE-2016-2177 CVE-2016-2178 CVE-2016-2180 CVE-2016-2181 CVE-2016-2182 CVE-2016-2183 CVE-2016-3424 CVE-2016-3440 CVE-2016-3452 CVE-2016-3459 CVE-2016-3486 CVE-2016-3492 CVE-2016-3495 CVE-2016-3501 CVE-2016-3518 CVE-2016-3588 CVE-2016-3614 CVE-2016-3615 CVE-2016-5436 CVE-2016-5437 CVE-2016-5439 CVE-2016-5440 CVE-2016-5441 CVE-2016-5442 CVE-2016-5443 CVE-2016-5444 CVE-2016-5507 CVE-2016-5584 CVE-2016-5598 CVE-2016-5609 CVE-2016-5612 CVE-2016-5616 CVE-2016-5617 CVE-2016-5624 CVE-2016-5625 CVE-2016-5626 CVE-2016-5627 CVE-2016-5628 CVE-2016-5629 CVE-2016-5630 CVE-2016-5631 CVE-2016-5632 CVE-2016-5633 CVE-2016-5634 CVE-2016-5635 CVE-2016-6302 CVE-2016-6303 CVE-2016-6304 CVE-2016-6306 CVE-2016-6662 CVE-2016-7440 CVE-2016-8283 CVE-2016-8284 CVE-2016-8286 CVE-2016-8287 CVE-2016-8288 CVE-2016-8289 CVE-2016-8290.
  6. This fix also addresses CVE-2014-3569 CVE-2015-0385 CVE-2015-0405 CVE-2015-0423 CVE-2015-0438 CVE-2015-0439 CVE-2015-0498 CVE-2015-0500 CVE-2015-0503 CVE-2015-0506 CVE-2015-0507 CVE-2015-0508 CVE-2015-0511 CVE-2015-2566 CVE-2015-2567 CVE-2015-2611 CVE-2015-2617 CVE-2015-2639 CVE-2015-2641 CVE-2015-2661 CVE-2015-4737 CVE-2015-4761 CVE-2015-4767 CVE-2015-4769 CVE-2015-4771 CVE-2015-4772.
  7. This fix also addresses CVE-2017-5398 CVE-2017-5400 CVE-2017-5401 CVE-2017-5402 CVE-2017-5404 CVE-2017-5407 CVE-2017-5408 CVE-2017-5409 CVE-2017-5410.
  8. This fix also addresses CVE-2016-3492 CVE-2016-5584 CVE-2016-5612 CVE-2016-5616 CVE-2016-5617 CVE-2016-5624 CVE-2016-5629 CVE-2016-6662 CVE-2016-7440 CVE-2016-8283.
  9. This fix also addresses CVE-2016-8318 CVE-2016-8327 CVE-2017-3238 CVE-2017-3244 CVE-2017-3251 CVE-2017-3256 CVE-2017-3257 CVE-2017-3258 CVE-2017-3265 CVE-2017-3273 CVE-2017-3291 CVE-2017-3312 CVE-2017-3313 CVE-2017-3317 CVE-2017-3318 CVE-2017-3319.
  10. This fix also addresses CVE-2016-7055 CVE-2017-3731.
  11. This fix also addresses CVE-2012-2369.
  12. This fix also addresses CVE-2015-7545.
  13. This fix also addresses CVE-2016-10009 CVE-2016-10012.
  14. This fix also addresses CVE-2017-8362 CVE-2017-8363 CVE-2017-8365.
  15. This fix also addresses CVE-2016-10350.
  16. This fix also addresses CVE-2017-5398 CVE-2017-5400 CVE-2017-5401 CVE-2017-5402 CVE-2017-5404 CVE-2017-5408 CVE-2017-5410.
  17. This fix also addresses CVE-2016-8745.
  18. This fix also addresses CVE-2017-5429 CVE-2017-5432 CVE-2017-5433 CVE-2017-5434 CVE-2017-5435 CVE-2017-5436 CVE-2017-5437 CVE-2017-5438 CVE-2017-5439 CVE-2017-5440 CVE-2017-5441 CVE-2017-5442 CVE-2017-5443 CVE-2017-5444 CVE-2017-5445 CVE-2017-5446 CVE-2017-5447 CVE-2017-5448 CVE-2017-5459 CVE-2017-5460 CVE-2017-5461 CVE-2017-5464 CVE-2017-5465 CVE-2017-5469.
  19. This fix also addresses CVE-2016-9840 CVE-2016-9842 CVE-2016-9843.
  20. This fix also addresses CVE-2016-9042 CVE-2017-6451 CVE-2017-6455 CVE-2017-6458 CVE-2017-6459 CVE-2017-6460 CVE-2017-6462 CVE-2017-6463 CVE-2017-6464.
  21. This fix also addresses CVE-2017-7586.
  22. This fix also addresses CVE-2017-7700 CVE-2017-7701 CVE-2017-7702 CVE-2017-7703 CVE-2017-7704 CVE-2017-7705.
  23. This fix also addresses CVE-2017-7619 CVE-2017-8344 CVE-2017-8345 CVE-2017-8346 CVE-2017-8347 CVE-2017-8348 CVE-2017-8349 CVE-2017-8350 CVE-2017-8351 CVE-2017-8352 CVE-2017-8353 CVE-2017-8354 CVE-2017-8355 CVE-2017-8356 CVE-2017-8357 CVE-2017-8765 CVE-2017-8830 CVE-2017-9098.
  24. This fix also addresses CVE-2017-5648 CVE-2017-5650 CVE-2017-5651.
  25. This fix also addresses CVE-2017-3302 CVE-2017-3305 CVE-2017-3308 CVE-2017-3309 CVE-2017-3329 CVE-2017-3453 CVE-2017-3456 CVE-2017-3461 CVE-2017-3462 CVE-2017-3463 CVE-2017-3464.
  26. This fix also addresses CVE-2017-4966 CVE-2017-4967.