No results found

Your search did not match any results.

We suggest you try the following to help find what you’re looking for:

  • Check the spelling of your keyword search.
  • Use synonyms for the keyword you typed, for example, try “application” instead of “software.”
  • Try one of the popular searches shown below.
  • Start a new search.
Trending Questions

Oracle Mobile Application Framework 2.6.2 Migration Notes

The following notes correspond to a migration from 2.5.1 to 2.6.2. Note: From 2.6.0 to 2.6.2 only the Android SDK changed.  If you are migrating from an earlier release, please also refer to previous migration notes.

1.This release of MAF requires Xcode 10.x to build and deploy your MAF applications to the iOS platform. Also, beginning with Xcode 10.2 Apple has changed how Swift based applications are built.

2.On Android, for push notifications in MAF applications, MAF now uses Firebase Cloud Messaging (FCM) to replace Google Cloud Messaging (GCM), which has been deprecated by Google. To migrate to FCM see Migrating an Application to MAF 2.6.0.

3.You are required to install Android API Level 28 to build and deploy MAF applications to the Android platform. Ensure that you install the Android SDK Platform API Level 28 into the Android SDK Location that you have specified in your MAF preferences, as described in Setting Up Development Tools for the Android Platform.

4.Updated the Cordova engine versions that MAF uses (Android: 7.0.0 and iOS: 4.5.4). See Migrating Cordova Plugins from Earlier Releases to MAF 2.6.0.