Java 徽标


 


JAVA SE EMBEDDED 系统要求


红色三角形  JAVA SE EMBEDDED 系统要求

Oracle Java SE Embedded 支持传统的 Java SE 桌面和服务器平台。有关这些受支持的平台,请访问:Oracle JDK 7 和 JRE 7 认证的系统配置Oracle 认证的系统配置 — Java SE 6

此外,Java SE Embedded 还支持专门针对嵌入式市场的平台。这些平台包括 ARM 和 x86。我们的工程服务团队可以开发针对其他平台的定制版本 — 更多信息,请联系我们。下面汇总了当前可用的 Oracle Java SE Embedded 版本支持的系统配置。

 

ARM EABI、小端、Linux 上的 Java SE Embedded 8 无头

CPU ARM v5/v6/v7 ARM v6/v7

操作系统* Linux:内核 2.6.28 或更高版本;glibc 2.9 或更高版本 Linux:内核 2.6.28 或更高版本;glibc 2.9 或更高版本

FP SoftFP1 VFP、HardFP ABI3

RAM 至少 32MB 空间可用于 Java 至少 32MB 空间可用于 Java

完整 JRE 所需 ROM/闪存/磁盘大小 Compact1:11MB
Compact2:15.4MB
Compact3:21.5MB
完整 JRE:47.2MB
Compact1:11MB
Compact2:15.4MB
Compact3:23.6MB
完整 JRE:45.8MB

ARM EABI、小端、Linux 上的 Java SE Embedded 8 有头

CPU ARM v6/v7

操作系统* Linux:内核 2.6.28 或更高版本;glibc 2.9 或更高版本

有头 5

FP VFP、HardFP ABI3

RAM Swing/AWT:64MB

完整 JRE 所需 ROM/闪存/磁盘大小 Swing/AWT:45.8MB


x86 Linux 上的 Java SE Embedded 8

CPU x86

操作系统* Linux:内核 2.6.28 或更高版本;glibc 2.9 或更高版本

有头

RAM 至少 32MB 空间可用于 Java

完整 JRE 所需 ROM/闪存/磁盘大小 Compact1:11.3MB
Compact2:15.7MB
Compact3:22.4MB
完整 JRE:50.1MB


  

 
*  上述最低内核和 glibc 版本基于有代表性系统上的测试。不过,一些嵌入式主板,尤其是是较新的多核系统,可能需要比上述最低要求更新的内核、glibc 版本。核实您的平台资源,包括系统供应商、Linux 供应商、通用内核、glibc、第三方库版本/补丁信息,确保您运行的内核、glibc 和第三方库版本均适合您的平台。
1   使用的 gcc 选项包括:-msoft-float
2   使用的 gcc 选项包括:-mfloat-abi=softfp -mfpu=vfp
3   使用的 gcc 选项包括:-mfloat-abi=hard -mfpu=vfp
4   仅 ARM v7
5   Swing/AWT 支持需要 X11 
false ,,,,,,,,,,,,,,,,